15:02:22 <tnadeau__> #startmeeting spectrometer meeting
15:02:22 <odl_meetbot> Meeting started Fri Apr 15 15:02:22 2016 UTC.  The chair is tnadeau__. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:02:22 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:22 <odl_meetbot> The meeting name has been set to 'spectrometer_meeting'
15:03:26 <tnadeau__> #topic agenda bashing
15:04:03 <tnadeau__> thanh would like to discuss branching strategy
15:04:49 <tnadeau__> vasu would like to talk about CI/installation
15:05:55 <tnadeau__> mo would like to discuss if we have any idea about how we do per-company extraction from commit info. what is our method for that.
15:06:07 <tnadeau__> an - would like to talk about the bulild
15:06:16 <tnadeau__> #topic branching strategy
15:06:20 <tnadeau__> http://cl.ly/1w1S3m360C2E
15:07:29 <tnadeau__> thanh suggesting that at the point of branching on wards is tracked.  we need to track when a branch actually happens.
15:07:45 <tnadeau__> we have an algorithm for taking two branches and walking back to their common parent
15:07:52 <tnadeau__> a release starts when a branch happens
15:09:18 <tnadeau__> thanh - we may need a metadata file that tracks when a release starts. some sort of key mapping file that keeps track of the ordering
15:09:36 <tnadeau__> tom/an - is that ODL-specific?
15:09:58 <tnadeau__> last week we discussed a meta data component
15:10:06 <tnadeau__> thanh - this is a config file, not in repo
15:10:35 <tnadeau__> last time we agreed to have ea config file that drives the startup of the system - its config data
15:10:42 <tnadeau__> we agreed that this config file is YAML format btw
15:11:30 <tnadeau__> #agree we will include this meta data in the startup config file
15:12:43 <tnadeau__> mo - discussed some issues around algorithm
15:13:03 <tnadeau__> thanh - we should push the entire JSON file into the "data' field in the database
15:13:08 <tnadeau__> we're using the DB as a cache anyways
15:13:27 <tnadeau__> update object once in a while
15:13:35 <tnadeau__> (pushing to mongo db)
15:13:41 <tnadeau__> vasu - how long do we keep that file?
15:13:56 <tnadeau__> thanh - we need a configurable value
15:14:09 <tnadeau__> tom - we need to store this config parameter in the startup config file
15:14:15 <tnadeau__> default 5 minutes?
15:20:09 <odp-gerritbot> A H proposed a change to spectrometer: Add gerrit api for project tags.  https://git.opendaylight.org/gerrit/37672
15:20:12 <odp-gerritbot> A comment has been added to a proposed change to spectrometer: Add gerrit api for project tags.  https://git.opendaylight.org/gerrit/37672
15:20:41 <odp-gerritbot> A comment has been added to a proposed change to spectrometer: Add gerrit api for project tags.  https://git.opendaylight.org/gerrit/37672
15:21:24 <odp-gerritbot> A comment has been added to a proposed change to spectrometer: Add gerrit api for project tags.  https://git.opendaylight.org/gerrit/37672
15:27:07 <tnadeau_> #agree to use memcache instead of mongoldb
15:27:18 <tnadeau_> #agree store the JSON object locally. query it like its a DB once its in the DB.
15:31:40 <tnadeau_> #agree lets just stick with mongoldb for now.   we can investigate memcache in the future
15:33:14 <tnadeau_> thanh - we have a db file thats different for the git handler file. could we have a keyword that tells it to just use the db or cache?
15:33:38 <tnadeau_> our db code also constructs its own commit. if we use the JSON file approach, that can be the same function
15:33:46 <tnadeau_> mo - disagree about the first point
15:34:08 <tnadeau_> need to change the ID of the commit
15:34:26 <tnadeau_> thanh - the id can actually be the function name
15:34:32 <tnadeau_> mo - the "api signature" ?
15:34:36 <tnadeau_> thanh -yes
15:35:04 <tnadeau_> mo - do not want to move the code of the handler into the git db code
15:35:15 <tnadeau_> thats less coupled to other things
15:35:49 <tnadeau_> thanh- there are 3 places to update when we add a new feature: api file, git handler, and now update the DB file. should be the same
15:36:06 <tnadeau_> mo - OTOH if you want to change the DB logic, its cleaner
15:38:22 <tnadeau_> https://trello.com/b/fIVlZ0M5/opendaylight-spectrometer
15:40:10 <tnadeau_> #action  tom created new Trello stack called backlog and added a card for this item to address post .1
15:40:52 <tnadeau_> #topic CI/installation
15:40:59 <tnadeau_> vasu wants to know what we need to do to progress here
15:41:21 <tnadeau_> thanh experiencing npm failures. need that to work correctly
15:42:35 <tnadeau_> hangout later today possibly to sit down and get this working
15:43:11 <tnadeau_> #topic discuss if we have any idea about how we do per-company extraction from commit info
15:53:59 <tnadeau_> #agree we will use a switch in the startup config file to use the local dummy LDAP file, or query the LF LDAP backend
15:54:16 <tnadeau_> #agree devs can also use the CI when pushing patches, to test with the actual LF LDAP
15:55:00 <tnadeau_> #action thanh to take a dump of LDAP and check in a dummy file to use.
15:56:14 <tnadeau_> an - asking about privacy issues around distribution of LDAP info
15:59:02 <tnadeau_> #action tom to send email to Phli to ask about legal concerns around LDAP information
16:01:32 <tnadeau_> an makes point about privacy issues around EU laws/etc...
16:02:08 <tnadeau_> LF ldap access is only available to LF staff
16:04:29 <tnadeau_> #agree lets create the dummy file with only the spectrometer dev team
16:04:57 <tnadeau_> does gerrit have  a limit on the # of accesses ?
16:05:03 <tnadeau_> tom - like rate limit?
16:06:33 <tnadeau_> the cache model will help with this
16:07:31 <tnadeau_> #endmeeting