20:02:29 <KLuehrs> #startmeeting UNI Manager
20:02:29 <odl_meetbot> Meeting started Wed Oct  7 20:02:29 2015 UTC.  The chair is KLuehrs. Information about MeetBot at http://ci.openstack.org/meetbot.html.
20:02:29 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:02:29 <odl_meetbot> The meeting name has been set to 'uni_manager'
20:02:43 <grmontpetit> #indo
20:02:45 <grmontpetit> #info
20:02:47 <adetalhouet> #info adetalhouet
20:02:51 <grmontpetit> #info grmontpetit
20:03:02 <KLuehrs> #info Kevin Luehrs
20:03:49 <adetalhouet> KLuehrs: is Muffadal going to join?
20:06:19 <adetalhouet> KLuehrs: could you make me chair so I can help with the minutes
20:07:55 <KLuehrs> #chair Mufaddal Makati
20:07:55 <odl_meetbot> Warning: Nick not in channel: Makati
20:07:55 <odl_meetbot> Current chairs: KLuehrs Makati Mufaddal
20:08:08 <grmontpetit> #chair Mufaddal
20:08:09 <KLuehrs> #chair Mufaddal
20:08:09 <odl_meetbot> Current chairs: KLuehrs Makati Mufaddal
20:10:27 <KLuehrs> #topic Current Project Status
20:10:44 <adetalhouet> I can't see the screen as I'm using hangout
20:11:19 <adetalhouet> there is a lot of background noise
20:12:18 <adetalhouet> #info WIP to add UNI under network-topology
20:12:47 <adetalhouet> #info SB plugin of OVSDB is supported but this is not the end goal, it was more a POC
20:12:51 <KLuehrs> #info Currently developing UNI and EVC YANG model. An initial prototype model exists.
20:12:57 <adetalhouet> #info the purpose is now to migrate to netconf
20:13:55 <adetalhouet> #info Mufaddal says yang model is ready to migrate UNI and EVC under network topology
20:14:07 <adetalhouet> #undo
20:14:11 <KLuehrs> #info An updated YANG model integrating UNI Manager with ODL topology manager is ready to be incorporated
20:14:22 <KLuehrs> : )
20:14:49 <adetalhouet> KLuehrs: true, I'm not chair I can't #info. Nvm I can see you're doing it so I let you do the minutes
20:15:21 <KLuehrs> adetalhouet: I thought anyone can #info
20:15:37 <KLuehrs> But I'll try to capture minutes
20:15:51 <adetalhouet> well anyone can #info, but only chair can manage the minutes, so my #undo didn't do anything
20:16:26 <adetalhouet> KLuehrs: ok thanks, it is nice to leave trace of what happen during the meetings
20:16:38 <KLuehrs> #info Gabriel will integrate new YANG model with integration with Topology by Monday October 12
20:18:43 <KLuehrs> #info We would like to change YANG model but that will be targeted for Boron release
20:20:47 <KLuehrs> #info For the Beryllium release we will make a small change to YANG model to add incorporation with ODL Topology Manager. This YANG model is ready for incorporation. The goal is incorporate the new YANG model by October 12.
20:21:38 <KLuehrs> #info After incorporating the YANG model the effort will be to implement full CRUD functionality for UNI and EVC
20:24:38 <KLuehrs> #info How can we make tasks to be done visible to other resources?
20:25:23 <adetalhouet> people need to be added to the board
20:25:32 <adetalhouet> as per as they username or email address
20:25:45 <adetalhouet> tasks are visible to everyone
20:25:46 <KLuehrs> #info Mufaddal will create a UNI Manager Trello board and start adding tasks and users to it. Alexi and team will also add tasks.
20:25:59 <adetalhouet> but only ppl having access to the board can interact to the card
20:26:45 <KLuehrs> #action Mufaddal will create UNI Manager Trello board and add users.
20:27:04 <KLuehrs> #action Mufaddal and Alexi will add tasks to the UNI Manager board
20:27:43 <KLuehrs> #topic UNI Manager M3 Status for Beryllium release
20:29:34 <KLuehrs> #info Feature/Functionality Freeze: This refers to karaf features. Example ODL UNI Manager NetConf
20:30:22 <KLuehrs> #action Gabriel will update UNI Manager with updated YANG model. Goal is to incorporate the YANG model by October 12.
20:31:22 <KLuehrs> #info Karaf Features Defined: Refers to features in the karaf feature file. This is already defined. No more is needed for UNI Manager, for Beryllium release
20:32:20 <KLuehrs> #info For Karaf Features - deliverable is Jenkins job
20:34:17 <KLuehrs> #info Any project must have (1) verify job (push a patch), (2) merge job, (3) installation job. Refer to 'Karaf step by step guide'.
20:35:14 <adetalhouet> https://jenkins.opendaylight.org/releng/view/unimgr/
20:35:31 <KLuehrs> #info Link to where verify and merge jobs are posted
20:35:46 <KLuehrs> #info  https://jenkins.opendaylight.org/releng/view/unimgr/
20:36:41 <KLuehrs> #info Documentation Started - Mufaddal posted documentation in UNI Manager Docs project
20:37:11 <KLuehrs> #action Gabriel and team will review document patch
20:38:54 <KLuehrs> #info Feature Test Started: Is this needed given that UNI Manager is an incubation project? Gabriel feels we should create a Robot job. Alexi confirmed we need System test for M3.
20:40:07 <KLuehrs> #action Gabriel and team will develop a Robot job to create two UNIs and tunnel between them
20:40:47 <KLuehrs> #info Test Plan - contains test suites. The test suites are the Robot files. This is documented in the ODL wiki testing page.
20:41:09 <adetalhouet> #link https://wiki.opendaylight.org/view/CrossProject:Integration_Group:System_Test:Step_by_Step_Guide System Test How To
20:41:52 <adetalhouet> #link some more context about robot: https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Using_Robot_Framework
20:42:03 <adetalhouet> #link some more context about CSIT: https://wiki.opendaylight.org/view/CrossProject:Integration_Group:CSIT
20:46:58 <KLuehrs> #info Tasks to be completed before the end of the M3: integrate the new YANG file with ODL Topology Manager integration, retain Create and Read for EVC and UNI, and add Delete for EVC and UNI. If possible also add Update for EVC and UNI.
20:47:53 <KLuehrs> #topic Future Tasks and Direction
20:48:31 <adetalhouet> I'm willing to help on netconf once we will get there
20:48:39 <KLuehrs> #info Support for additional MEF attributes, including UNI attributes (e.g., MTU size), Class of Service attributes, and Bandwidth Profile attributes
20:49:01 <KLuehrs> #info Support for multiple service provider connections:  OVC, ENNI
20:54:57 <KLuehrs> #info Kevin informed the group about the MEF LSO Hackathon that is scheduled to occur in conjunction with MEF GEN 15 conference
20:55:20 <KLuehrs> #link https://wiki.mef.net/display/LH/MEF+LSO+Hackathon
20:57:17 <KLuehrs> #info Primary project focus now is to complete the remaining requirements for Beryllium M3 milestone October 15. We estimate we are 60% - 70% complete with the tasks at this point.
20:57:23 <KLuehrs> #endmeeting