#opendaylight-users: AdvisooryGroup

Meeting started by CaseyODL at 15:03:34 UTC (full logs).

Meeting summary

  1. CORD/Edge Computing discussion (CaseyODL, 15:08:50)
    1. Phil asks for a follow up on the email thread regarding CORD and where we may want to focus our efforts. (CaseyODL, 15:09:36)
    2. Beau points out that there is another discussion where we would do a presentation of our own version of CORD in the ODL booth at OpenStack (CaseyODL, 15:11:05)
    3. Discussions are early, but OPNFV is still a potential home for the edge computing elements. (CaseyODL, 15:12:04)
    4. Bryan notes that AT&T is interested in CORD and it's future. (CaseyODL, 15:12:57)
    5. Bryan: The advantage of OPNFV is it's focus on the datacenter. (CaseyODL, 15:13:47)
    6. Beau notes that 2 POC solution is challenging at first due to the logistics. MCORD is more difficult to implement due to limited NFV functions. (CaseyODL, 15:16:19)
    7. Beau: We are currently testing and I will report back as we develop new research and testing. (CaseyODL, 15:17:28)
    8. Pedro responds to a question regarding RIFT.io. He points out that there is a open source MANO project that works with ODL. (CaseyODL, 15:20:55)
    9. Phil we will continue to work with the Open CORD and OPNFV communities. We are actively looking for people who interested in working on these projects. (CaseyODL, 15:26:21)

  2. Discuss impending changes to ODL's YANG Models and RESTCONF interface and it's impact on end users. How best can the ODL community communicate and execute on changes that impact end users? (CaseyODL, 15:26:51)
    1. https://wiki.opendaylight.org/view/Tech_Work_Stream:Main#Information_From_Past_Meetings (colindixon, 15:26:53)
    2. https://wiki.opendaylight.org/view/Tech_Work_Stream:Main#Information_From_Past_Meetings (CaseyODL, 15:27:08)
    3. Colin: There is a chance that we may be moving to RESTCONF draft 11. It is currently under final review by ISG. We would like to have a standards compliant version of RESTCONF. There are a number of changes. It will change the way that people are building apps on top of ODL. (CaseyODL, 15:29:11)
    4. Tighter integration with the IETF would be better. (CaseyODL, 15:29:52)
    5. https://wiki.opendaylight.org/view/File:Restconf_v2_analysis.odt writeup of the differences (colindixon, 15:29:53)
    6. Some of the encoding of patches will change and URLs will change. (CaseyODL, 15:30:48)
    7. The ways that keys are expressed will also change. (CaseyODL, 15:30:59)
    8. It is all loosely coupled. Random things will break. We will not be able to deprecate this in Carbon. This will take time. (CaseyODL, 15:32:42)
    9. This is the biggest migration since the AD/MD SAL migration. (CaseyODL, 15:32:59)
    10. This is something that is coming in the next 6 to 18 months. (CaseyODL, 15:33:34)
    11. Brian asks if this was a topic at ODL Summit. (CaseyODL, 15:34:12)
    12. Colin: I would be floored if it isn't. (CaseyODL, 15:34:33)
    13. ACTION: Phil will ensure that this is a topic at ODL Summit. (CaseyODL, 15:34:54)
    14. Colin: My personal take is given the widespread use of Draft 2, we should continue to support it for as long as we can. But there is a cost to maintain two different versions of RESTCONF. (CaseyODL, 15:36:03)
    15. Chris asks how much is contained in a certain module vs a Project? (CaseyODL, 15:36:27)
    16. ACTION: phrobb to ensure there is a session on RESTCONF migration at the ODL Summit in September (phrobb, 15:36:56)
    17. It's mostly contained in RESTCOF (CaseyODL, 15:37:05)
    18. I expect that we have at least two releases where both drafts will exist side by side. There is no automated tool to update your applications and we need to give time for our community to update. (CaseyODL, 15:39:03)
    19. RESTCONF will use YANG 1.1 and not 1.0. ODL currently doesn't have support for YANG 1.1. This may result in some weird issues depending on how that turns out. (CaseyODL, 15:40:25)
    20. Brian asks what our plan is for YANG 1.1. (CaseyODL, 15:43:07)
    21. Colin: The simple answer is that we want to do it, but we don't have a current plan. (CaseyODL, 15:43:32)
    22. The challenge of maintaining multiple versions of YANG north and south bound will not be easy. (CaseyODL, 15:44:58)
    23. Pedro: If we want to keep up with the IETF, we need to focus on this. (CaseyODL, 15:46:06)
    24. Pedro: IETF Berlin met to discuss Open Source again. There is a lot of awareness and we should be a part of that. (CaseyODL, 15:48:33)
    25. Chris: Some of the larger vendors who work in ODL are sending reps to IETF. (CaseyODL, 15:49:00)
    26. Harvey Newman notes that the orchestrators that he is aware of are not dealing with service delivery across regions... the problems they are solving are smaller than the real problems (phrobb, 15:54:38)
    27. Harvey asks, if there are orch. ideas that include data center, storage systems, etc. are there orch. that incorporate those ideas? (phrobb, 15:55:17)
    28. Harvey notes, the question is about orch of end to end systems, apart from academia is a coherent unified orchestration/abstraction being worked on anywhere? (phrobb, 15:57:36)
    29. Colin states that nobody is currently working on this. However it is something that we should discuss further in the future. (CaseyODL, 15:59:55)
    30. ACTION: Colin will send out the TWS meeting info regarding migration efforts. (CaseyODL, 16:01:11)
    31. https://meetings.webex.com/collabs/#/files/detail?fileID=OEG1MNBKU72KYGJMFXJCCA9INV-9VIB&containerID=U537T353F0XW3RDNWO0OL2ZB0O-9VIB&containerType=us (CaseyODL, 16:01:48)
    32. link to the Webex recording (CaseyODL, 16:02:13)


Meeting ended at 16:02:21 UTC (full logs).

Action items

  1. Phil will ensure that this is a topic at ODL Summit.
  2. phrobb to ensure there is a session on RESTCONF migration at the ODL Summit in September
  3. Colin will send out the TWS meeting info regarding migration efforts.


Action items, by person

  1. phrobb
    1. phrobb to ensure there is a session on RESTCONF migration at the ODL Summit in September
  2. UNASSIGNED
    1. Phil will ensure that this is a topic at ODL Summit.
    2. Colin will send out the TWS meeting info regarding migration efforts.


People present (lines said)

  1. CaseyODL (40)
  2. phrobb (5)
  3. odl_meetbot (4)
  4. colindixon (4)


Generated by MeetBot 0.1.4.