#opendaylight-users: advisory group

Meeting started by colindixon at 15:06:44 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 15:06:57)
    1. three possible topics: colindixon giving a TSC update, LuisGomez presenting on the performance report, and Johan presenting on a Telia use case (colindixon, 15:08:50)
    2. some notes about new advisors (Kevin from Tencent) and upcoming changes (Margaret leaving AT&T) (colindixon, 15:10:22)

  2. Telia use case (colindixon, 15:10:27)
    1. TeliaSonera has renamed to Telia Company (CaseyODL, 15:12:56)
    2. Telia Company (formerly known as TeliaSonera), headquartered in Stockholm, ~21,000 employees, 15+ countries (mainly nordic and baltic), first commercial 4G, targeting 2018 5G in Stockholm and Tallinn (colindixon, 15:13:37)
    3. generally good things to say about OpenDaylight, helps to run the Stockholm ODLUG (colindixon, 15:14:52)
    4. biggest problems: difficult for devs to get started (MD-SAL, consumer/provider, docs), protcols/plugins still need testing from member vendors, BGP in clustering, migration (happy to not have been an early adopter and thus not needing to deal with migration) (colindixon, 15:16:23)
    5. commented that recent efforts to improve docs have been greatly appreciated (colindixon, 15:16:47)
    6. ACTION: colindixon to figure out what the situation with BGP speakers in clustering is with best practices (colindixon, 15:18:45)
    7. in use: MD-SAL, YANG Tools, BGP -LS, flowspec, IP, PCEP, NETCONF, BMP, Service Function Chaining, Telia customised Karaf bundles (colindixon, 15:19:31)
    8. need: distributed transactions, TransportPCE, Kafka producer (colindixon, 15:19:51)
    9. initial use cases: Automated and centralized management/LCM of traffic engineering and services/policies in multi-vendor environment, DCI apps, DDoS mitigation, Overriding BGP best-paths, NFV (SFC+NSH to provide vCPE/VNFaaS) (colindixon, 15:21:18)
    10. kevin asks if the traffic engineering stuff is private or open source, answer is it's private at least for now (colindixon, 15:23:03)
    11. kevin asks about BGP use case, tencent seems to have issues with ~1M routes and memory issues, also with clustering (colindixon, 15:24:24)
    12. Johan notes that they have hit bumps, but they haven't been showstoppers so far (colindixon, 15:24:42)
    13. talks about the TransportPCE project (currently proposed and scheduled for a creation review on the 5/26 TSC meeting) (colindixon, 15:28:14)
    14. Aim of TransportPCE: aid in the realization of multi-layer transport uses cases using OpenDaylight (colindixon, 15:28:39)
    15. there's discussion about whether having code discussions on the call is a good idea, there's one idea of having it on this call, another idea is to have a spawned out group more interested in the code, for now Chris Luke decides to kick off an e-mail on the mailing list (colindixon, 15:34:27)
    16. ACTION: Chris Luke to start an e-mail about the BPG code and AG needs (colindixon, 15:36:52)

  3. TSC update (colindixon, 15:36:57)
    1. colindixon provides an overview of new Projects (CaseyODL, 15:46:21)
    2. colindixon announces major new functionality. (CaseyODL, 15:47:29)
    3. OpenFlow will have a new design that significantly improves performance. It will be shipped in Beryllium, but will not be default. (CaseyODL, 15:48:13)
    4. There is a possibility of moving to RESTCONF Draft 11, but this will likely be differed to next release. (CaseyODL, 15:49:09)
    5. Support for Devices without NETCONF monitoring. (CaseyODL, 15:49:47)
    6. the implementation of YANG binding v2 will be available, but will not be the default until a later release. (CaseyODL, 15:50:32)
    7. colindixon explains that we are working on improving upgrades (CaseyODL, 15:52:23)
    8. We are strongly considering moving to a new Docs toolchain. AsciiDoc to ReStructed Text (CaseyODL, 15:54:56)
    9. colindixon spoke about Usability. In addition to NETCCONF support and documentation improvements, we are also working on improving the log message database. (CaseyODL, 15:57:21)


Meeting ended at 16:01:22 UTC (full logs).

Action items

  1. colindixon to figure out what the situation with BGP speakers in clustering is with best practices
  2. Chris Luke to start an e-mail about the BPG code and AG needs


Action items, by person

  1. colindixon
    1. colindixon to figure out what the situation with BGP speakers in clustering is with best practices


People present (lines said)

  1. colindixon (23)
  2. CaseyODL (11)
  3. odl_meetbot (4)
  4. gzhao (1)


Generated by MeetBot 0.1.4.