#opendaylight-users: March AG Meeting

Meeting started by CaseyODL at 15:08:51 UTC (full logs).

Meeting summary

    1. roll call was conducted by Neela Jacques (CaseyODL, 15:09:17)
    2. Allen from Tencent started his presentation to the AG group. (CaseyODL, 15:10:15)
    3. Tencent is using ODL as a BGP router to address best link routes. (CaseyODL, 15:13:18)
    4. Carlos asked what else was being calculated besides the AS path? (CaseyODL, 15:15:33)
    5. Besides calculating the shortest AS path, they also adjust for latency. (CaseyODL, 15:18:03)
    6. A question was asked if polling mechanisms were used. Particularly IGMP access polling. (CaseyODL, 15:20:20)
    7. Allen was not sure if IGMP was being used. (CaseyODL, 15:21:57)
    8. After a short discussion, the AG group agreed that using a centralized algorithm to solve the BGP preferred routes. This is normally solved by 3rd parties. What Tencent is doing is potentially very exciting by using a brute force method. (CaseyODL, 15:25:39)
    9. Chris thought that this was a very aggressive method for resolving the preferred routes when other ISPs offer differentiated routes. (CaseyODL, 15:27:32)
    10. Jamil thought from a monitoring and topology management standpoint, using ODL here is an excellent idea. (CaseyODL, 15:28:45)
    11. Carlos If I'm under a DDoS attack, this method would be very effective for re-routing attacking traffic to a honeypot. (CaseyODL, 15:30:11)
    12. Dave said that the ability to manipulate this traffic in this fashion is an excellent idea and asked if any clustering was being used. (CaseyODL, 15:31:42)
    13. Not yet. There is a separate BPG session on each node. (CaseyODL, 15:32:11)
    14. Chris: How does ODL handle this? (CaseyODL, 15:32:30)
    15. Dave: Currently ODL works the same way, I've put in a request to the team to address this issue. (CaseyODL, 15:32:55)
    16. Chris to Allen, are you willing to open source the application that you are presenting? (CaseyODL, 15:33:33)
    17. Allen: We may not be able to open source this particular code. (CaseyODL, 15:33:50)
    18. Chris, I wouldn't want you to release anything proprietary. But I'd love to see the algorithm that you use. (CaseyODL, 15:34:43)
    19. Allen: we can discuss this at another time. (CaseyODL, 15:35:05)
    20. Chris the presentations that we've had has been great. But maybe we can start looking at code examples to help others to get started. (CaseyODL, 15:36:01)
    21. Dave: AT&T would love to participate in something like this. (CaseyODL, 15:36:22)
    22. Allen continued his presentation with examples of how the BGP modeling works. (CaseyODL, 15:38:57)
    23. ACTION: ODL to look into how we can have a BGP Route Optimization discussion at ODL Summit. (CaseyODL, 15:42:43)
    24. Chris, how do you filter? (CaseyODL, 15:43:43)
    25. Allen: By checking to see if the route is the same. (CaseyODL, 15:43:58)
    26. Alex: Do we have projects in ODL that could used host the code for consolidating some if this work? (CaseyODL, 15:45:10)
    27. Dave: This could probably live in an app (CaseyODL, 15:45:28)
    28. Neela: Is this a Dev Design topic or something that needs to be in a working group? (CaseyODL, 15:45:53)
    29. Chris: This is something that we should potentially start working on now. (CaseyODL, 15:46:53)
    30. John B would be interested in participating. (CaseyODL, 15:47:32)
    31. China Mobile would get back to us (CaseyODL, 15:47:45)
    32. Most of the AG members mentioned that they would be interested in working closely together on this. (CaseyODL, 15:48:20)
    33. ACTION: ODL staff to start a thread to coordinate a working group for BGP route optimization. (CaseyODL, 15:49:04)
    34. Dave: We are also working with the BGP team to get route path added. (CaseyODL, 15:49:55)
    35. Carlos: It would be good to have benchmarks of network segments based on the environment. (CaseyODL, 15:51:37)
    36. ACTION: Casey to request performance team to look into the possibly providing specific examples based on the equipment and hardware benchmark numbers. (CaseyODL, 15:53:25)
    37. Neela asked the AG to review the current performance remote that ODL published and provide thier feedback about what we did right, wrong and how we can improved. (CaseyODL, 15:55:16)
    38. Carlos: Perception is the limitation of adoption. People have been discounting SDN based on perceptions. I'd like to see us work towards resolving these issues. (CaseyODL, 15:56:51)
    39. Neela: Beau has been working very hard at this. (CaseyODL, 15:57:18)
    40. Neela: We recently had a board meeting. We had a number of discussions particularly around performance. Neela wants everyone to know that this will be an ongoing effort and would love continued feedback from the AG. We are also aware of the need to resolve our documentation needs. We are looking at investing in this area. (CaseyODL, 15:59:37)
    41. Neela: if and where you can, please provide feedback and support with the documenation. (CaseyODL, 16:00:49)
    42. Beau I would love access to the getting started guide. (CaseyODL, 16:01:33)
    43. ACTION: Casey will get the Getting Started Guide to the AG. (CaseyODL, 16:01:54)
    44. Where is the API guide and service install guide? (CaseyODL, 16:02:48)
    45. Neela: Our Documentation group isn't specifically there to write the documentation but to plan and orchestrate the documentation. Please feel free to join that group. (CaseyODL, 16:03:45)
    46. ACTION: Casey to invite AG to the Documentation meetings. (CaseyODL, 16:05:50)


Meeting ended at 16:05:56 UTC (full logs).

Action items

  1. ODL to look into how we can have a BGP Route Optimization discussion at ODL Summit.
  2. ODL staff to start a thread to coordinate a working group for BGP route optimization.
  3. Casey to request performance team to look into the possibly providing specific examples based on the equipment and hardware benchmark numbers.
  4. Casey will get the Getting Started Guide to the AG.
  5. Casey to invite AG to the Documentation meetings.


People present (lines said)

  1. CaseyODL (53)
  2. odl_meetbot (5)


Generated by MeetBot 0.1.4.