#opendaylight-users: advisory_group

Meeting started by CaseyODL at 15:07:42 UTC (full logs).

Meeting summary

  1. Update from Phil (CaseyODL, 15:08:47)
    1. Mr. Jacques has moved on to Bain Capitol. Phil is now the Interim Director and VP of Networking at Linux Foundation (CaseyODL, 15:10:35)
    2. Carbon is due to release on schedule. (CaseyODL, 15:10:50)
    3. The TSC is investigating moving to a 6 month fixed release schedule. (CaseyODL, 15:11:35)
    4. We have talked at length about semantic versioning. We have about 60 projects in any given release. We have also looked at a almost continuous release. Building that flexibility our first priority in our release processes. (CaseyODL, 15:16:14)
    5. Chris asked if ODL has considered always updating to the latest version of karaf at every update. (CaseyODL, 15:19:26)
    6. Colin We have considered it, but it adds a level of complexity and compatibility with other dependencies. (CaseyODL, 15:20:47)
    7. Phil: We are scheduled to meet with OPNFV TSC to discuss with them what timeline would work best with them if we were to try to sync our release to theirs. (CaseyODL, 15:23:53)
    8. Phil asks what release schedule works best for the members of the AG. (CaseyODL, 15:25:29)
    9. Brian: We generally try to update to the latest releases but sometimes we are hindered by the level of complexity which slows that down. (CaseyODL, 15:27:41)
    10. Will Karaf have dramatically different features? (CaseyODL, 15:28:01)
    11. Colin: Not that should dramatically affect you. (CaseyODL, 15:28:31)
    12. We are also helping to improve the ability to perform Upgrades. (CaseyODL, 15:29:17)
    13. The problem is that there are some projects are experimental which may not have release compatibly. (CaseyODL, 15:30:30)
    14. Brian: How many people are using the experimental features. (CaseyODL, 15:31:11)
    15. Colin: Some people are using SNMP. (CaseyODL, 15:31:31)
    16. Phil: Who here is using SNMP? (CaseyODL, 15:31:44)
    17. *Nobody answered (CaseyODL, 15:31:57)
    18. There are some discussions about asking customers to allow a telemetry ping to tell us that you've installed ODL and what features you are using. But we recognize that it isn't realistic. (CaseyODL, 15:36:17)
    19. We could also consider doing user surveys to poll users. (CaseyODL, 15:39:49)

  2. SDWAN (CaseyODL, 15:40:58)
    1. Phil: I'd like to see this group to start looking how they can use SDN to provide better solutions for your customers by exploring use-cases. (CaseyODL, 15:42:51)
    2. SDWAN is just an example use case that we could explore as a possible solution. (CaseyODL, 15:43:57)
    3. How will we structure the use-case discussions? (CaseyODL, 15:44:31)
    4. Phil: We can ask at the end of each meeting what we will discuss each month. (CaseyODL, 15:45:24)
    5. It could be time bound. (CaseyODL, 15:45:44)
    6. Sharing user experiences is still important. But I think exploring use cases and answering specific questions will help this group more. (CaseyODL, 15:47:12)
    7. Brian: It would also be helpful that we have a 1 month advance topic notice with a reminder. (CaseyODL, 15:47:49)
    8. ACTION: Casey will open topic discussion on the Friday following the meetings and send a reminder email about the AG meeting on the Monday before the meeting. (CaseyODL, 15:48:59)
    9. It would also be nice if sometime the development community of a given topic can come to the meeting so that we can provide direct feedback. (CaseyODL, 15:50:14)

  3. OpenDaylight summit (colindixon, 15:56:18)
    1. phrobb and colindixon note that there will be on OpenDaylight summit this year, so it woudl be good to know where the user community would like to see more OpenDaylight presnece in other events to make up for that (colindixon, 15:56:33)
    2. phrobb notes that this is part of a broader shift in the LF to have a few more cross-project events, obviously ONS focusing on User stuff, use cases, less tech for tech's sake and interals (colindixon, 15:57:09)
    3. looking to have a fall event that is a bit more interally focused with cross-project collaboration, some internal tech focus, and the like (colindixon, 15:57:38)
    4. as we're halfway through that process, this year is odd, there won't be an OpenDaylight summit, there will be an OPNFV summit in June (colindixon, 15:58:09)
    5. phrobb asks where else would help to have OpenDaylight present? (colindixon, 15:59:09)
    6. Dan B says more involvement in the IETF would help (colindixon, 15:59:25)
    7. Brian Freeman says they want to be able to send their deevelopers to work with key OpenDaylight developers, phrobb notes that DDFs are still working (colindixon, 16:00:34)
    8. BrianF further notes that there's no boot camp like thing, they miss that, having something or anything in the northeast would help (colindixon, 16:00:52)
    9. phrobb had pointed out that we're looking to do more local events and smaller opendaylight days, somewhat like the thing we did in China is more of a focus than a huge single event (colindixon, 16:01:28)
    10. ACTION: phrobb to put together an ODL user group meetin ageda for ONS (colindixon, 16:02:30)


Meeting ended at 16:03:58 UTC (full logs).

Action items

  1. Casey will open topic discussion on the Friday following the meetings and send a reminder email about the AG meeting on the Monday before the meeting.
  2. phrobb to put together an ODL user group meetin ageda for ONS


People present (lines said)

  1. CaseyODL (41)
  2. colindixon (14)
  3. odl_meetbot (4)


Generated by MeetBot 0.1.4.