17:00:33 <bobmon01> #startmeeting Dec10
17:00:33 <collabot> Meeting started Thu Dec 10 17:00:33 2015 UTC.  The chair is bobmon01. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:33 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:00:33 <collabot> The meeting name has been set to 'dec10'
17:03:34 <bin_> #info Bin Hu
17:06:50 <bobmon01> Joe give Lab update after week in Stockholm with Enea Lab team
17:07:46 <bobmon01> OpenStack exercise to get running was run this week
17:08:04 <bobmon01> had to rebuild Mirantis Openstack for ARM
17:09:14 <bobmon01> QEMU version coming from the repo was an old version
17:09:57 <bobmon01> Enea had been using in house a newer version previously
17:10:12 <bobmon01> Openstack is running on the Cavium
17:10:48 <bobmon01> But starting up KVM VMs is where they run into issues with Qemu
17:14:31 <bin_> #info The effort of creating and populating Mirantis OpenStack for ARM took about 1.5 weeks of 1.5 staff
17:15:12 <bobmon01> #info Bob Monkman
17:15:23 <bobmon01> #info Joe Kidder
17:15:27 <bin_> #info plus 50% overhead, because every staff was quite stretched out. So totally about 3.5 staff-week
17:15:47 <bin_> #info the most of time was spent on figuring out how to do it.
17:16:03 <bobmon01> #info Kin-Yip Liu
17:16:08 <bin_> #info once we know the recipe, it is quite straightforward to do it
17:16:46 <bin_> #info for example, installing Fuel OpenStack may only take a few hours, if everything works well
17:17:52 <bobmon01> #action Joe to clarify with his team where Fuel is getting components from
17:17:58 <bin_> #info we expect that it will take much fewer staff-days to repeat the same procedure on another lab with the same type of hardware and similar configuration
17:19:07 <bobmon01> Michael Rooke asks if Cavium Ubuntu is custom
17:19:40 <collabot> bin_: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
17:20:08 <bobmon01> Prasun from Cavium believes it is just ISO image for the base Linux
17:21:41 <bobmon01> Device drivers, NUMA support are still in upstreaming process, internal to kernel
17:25:58 <bobmon01> Everyone agrees that the upsteaming of the kernel for ARM servers is crucial
17:26:35 <bobmon01> Bob asks if Cavium team and Enea team need to work together more closely to make more progress
17:27:45 <bobmon01> Prasun 's team is also working in parallel in to bring up Openstack in their own lab and could probably help make progress in the Enea Lab
17:29:51 <bobmon01> Joe and Prasun agreed to get a collaboration effort going full force. Upgrading firmware and kernel versions are a first step
17:33:01 <bobmon01> Jon reiterates that it is really important for deployments that there are standard versions in place for UEFI, Kernel 4.2 etc becuase everything falls into place much better with fewer hacks
17:35:10 <bobmon01> ACPI also discussed and Prasun simply noted that there are dependencies in kernel community that are outside of our control and we need to balance with the need to get OPNFV stack running on ARM
17:39:17 <bobmon01> #action Joe and Prasun
17:42:45 <bobmon01> Functest familiarization is already underway in parallel and so that will be next once the Fuel installation is completed.
17:43:55 <bobmon01> next meeting is Friday Dec18
17:44:01 <bobmon01> #endmeeting