#opnfv-armband: armband 18Mar2016

Meeting started by bobmon01 at 14:11:00 UTC (full logs).

Meeting summary

    1. bob Monkman (bobmon01, 14:11:09)
    2. Stan Kardach (Cavium) (StanKardach, 14:11:32)
    3. Mike Holmes (MikeHolmes, 14:11:33)
    4. Alexandru Avadanii (Enea) (AlexAvadanii, 14:11:39)
    5. Florin Dumitrascu (florind, 14:11:45)
    6. Joe Kidder (joekidder_, 14:11:47)
    7. puppet scripts completed for installing ODL to handle manually (bobmon01, 14:12:45)
    8. ODL depends on a library for cluster db and ODL pulls in an x86 dependent and so we have to manually install with puppet scripts (bobmon01, 14:14:42)
    9. we build our own ARM version of library and manually install thru puppet scripts to start ODL service (bobmon01, 14:15:57)
    10. still seeing an intermittent issue where ODL stalls but other times it starts fine. (bobmon01, 14:16:47)
    11. so we know it works but need to determine the occasional failure (bobmon01, 14:17:05)
    12. basically we need to have direct kernel boot for cirros (StanKardach, 14:18:06)
    13. found another bug, which is fixed, related to the cirrus image (bobmon01, 14:18:09)
    14. it is required to boot machines on arm64. In the change implementing the direct boot mechanism I've made several mistakes in terms of code and image formats. I've fixed it, tested manually and now am applying it to fuel master for automation (StanKardach, 14:19:46)
    15. thanks Stan (bobmon01, 14:20:06)
    16. Ciprian is not on the call and so we do not have an update on FuncTest (bobmon01, 14:24:29)
    17. there are still nice things that are not mandatory, but easy to add, and we plan to; like UEFI (EFK2) fw support for guest VMs (AlexAvadanii, 14:25:08)
    18. ACTION: Joe to chase down update on Functest (bobmon01, 14:25:09)
    19. ACTION: we have a quorom on approving 3 new committers and Bob will send the request to IT. (bobmon01, 14:30:15)
    20. https://build.opnfv.org/ci/computer/arm-pod1/ (AlexAvadanii, 14:33:26)
    21. https://build.opnfv.org/ci/computer/arm-build1/ (AlexAvadanii, 14:33:35)
    22. Jenkins is in the works, Josep created the slaves and an internal master, we are still configuring some stuff (AlexAvadanii, 14:34:12)
    23. http://linux.enea.com/mos-repos/ (AlexAvadanii, 14:42:55)
    24. this is very, very similar to official fuel-infra mirrors, but has arm64 packages too, including a linux-lts-trusty kernel for aarch64 (AlexAvadanii, 14:43:33)
    25. also newer libvirt for armv8 support, and qemu 2.5 (AlexAvadanii, 14:43:59)
    26. the team are working with fathi to get all Jenkins slaves set up for CI (bobmon01, 14:46:29)
    27. ACTION: Joe' steam will work with other labs to begin to hand over deployment artifacts and instructions to replicate the ARM pod configuration (bobmon01, 14:55:53)
    28. http://pasteboard.co/2mm6pZ5B.png (AlexAvadanii, 14:58:20)
    29. Ciprian arrived and reports that he is pushing some fixes into Functest tests (bobmon01, 14:58:29)
    30. http://pasteboard.co/2mm8UHMR.png (AlexAvadanii, 14:58:45)
    31. Ciprian plans to working on a Fuel 8 deployment any day now- needs help in setup of a Fuel Master (bobmon01, 15:00:58)
    32. then Functest on Brahamaputra components will proceed. (bobmon01, 15:01:35)


Meeting ended at 15:03:36 UTC (full logs).

Action items

  1. Joe to chase down update on Functest
  2. we have a quorom on approving 3 new committers and Bob will send the request to IT.
  3. Joe' steam will work with other labs to begin to hand over deployment artifacts and instructions to replicate the ARM pod configuration


People present (lines said)

  1. bobmon01 (22)
  2. AlexAvadanii (14)
  3. StanKardach (9)
  4. collabot` (3)
  5. florind (1)
  6. joekidder_ (1)
  7. MikeHolmes (1)


Generated by MeetBot 0.1.4.