14:14:06 <bobmonkman> #startmeeting armbandMarch25
14:14:06 <collabot`> Meeting started Fri Mar 25 14:14:06 2016 UTC.  The chair is bobmonkman. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:14:06 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:14:06 <collabot`> The meeting name has been set to 'armbandmarch25'
14:14:12 <joekidder> just do IRC?  that can work...just have to be patient when a question is asked...to wait for the answer;)
14:14:15 <bin_> it was 6am PST before DST
14:14:20 <AlexAvadanii1> #info Alex Avadanii (Enea)
14:14:21 <bobmonkman> Let's proceed on IRC only today
14:14:40 <bin_> Now it is 7am PDT, which conflicts with our meeting
14:14:43 <bobmonkman> I just want a quick update anyways as it is holiday for many
14:15:14 <bobmonkman> I will work it out with Dovetail next week
14:15:46 <AlexAvadanii1> #info latest ISO built from our repos deploys and passes ostf (self-tests) on non-HA setup, with ODL; HA setup is currently redeployed, seems to work fine too so far
14:15:49 <bin_> They said they would move the meeting back to 6am PDT, which would be 13:00UTC
14:15:51 <bobmonkman> #info Can Enea give an update on B-release deployment
14:15:58 <bin_> starting from next week
14:16:25 <AlexAvadanii1> #info we are able to able launch VMs without any manual intervention
14:16:53 <AlexAvadanii1> #info still refining some UX stuff, like web-browser VNC, or misleading failing tests
14:17:01 <bobmonkman> #info Joe, please confirm that Brahameputr deploy HA scenario with SDN works fine
14:17:19 <joekidder> #info the HA deploy has ODL, does it not?
14:17:25 <AlexAvadanii1> #info there are some expected fails with HA self-tests, since gic v3 does not yet support migrate (not upstream in kernel, nor in qemu for now)
14:17:41 <AlexAvadanii1> #info joekidder: yes, HA deploy with ODL, what is left testing there is ceph
14:17:53 <joekidder> #info thanks, alex.
14:18:05 <bobmonkman> #info wel I think HA is orthogonal to ODL or no ODL
14:18:52 <bobmonkman> #info team, i believe this means we can declare that Brahamutra reference stack on ARM officially deploys!!!
14:19:04 <AlexAvadanii1> #info if you were to grab the latest armband git repo and the latest linux.enea.com packages, you should get a fully working ISO; some minor patches are still refined, but they do not prevent a succeful deploy with Fuel
14:19:27 <bobmonkman> #info Testing phase now and congrats to the team
14:19:35 <AlexAvadanii1> bobmonkman: I would wait a few more days to bring in the new patches
14:19:40 <AlexAvadanii1> and properly run functest
14:20:09 <AlexAvadanii1> bobmonkman: but the B release has been deploying and working for a few days now, Joe tested a few VMs on it during last weekend
14:20:13 <bobmonkman> #info yes, we still need to run functest and assess the results, but the deloy is working. Great milestone
14:20:29 <StanKardach> and we need to push all that code to gerrit, it's still in my gitlab repo
14:20:34 <bobmonkman> #info the rest of the team may not have known this earlier
14:20:45 <AlexAvadanii1> StanKardach: actually, Florin synced 2 days ago, we are 2-3 patches behind
14:20:58 <StanKardach> yes, I know, I've prepared the patch
14:21:04 <StanKardach> I mean those 2-3 patches :)
14:21:27 <bobmonkman> #info so what does pushing to gerrit mean? Please elaborate
14:21:42 <joekidder> josep: can you try the jenkins build and deploy jobs with what's in the armband git repo?
14:22:06 <joekidder> bob's question first.
14:22:15 <StanKardach> #info Currently we are working on gitlab repository that I've created. From time to time we're pushing to opnfv gerrit when we have quasi-stable state
14:22:25 <AlexAvadanii1> #info we used an internal repo, which we migrated to armband repo (gerrit) as squashed patch-sets
14:22:47 <AlexAvadanii1> #info current armband repo is 2-3 commits behind internal repo, mostly fixing UX issues
14:22:49 <StanKardach> and as I still don't have commit rights for opnfv gerrit, it is easier for us all to work there
14:22:59 <josep> joekidder: ok
14:23:08 <bobmonkman> #info OK, so bringing into an opnfv established repo...thank you
14:23:13 <AlexAvadanii1> #info yes, please give Stan rights to armband, this is why gerrit is lagging :)
14:23:58 <joekidder> #info bob - do you need me to re-send you and aric (?) the committer votes?  I have them in my inbox (the votes were all public, so I'm not sure what the issue is).
14:24:29 <bobmonkman> #info apologies. I have opened to ticket to reflect the vote, but the project has asked for the email approval trail, which I will do today, then Stan will be official committer along with other two
14:24:33 <AlexAvadanii1> #info anyone using linux.enea.com: keep in mind this is Amazon EC2, if you can use a local mirror of that, we would greatly appreciate it, thank you
14:25:07 <bobmonkman> joe, I have them, I will do it right after our meeting
14:25:18 <StanKardach> #info We'd need official space to host all the packages that we've prepared. EC2 is not the most cost-effective way
14:26:48 <bobmonkman> #info Can I please get an update on connecting to Jenkins? How is that process going?
14:28:00 <joekidder> #info josep: can you give jenkins update?
14:28:33 * josep is typing
14:29:28 <josep> #info bobmonkman: there are two tracks, deploy and buiild. I have been looking at the different configuration files required for deployments, but I am not there yet
14:30:54 <bobmonkman> #info Josep: So do you have what you need to keep going or is there a blocker?
14:31:49 <josep> #info bobmonkman: I'll need help from fuel
14:32:34 <josep> #info bobmonkman: but I don't see any obvious blockers (except maybe that the deploy script uses ipmitool, which won't work great on some targets)
14:33:01 <josep> #info but I have not come that far yet to tell
14:33:03 <bobmonkman> #info OK, Joe I assume can help facilitate that and then do we have any idea of how long we expect the process to be to get started tetsing under Jenkins?
14:33:14 <AlexAvadanii1> #info some aarch64 "servers" do not support out-of-band power control - e.g. APM
14:34:18 <bobmonkman> #info @Alex: so is there a way around such limiitations as cannot run ipmi on a given box?
14:36:05 <bobmonkman> #info I want to get some sort of estimate as to when we could be ready with Jenkins, please
14:36:11 <joekidder> #info simple workaround is a network power switch, as that's what most of ipmi is used for (I believe) in this setup - to reboot machines.
14:36:23 <bobmonkman> #info Can we get a Functest update as well?
14:36:56 <AlexAvadanii1> #info bobmonkman: in our case, we might have something, as we use some powercontrollers that support SNMP, and we can power-on/off the targets with those, but it's not a universal solution
14:37:06 <josep> #info bobmonkman: as far as I've seen, the deploy script powers on/off the targets, and uses ipmi for that. It also sets the default boot order this way
14:37:59 <josep> #info for virtual deployments it uses libvirt, though (there is a class abstracting all this)
14:38:00 <bobmonkman> #info, so it appears we wil have to request a change to the deploy scripts for targets that do not support ipmi
14:38:50 <josep> #info this is something we could contribute if necessary, I believe
14:38:53 <AlexAvadanii1> #info there is no workaround for boot order though, not without adding a serial controller to the setup, which again, we do have in our lab, but not an universal solution
14:40:16 <bobmonkman> #info...ok something to note as to how to work with Octopus team or whomever to decide how to handle power cycle and boot order more generically
14:40:46 <bobmonkman> Is someone able to talk about Functest status?
14:40:48 <josep> #info bobmonkman: hard to give a time estimate for jenkins, but not by next week
14:41:29 <bobmonkman> #info OK, josep....we will revisit in 2 weeks. No meeting next week due to holiday break.
14:41:45 <josep> ok
14:41:59 <bobmonkman> Functest?
14:42:06 <bobmonkman> Ciprian?
14:43:39 <joekidder> ciprian-barbu: can you give status on functest?
14:45:05 <ciprian-barbu> joekidder: unfortunately I had near zero success in running on Fuel 8, I had multiple problems in my way
14:45:25 <ciprian-barbu> I encountered a few bugs as well, I had to spent time debugging
14:45:58 <bobmonkman> #info,, Ciprian please use #info so we capture in minutes bot
14:45:59 <ciprian-barbu> I had a problem with the network setup in the lab, I could only run functest on POD1, which turns out has a problem with libvirt
14:46:02 <joekidder> can you put "#info" in front to get status into log please?
14:46:11 <joekidder> thanks.
14:46:16 <ciprian-barbu> #info unfortunately I had near zero success in running on Fuel 8, I had multiple problems in my way
14:46:23 <ciprian-barbu> #info I encountered a few bugs as well, I had to spent time debugging
14:46:33 <ciprian-barbu> #info I had a problem with the network setup in the lab, I could only run functest on POD1, which turns out has a problem with libvirt
14:47:05 <bobmonkman> #info I thought the libvirt problem was solved?
14:47:09 <ciprian-barbu> #info yesterday Magnus from IT solved the connectivity problem to POD2, so I managed to actually start working on that
14:47:22 <ciprian-barbu> bobmonkman: it wasn't deployed on POD1
14:47:37 <ciprian-barbu> bobmonkman: and I couldn't run on POD2 until today
14:47:55 <ciprian-barbu> ${repos_dir}/functest/docker/run_tests.sh --test vping_ssh
14:48:02 <ciprian-barbu> sorry, not here
14:48:22 <ciprian-barbu> #info I am continuing with this, I've been delayed so far
14:48:33 <bobmonkman> #info to be clear, Ciprian, you are seeing failures on Functest, when running Fuel 8 based deploy, that you were not seeing before on Fuel 6?
14:49:26 <ciprian-barbu> #info no, there were a few minor things, keystone client has been deprecated and that was an easy fix
14:49:48 <ciprian-barbu> #info but in fact I wasn't able to run functest at all on Fuel 8
14:50:52 <ciprian-barbu> #info in fact, I tried to run, but I bumped into this issue that seems like libvirt related
14:51:04 <ciprian-barbu> #info I'm not 100% sure about it, could be something else
14:51:57 <bobmonkman> #info OK, team, lets cme up with a plan for the next 2 weeks to help find out why Functest will not run. This is central to connecting to Jenkins and being in CI loop
14:52:49 <bobmonkman> #info Joe, can you please work with the team to get on top of this?
14:52:56 <joekidder> #info yep.
14:53:36 <bobmonkman> Ok...any thing else people want to note today? I will get the committer adds and subtracts going today.
14:54:09 <bobmonkman> #action Bob will send IT the committer vote log and committer drop confirmations
14:54:40 <bobmonkman> #action Joe will work with the team to get over Functest issues
14:56:06 <bobmonkman> #info Next team meeting will be 2 weeks from today. I will be out for the holiday week and will check in early in the week of April 4
14:56:12 <StanKardach> #info we would need a bit of help with DHA/DEA files
14:56:40 <StanKardach> #info we can't seem to find documentation on them and they seem vital in understanding how the deployment testing works
14:57:26 <bobmonkman> #info @StanK: Could this be an Octopus item? Fuel?
14:57:31 <josep> fuel
14:58:03 <StanKardach> #info I'm almost sure it's not Mirantis related but rather OPNFV-Fuel related
14:58:24 <StanKardach> #info I'm not sure if it's present in other installers as I'm not familiar with them
14:58:47 <bobmonkman> #info OK, I suggest sending a question to the list asking for help.
14:59:44 <StanKardach> thanks Bob!
15:00:17 <bobmonkman> #action Stan to ask Fuel team for help on documentation of DHA/DEA procedures
15:00:30 <bobmonkman> anything else?
15:00:57 <bobmonkman> I will be able to respond to emails maybe once a day the next week
15:01:15 <bobmonkman> let me know if there is anything super urgent, Joe
15:01:43 <bobmonkman> let's wrap then and c u all in a couple of weeks
15:02:00 <bobmonkman> #endmeeting