14:08:33 <bob_monkman> #startmeeting armband 08April2016
14:08:33 <collabot`> Meeting started Fri Apr  8 14:08:33 2016 UTC.  The chair is bob_monkman. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:08:33 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:08:33 <collabot`> The meeting name has been set to 'armband_08april2016'
14:08:41 <bob_monkman> #info Bob Monkman
14:10:54 <joseppc> #info Josep Puigdemont
14:11:09 <AlexAvadanii> #info Alexandru Avadanii (Enea)
14:11:38 <Vijayendra> #info Vijayendra Radhakrishna (Cavium)
14:13:13 <dali`> #info Dan Lilliehorn (Enea)
14:13:31 <florind> #info Florin Dumitrascu
14:13:47 <bob_monkman> #info Continuous Deployment script for Jenkins had to be created and worked through and this is now ready and should be able to procced with Jenkins now
14:14:28 <bob_monkman> #Functest- There is still a vPing with the configuration of Security Groups. This is being debugged
14:15:36 * fdegir is very excited to see the first automated deployment of OPNFV on ARM from Jenkins!
14:16:00 <florind> Bob, we have solved one blocker issue found for Continuous Deployment and now we are moving further; we cannot say we have it ready for Jenkins yet; need to attempt a new deploy to see if it works
14:17:32 <fdegir> no pressure :)
14:17:44 <bob_monkman> Thank you, Florin...do you have a view towards how many more hurdles we need.
14:18:49 <joseppc> Firstly the lack of IPMI support on some targets. We've solved that by wrapping around a python class to ignore the targets that lacked IPMI support so we could go further.
14:19:03 <joseppc> In the future we will have a POD with nodes that support IPMI so we remove this variable from the equation (next week)
14:19:13 <joseppc> The second issue has been about predictable network interface names. The ethernet interfaces cam up in random order after each boot, which upset the automatic deployment (it expects eth0 to always be the same interface)
14:19:33 <joseppc> This was a blocker florind referred to, because the DEA files tell what network goes to what interface.
14:19:51 <joseppc> We solved that problem yesterday
14:20:03 <bin_> #info Bin Hu
14:20:06 <joseppc> Now we're in the middle of another manual deployment on POD1
14:20:22 <joseppc> we'll gather the DEA/DHA files from there and continue with the automatic deployment
14:21:12 <joseppc> One issue ahead is that the deploy script creates the fuel master on a virtual machine
14:21:38 <joseppc> we're currently running the deploy script in a VM already. We need to tell it where to create the VM
14:22:15 <joseppc> I think this is not very hard to fix (setting the LIBVIRT_DEFAULT_URI environment variable might do)
14:23:03 <joseppc> when we have this in place, we'll make fdegir happy with automatic deployments with jenkins! :)
14:23:42 <fdegir> that's right :)
14:23:43 <joseppc> I think I didn't forget anything...
14:24:25 <bob_monkman> #info Between Arno and B-releae there are changes in Security Groups and this has required work to p=figure out the vping failures
14:24:55 <bob_monkman> #info Functest Rally tests have issues with Cinder volume test
14:27:02 <Madhu> #info Madhukesh (Cavium)
14:27:24 <bob_monkman> #info Tempest tests in OPNFV are about 210+ and we pass > 90% tests.
14:27:58 <bob_monkman> #info Rally estimated around 60% of tests passing
14:33:25 <bob_monkman> #info Team has been communicating with community on vPing
14:34:29 <bob_monkman> #action Team to ask on the list for Cinder problems help.
14:35:04 <bob_monkman> #action Bob to look for OpenStack testing help in other areas
14:36:10 <bob_monkman> #info OPNFV uses Ceph under Cinder to implement volumes
14:37:27 <bob_monkman> #info Ceph requires 3 nodes to support it and the Enea test pod for Functest just got updated with enough nodes to support Ceph
14:41:18 <bob_monkman> #so the new HA 5 node pod will be open next week for testing Functest
14:42:28 <bob_monkman> #info so the new HA 5 node pod will be open next week for testing Functest in parallel with maintaining the deployment Pod
14:43:36 <bob_monkman> #action we need to determine a way to accelrate - the Jenkins connection, the Functest completion
14:48:35 <bob_monkman> #endmeeting