14:02:26 <joekidder> #startmeeting armband-weekly
14:02:26 <collabot> Meeting started Fri Apr 15 14:02:26 2016 UTC.  The chair is joekidder. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:26 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:02:26 <collabot> The meeting name has been set to 'armband_weekly'
14:02:58 <joekidder> #topic roll-call
14:03:04 <joekidder> #info Joe Kidder
14:03:06 <joseppc> #info Josep Puigdemont
14:03:17 <florind> #info Florin Dumitrascu
14:04:39 <joekidder> #info we are on the go to meeting setup if anyone wants to join.  I didn't realize (or forgot) that Bob indicated we might not have the meeting, although he asked me to chair today.
14:04:57 <joekidder> #info so I didn't send out a reminder.
14:07:43 <joekidder> #topic status of ISO
14:08:19 <joekidder> #info currently the velocity of changes to the Fuel ISO for armband has decreased significantly indicating a level of stability
14:08:43 <joekidder> #info there was a change last week to support mongodb (a feature needed for ceilometer)
14:09:26 <joekidder> #info we are currently making some changes related to interface ordering that are needed for predictable/reproducible behavior in automated deployments under Jenkins.
14:10:07 <joekidder> #info all of the work is being done in the public repo (for packages, etc retrieved by Fuel) and in the opnfv-armband git repo.
14:10:24 <joekidder> #topic status of Functest
14:11:17 <joekidder> #info Currently debugging vping-ssh issues.  Sometimes this passes, but after it has run, we see some network misbehavior. We are still characterizing this and investigating.
14:11:32 <AlexAvadanii> #info Alexandru Avadanii (Enea)
14:11:48 <joekidder> #info we are looking at both ODL-L2 and ODL-L3 scenarios to see if there's any difference.
14:11:52 <NokMikeR> #info Mike Rooke
14:13:29 <MikeHolmes> #info Mike Holmes
14:13:33 <AlexAvadanii> joekidder: are you talking? I can't her you
14:13:51 <joekidder> #info tempest passes all tests in nosdn scenario.  Investigating failures (between 2 and 25 failures out of 200) on L2 and L3 scenarios.
14:15:02 <joekidder> #info rally much better...failling heat (seems like an administrative problem) nova (2 out of 12, but migration-related...see following comment), and VM tests related to networking that may be due to network problems introduced by vping-ssh.
14:16:01 <joekidder> #info there are issues with migration due to some support not yet upstreamed, and therefore not consistent across all server platforms.  We do not expect to pass migration tests at this time in a generic setting such as we're aiming for.
14:16:14 <joekidder> #info  we can discuss migration and issues if desired.
14:16:34 <joekidder> #topic status CI/Jenkins
14:17:14 <joekidder> #info we arer stabilizing an all-CaviumThunder pod (due to IPMI availability and its requirement for CI integration).
14:17:47 <joekidder> #info this is up and we're testing manual deployment prior to running automated jenkins deployment.
14:20:16 <AlexAvadanii> #info half the commits in armband repo (gerrit) are now rebases due to upstream repo changes
14:22:50 <joekidder> #info a jenkins build script is ready for discussion/review with fatih from octopus to answer a few questions as well as do some review, as it needs to go to the octopus git rather than armband.
14:23:24 <joekidder> #info the perceived risk/concern around the build script is low - it seems pretty straightforward, and we're focusing on the deploy script.
14:24:04 <joekidder> #topic migration
14:24:59 <joekidder> #info Mike Holmes and Alex discussed the normalization and consolidation of migration needs in the kernel and whether Linaro kernel folks can help with this.
14:25:00 <AlexAvadanii> #info AP Alex (Enea) + Stan (Cavium) to talk with Linaro about GICv3 migration support in upstream kernel / qemu
14:25:31 <AlexAvadanii> #action Alex (Enea) + Stan (Cavium) to talk with Linaro about GICv3 migration support in upstream kernel / qemu
14:27:42 <joekidder> #endmeeting