14:02:33 <[1]JonasB> #startmeeting Fuel daily followup 1
14:02:33 <collabot> Meeting started Fri Apr 10 14:02:33 2015 UTC.  The chair is [1]JonasB. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:33 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:02:33 <collabot> The meeting name has been set to 'fuel_daily_followup_1'
14:02:44 <stefan_berg> #info Stefan Berg
14:03:44 <Szilard> ok
14:03:45 <[1]JonasB> any one knowing Daniel alias?
14:03:56 <[1]JonasB> #info Jonas
14:04:02 <stefan_berg> Hang on.
14:04:16 <Szilard> #info collabot
14:04:45 <stefan_berg> lmcdasm
14:04:51 <stefan_berg> :)
14:05:05 <fdegir> can someone forward daily followup meeting to me please?
14:05:20 <[1]JonasB> Not online
14:05:35 <stefan_berg> Doesn't seem so.
14:05:52 <[1]JonasB> fdegir: Absolutely, I will going forward, sorry.
14:05:58 <fdegir> thanks
14:06:24 <[1]JonasB> Could we start with the issues mskalski is experiencing.
14:06:29 <Szilard> ok
14:06:37 * dfarrell07 is a Daniel, likely not the one you're looking for
14:07:02 <[1]JonasB> #topic Fuel deployment issues
14:07:36 <[1]JonasB> Michal, have you come any further, and have you gotten any env from Daniel?
14:07:55 <mskalski> so today I started deploy opnfv fuel RC0 on lab provided by Jonas
14:08:10 <mskalski> IILO give me only possibility to mount iso from external http resource, which significantly increase time required for installation
14:08:24 <mskalski> When it is done I will deploy controller and compute nodes
14:08:31 <Szilard> there is another way
14:08:45 <[1]JonasB> On the landing server I have installed a webserver
14:08:56 <Szilard> iLO => Remote Console
14:09:04 <Szilard> run the java plug-in
14:09:04 <mskalski> I also tried deploy rc0 on esxi with nested virtualization
14:09:05 <[1]JonasB> so you can place your stuff under public_html
14:09:29 <mskalski> and problems were the same as in virtualbox
14:09:30 <[1]JonasB> Okay what was the result
14:09:41 <[1]JonasB> Oups.
14:10:06 <mskalski> Szilard: i do this exactly in this way
14:10:08 <[1]JonasB> I'm not sure that Daniel deployed RC0
14:10:25 <[1]JonasB> Can you rebuild, maybee RC0 is broken.
14:10:49 <stefan_berg> mskalski: Where does it break down?
14:11:03 <stefan_berg> mskalski: Fuel master installation or at deploy time?
14:11:12 <mskalski> stefan_berg: during ubuntu instalation on controller and compute nodes
14:11:18 <[1]JonasB> #info Michal still have problems deploying, now in the Ericsson Lab.
14:11:41 <mskalski> [1]JonasB: i use rc0 from here http://artifacts.opnfv.org/genesis/fuel/opnfv-32.iso
14:11:53 <stefan_berg> mskalski: And of course you did the /opt/opnfv/pre-deploy.sh thingie before pressing deploy in the GUI? I'm sure you did.
14:12:40 <[1]JonasB> mskalski: Ok, lets assume that is broken, can you rebuild.
14:12:42 <mskalski> stefan_berg: Yes I did, but it broke even before ubuntu is installed so puppet manifest are not run
14:13:31 <stefan_berg> mskalski: OK!
14:13:51 <mskalski> [1]JonasB: i tired to rebuild is on thuesday and problems still existed
14:14:10 <mskalski> I don't now if there are even additional commits from this time
14:14:24 <[1]JonasB> szilard: Have you deployed recently?
14:14:32 <stefan_berg> [1]JonasB: And that one is a known good build, you've tried it? Maybe we should all try that one to find out if it's a build or deploy issue.
14:14:58 <Szilard> no I'm setting up my work environment on Blade 4
14:15:19 <Szilard> and also I'm playing with the HP Hardware Adapter
14:15:39 <Szilard> will push the code this evening
14:16:16 <[1]JonasB> stefan-berg: No I havn't tried it, but as understan Daniel have tried it. Maybe you could try it. I dont like that we have inconsistent results.
14:17:00 <mskalski> we should try use the same ISO i propose to use official rc0: http://artifacts.opnfv.org/genesis/fuel/opnfv-32.iso
14:17:39 <Szilard> guys, question, which blades are you guys using on the HP server
14:18:02 <Szilard> do we have a table, where we have accountancy of who is using which blade
14:18:03 <[1]JonasB> stefan-berg: Can you try to deploy rc0?
14:18:14 <stefan_berg> [1]JonasB: Spinning it up during the weekend. If it's OK, building fresh and spinning that up.
14:18:25 <mskalski> Szilard:  for now I'm installing fuel on blase in bay 2
14:18:32 <mskalski> *blade
14:18:34 <Szilard> yes I can see that :)
14:18:51 <[1]JonasB> #action Stefan B will try to deploy RC0
14:19:13 <Szilard> mskalski: and you will need two more blades, 1 for compute and another for controller
14:19:19 <[1]JonasB> So next autodeploy
14:19:29 <mskalski> Szilard: yes let say 3 and 4
14:19:34 <[1]JonasB> #topic autodeploy status
14:19:57 <[1]JonasB> Szilard: where do you stand?
14:20:03 <mskalski> Szilard: 2 blades in bay 3 and 4
14:21:00 <Szilard> [1]JonasB: I'm moving and testing code from 15B with the HP hardware adapter, so that other's can use it as a reference
14:21:45 <Szilard> [1]JonasB: I also tried to find out where to modify the Fuel IP address, but no success yet, got lost in the build scripts :)
14:22:22 <[1]JonasB> Szilard: How far away do you think you are from a deploy on HP?
14:22:34 <mskalski> Szilard: did you tried https://github.com/stackforge/fuel-main/blob/master/iso/isolinux/isolinux.cfg and https://github.com/stackforge/fuel-web/blob/master/fuelmenu/fuelmenu/settings.yaml ?
14:22:36 <stefan_berg> Szilard: Let's discuss that Monday.
14:23:01 <Szilard> [1]JonasB: and I'm trying to create a virtlib environment where I can have 3 VMs, 1 for fuel, and 2 others for controller and compute
14:23:01 <stefan_berg> Szilard: (Changing IP that is). I have some ideas on serial console control for the install (testing that in libvirt).
14:23:36 <Szilard> mskalski: no,  but thanks I will try it :)
14:23:42 <[1]JonasB> szilard: Great.
14:24:08 <[1]JonasB> stefan_berg: Stefan how is it going with libvirt?
14:24:57 <stefan_berg> Doing experimentation. No problem starting and stopping obviously, now trying out scripting the ISO install from Python through the serial console.
14:25:21 <Szilard> [1]JonasB: I finish importing and testing the HP Hardware Adapter, I'm close to the end, and then I continue with the fuel automation code
14:25:26 <[1]JonasB> stefan_berg: great.
14:25:40 <stefan_berg> The thinking is that this would be a generic way to setup boot parameters for Fuel, and also to orchestrate the bootup of controllers of computes so that they get the correct ordering in Fuel.
14:25:50 <[1]JonasB> Finaly, lets discuss how we devide the POD between us.
14:26:02 <[1]JonasB> #topic Lab allocation
14:26:33 <Szilard> [1]JonasB: good idea, I already  started to install on blade 4, but I'll move on to some other one, Michal needs it :)
14:27:02 <mskalski> I think that in the current infrastructure we can't have more then one fuel master node
14:27:10 <[1]JonasB> So I lost Radar contact with lmcdasm (dan) yesturday, he was going to work on the lab, but I dont know the status.
14:27:10 <mskalski> because of dhcp
14:27:44 <Szilard> mskalski: gosh you're right, offff
14:27:58 <mskalski> probably we should split this lab somehowe
14:28:00 * stefan_berg is not using the POD, have my own rig.
14:28:29 <[1]JonasB> mskalski: yes that is probably true unless we run virtualized and set up internal networks.
14:28:33 <mskalski> I can also use my esxi lab but wanted to check if rc0 deploy on bare metal
14:28:47 <Szilard> mskalski: isolation with VLANs
14:29:53 <mskalski> Szilard: yes it probably this only one option here
14:31:41 <mskalski> do we have someone who can create this network conifguration for us on switch?
14:31:48 <[1]JonasB> So I propose mskalski gets blade 2-4 and szilard gets 5-7 and we use vlan separation for the admin network.
14:32:21 <[1]JonasB> Would that be OK?
14:32:32 <mskalski> for me yes
14:32:33 <Szilard> I also need a blade as build server and other stuff blade 8 if possible
14:33:00 <[1]JonasB> Szilard: granted
14:33:08 <Szilard> [1]JonasB: thanks :)
14:33:21 <[1]JonasB> #info mskalski gets blade 2-4 and szilard gets 5-8 and we use vlan separation for the admin network.
14:33:33 <[1]JonasB> Anything more for today?
14:33:39 <fdegir> Szilard: what you mean with build serrver?
14:33:41 <Szilard> [1]JonasB: deal!
14:34:06 <[1]JonasB> fdegir: I asume private buildserver
14:34:11 <Szilard> fdegir: just to have a server where I can build my stuff, and maybe setup some virtlib ennvironment, my own playground
14:34:16 <fdegir> ok
14:34:21 <fdegir> so you're not taking my server :D
14:34:28 <mskalski> but we need to configure vlans on switch
14:36:40 <Szilard> somebody know the username password for the switch ?
14:36:56 <Szilard> [1]JonasB: maybe Jonas ?
14:37:10 <mskalski> hmm
14:37:12 <mskalski> ssh ericsson:2001@192.168.0.1
14:37:36 <Szilard> mskalski: wow how did you find out ?
14:38:00 <Szilard> https://wiki.opnfv.org/get_started/ericsson_hosting
14:38:01 <mskalski> Szilard: Jonas send me a document
14:38:01 <[1]JonasB> mskalski: vlan 1000-1200 are already configured on the traffic networks. Lets use them for the time being, until Daniel is back!
14:38:28 <[1]JonasB> I'll send you all the more detailed document.
14:38:35 <Szilard> [1]JonasB: thanks :)
14:38:53 <[1]JonasB> Anything more?
14:39:00 <Szilard> that'
14:39:04 <Szilard> s all from my side
14:39:08 <stefan_berg> Nope.
14:39:33 <Szilard> [1]JonasB: thanks for organizing this meeting :) it was good
14:40:06 <aricg> Hey I'm fixing jira so that an issue can have a security setting, can somone who is a commiter/contributor to genesis follow this link and tell me if they can still see the issues? https://jira.opnfv.org/issues/?jql=project%20%3D%20BGS
14:40:27 <[1]JonasB> #info vlan 1000-1200 are already configured on the traffic networks. Lets use them to partition the admin pxe network for the time being, until Daniel is back!
14:40:39 <[1]JonasB> #endmeeting