14:01:34 <[1]JonasB> #startmeeting Fuel OPNFV status No6
14:01:34 <collabot> Meeting started Thu Apr 16 14:01:34 2015 UTC.  The chair is [1]JonasB. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:34 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:34 <collabot> The meeting name has been set to 'fuel_opnfv_status_no6'
14:01:48 <[1]JonasB> #topic RC2 status
14:02:13 <[1]JonasB> Status on KVM deploy - Stefan, please use info
14:02:55 <stefan_berg> #info The full deploy chain is completed for libvirt, "deploy.sh <iso>" will spin up the environment.
14:03:25 <stefan_berg> #info Fatih has integrated with Jenkins and we're using blade 15 to test this.
14:03:56 <stefan_berg> #info The commit for this is finalized and ready for approval/merge.
14:04:00 <stefan_berg> #link https://gerrit.opnfv.org/gerrit/#/c/306/
14:04:23 <stefan_berg> That's it.
14:04:32 <stefan_berg> Oh.
14:04:41 <[1]JonasB> Cool, we can soon declare victory for RC2
14:04:52 <stefan_berg> #info The deploy is one Fuel master, three controllers, two computes, full HA with Ceilometer.
14:05:20 <[1]JonasB> #info first cut of documentation done and merged into the repo.
14:05:40 <lmcdasm> #info - comment on that
14:05:55 <[1]JonasB> #docs will be built in RC2 and put on the google artifact repository
14:06:27 <[1]JonasB> yes Daniel
14:07:21 <lmcdasm> #info for nested environments with such a payload (3x3 and that turned on) - have you done this anywhere before?  I have had failures (to to massive i/o wait at the disk, when trying to fire three controllers on a single blade)
14:08:48 <stefan_berg> We can scale back on that, but yes, I've done it before - that was the smoke test for 15A :) - and usually works OK.
14:09:29 <lmcdasm> #info - on your own setup Sberg or elsewhere? - i guess my question is more of - is that something we really want to push - that layout - for nested environments.  Judging from the support questions we have receivd thus far, i can see it being a bit of a hassle - can we simply have two profiles (a simple MultiNode - no Ha and bells/whistles) and then the full HA one
14:09:49 <stefan_berg> It's pretty easy to tune this (look in functions/deploy_env.sh) for a smaller config.
14:09:52 <lmcdasm> #info - it will make sense in the long run cause we can have simple test (smoke test) on smaller profile) and larger / longer ones
14:09:55 <lmcdasm> ok
14:10:05 <[1]JonasB> #info I have now rebsed fuel due to upstream repo changes
14:10:09 <lmcdasm> just thinking about testing times / deployment cycles from jenkins
14:10:30 <[1]JonasB> Stefan and szilard, you need to rebase your patch sets.
14:10:34 <SzilardCserey_ER> ok
14:11:05 <stefan_berg> #info The plan moving forward is to have the "create_dea.sh" script detect also node roles, and then I'd suggest to turn our example into a non HA one, that makes sense yes.
14:11:29 <lmcdasm> #info - as part of my nested i will end up doing it anyway
14:11:57 <lmcdasm> #info - since i will use your structure to pass a common "profile" so that we dont have two different formats for two different types (or other hypervisors we add later)
14:12:27 <[1]JonasB> Okay, is that all for RC2?
14:13:18 <[1]JonasB> #info GREAT WORK DONE EVERYONE, REALLY APPRECIATED!
14:13:46 <[1]JonasB> So lets go to the items for RC3 next week?
14:14:02 <[1]JonasB> #topic debootstrap patch
14:14:06 * stefan_berg nods
14:14:19 <mskalski> I prepared change which will fix debootstrap problems
14:14:21 <[1]JonasB> mskalski: updates?
14:14:25 <mskalski> #link https://gerrit.opnfv.org/gerrit/#/c/351/
14:14:32 <mskalski> I need to test it more, but today it will be ready
14:14:49 <lmcdasm> make sure you rebase before you push :)
14:15:18 <mskalski> I think I included last Jonas commit
14:16:30 <mskalski> when it will be done I will add you guys as reviewers
14:16:43 <mskalski> then switch to work on centos integration
14:17:48 <[1]JonasB> #info mskalski and all: Seems that you need to add revievers, otherwise it is not vissible to others. I think that behavior has changed in gerrit lately.
14:17:51 <fdegir> I think questions coming for you
14:17:55 <fdegir> in opnfv-meeting
14:18:16 <fdegir> nope, skipped
14:18:29 <[1]JonasB> Multitasking :-)
14:18:59 <[1]JonasB> # info mskalski: so add all of us as reviewers.
14:19:08 <[1]JonasB> Great Michal
14:19:40 <[1]JonasB> So lets move on to next topic - Centos
14:19:51 <[1]JonasB> #topic Cento support
14:20:03 <[1]JonasB> mskalski: any update?
14:20:43 <mskalski> [1]JonasB: I was focused on debootstrap, today it will be ready and I will come back to centos integration
14:21:23 <[1]JonasB> #info Centos work will start from tomorrow.
14:21:34 <[1]JonasB> mskalski: Thanks
14:23:44 <[1]JonasB> Lets move on to autodeploy
14:24:01 <[1]JonasB> #topic Auto deploy
14:24:12 <[1]JonasB> Szilard - updates
14:24:49 <SzilardCserey_ER> [1]JonasB: okay, so I'm adding the last bits for Autodeploy, tommorrow I start testing on Nested Environment
14:25:30 <SzilardCserey_ER> but the Libvirt Adapters are missing, I will take from Stefan's code and integrate it into mine ...
14:26:14 <SzilardCserey_ER> depending on which type of environment you want to run it, you need either ESXi Adapters of Libvirt Adapters
14:26:15 <[1]JonasB> Szilard, can you "info" your updates
14:26:20 <SzilardCserey_ER> sorry
14:26:48 <SzilardCserey_ER> you wan't me to do shoot it again ? :)
14:27:04 <SzilardCserey_ER> with info
14:27:16 <[1]JonasB> Yes please
14:27:19 <SzilardCserey_ER> ok
14:27:33 <SzilardCserey_ER> #info  I'm adding the last bits for Autodeploy, tommorrow I start testing on Nested Environment
14:27:43 <SzilardCserey_ER> #info but the Libvirt Adapters are missing, I will take from Stefan's code and integrate it into mine
14:27:48 <SzilardCserey_ER> # depending on which type of environment you want to run it, you need either ESXi Adapters of Libvirt Adapters
14:27:53 <SzilardCserey_ER> #info depending on which type of environment you want to run it, you need either ESXi Adapters of Libvirt Adapters
14:28:06 <SzilardCserey_ER> that's all
14:28:30 <[1]JonasB> Great szilard
14:28:40 <[1]JonasB> Stefan Updates
14:29:16 <stefan_berg> #info Tuning of how the libvirt DEA is created and used at deploy.
14:29:46 <stefan_berg> #info Then looking into how to move forward together with Daniel and Szilard for real iron deploy.
14:30:44 <SzilardCserey_ER> stefan_berg: this will be Cisco, we have to do the Hardware Adapters for that as well
14:30:47 <stefan_berg> #info Hopefully the deployement logic of my libvirt prototype can be reused for the main functionality.
14:31:17 <lmcdasm> #info - i have ciso and hp prototype (on/off attach media) working - delivered for friday or monday along with esxi adapter
14:31:24 <[1]JonasB> stefan_berg: Great, maybe a place for an audio call on how to bring all pieces together for the final?
14:31:46 <fdegir> bgs status reporting coming
14:31:46 <stefan_berg> [1]JonasB: That's a good idea, let's do an audio/Etherpad call on Monday!
14:31:53 <fdegir> opnfv-meeting
14:32:43 <[1]JonasB> So lets move on to our fantastic lab
14:32:52 <[1]JonasB> #topic Lab status
14:32:57 <lmcdasm> ok.. my update above for autodeploy was enough then?
14:33:12 <[1]JonasB> #undo
14:33:12 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1ed2350>
14:33:26 <[1]JonasB> Daniel, sorry go on
14:33:51 <[1]JonasB> I dont really have what it takes to be in two parallel meetings
14:34:36 <lmcdasm> #info - esxi adapter works, will rebase with autodeployable ISO from SBerg and hook in a jenkins slave to esxi for Friday
14:34:51 * stefan_berg wonders if we should go for a 10 meeting coffe break in this meeting?
14:34:57 <lmcdasm> #info - HP adapter prototype work (API method) for attach, on/off or
14:35:09 <lmcdasm> #info - Cisco done as well - only against Simulator
14:35:18 <lmcdasm> #info - will merge Friday night and set reviewers
14:35:24 <lmcdasm> thats all
14:35:43 <[1]JonasB> lmcdasm: That is cool, using their python SDK?
14:35:46 <stefan_berg> lmcdasm: Just to be clear, this autodeploy stuff is not on the ISO, only in the repo.
14:35:48 <lmcdasm> #info yes
14:36:10 <[1]JonasB> Daniel: thanks!
14:36:14 <[1]JonasB> Now to lab
14:36:17 <stefan_berg> OK, now Jonas will do a report in the meeting.
14:36:23 <lmcdasm> #stefan_berg - understood - i meant im gonna clone your setup to blade 15 from my own build server
14:36:25 <stefan_berg> Frank s asking for Fuel update Jonas.
14:36:26 <[1]JonasB> #topic Lab status
14:36:39 <fdegir> [1]JonasB: now the question asked for Fuel status
14:36:56 <stefan_berg> Let's take five, people. :)
14:39:01 <fdegir> :D
14:41:47 <lmcdasm> argh - too many windows - i meant to ask in here to Jonas - can i get HW access for the LF stuff and ill just do the setup/install there.
14:42:22 <[1]JonasB> lmcdasm: I will fix that for you!
14:42:46 <lmcdasm> ok - i mean, might as well just do it since we are (or i am) in a build-out / install mode
14:43:49 <[1]JonasB> lmcdasm: Makes sense
14:45:21 <[1]JonasB> lmcdasm: Labstatus since yesturday use "info"
14:48:19 <[1]JonasB> #info Daniel have the nested environment up, documented on the Wiki
14:49:22 <SzilardCserey_ER> [1]JonasB: super great
14:49:38 <[1]JonasB> #link https://wiki.opnfv.org/_media/get_started/opnfv_montreal_lab-revc.pdf
14:50:49 <[1]JonasB> So can we move on to next topic - repo mirror
14:51:00 <lmcdasm> uh hno
14:51:09 <lmcdasm> i have outstanding questions on the Lab for you and Stefan
14:51:15 <lmcdasm> for finsihing the repo/web cloner
14:51:19 <lmcdasm> and getting that done today
14:51:29 <lmcdasm> sorry - lemme try again
14:51:35 <[1]JonasB> That is the next topic
14:51:37 <lmcdasm> #info - outstanding questions on the repo/web server
14:51:47 <[1]JonasB> #topic Local repo mirror
14:51:56 <[1]JonasB> lmcdasm: shoot
14:51:57 <lmcdasm> #info - outstanding questions on the repo/web server
14:52:22 <lmcdasm> #info - system is ready and staged - need to know how much / where desired clone point is
14:53:08 <lmcdasm> #info - as soon as input is received ITTE will set firewall and we can point the build sytems at the CLONE_REPO in config.mk (probably some nicer code if you want options as outlined is good).
14:53:31 <lmcdasm> #info - will take about 1 hour once i create the domain name for DNS around the world to update and  we are in business
14:53:34 <lmcdasm> thats it
14:53:34 <[1]JonasB> mskalski: Can you/Mirantis help here?
14:55:52 <[1]JonasB> lmcdasm: Do you know how to set up the mirrors or do you need help from Mirantis?
14:55:53 <mskalski> [1]JonasB: what kind of help is needed? Poiting to external repo I described yesterday in mail, regarding clone point it can be also done in config.mk
14:56:00 <mskalski> #link http://docs.mirantis.com/fuel-dev/develop/env.html
14:57:36 <lmcdasm> #info - the question is not just about the FUEL_REPO Pointing - there are the other repos in config.mk and other upstream items that we use.  The question about what we are "snapshoting" from upstream is more to the focus of my point
14:58:26 <lmcdasm> #info - for example other libs in our build, and do we want to freeze other parts as well - working towards having the structure that i outilned in the mail on the server for dealing with control of the repo, etc.
14:59:24 <[1]JonasB> lmcdasm: Lets figure that out off-line you and I tonight
14:59:27 <lmcdasm> #info - simply setting up a "mirror" of their Repo is not what we want, otherwise we are just a hop in the chain - anyway - if you can take a look at the mail and send me an answer to the questions that would be wonderful.
15:00:04 <mskalski> lmcdasm: so you mean ubutnu/centos repos which can be configured here? https://github.com/stackforge/fuel-main/blob/master/config.mk#L191?
15:00:07 <lmcdasm> #info - since a mirror (nightly) will change in sync with others - we want to "freeze" frame the upstream and control it - to match with released / builds (and now the auto-deploy and testing parts).
15:00:21 <[1]JonasB> #action Jonas and Daniel to come with a mirror strategy proposal
15:00:43 <lmcdasm> #mskalski = yes - that is a part of it correct
15:03:13 <[1]JonasB> Can we end here?
15:04:11 <[1]JonasB> 1
15:04:38 <[1]JonasB> 2
15:04:46 <fdegir> :)
15:04:51 <[1]JonasB> 3
15:05:05 <[1]JonasB> THanks everyone for a fantastic work
15:05:13 <[1]JonasB> #endmeeting