13:55:00 <[1]JonasB> #startmeeting BGS Fuel status update May 13
13:55:00 <collabot> Meeting started Wed May 13 13:55:00 2015 UTC.  The chair is [1]JonasB. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:55:00 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:55:00 <collabot> The meeting name has been set to 'bgs_fuel_status_update_may_13'
13:55:08 <[1]JonasB> #info Jonas Bjurel
13:55:13 <szilard> #info Szilard Cserey
13:56:01 <fdegir> #info Fatih Degirmenci
13:58:50 <mskalski> #info Michal Skalski
14:00:09 <[1]JonasB> Close now!
14:00:27 <[1]JonasB> Close to deploy ready I mean!
14:00:41 <jose_lausuch> #info Jose Lausuch
14:01:13 <lmcdasm> #info Daniel Smith
14:01:47 <[1]JonasB> Now deployed, helthcheck running!
14:02:44 <lmcdasm> 10 people all watching the same screen
14:02:46 <lmcdasm> good stuff!
14:02:59 <lmcdasm> but that means we have a successful deploy! groovy
14:03:21 <jose_lausuch> yep! :)
14:03:31 <fdegir> sorry, it seems I got hypnotised by rotating thingy
14:03:33 <lmcdasm> and Michal gets the kudos for the debugging our stuff!
14:03:51 <lmcdasm> see - my joke about adding something nicer aint such a bad idea afterall maybe :)
14:04:00 <[1]JonasB> So let's slowly start
14:04:16 <[1]JonasB> Why not start with autodeployment
14:04:27 <[1]JonasB> #topic Autodeploy status
14:04:29 <szilard> #info ok
14:04:47 <szilard> #info so I have the Python code ready, now I am testing it on Libvirt BLade 13
14:05:18 <[1]JonasB> Great, how is the testing progressing?
14:05:19 <szilard> #info tommorrow I will add the IPMI adapter
14:05:33 <szilard> #info and then we can test it on baremetal
14:05:44 <szilard> #info Linux Foundation lab if its possible
14:06:01 <lmcdasm> hmm.  what is the prio here Jonas
14:06:09 <lmcdasm> Jose functest on LF or DHA on LF?
14:06:16 <szilard> #info or I can do the IPMI testing on HP
14:06:36 <jose_lausuch> DHA?
14:06:43 <szilard> #info first HP, then switch to LF
14:06:46 <lmcdasm> Deployment Hardware Adaprter
14:06:49 <jose_lausuch> ah sorry
14:06:52 <jose_lausuch> as you wish
14:06:54 <lmcdasm> (autodeployment end to end include env and ipmi stuff)
14:06:56 <lmcdasm> no problem Jose
14:07:00 <lmcdasm> (lots of stuff)
14:07:07 <jose_lausuch> I Can test tomorrow as well
14:07:16 <[1]JonasB> #info We will decide next week on which HW we will start baremetal tests on Szilards piece of beuty
14:07:31 * fdegir DONE!!!
14:07:34 <szilard> :)
14:07:36 <lmcdasm> nice work Fatih!
14:07:43 <fdegir> I've done nothing
14:07:45 <[1]JonasB> #info Stefans prototype is working on LF POD-1
14:07:56 <fdegir> congrats to everyone
14:08:08 <[1]JonasB> #info it just finished the first jenkins deploy
14:08:34 <[1]JonasB> #link https://build.opnfv.org/ci/view/genesis/job/genesis-fuel-deploy/7/consoleFull
14:08:57 <szilard> wonderfull
14:09:00 <[1]JonasB> #info realy great work - all!
14:09:06 <jose_lausuch> great
14:09:14 <lmcdasm> groovy .. now you all can help me with the demo right ? :P
14:09:17 <lmcdasm> haha
14:09:27 <[1]JonasB> hahaha
14:10:10 <[1]JonasB> #info so what is the next step, should we redeploy on every nightly, or does that hinder func-test?
14:10:22 <[1]JonasB> Jose?
14:10:28 <[1]JonasB> fdegir?
14:10:44 <jose_lausuch> #info functest needs a manual step to run a script to install all the tools
14:10:47 <fdegir> I really think we should redeploy every night
14:10:55 <jose_lausuch> its ok
14:10:57 <lmcdasm> can we get the nightly deploy to call that manual step?
14:11:06 <jose_lausuch> yes
14:11:07 <fdegir> but I think jose_lausuch should go first and get his run done first
14:11:08 <jose_lausuch> but
14:11:20 <lmcdasm> agreed - lets give it to jose until monday (proposal)
14:11:25 <jose_lausuch> the manual steps needs some human interaction
14:11:27 <fdegir> and then we can enable automatic/daily deployments
14:11:30 <lmcdasm> and then look at end to end nightly automation next week?
14:11:49 <[1]JonasB> looks like a plan!
14:11:57 <fdegir> have one extra question
14:11:57 <jose_lausuch> I might be working 50% of time on friday and 0% during this weekend
14:12:03 <lmcdasm> do what you can Jose.
14:12:03 <jose_lausuch> but tomorrow is fine
14:12:17 <lmcdasm> there is thursday as well :)
14:12:17 <fdegir> can I restart deployment again to see what happens with a new deployment on top of already deployment cluster?
14:12:29 <[1]JonasB> #info We will start nightly deploys from midnight 18-19 May
14:12:40 <lmcdasm> thats a good idea (negative test) fatih
14:12:52 <[1]JonasB> #info Until then POD1 is entirely dedicated to functest
14:12:57 <lmcdasm> to see it wipes clean and starts again (the fdisk/ partitions are tricky)
14:13:01 <fdegir> or jose_lausuch should go first?
14:13:09 <fdegir> since this might mess things up
14:13:15 <lmcdasm> my 2 cents
14:13:19 <lmcdasm> let Jose get a full test done
14:13:20 <[1]JonasB> Let Jose go first
14:13:23 <fdegir> ok
14:13:29 <jose_lausuch> yes, I'll do
14:13:30 <lmcdasm> caue then we have a some baseline to see
14:13:33 <lmcdasm> cool
14:13:35 <jose_lausuch> yep
14:13:38 <fdegir> Jose, please notify me once pod1 is free so I click the button
14:13:41 <jose_lausuch> and I can document the failed test cases
14:13:45 <jose_lausuch> but wait
14:13:45 <lmcdasm> eact!
14:13:54 <jose_lausuch> there is a problem and I have to start the tests later
14:13:57 <jose_lausuch> cannot now
14:13:59 <jose_lausuch> in 2 hours maybe
14:14:08 <jose_lausuch> si you can redeploy now if you need
14:14:14 <lmcdasm> hmm.
14:14:16 <lmcdasm> i would say dont
14:14:17 <fdegir> I think it shouldn't be touched
14:14:18 <[1]JonasB> Then let fdegir go another lap?
14:14:23 <lmcdasm> give Jose the system now
14:14:24 <lmcdasm> first run
14:14:29 <lmcdasm> lets not get too fancy yet
14:14:32 <jose_lausuch> ok
14:14:36 <lmcdasm> and the Fatih can start monday ?
14:14:39 <lmcdasm> (again - suggestions).
14:14:43 <jose_lausuch> its just that I cannot start right away, need to do some things first
14:14:48 <lmcdasm> cause if we redploy and have issue
14:14:52 <[1]JonasB> Ok I agree, let it sit for Jose to start
14:15:06 <lmcdasm> then jose wont get time and we obscure the test results (with unknowns)
14:15:16 <lmcdasm> if we have a system now.. lets give it to jose and get a runthrough done
14:15:21 <lmcdasm> and then play with variants after
14:15:33 <jose_lausuch> +1
14:15:54 <fdegir> +1
14:16:03 <[1]JonasB> #agree Jose will have access to POD1 from now until late Monday when nightly redeplys start
14:16:09 <fdegir> I can trigger stuff during the night/tomorrow/friday
14:16:13 <fdegir> whenever Jose is done
14:16:22 <jose_lausuch> ok
14:16:33 <jose_lausuch> #info I'll send an email with status tomorrow
14:16:36 <[1]JonasB> Should we move to functest?
14:16:39 <lmcdasm> im not sure that its necessary to do work on holiday for that part.. is nightly deploys a real need for R1?
14:17:01 <[1]JonasB> #topic functest status
14:17:11 <[1]JonasB> Jose, give an update
14:17:28 <jose_lausuch> morgan_orange: there?
14:17:33 <jose_lausuch> morgan created wikis
14:17:38 <jose_lausuch> nice places to put our results
14:17:45 <[1]JonasB> Pound in the link
14:17:52 <jose_lausuch> #info  https://wiki.opnfv.org/r1_tempest
14:18:03 <jose_lausuch> #info https://wiki.opnfv.org/r1_rally_bench for Rally
14:18:16 <morgan_orange> will do the same for vPing
14:18:17 <jose_lausuch> #info we will put all the results there from the LF PODs
14:18:37 <jose_lausuch> #info vPings is now perfectly working with the console-log fix
14:18:58 * fdegir lmcdasm we should have repeated/automatic builds/deploys/tests
14:19:20 * fdegir lmcdasm if you ask me, we should do this whenever something gets merged to master, not just once a night
14:19:27 <[1]JonasB> #info The console fix is now merged
14:19:58 <fdegir> #info and a new ISO was built based on that fix
14:20:00 <jose_lausuch> #info for vPing, use of cirros images with sh script injected instead of cloud-init for Ubuntu
14:20:21 <jose_lausuch> #info documentation updated accordingly
14:20:34 <[1]JonasB> Great Jose
14:20:50 <jose_lausuch> anything else morgan?
14:21:13 <jose_lausuch> besides code improvements?
14:21:26 <[1]JonasB> Can we move over to ODL?
14:21:29 <jose_lausuch> yep
14:21:31 <jose_lausuch> thats it
14:21:40 <[1]JonasB> #topic ODL issue
14:22:02 <[1]JonasB> #info we have an issue with HA deployment and ODL
14:22:07 <lmcdasm> is that me?
14:22:16 <[1]JonasB> Kind of :-)
14:22:39 <[1]JonasB> Daniel, when do you think we can have the patch fon non HA?
14:22:48 <lmcdasm> #info - ODL integration with HA proxy bridges will require more integration work since the VXLAN tunnels are Tricky with the steup
14:23:09 <lmcdasm> #info - i will push the updateds for SR3 today and the prep_nets for non-HA today (once i am sure it works)
14:23:25 <[1]JonasB> Great Daniel
14:23:29 <lmcdasm> #info - for now, we will not do HAproxy integrtaion to ODL - simply for time - and focus on the NON_hA
14:23:48 <[1]JonasB> #info we might need to push combination ODL and HA deployment to SR1
14:23:50 <lmcdasm> #info - BM and Nested with ODL is working OK ' however the VNF (CSCF/HSS) is having some issues
14:24:12 <lmcdasm> #info - we should also look at 6.1 MOS for SR1 (my thoughts) of ARNO
14:24:48 <[1]JonasB> Agree with Daniel, we should kick that of ASAP. Lets spend a little time next week on SR1
14:24:53 <lmcdasm> #info - VXLAN tunnels over Virtual Router VMs (vyatta) is being a bit "tough" right now .. so i have to see if its an issue with Vyatta or not
14:25:25 <lmcdasm> #info - the scaler for Demo next week might be a bit tough - i will have "something" running - just not sure what percentage of the overall demo i will have
14:25:40 <lmcdasm> perhaps a running CSCF with just scaling and no real HSS calls (
14:25:44 <[1]JonasB> Cool great work Daniel
14:25:45 <lmcdasm> but i will update the team outside of this
14:26:01 <lmcdasm> sorry - i thought it would be easier than it is...
14:26:34 <lmcdasm> question?
14:26:40 <[1]JonasB> Daniel, will you be able to give me guidelines on how to start ODL for the documentation early next week?
14:26:46 <lmcdasm> yes..
14:26:52 <[1]JonasB> Super
14:26:57 <lmcdasm> the scripts are there and you just need to call em
14:27:00 <lmcdasm> and it will sart it up all for you
14:27:14 <lmcdasm> i will do some docs on the plane this weekend flying to VAn
14:27:24 <[1]JonasB> ;-)
14:27:30 <lmcdasm> question though - for Arno are we including any testing of the ODL (bring up gui or something)
14:27:31 <lmcdasm> ?
14:27:43 <lmcdasm> for example - vPing test with integrated OVSDB/ODL (tunnel)/
14:27:51 <lmcdasm> or is that out of scope / how do we test ODL?
14:27:54 <[1]JonasB> Yes we should
14:28:12 <lmcdasm> three is a simple test to see if its "up and configured" that you can script with curl
14:28:20 <lmcdasm> i will send some info to Jose and we can start to work on a test for that?
14:28:30 <jose_lausuch> sure
14:28:34 <[1]JonasB> Sounds like a good plan
14:28:45 <[1]JonasB> Anything more?
14:29:03 <lmcdasm> #info - we should consider OVS upgrade in SR1 for arno as well
14:29:24 <lmcdasm> #info - cause we are way back in OVS on the openstack release - just fYi and at some point we will be caught out
14:29:36 <[1]JonasB> #action SR1 to be discussed next week
14:29:37 <lmcdasm> done*
14:29:47 <[1]JonasB> #topic AOB
14:30:25 <[1]JonasB> I would like to take down the number of meets to lets say 2 a week?
14:30:55 <[1]JonasB> Tue and Thu?
14:31:22 <szilard> sounds good to me
14:31:25 <[1]JonasB> Votes against?
14:31:25 <fdegir> +1
14:32:01 <[1]JonasB> #info Going forward we will have Fuel meetings on Tue and Thu.
14:32:14 <lmcdasm> +1
14:32:18 <[1]JonasB> #info Jonas will reschedule the meeting series
14:32:20 <lmcdasm> err. that was for :)
14:32:22 <lmcdasm> not against
14:32:27 <[1]JonasB> :-)
14:32:55 <[1]JonasB> #info Starting from next week we should start planning on SR1 and R2
14:33:11 <lmcdasm> Fatih and i are in Vancouver .. so might be tough time wise
14:33:24 <lmcdasm> cause these meetings would be 730am Van time
14:33:26 <lmcdasm> just fyi
14:33:31 <[1]JonasB> lmcdasm, fdegir: understand
14:33:58 <[1]JonasB> Can we stop here?
14:34:06 <lmcdasm> +1
14:34:09 <fdegir> yes
14:34:19 <lmcdasm> nice work you guys! really impressive stuff this week
14:34:44 <[1]JonasB> Agree , thank you all!
14:34:49 <[1]JonasB> #endmeeting