13:59:54 <[1]JonasB> #startmeeting Fuel OPNFV meeting
13:59:54 <collabot> Meeting started Thu Jun  4 13:59:54 2015 UTC.  The chair is [1]JonasB. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:54 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:59:54 <collabot> The meeting name has been set to 'fuel_opnfv_meeting'
14:00:00 <szilard> #info Szilard Cserey
14:00:03 <lmcdasm> #info Daniel Smith
14:00:18 <[1]JonasB> #info JonasBjurel
14:01:14 <stefan_berg> #info Stefan Berg
14:04:20 <[1]JonasB> #info Before we start I want to thank everyone for a fanastic work done for the Arno release!
14:05:02 <[1]JonasB> #info status is that we have cut the Arno branch and will release during the day.
14:05:28 <[1]JonasB> So should we move on to branching strategy
14:05:52 <[1]JonasB> #Topic Branching strategy
14:06:33 <[1]JonasB> So my proposal is that we immediaty start the R2 work on the master branch
14:06:49 <lmcdasm> question -
14:06:58 <lmcdasm> if we work on R2 on master - what about SR1 patches / ec
14:07:05 <[1]JonasB> And that Szilard continue on the Arno maintenance branch
14:07:09 <lmcdasm> will that be done on "stable" or a different branch?
14:07:12 <stefan_berg> There's a separate branch now for Arno.
14:07:14 <szilard> got it
14:07:16 <fdegir> stable/arno
14:07:25 * ChrisPriceAB wonders if we still plan to move to a fuel repo
14:07:48 <lmcdasm> ok.. but if we modify the stable branch wont the nightly builds be affected - or thta is the idea - the ISO is frozen and stable continues ?
14:07:54 <lmcdasm> for patches, etc
14:07:57 * ChrisPriceAB thinks that might create a pretty clean distinguisher
14:08:05 <[1]JonasB> Chris, think we continue on genesis or?
14:08:31 <ChrisPriceAB> The current proposal for genesis is that it no longer hosts deploy code
14:08:37 <ChrisPriceAB> post Arno
14:08:40 <[1]JonasB> Nightlys run of master so that will stop building
14:09:05 <fdegir> should maintenance be left in genesis repo
14:09:13 * ChrisPriceAB needs to clarify, common modules would live in genesis
14:09:15 <fdegir> or move to fuel?
14:09:27 <ChrisPriceAB> maintenance would have to stay of course
14:09:35 <fdegir> ok
14:09:39 <[1]JonasB> Chris, but does the place matter for this discussion?
14:09:53 <fdegir> then we have ci on both branches
14:09:57 * lmcdasm is confused - do we have a document on the branching proposel to look at so i can visualize the trees / strategy?
14:09:58 <ChrisPriceAB> No, not really.  :) but it creates practical realities
14:10:10 <fdegir> no matter which repo we're in
14:10:13 <stefan_berg> So where is this repo reordering discussion taking place?
14:10:26 <ChrisPriceAB> it will take place post Arno in the BGS team.
14:10:27 * lmcdasm agrees - i didnt see / hear this proposal
14:11:19 <[1]JonasB> So my proposal as a generic one is that the progress towards SR1 and R2 happends on the master
14:11:48 <[1]JonasB> and we rebase the Arno maintenance branch when were aproaching SR1
14:12:01 <[1]JonasB> With one exemption
14:12:06 <lmcdasm> by "maintenance" you mean "stable/arno"?
14:12:49 <[1]JonasB> Szilard works out of the maintenance branch because he has stuff ready and want to test it without being disturbed by broken commits.
14:13:00 <[1]JonasB> Stable/arno yes
14:13:08 <stefan_berg> Seems like a good plan.
14:13:26 <lmcdasm> ok - sorry if im dumb.. but i need to udnestand
14:13:30 <lmcdasm> if we are working on stable/arno
14:13:32 <lmcdasm> and something is wrong
14:13:37 <lmcdasm> and people download the genesis repo
14:13:41 <lmcdasm> wont their build system be impacted?
14:13:48 <lmcdasm> or did i miss something there?
14:13:57 <[1]JonasB> but they need to check out the tag
14:14:10 <[1]JonasB> arno.2015.1.0
14:14:27 <[1]JonasB> anything non tagged is unknown
14:14:34 <lmcdasm> ahh.. ok.. i see .. do when epople want the build system release at Arno - they do a git clone with that tag
14:14:36 <stefan_berg> Well, depends in what context they are working. For maintenance of arno they simply checkout that branch... and Jonas is typing quicker than me.
14:14:58 <lmcdasm> and if they dont specify a tag, then they get whatever is in "master of stable/arno" at that point
14:15:14 * lmcdasm Dan feels dumb for asking simpleton questions :P
14:15:17 <[1]JonasB> Exactly
14:15:30 <lmcdasm> we should document this (so i can remember if for not other reson)
14:15:31 <fdegir> quick question: will montreal lab be used for R2 and SR(s) work and CI or LF?
14:15:41 * lmcdasm would prefer Montreal lab
14:15:50 <stefan_berg> Its a topic for another meeting I guess, but I would still like to know more about the driving force for a repo reordering. Not saying that it doesn't make sense.
14:16:41 <stefan_berg> I assume we would look at a build system using git submodules in that case, which imho can be an unnecessary complication.
14:16:41 <[1]JonasB> Szilard wants to try out LF
14:16:56 <fdegir> ok
14:16:56 <lmcdasm> since a) Szi already has stuff going on there, and B) we are overloading the LF guys with two platforms and 6:2 ratio of requests (at minimum)..
14:17:01 <lmcdasm> hmm..  okies...
14:17:22 <fdegir> we'll need to setup jobs for stable/arno now
14:17:23 <szilard> I'm actually planning to start using LF from Tuesday next week
14:17:23 <lmcdasm> i would suggest Szi that you call a meeting with LF first to have the networks sorted out prior to starting
14:17:30 <fdegir> thats why I asked
14:17:31 <lmcdasm> caues you are going to have problems
14:17:56 <lmcdasm> unless you use the exact config set that CI pipeline has been using
14:17:56 <szilard> aha, which guys should I contact ?
14:18:00 * stefan_berg nods, the LF network setup is "interesting".
14:18:06 <lmcdasm> well.. this is what i mean -
14:18:24 <lmcdasm> Raymond said there is a retrospective.. but aric and Peter are working as hard as they can
14:18:32 <[1]JonasB> But it should in theory work in the same way as Stefans proto
14:18:38 <lmcdasm> but the dependancy and networking setup - outlined by Colin b ack in March - has a problem
14:18:45 <lmcdasm> hehe... yes.. in theroy
14:18:52 <[1]JonasB> :-)
14:18:59 <lmcdasm> but we know we still have to fix the VXLAN tunnels at some point and i think that needs to eb sorted
14:19:09 <lmcdasm> otherwise we are still not targetting the SUT that Chris has outlined
14:19:24 <[1]JonasB> lmcdasm: agree
14:19:27 <lmcdasm> so perhaps - before we continue - we can either sort out that Hardware and a support method so we arent locksteipping
14:19:37 <stefan_berg> Szilard, for now you and I can cook something up. I have a workaround for the strange tagging on vlan 1 for now, so that will not be visible for the Fuel VM.
14:19:40 <lmcdasm> and get either - A) some comptenence to do the switching stuff ourselves
14:19:49 <lmcdasm> or b) setup a timetable so its not so "roughshod" on the LF guys
14:20:09 <szilard> ok Stefan :)
14:20:27 <[1]JonasB> lmcdasm: Agree, maybe a meeting with Peter and Aric to sort WOW
14:20:35 <lmcdasm> my concerns is that the "special stuff" for LF doesnt have to exist elsewhere, so we will need to do it on Motnreal or some other place with a more "Generic" setup
14:20:43 <stefan_berg> szilard: Let's share a tmux/screen connection to the LF pod1 jumphost and I can give you a quick tour.
14:20:45 <lmcdasm> that matches our Reference Architecuter since LF does not
14:20:58 * lmcdasm wants to be shown from Herr Berg as well ;P
14:21:23 <stefan_berg> lmcdasm: A group tour it is then! :)
14:21:39 <szilard> good, thanks Stefan !
14:21:50 <lmcdasm> since im pretty convinced (watching VXLAN packets go out tagged with 1) that this is the reason the tunnnels are not coming up
14:21:52 <szilard> when right after this meeting ?
14:22:04 <[1]JonasB> So back to the Branching strategy, do we agree in principle?
14:22:20 <szilard> well, I agree :)
14:22:28 <stefan_berg> I would prefer Monday if possible though, I would like to set something up tomorrow on an internal host before I loose it. But if you need to get started that takes precedence, Szilard.
14:22:32 <lmcdasm> #agreed - in principle - would like to see a diagram so its more clear for everyone (and new people who will join -0 Ulf, etc)
14:22:40 <lmcdasm> today is tough for me - MOnday is better
14:22:41 <lmcdasm> :)
14:23:13 <szilard> can we do it Tuesday, Monday I must got to a conference
14:23:28 <lmcdasm> send a meeting req out and propose a time that works
14:23:30 <[1]JonasB> #info In general work towards SRs and R2 happens in the master branch and we rebase the stable/arno when were progressing the SR releases
14:23:31 <lmcdasm> and ill accomodate
14:23:32 <szilard> thanks
14:24:06 <stefan_berg> lmcdasm: In general I think repo structures, branching strategies, a WoW on submodules etc would be great to have on a Wiki once us tech guys agree ("we" as in Fuel + Foreman of course).
14:24:21 <[1]JonasB> #info Exemption, Szilard will work on the stable/arno not to be disturbed by broken commits
14:24:51 <[1]JonasB> Lets go to szilards deploy tool
14:25:06 <[1]JonasB> #topic Deployment tool
14:25:06 <dneary> Looks like 112 is stuck in the same place...
14:25:31 <[1]JonasB> Zci How is it going in mtrl
14:25:40 <fdegir> dneary: ChrisPriceAB is on #opnfv-octopus channel
14:25:44 <[1]JonasB> Zsilard How is it going in mtrl
14:25:58 <fdegir> looking for you and trozet
14:27:45 <[1]JonasB> Did szilard leave?
14:27:53 <szilard> no sorry I'm here
14:27:59 <[1]JonasB> Ha!
14:28:04 <szilard> I am deploying
14:28:59 <szilard> and trying to display the ODL GUI somehow
14:29:22 <[1]JonasB> Szilard: So you want to move to LF
14:29:25 <szilard> I am deploying on 6 blades 3 compute 3 controller
14:29:30 <[1]JonasB> on tue
14:29:36 <szilard> not yet, yes on Tuesday
14:30:13 <szilard> because I'm preparing for a demo that will be held on monday at the Openstack CEE
14:30:21 <[1]JonasB> That should be fine, but as said lets do it together so we can use the competence already gained
14:30:36 <szilard> sure
14:30:46 <lmcdasm> hey Szi.. ping me and i can show you some tricks
14:30:50 <lmcdasm> for the ODL gui and such
14:31:04 <lmcdasm> if you are having issue getting that thing up - it can be tricky sometimes
14:31:05 <szilard> thank Daniel, that is cool, I really need that now
14:31:15 <lmcdasm> ok..  let do it today then after your deploy is there
14:31:17 <[1]JonasB> #info Szilard will go on LF on Tue with the rebased auto deployer
14:31:31 <lmcdasm> (if you have time that is :P).
14:31:34 <[1]JonasB> #info Stefan and Daniel will be at help
14:31:40 <szilard> of course I have time :)
14:31:54 <szilard> thanks guys :)
14:32:16 <stefan_berg> Of course, just call anytime you need help!
14:32:19 <lmcdasm> sorry - one last question - aare you doing full vxlan or just showing the ODL is up and ready?
14:32:31 <lmcdasm> ^^ what Herr_berg said!
14:32:43 <szilard> just the ODL
14:32:57 <[1]JonasB> Should we have a meeting with LF to sort out support WOW or should that be done by genesis?
14:34:26 <szilard> I think it's a good idea to have a separate meeting with LF
14:34:46 <stefan_berg> Yes, I think so too.
14:35:14 <[1]JonasB> So lets set up something with them next week - who?
14:35:15 <stefan_berg> We seem to be hit differently (Fuel and Foreman that is) by the nw setup.
14:35:42 <stefan_berg> With who on the LF side, or who from us? :)
14:35:57 <[1]JonasB> Who too arrange, I can do it
14:36:51 <stefan_berg> I'm in, have no idea who to hook up with on the LF side though.
14:37:09 <fdegir> wasn't it Konstantin?
14:37:09 <stefan_berg> Quick brainstorm on the topics to bring up?
14:37:16 <fdegir> and Aric
14:37:20 * lmcdasm proposes the first conversation be about just WoW - and how to communicate, how to address issues in a formal / traceable way
14:37:31 * lmcdasm then we have a second discussion about networking needs..
14:37:35 <stefan_berg> lmcdasm: Sounds wise.
14:37:48 <[1]JonasB> #agree Jonas will arange a meeting with LF to discuss lab support
14:37:52 <lmcdasm> since i dont want to see the two conversations merged - first lets set the framework
14:38:01 <lmcdasm> then use that framework to get what we need Network wise done
14:38:35 <[1]JonasB> Aric and Konstantin I think should be fine
14:38:44 <lmcdasm> Does anyone else have some thoughts on how we address the delta between LF CI pipeline (i.e Stefans hack for the UCS fabric) vs our published Reference Archittecture?
14:38:49 <lmcdasm> is documentation enough - ?
14:39:01 * lmcdasm things Raymong Paik shouold be in that discussion as well
14:39:28 <aricg> imo send the meeting request to Infra-steering@lists.opnfv.org
14:39:44 <stefan_berg> Eliminating the delta...?
14:39:48 <lmcdasm> we cannot
14:40:00 <lmcdasm> eleminate the delta.. since its intrisinc to the UCS fabric
14:40:01 <[1]JonasB> aric: good proposal
14:40:09 <lmcdasm> or do you mean - that we change our reference arch?
14:40:39 <lmcdasm> so that we include a mention of "possible fabric taggin" (which might be worthwhile since the IBM blade centre the guys out in Telstra / Aussieland have similar issues
14:40:40 <stefan_berg> OK, so a patch to UCS to come back on track is a no go?
14:40:57 <[1]JonasB> #agree Jonas will arange a meeting with Infra-steering@lists.opnfv.org
14:41:00 <lmcdasm> well.. thats what im getting at really
14:41:12 <lmcdasm> if we patch our stuff to accomodate a single HW type and that is what we are testing
14:41:23 <lmcdasm> then we really are blind to using our "ref arch"
14:41:34 <lmcdasm> now we "know" (cause we are doing the work).. but how will anyone else?
14:41:47 <[1]JonasB> We need to come back to the stated ref arch.
14:41:55 * fdegir foreman is done - we're good to go
14:42:17 <[1]JonasB> fdegir - good news
14:42:21 <stefan_berg> Yep. The there needs to be an "HW instantiation framework"... which imho would be messy.
14:46:23 <[1]JonasB> #topic Meeting series going forward
14:48:03 <[1]JonasB> I propose to only have one meeting a week on Thursdays, and a informal rendevouz on Tue - what about that?
14:48:56 <stefan_berg> Sounds good.
14:49:12 <szilard> me too
14:50:14 <[1]JonasB> #info going forward we will have fuel meeting on Thursdays, and a informal rendevouzs on Tuesdays
14:50:31 <[1]JonasB> Anything more for today?
14:51:25 * stefan_berg is waiting for the countdown...
14:51:41 <szilard> :)
14:52:18 <[1]JonasB> 321
14:52:30 <[1]JonasB> #endmeeting