13:57:16 <jonasbj> #startmeeting Weekly Fuel@OPNFV sync
13:57:16 <collabot> Meeting started Thu Aug 13 13:57:16 2015 UTC.  The chair is jonasbj. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:57:16 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:57:16 <collabot> The meeting name has been set to 'weekly_fuel_opnfv_sync'
13:57:33 <jonasbj> #info Jonas Bjurel
13:57:34 <szilard> #info Szilard Cserey
13:57:40 <szilard> hi Jonas
13:57:47 <mskalski> #info Michal Skalski
13:57:51 <jonasbj> Hi Szilard!
13:58:00 <jonasbj> Hi Michal
13:58:07 <szilard> Hi Michal :)
13:58:14 <mskalski> Hi guys:)
14:01:10 <jonasbj> I guess itt will be a short meeting - people are still on vaccation
14:01:27 <jonasbj> But let's start anyway.
14:01:45 <jonasbj> Lets start with stable arno
14:01:48 <szilard> yes
14:01:56 <jonasbj> #topic stable arno
14:02:12 <jonasbj> #info The build issues have been resolved
14:02:32 <szilard> super great, good job Jonas! :)
14:02:55 <jonasbj> #info They were due to upstream Fuel changes that is not under fuel repo change control
14:03:23 <jonasbj> mskalski: Are you looking into why this happend and how we can avid it in the future?
14:03:48 <szilard> yes, could be great if you can give a brief info
14:04:26 <mskalski> jonasbj: It happen because devops repository which contain only packages for building iso is no divided by fuel releases
14:04:31 <ruijing> don't understand what issue.
14:04:53 <mskalski> so when they change something in this ubuntu repo
14:04:58 <mskalski> it affect all versions
14:05:24 <mskalski> I write about it to devops team but don't have response from them yet
14:05:38 <jonasbj> ruijing: The issue is that even if we nail down our upstream repos to a specific commit - the build is not reproducable
14:05:39 <ruijing> you mean released artifect is not immutable.
14:06:20 <mskalski> I assume that should not happen often but still it is a problem
14:06:25 <jonasbj> mskalski: Can we keep an own mirror?
14:06:37 <ruijing> yes. it is big issue for us. we need to have repeatable build tool and repeatable source code.
14:07:59 <jonasbj> mskalski: Can you look into this issue and come back with a proposal?
14:08:15 <mskalski> jonasbj: I think yes but the we just need to change this line in prepare-build-env.sh https://github.com/stackforge/fuel-main/blob/master/prepare-build-env.sh#L44
14:09:14 <jonasbj> Everyone - should we try with local repo mirrors for the B-release
14:10:19 <jonasbj> +1
14:11:20 <szilard> good idea
14:11:24 <jonasbj> Any oppinions?
14:12:23 <jonasbj> #agree We need to look into ways to accomplish reproducable builds, using local mirrors or otherwise.
14:12:59 <jonasbj> Szilard - status on the POD move and needed deploy changes for that.
14:13:22 <ruijing> use vagrant and save box in our repo?
14:13:29 <szilard> #info I pushed the DEA/DHA config files for POD2
14:13:52 <jonasbj> Does it work yet?
14:13:53 <szilard> #info I'm updating releng/jjb  to run the Production Autodeployer for master
14:14:07 <szilard> I tested for multinode it works
14:14:14 <szilard> now I'm testing for HA
14:14:25 <jonasbj> szilard: Great!
14:14:28 <szilard> waiting to be finished
14:14:37 <ruijing> Great!
14:14:51 <mskalski> When do you guys plan to switch to 6.1 ?
14:15:04 <jonasbj> Szilard: What about the clean up script - Tim has started working on a common one?
14:15:28 <ruijing> I already switch to 6.1 since odl plugin is based on 6.1
14:15:30 <szilard> Yes he did the cleanup script, and created a patch
14:15:40 <jonasbj> mskalski: I think we should switch master next week when Stefan is back!
14:15:41 <szilard> but now we have to integrate into jenkins
14:15:43 <szilard> somehow
14:16:01 <jonasbj> szilard: That's good!
14:16:20 <ruijing> hi, szilard. jenkins is up? can you tell me URL?
14:16:21 <szilard> so we have to invoke that script in a separate job afte deploy finished
14:16:43 <jonasbj> Should we move to SR1
14:16:57 <jonasbj> #topic SR1
14:17:07 <szilard> https://build.opnfv.org/ci/
14:17:17 <jonasbj> So just to refresh us on status
14:17:35 <jonasbj> Michal - status on the plug-in, anything left?
14:18:48 <mskalski> In branch with juno/helium (https://github.com/stackforge/fuel-plugin-opendaylight/tree/juno/helium) there is nothing happen, so this what I show on the demo
14:19:17 <jonasbj> mskalski: Great, good status there.
14:19:50 <mskalski> jonasbj: what is a date of SR1 release?
14:19:55 <jonasbj> szilard: I know you been working on the deployer for 6.1 and plugin installation - status?
14:20:04 <jonasbj> mskalski: Sometime Sep
14:20:06 <szilard> end of september is the release
14:20:11 <szilard> mid september is code freeze
14:20:18 <mskalski> ok thanks
14:20:27 <szilard> as agreed with Frank Brockners
14:20:57 <szilard> #info I have adapted Autodeployer for 6.1 and  plugin installation and ODL
14:21:02 <jonasbj> mskalski, could you info the status you just gave
14:21:42 <mskalski> #info In branch with juno/helium (https://github.com/stackforge/fuel-plugin-opendaylight/tree/juno/helium) nothing happen from month, so this what I show on the demo
14:21:48 <szilard> #info ODL is not very stable, yesterday Michal and I found out that  puppet manifest fails
14:22:33 <szilard> #info because ovsdb plugin in ODL is not started first time
14:22:41 <jonasbj> are those our puppet manifests?
14:22:48 <szilard> #info we restarted ODL, and second time it worked
14:23:03 <mskalski> jonasbj: no, its OpenDaylight controller behaviour
14:23:09 <szilard> yes
14:23:24 <jonasbj> Ok
14:24:16 <szilard> #info I also added Daniel's pre-deploy functionality in Autodeployer, with values
14:24:26 <mskalski> I thought how to resolve this from puppet for example always restart ODL but it will be nasty piece of code
14:24:29 <szilard> #info in Arno it was just an empty dictionary
14:25:03 <szilard> Michal can you still put that code there, and you can take it out later when ODL becomes stable
14:25:23 <jonasbj> Okay, it seems that much of the pieces for SR1 are in place, we just need to rebase the build system.
14:25:53 <mskalski> I also compare my approach with devstack script and I do the same thing as there
14:26:18 <jonasbj> #info Next week we will start rebasing the build system for Fuel 6.1 and turn any reminding patches/mods into Fuel plugins.
14:26:19 <szilard> It's enough to restart once or twice only
14:26:31 <lmcdasm> jonas - question for you?
14:26:41 <jonasbj> lmcdasm: Go
14:26:51 <lmcdasm> should we be looking to add support for the SFC-ODL modules / build (rather than just lithium)?
14:27:03 <lmcdasm> or you want to just have lithium karaf up for SR1
14:27:05 <szilard> well it would be nice :)
14:27:10 <lmcdasm> and then SFC-ODL with chain for B-rel?
14:27:30 <jonasbj> SFC is for B in my oppinion
14:27:30 <lmcdasm> since its just (thx to Michal's work) simplying a different rpm build
14:27:38 <lmcdasm> ok - just wanted to see your plan :)
14:27:51 <jonasbj> Whatabout Lithium, should we go for that in SR1
14:28:04 <mskalski> lmcdasm: what is difference between SFC-ODL and standard ODL? I assume that different features enabled but something more?
14:28:30 <lmcdasm> ya.. they have hacked it a bit
14:28:45 <lmcdasm> there is the modules and a lib you need to get
14:28:57 <lmcdasm> not a huge deal easy to add in a .spec file for a rpm
14:29:10 <lmcdasm> but its a question of our "track" and what we want to say we have support for and when
14:29:21 <lmcdasm> and the sfc stuff (with gbp/nsh) isnt quite there yet
14:29:41 <lmcdasm> (i think :) )
14:29:56 <lmcdasm> yes jonas - i think lithium for SR1 is the idea no?
14:30:10 <mskalski> for me adding support for SFC is a interesting thing to do
14:30:19 <lmcdasm> my understanding would be that in the build environment we are able to generate that rpm during the build
14:30:20 <jonasbj> mskalski: What do you think for SR1 Helium or Lithium?
14:30:45 <lmcdasm> pointing at a source we want (i.e helilum / lithium - you can do either source build or gz fetch method)
14:30:51 <lmcdasm> i think that would be doable no Michal?
14:30:51 <ruijing> SFC has 2 dependency
14:30:56 <lmcdasm> go rui!
14:31:26 <ruijing> 1. OVS with NSH (ETA: commit to upstream: Oct)
14:31:41 <mskalski> jonasbj: lithium is already implemented in juno/lithium branch so it can be Lithium for SR1
14:31:55 <ruijing> 2. enable SFC in karaf (maybe GBP/SFC or netvirt/SFC)
14:32:00 <lmcdasm> <nice info Michal>
14:32:13 <lmcdasm> and rui - thanks for that - this is why i think we are good with Lith for SR1
14:32:15 <lmcdasm> since its done
14:32:26 <lmcdasm> and then target SFC support with NSH when its due for B release
14:32:28 <jonasbj> mskalski: What do you need to do with the plugin to go with Lithium?
14:32:51 <lmcdasm> (or maybe if the time slips b-sr1 with frameowrk for it in B).. its up to Jonas who knows the velocity of work for fuel really
14:32:57 <jonasbj> ruijing: Those dependencies will be for the B-release
14:33:30 <mskalski> jonasbj: nothing because OpenStack Juno not allow us to for example use L3 managed fully by ODL
14:33:51 <mskalski> jonasbj: so current implementation is the same as for helium
14:33:55 <ruijing> I am looking at how to install ovs and enable sfc.
14:34:09 <jonasbj> #agree We will go with ODL Lithium for SR1
14:34:22 <lmcdasm> we arent looking for the L3 stuff anyway
14:34:42 <lmcdasm> and by b-rel we can see how far along they are - rui - getting the OVS to make a SFF rigth now doesnt work
14:34:43 <jonasbj> lmcdasm, and others: Correct - no L3 for SR1
14:34:56 <lmcdasm> that ODL (tim and I were talking as well) is really dumb and you have to send it anything
14:35:01 <lmcdasm> (we can chat offline if you like)
14:35:12 <ruijing> Right. We need to wait for pushing NSH to ovs
14:35:19 <jonasbj> Anything more on SR1 plans?
14:35:30 <mskalski> Im curently investigating L3 with lithium and Kilo which will be a part of Fuel 7.0
14:36:04 <ruijing> when Fuel 6.1 release?
14:36:12 <jonasbj> mskalski: That could be a B-project milestone/sprint to have that working!
14:36:18 <mskalski> ruijing: is already released
14:37:31 <jonasbj> For the sake of formality - lets say something on B-release
14:37:42 <jonasbj> #topic B-release
14:38:21 <jonasbj> #info A new fuel@OPNFV gerrit repo is set-up
14:39:17 <jonasbj> #info can all fuel@OPNFV committers send me a +2 on the following patch just so we know the access policies are correct
14:39:29 <jonasbj> #link https://gerrit.opnfv.org/gerrit/#/c/1164/
14:39:31 <lmcdasm> patch id please (sorry lots of mail clutter)
14:39:32 <lmcdasm> haha
14:40:20 <jonasbj> #info we also have a own Jira area which we should start using
14:40:33 <lmcdasm> are we going 6.1 for B-rel?
14:40:49 <jonasbj> lmcdasm: No - 8.0
14:41:12 <jonasbj> As it stands today - provided release in Mar
14:41:52 <jonasbj> mskalski: Thanks for your +2 :-)
14:42:21 <jonasbj> But B-release is a little vague to mee - yet
14:43:19 <jonasbj> Anything more this week?
14:43:39 <ruijing> just question, why B-Release use Fuel 8.0 instead of Fuel 7.0?
14:44:05 <szilard> good question :)
14:44:12 <jonasbj> Can we have the formal sync and casual meeting swaped next week - I will travel on Thu
14:44:37 <mskalski> In Fuel 8.0 we should have OpenStack Liberty maybe this is one of the requirments
14:44:43 <szilard> That's okay, I will be on holiday on Thu (national)
14:44:51 <jonasbj> ruijing: At current TSC is setting Liberty as a targer
14:45:49 <ruijing> yes, understood
14:46:35 <jonasbj> Shall we end the call?
14:46:46 <jonasbj> 3
14:46:51 <ruijing> 2
14:46:56 <jonasbj> 1
14:46:58 <mskalski> one more thing from me I will be on holiday from 24.08 to 4.09
14:47:01 <jonasbj> Thanks everyone
14:47:07 <jonasbj> #endmeeting