14:02:40 <[1]JonasB> #startmeeting Weekly fuel sync
14:02:40 <collabot> Meeting started Thu Sep  3 14:02:40 2015 UTC.  The chair is [1]JonasB. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:40 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:02:40 <collabot> The meeting name has been set to 'weekly_fuel_sync'
14:02:51 <[1]JonasB> #info Jonas Bjurel
14:02:54 <s_berg> #info Stefan
14:03:04 <lmcdasm> #info daniel smith
14:03:11 <lmcdasm> noone in the GTM?
14:03:59 <[1]JonasB> Ahh - sorry missed that we had a goto meeting
14:03:59 <szilard> #info Szilard Cserey
14:04:07 <lmcdasm> not a big deal
14:04:10 <lmcdasm> i just noticed it
14:04:22 <lmcdasm> in the invite
14:04:32 <[1]JonasB> I dont have any headset today:-(
14:05:46 <szilard> I forgot too
14:08:32 <[2]JonasB> Sorry my pc blue-screened
14:08:33 <s_berg> (Jonas is having issues with some AI function in his OS.)
14:09:05 <[2]JonasB> So I was thinking we might quickly go through the Jiras for SR1
14:09:30 <[2]JonasB> #topic Arno SR1
14:10:39 <[1]JonasB> #topic Arno SR1
14:11:03 <[1]JonasB> Jira Fuel-3
14:11:12 <[1]JonasB> #info Jira Fuel-3
14:11:29 <[1]JonasB> #undo
14:11:29 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2b08450>
14:11:37 <[1]JonasB> #info Jira Fuel-4
14:12:31 <[1]JonasB> #info rebasing build to 6.1 on Stefan
14:13:16 <[1]JonasB> Ongoing I guess
14:13:21 <s_berg> Yes.
14:13:35 <[1]JonasB> #info in progress
14:13:35 <s_berg> Have a few questions for Michal, but no blockers.
14:13:46 <[1]JonasB> Michal is back on Mon
14:13:58 <s_berg> Great timing.
14:14:30 <[1]JonasB> #info Fuel 5rebasing deploy to 6.1 on Szilard
14:14:42 <[1]JonasB> #undo
14:14:42 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2950310>
14:14:46 <[1]JonasB> #info Fuel 5 rebasing deploy to 6.1 on Szilard
14:15:41 <[1]JonasB> ping szilard
14:18:09 <s_berg> (My guess is that this is almost completed, remaining is the discussion with Michal how to improve reaping of existing deployment in 6.1.)
14:18:32 <[1]JonasB> Hi szilard - short status on Fuel 5, deploy system for 6.1
14:18:44 <szilard_> HI
14:18:57 <szilard_> I'm finished with cleanup part of autodeploy
14:19:12 <[1]JonasB> Szilard can you info that'
14:19:14 <szilard_> regarding 6.1
14:19:33 <szilard_> #info finished with cleanup mechanism for autodeploy
14:19:52 <szilard_> #info 6.1 installation sometimes hangs-up
14:20:27 <szilard_> #info most of the time installation succeeds, but sometime turns out to be erronous
14:20:35 <[1]JonasB> szilard: Will you troubleshoot with Michal?
14:20:37 <szilard_> #info maybe I''m killing the menu process too early
14:20:47 <[1]JonasB> Ok
14:20:58 <szilard_> Michal will get back on Monday, I'll try to find out till then
14:21:12 <[1]JonasB> #info Fuel 7 covered by szilard above
14:22:03 <[1]JonasB> #info Fuel 8 virtualized deployment through deploy.sh
14:22:17 <[1]JonasB> #undo
14:22:17 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2ade5d0>
14:22:26 <[1]JonasB> #info Fuel 8 virtualized deployment through deploy.sh on Szilard
14:22:29 <szilard_> #info regarding ODL, ovsdb part doesn't start always in time, so I have to ask Michal to add the restart function in ODL plugin
14:23:11 <[1]JonasB> Szilard can you info on Fuel 8
14:23:41 <szilard_> #info Fuel 8 - I haven't tried it yet
14:23:53 <[1]JonasB> Ok
14:23:54 <szilard_> #info Fuel 6.1 I'm working with
14:24:12 <lmcdasm> hehe  -FUEL- 8 is the issue number i think
14:24:20 <lmcdasm> not Fuel v8
14:24:37 <s_berg> I got a bit confused there, thanks lmcdasm.
14:24:40 <szilard_> ok
14:24:43 <szilard_> :)
14:24:49 <[1]JonasB> #info Fuel 11 Update install instructions for Fuel 6.1/Arno SR1 on Daniel
14:24:59 <lmcdasm> i think it was "Fuel isuse #8 - virtualizations, blah blah)
14:25:03 <lmcdasm> #info - not started
14:25:24 <[1]JonasB> Thanks Dan
14:25:25 <lmcdasm> will give a run through of the manual tomorrow
14:25:39 <lmcdasm> how do we want to deal with ODL - manual steps inlude plugin creation
14:25:48 <lmcdasm> or assumption that plugin is built and just loading at deploy time?
14:26:02 <lmcdasm> include*
14:26:05 <szilard_> 1 question Fuel 8 is deployment on virtual environment ? we have that long time ago
14:26:25 <[1]JonasB> I think we assume it is buildt and need to be installed
14:26:29 <lmcdasm> Agree with Szi - we have virtual auto deployment for a while
14:26:41 <[1]JonasB> Szilard - should I close Fuel 8 then?
14:26:43 <lmcdasm> ok Jonas - thanks for the answer to my question
14:26:49 <szilard_> yes we can close Fuel 8
14:27:05 <szilard_> I will close it
14:27:05 <[1]JonasB> #Action Jonas to close Fuel 8
14:27:21 <szilard_> cause it was assigned to me :)
14:27:37 <[1]JonasB> Daniel, I guess the plugin resides on the .iso - though not clear how/where?
14:27:51 <lmcdasm> that is the bigger questino
14:27:56 <[1]JonasB> #undo
14:27:56 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2c56650>
14:28:05 <lmcdasm> when we release the ISO (built one for SR1) can i assume the plugin is there
14:28:07 <[1]JonasB> #Action Szilard to close Fuel 8
14:28:12 <lmcdasm> or that the person will have to do the steps
14:28:34 <lmcdasm> and if we assume the the plugin is pre-built  - no problem - we then have a new (or updated) requirement on the content of the SR1 ISO
14:28:43 <[1]JonasB> lmcdasm - I think so but we probably should ask Michal
14:28:45 <lmcdasm> for FUEL - (i.e plugin must be built by "make all"
14:29:02 <lmcdasm> hehe.. well.. it doesnt get built today if i get genesis, ill tell ya that :)
14:29:20 <lmcdasm> and do make all - so we will need to add a "f_odl_plugin_builder" or something i would think
14:29:29 <lmcdasm> but sure - lets see what Michal has built in for us to use first!
14:29:34 <lmcdasm> before we go remaking the wheel
14:29:42 <[1]JonasB> I think we should have a discussion around this when Michal is back
14:29:53 <s_berg> I would suggest one target "plugins", and that "make iso" adds that. We need to discuss whether plugins by default should end up on the ISO or not...
14:30:04 <lmcdasm> can you action to call the meeting?
14:30:05 <s_berg> Let's wait for Michal, agree.
14:30:16 <[1]JonasB> #info Fuel 12 Update build instructions on Jonas
14:30:17 <lmcdasm> ill set the agenda and do a little overview slide to start us on the meeting?
14:30:39 <[1]JonasB> #info I will start do that when the build rebase is finalized
14:30:45 <lmcdasm> agreed s_berg - im a bit fuzzy on how much we want to carry
14:30:56 <lmcdasm> vs. maybe making sure the facility is just on the FUEL master so people can "build plugins"
14:31:05 <lmcdasm> since MOS 6.1 means you are on the internet with FUEL anyway
14:31:14 <s_berg> Well...
14:31:18 <lmcdasm> if the MOS guys are moving away from carrying software, maybe we want to as well
14:31:35 <s_berg> We need to discuss that as well. I really think we need to have a way to do a non-Internet deploy!
14:31:53 <lmcdasm> agreed!!! - cause assumptino of a route to the net is a false one
14:31:54 <s_berg> Maybe that's just instructions though, to setting up a local repo.
14:31:55 <lmcdasm> in DC's
14:31:58 <[1]JonasB> That is actually a genesis requirement nowadays
14:31:58 <lmcdasm> i think so :)
14:32:06 <lmcdasm> which part Jonas?
14:32:26 <[1]JonasB> lmcdasm: Deploy without connectivity
14:32:53 <lmcdasm> anyway - two agenda points for the meeting with Michal
14:33:05 <lmcdasm> we should wait till wednesday before we bombard him with this (and monday is holiday here :PO )
14:33:09 <[1]JonasB> #info Fuel 13 Update deploy system documentation
14:33:13 <lmcdasm> (1 of the 5 we get a year :P)
14:33:25 <[1]JonasB> #undo
14:33:25 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2ac5dd0>
14:33:30 <[1]JonasB> #info Fuel 13 Update deploy system documentation on Szilard
14:34:08 <szilard_> I can take that
14:34:35 <szilard_> it's already assigned to me :)
14:34:37 <[1]JonasB> Cool
14:34:51 <[1]JonasB> #info Szilard will start on 13
14:34:52 <szilard_> great :)
14:35:16 <[1]JonasB> #info Fuel 14 Update release notes on Jonas
14:35:32 <szilard_> this apart from deploy/README.txt
14:35:47 <[1]JonasB> #info Jonas Will start next week.
14:36:00 <[1]JonasB> Szilard - I guess thats it!
14:36:14 <szilard_> ok
14:36:57 <[1]JonasB> #info Fuel 16 Deploy and configure ODL plugin for CI pipeline on Michal
14:37:21 <[1]JonasB> I guess it is deploy that will do this configuration? Szilard..
14:37:40 <szilard_> Autodeploy handles the ODL configuration
14:37:42 <szilard_> yes
14:37:52 <szilard_> in dea.yaml settings
14:38:04 <lmcdasm> ya.. Szi has done some friggin amazin' work
14:38:06 <[1]JonasB> So should I move this ticket to you?
14:38:07 <lmcdasm> just so you all know!
14:38:21 <szilard_> regarding CI pipeline
14:38:21 <lmcdasm> the auto deploy works sweet!
14:38:28 <[1]JonasB> I KNOW - Heja Szilard
14:38:35 <lmcdasm> Fatih can easily hook his stuff into it
14:38:48 <lmcdasm> the integration into CI should be done soon - we have the labs
14:38:56 <szilard_> we should integrate the ODL plugin build into the CI pipeline, that's the one is missing
14:38:57 <lmcdasm> and get that running nightly on a blade (just my thoughts)
14:39:05 <szilard_> I can work with that as well
14:39:12 <lmcdasm> so that as merges come we have a build server (apart from stable/master) to use
14:39:32 <[1]JonasB> #Action Jonas Move Fuel 16 to Szilard
14:39:57 <szilard_> thanks :) I'm ready to do some more Bash scripting ;)
14:40:25 <[1]JonasB> #info Fuel 17 ODL plugin on Michal
14:40:42 <[1]JonasB> #Michal is largely done with it
14:41:30 <[1]JonasB> #info Fuel 18 & 19 Are placeholders incas wee need to carry patches for ntp and dns - on Stefan
14:41:45 <[1]JonasB> What do we think about this?
14:42:10 <s_berg> There seems to be NTP improvements in place for 6.1 at least, so we should evaluate them first.
14:42:23 <szilard_> that is still valid, we need to keep the puppet manifests
14:42:26 <s_berg> Haven't looked at DNS yet, but will come naturally as I step up 6.1 testing.
14:42:44 <s_berg> szilard_: We need to repackage this into plugins instead.
14:43:01 <szilard_> oh I see
14:44:30 <s_berg> But this begs the question... should we keep NTP and DNS fixes as is for SR1, and do the plugin rewrite for R2?
14:44:37 <s_berg> Time constraints...
14:44:52 <s_berg> Not saying the fixes are still compatible though!
14:44:55 <szilard_> I think for lack of time we should keep it
14:44:59 <[1]JonasB> I gues that is OK!
14:45:18 <[1]JonasB> We have them as low prio
14:45:28 <lmcdasm> my thoughts
14:45:30 <s_berg> That means working on two branches in parallel, or me moving my work to stable/arno for now, skipping master.
14:45:35 <lmcdasm> are that if we dont have time and they are broke
14:45:37 <lmcdasm> in SR1
14:45:46 <lmcdasm> its something we can document and say "manually fix this after"
14:46:08 <lmcdasm> or during - since its being deprecated in R2
14:47:00 <lmcdasm> sorry stefan - i didnt understand the last part
14:47:06 <lmcdasm> why is that a branch change for you?
14:47:37 <s_berg> I'm ripping out all patches from master (as they will be rewritten as plugin if needed), then doing 6.1 uplift.
14:48:04 <s_berg> Should we keep them for SR1, I need to follow another path for stable/arno when doing the 6.1 uplift.
14:48:26 <lmcdasm> ahh.. yes.. i see what you mean - thx
14:48:43 <lmcdasm> i think since you (berg) are doing the rebase
14:48:48 <lmcdasm> you get to set the tone to easiest path
14:48:53 <s_berg> Let's hope for sunshine, I'll continue on master and will write plugins very quickly if we need 'em. As a working assumption for now at least.
14:48:58 <[1]JonasB> #info Fuel 18 & 19 are on the backlog but with low prio
14:49:03 <lmcdasm> adn then if we need to fix dns/ntp (which szi already has in autodeployment with yaml)
14:49:06 <lmcdasm> then we fix it
14:49:24 <[1]JonasB> So thats all Jira issues for SR1 - anything forgotten?
14:50:42 <[1]JonasB> Anyone from Juniper/OpenContrail on the chat?
14:51:40 <[1]JonasB> Ok I guess when they come on-line we should discuss OpenContral plugin integration.
14:52:00 <[1]JonasB> Anything more for SR1?
14:52:47 <[1]JonasB> Just to be clear OpenContrail is for B-release
14:53:00 <[1]JonasB> #topi AoB
14:53:27 <[1]JonasB> #topic AoB
14:53:38 <[1]JonasB> Daniel is comming to stockholm end Sep - right lmcdasm?
14:54:44 <[1]JonasB> Any chances Szilard and Jose could come to Stockholm at that time?
14:54:59 <s_berg> That would be awesome! :)
14:55:06 <szila118> I can come if you invite me :)
14:55:34 <[1]JonasB> szila118: You have a standing invite !:-)
14:55:45 <szila118> yuppeee ! thanks !
14:56:11 <lmcdasm> yes - end of sept / first week of Oct
14:56:12 <[1]JonasB> Lets findout exactly when and arrange this
14:56:18 <lmcdasm> looking at the dates will send them monday morning
14:56:27 <[1]JonasB> Anything more for today?
14:56:32 <lmcdasm> trying to align it with Thanksgiving (2/5 holiday in canada :P)
14:57:05 <lmcdasm> check out the NMS in our lab
14:57:07 <lmcdasm> !!!
14:57:23 <[1]JonasB> lmcdasm - when you know let us know.
14:57:32 <lmcdasm> will do (for trip!).
14:57:36 <[1]JonasB> So youre hacking web GUIs too :-)
14:57:44 <lmcdasm> hack anything
14:57:50 <lmcdasm> at this point ya
14:57:53 <[1]JonasB> A URL please ;-)
14:58:08 <lmcdasm> http://10.118.36.101:8980/openms
14:58:13 <lmcdasm> assumes you are in opnfvgw with SOCKS on
14:58:18 <lmcdasm> admin/admin
14:58:52 <[1]JonasB> Ahh, will test later!
14:59:15 <lmcdasm> working on setting up the "PUBLIC PORTAL" on our opnfvericsson server with a tunnel into this one
14:59:16 <[1]JonasB> 3
14:59:19 <lmcdasm> so that people can see from out side -
14:59:22 <lmcdasm> have a nice day!
14:59:29 <[1]JonasB> 2
14:59:35 <[1]JonasB> 1
14:59:36 <szila118> have a nice you too!
14:59:45 <[1]JonasB> Thanks every one
14:59:51 <[1]JonasB> #endmeeting