13:57:10 <[1]JonasB> #startmeeting Weecly Fuel@OPNFV sync-up
13:57:10 <collabot> Meeting started Thu Oct  8 13:57:10 2015 UTC.  The chair is [1]JonasB. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:57:10 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:57:10 <collabot> The meeting name has been set to 'weecly_fuel_opnfv_sync_up'
13:57:22 <lmcdasm> #info Daniel Smith
13:57:30 <[1]JonasB> #info Jonas Bjurel
13:57:34 <mskalski> #info Michal Skalski
13:57:37 <s_berg> #info Stefan Berg
13:59:28 <mskalski> hi do have link to gotomeeting ?
13:59:46 <s_berg> Don't think gtm was in the call. IRC only?
13:59:52 <[1]JonasB> #info Today we will also use GOTO meeting
14:00:01 <[1]JonasB> #link https://global.gotomeeting.com/join/516426245
14:00:04 <s_berg> Oh!
14:00:06 <lmcdasm> fancy!
14:00:07 <lmcdasm> :)
14:00:12 <s_berg> Wait a sec then.
14:00:28 <[1]JonasB> #topic Agenda bashing
14:01:40 <[1]JonasB> #link https://etherpad.opnfv.org/p/fuel@opnfv-meet
14:02:05 <[1]JonasB> Today we will also use GOTO meeting
14:02:13 <[1]JonasB> https://etherpad.opnfv.org/p/fuel@opnfv-meet
14:04:26 <[1]JonasB> Welcome Stuart - will you jump on to GOTO-meeting
14:05:09 <StuartMackie> # downloading - yawn
14:05:44 <StuartMackie> Waiting for organizer?
14:06:20 <s_berg> StuartMackie: Shouldn't take more than a few sec to get in.
14:06:56 <[1]JonasB> ;-)
14:07:29 <[1]JonasB> #topic Integrated projects review
14:07:42 <sbanka> #info Szymon Banka
14:07:51 <ruijing> #Ruijing Guo
14:08:12 <billyoma> #info billyoma (OVS-NFV)
14:08:22 <[1]JonasB> #link https://wiki.opnfv.org/fuel_opnfv_integrated-project-guidelines
14:08:49 <s_berg> There's a goto meeting for this meeting: https://global.gotomeeting.com/join/516426245
14:08:54 <[1]JonasB> #link https://wiki.opnfv.org/fuel_opnfv
14:09:45 <[1]JonasB> #topic OVS
14:10:24 <[1]JonasB> #info Up and running
14:10:52 <ruijing> I'd like to update OVS plugin status
14:11:24 <[1]JonasB> #info issue with building .iso because of proxiy issues (not supported by Fuel@OPNFV)
14:12:53 <[1]JonasB> #info Daniel Smith can help out as a SPOC for integration.
14:14:57 <ruijing> Hi, JonasB. You want to say someting, right?
14:15:19 <[1]JonasB> ruijing - hop on to Goto meeting
14:15:36 <[1]JonasB> https://global.gotomeeting.com/join/516426245
14:16:54 <ruijing> ok. joining
14:17:27 <[1]JonasB> #info BaseOS: CentOS or Ubuntu is OK.
14:20:26 <lmcdasm> hey Ruui- are you on the GTM?
14:20:28 <lmcdasm> muted maybe?
14:23:27 <[1]JonasB> #info Ruijing is working on OVS with service header for SFC, this work is separate from the OVS for NFV activity.
14:26:27 <[1]JonasB> #info CentOS 7 may come in Fuel 8.0
14:30:37 <ruijing> what's ubuntu version in Fuel 8.0?
14:33:42 <lmcdasm> dont think its decided yet Rui
14:35:03 <ruijing> if we use vagrant to build OVS version, it cause issue for infrastruction?
14:35:04 <[1]JonasB> #info We should arrange a plug-in workshop next
14:35:14 <[1]JonasB> #agree We plan to schedule OVS for NFV Fuel@OPNFV B-release WP1
14:35:27 <lmcdasm> Rui - if you use a Vagrant machine to just do the bilding you should be ok
14:35:36 <lmcdasm> however, you would need to be careful about kernel requirements for portability
14:35:39 <s_berg> ruijing: I think it would be great if it was possible to converge on Docker as a build method, but that's my personal opinion.
14:36:00 <[1]JonasB> #topic OpenContrail
14:36:06 <ruijing> we use docker to build ovs, but it still has some issues
14:36:09 <lmcdasm> (actually i would use K8ns Sberg - but thats cause i've been playing).
14:36:20 <lmcdasm> what about just using virsh/KVM rui?
14:36:26 <s_berg> ruijing: We need to make sure that whatever way of building sub-parts we use are possible to co-locate on the same "build box" in the LF (and other) infrastructure.
14:37:20 <ruijing> can we setup jenkins to build ovs rpm and fuel plugin to pull rpm from jenkins
14:37:36 <s_berg> ruijing: Again, in my personal opinion, each build system must also be "built" in such a way that the build dependencies are known (to produce the same results when run in different environments).
14:38:27 <ruijing> Hi, s_berg. I agree with you. it is easy to release if we build from source
14:38:28 <[1]JonasB> #info There already exists a Fuel-plugin for OpenContrail.
14:38:33 <mskalski> #link https://github.com/stackforge/fuel-plugin-contrail
14:39:49 <[1]JonasB> #info Some work might be need to rebase the plug-in for later OpenContrail.
14:40:04 <ruijing> Hi, Micheal. I am not sure if build machine is VM or physical. if we use vagrant, it may use netsted VM.
14:40:12 <ruijing> some VM may not support it
14:40:23 <[1]JonasB> #info Kilo and Liberty shall be supported.
14:41:08 <s_berg> Can a plugin also install some additional health checks as the plugin is installed?
14:43:47 <[1]JonasB> #info We need to develop a Make file that includes the plug-in
14:44:48 <ruijing> Hi, JonasB. all plugin-in are same repo
14:45:05 <s_berg> I would suggest that sub projects producing plugins are hooked up in the fuel repo as Git submodules.
14:45:35 <[1]JonasB> #agree Target OpenContrail for Fuel@OPNFV WP1
14:45:55 <[1]JonasB> Anyone from SFC in the call?
14:46:31 <[1]JonasB> #topic SFC
14:48:39 <[1]JonasB> #Ruijing Is working on a SFC/ODL plug-in
14:48:47 <[1]JonasB> #info Ruijing Is working on a SFC/ODL plug-in
14:49:54 <lmcdasm> +1 to S_berg idea for Sub git mods
14:50:02 <ruijing> +1
14:53:18 <[1]JonasB> #info Proposal is to use current ODL-plug-in also for SFC (by configuration or similar).
14:54:11 <[1]JonasB> #info Michal  will help out in the plug-in devel.
14:54:48 <[1]JonasB> #info agree Target Fuel@OPNFV WP1.
14:55:16 <[1]JonasB> Anyone from L3VPN on the call?
14:56:04 <[1]JonasB> Any one from ONOSFW on the call?
14:57:45 <[1]JonasB> #info L3VPN and ONOS to be covered next week as there are no representatives from these projects.
15:03:48 <[1]JonasB> Thanks very much for this meeting.
15:03:54 <[1]JonasB> #endmeeting