00:58:42 <MatthewLi_> #startmeeting bottlenecks weekly meeting
00:58:42 <collabot`> Meeting started Thu Apr 7 00:58:42 2016 UTC. The chair is MatthewLi_. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:58:42 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
00:58:42 <collabot`> The meeting name has been set to 'bottlenecks_weekly_meeting'
00:58:56 <MatthewLi_> #info Jun Li
01:00:27 <Yaoguang_Wang> #info Yaoguang Wang
01:11:44 <MatthewLi__> so we begin
01:11:58 <Yaoguang_Wang> okay,
01:12:00 <MatthewLi__> #info agenda
01:12:20 <MatthewLi__> 1) Docs: Bottlenecks definition documents (MR) and C release document contribution in OPNFV DOCs project(all) 2) Integration & test workflow improvement newly submitted patches (matthew, yaoguang, Qiliang, etc ) 3) Puppet refactoring codes (yaoguang, Qiliang, matthew, etc) 4) Dashboard progress (mingjiang, Qiliang, matthew, etc)
01:12:36 <MatthewLi__> #info docs
01:12:57 <MatthewLi__> MR_Sandvine: how it going with your document?
01:13:05 <Yaoguang_Wang> #topic Docs: Bottlenecks definition documents
01:15:09 <Yaoguang_Wang> MatthewLi__: ping Manual first
01:15:15 <MatthewLi__> Yaoguang_Wang: do u have any ideas about the definition documents?
01:16:03 <Yaoguang_Wang> is the doc specific for Release C?
01:16:54 <MatthewLi__> Yaoguang_Wang: no, it will satisfy for all release
01:17:07 <MatthewLi__> definitly, it has evolution
01:17:28 <Yaoguang_Wang> i am not sure what the doc will cover, maybe objective, scope, methodology, right?
01:18:11 <MatthewLi__> in the means of content, it will cover VIM and MANO
01:20:19 <Yaoguang_Wang> i agree
01:21:09 <Yaoguang_Wang> i think the project could cover both data plane and control plane
01:21:22 <MatthewLi__> yep
01:22:33 <Yaoguang_Wang> in other words, any aspects that affect the performance can be covered in Bottlenecks
01:23:22 <MatthewLi> yep that's what we will do
01:25:05 <Yaoguang_Wang> i hope Manuel can divide into several big categories, and then small items
01:25:28 <MatthewLi> Yaoguang_Wang: yep we will wait for manuel's work
01:25:49 <Yaoguang_Wang> the definition doc is very important, which will guide us to make the Bottlenekcs better
01:26:48 <MatthewLi> #agree wait for mauel's definition document
01:27:02 <Yaoguang_Wang> +1
01:27:22 <Yaoguang_Wang> let's move on
01:27:47 <Yaoguang_Wang> #topic Integration & test workflow improvement
01:28:16 <MatthewLi> #info Jun Li has put up some patches about this
01:28:26 <Yaoguang_Wang> great
01:28:37 <MatthewLi> #info Jun Li is working with the openstack env
01:29:28 <MatthewLi> #info this will completed soon
01:29:37 <Yaoguang_Wang> Good
01:29:59 <MatthewLi> since I have a test recently, I don't know if I have enough time :(
01:31:11 <MatthewLi> I will try to complete this as soon as possible
01:31:15 <Yaoguang_Wang> okay, you have great ability to do many things together
01:31:36 <MatthewLi> Yaoguang_Wang: thank u
01:31:57 <Yaoguang_Wang> i am not sure if your HOT generator is flexible enough
01:32:33 <Yaoguang_Wang> maybe i will change the configuration parameters in rubbos test suite
01:32:37 <MatthewLi> Yaoguang_Wang: I will show u the code when it runs correct in openstack env
01:32:44 <Yaoguang_Wang> okay.
01:33:22 <Yaoguang_Wang> we can discuss the interfaces later
01:33:23 <MatthewLi> Yaoguang_Wang: u can complete the workflow inside the instance for rubbos
01:33:32 <MatthewLi> Yaoguang_Wang: yep
01:33:43 <MatthewLi> so we come to an agreement
01:33:48 <Yaoguang_Wang> yep
01:34:33 <MatthewLi> #agreed Jun Li to complete the Integration & test workflow improvement for instance creation and Yaoguang_Wang will complete the workflow inside instance for rubbos
01:34:55 <Yaoguang_Wang> #agreed
01:35:05 <MatthewLi> so let's move on
01:35:26 <MatthewLi> #topic Puppet refactoring codes
01:35:44 <MatthewLi> Yaoguang_Wang: how it goes?
01:36:46 <Yaoguang_Wang> #info YaoguangWang has completed 6 modules(total 7) for rubbos
01:37:00 <MatthewLi> Yaoguang_Wang: great job
01:37:16 <Yaoguang_Wang> i will finish all within this week
01:37:19 <MatthewLi> :)
01:38:09 <MatthewLi> good
01:38:10 <Yaoguang_Wang> the codes should be flexible and leave some labels or tags in config file, you know
01:38:26 <MatthewLi> yep
01:38:43 <Yaoguang_Wang> so i must clean the codes before uploading to the repo
01:38:57 <Yaoguang_Wang> i will finish it soon
01:39:03 <MatthewLi> what do u mean by clean the codes?
01:39:35 <Yaoguang_Wang> adding labels of tags there, i mean
01:39:47 <Yaoguang_Wang> in order to support other test cases
01:39:57 <MatthewLi> OK, that's good
01:40:16 <MatthewLi> so maybe u can give some #action here
01:40:32 <Yaoguang_Wang> #info rubbos can be executed in local vms successfully now
01:41:38 <Yaoguang_Wang> #action YaoguangWang will leave some labels or tags in config files to support other test cases
01:42:11 <Yaoguang_Wang> besides, we should consider vstf soon
01:43:19 <Yaoguang_Wang> first, vstf should also be configured in our unified entrance, right
01:44:15 <Yaoguang_Wang> let's make it an action?
01:44:25 <MatthewLi> Yaoguang_Wang: vstf is included in our workflow
01:44:32 <MatthewLi> yes
01:45:17 <MatthewLi> #action vstf integration and test workflow improvement
01:45:32 <Yaoguang_Wang> i mean we should configure vstf test cases flexibly, maybe yaml or cli parameters
01:45:56 <MatthewLi> #idea configure vstf test cases flexibly, maybe yaml or cli parameters
01:46:12 <MatthewLi> good
01:46:25 <Yaoguang_Wang> secondly, need vstf implement all Tu test cases in Colorado?
01:46:40 <MatthewLi> Yaoguang_Wang: it depends our time
01:46:55 <MatthewLi> we can talk about this next times
01:47:13 <MatthewLi> we should do things step by step
01:47:21 <Yaoguang_Wang> ok
01:47:30 <MatthewLi> we can give an idea here
01:47:44 <MatthewLi> #idea vstf implement all Tu test cases in Colorado
01:47:54 <Yaoguang_Wang> :)
01:48:29 <MatthewLi> anything else about the refactoring?
01:48:38 <Yaoguang_Wang> #idea should vstf be refactored using puppet
01:49:19 <Yaoguang_Wang> there are three things for vstf, that's all
01:49:39 <MatthewLi> good
01:49:43 <Yaoguang_Wang> we need more contributors :)
01:49:50 <MatthewLi> Yaoguang_Wang: yep
01:50:14 <MatthewLi> so I have an idea, if can we change the meeting to #opnfv-meeting channel
01:51:42 <Yaoguang_Wang> after we can run one rubbos test case in Openstack env?
01:52:18 <MatthewLi> Yaoguang_Wang: yep
01:52:36 <Yaoguang_Wang> okay. next?
01:52:41 <MatthewLi> more advertisement I mean
01:53:10 <Yaoguang_Wang> good
01:53:16 <MatthewLi> next meeting
01:53:26 <Yaoguang_Wang> no more topic?
01:53:45 <MatthewLi> #agreed weekly meeting changed to #opnfv-meeting channel next time
01:53:55 <MatthewLi> #topic dashboard
01:53:58 <Yaoguang_Wang> :)
01:54:37 <MatthewLi> #info waiting for Mingjiang's dashboard progress
01:54:46 <Yaoguang_Wang> :(
01:55:09 <MatthewLi> #info when Jun Li and Yaoguang_Wang has some time, will pay attention to the dashboard
01:55:36 <Yaoguang_Wang> okay:(
01:56:08 <MatthewLi> #action Mingjiang preparation for the dashboard research slide
01:56:31 <MatthewLi> so we come to the end
01:56:39 <Yaoguang_Wang> yep
01:56:43 <MatthewLi> bye
01:56:49 <Yaoguang_Wang> bye
01:56:51 <MatthewLi> #endmeeting
01:58:00 <MatthewLi__> #endmeeting
01:59:03 <Yaoguang_Wang> #endmeeting