18:16:44 <dfarrell07> #startmeeting cperf
18:16:44 <collabot> Meeting started Thu Oct 27 18:16:44 2016 UTC. The chair is dfarrell07. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:16:44 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:16:44 <collabot> The meeting name has been set to 'cperf'
18:19:08 <dfarrell07> #info dfarrell07 has been helping Veryx people make progress on PktBlaster test
18:19:21 <dfarrell07> #info dfarrell07 wrote docs about how to define jobs, add tests to CPerf
18:19:50 <dfarrell07> #link https://wiki.opnfv.org/display/cperf/Adding+Tests new CPerf docs about adding tests
18:20:28 <dfarrell07> #info Al has updated his JIRA with info about IETF draft updates/progress relevant to us
18:23:25 <dfarrell07> #info Al talks about draft, and test about path creation. We don't do this he thinks. Idea is to create a path and test path in dataplane.
18:23:47 <dfarrell07> #info Nikos can/should use the adding test docs dfarrell07 wrote as well
18:25:22 <dfarrell07> #info Can imagine this path test as a perf test, how fast can we create paths between OVSs
18:26:20 <dfarrell07> #info dfarrell07 and jamoluhrsen think we have the basic keywords required to do such a test in ODL CSIT already, wouldn't be crazy hard to add
18:26:49 <dfarrell07> #info Al clarifies that switches would be connected to ODL already, then to ODL NB we say "make this path", then time how long until pings work
18:27:42 <dfarrell07> #info Would also want to take away protocol details, don't really care if OF
18:27:59 <dfarrell07> #info Black box: Two hosts connected, tell controller to make path, how long until they can talk to each other
18:28:16 <dfarrell07> #info So, I guess we're looking for someone to take this TODO, write this test
18:35:43 <dfarrell07> #info Discussion about sharing POD
18:35:58 <dfarrell07> #info dfarrell07 talks about idea of federating dev pods, allowing them to be checked out
18:36:28 <dfarrell07> #agreed We are okay with sharing our POD in this federated way, as long as we can check it out for long periods of time to do dev work (like with broken deployments)
18:37:30 <dfarrell07> #info mgkwill reports progress on ODL with OpenStack full deploy, many compute nodes, Rally for testing
18:37:59 <dfarrell07> #info this OpenStack test is making progress, but contractor's work needs some review from mgkwill
18:40:05 <dfarrell07> #info jamoluhrsen has given some CPerf cycles to getting job running, standard run, see a fairly normal problem, fix, re-run
18:40:22 <dfarrell07> #info Job is running for ~10 mins now before failing, so good
18:41:01 <dfarrell07> #info Question about OS on boxes, none have OS except jumphost, this is how it's supposed to be says mgkwill, Apex will install OS once we get that far in deploy
18:41:27 <jamoluhrsen> #link https://build.opnfv.org/ci/view/All/job/apex-runner-cperf-colorado/ <--- cperf parent job
18:41:44 <dfarrell07> #info Build with Params that^
18:41:49 <jamoluhrsen> #link https://build.opnfv.org/ci/job/apex-deploy-baremetal-os-odl_l2-nofeature-ha-colorado/ <--- cperf deploy job
18:41:58 <dfarrell07> #info To kick off this job^
18:42:21 <dfarrell07> #info mgkwill et all can help by doing that process, finding whatever's failing, fixing and rerunning
18:43:30 <dfarrell07> #info Al reports that Jack had said he would be moving Intel POD after OpenStack summit, so they will likely break us next week
18:44:03 <dfarrell07> #endmeeting