12:55:58 <r-mibu> #startmeeting doctor
12:55:58 <collabot> Meeting started Tue Aug 25 12:55:58 2015 UTC.  The chair is r-mibu. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:55:58 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
12:55:58 <collabot> The meeting name has been set to 'doctor'
12:56:06 <r-mibu> #topic roll call
12:56:11 <r-mibu> #info Ryota Mibu
12:58:30 <tojuvone> #info Tomi Juvonen
13:00:16 <ildikov> #info Ildiko Vancsa
13:01:09 <GeraldK> #info Gerald Kunzmann
13:01:34 <bertys> #info Bertrand Souville
13:03:27 <maryamtahhan> #info Maryam Tahhan
13:03:59 <bryan_att> #info Bryan Sullivan
13:04:04 <TommyL> #info Tommy Lindgren
13:05:17 <GeraldK> #topic Ceilometer BP status
13:05:39 <GeraldK> #link https://review.openstack.org/#q,topic:bp/event-alarm-evaluator,n,z
13:06:03 <GeraldK> last week 2 patches got merged; one additional patch proposed 3 days ago
13:06:51 <GeraldK> #info last week 2 patches got merged; one additional patch proposed 3 days ago (already merged today)
13:07:15 <GeraldK> #info Ceilometer blueprint approved
13:07:39 <dandruta> #info Dan Druta
13:07:51 <GeraldK> #info we can again focus on specification / documentation
13:08:09 <r-mibu> #topic Nova BP
13:08:27 <GeraldK> #link https://blueprints.launchpad.net/nova/+spec/robustify-evacuate
13:08:48 <r-mibu> #chair GeraldK
13:08:48 <collabot> Current chairs: GeraldK r-mibu
13:08:52 <GeraldK> #info this BP has relation to our work. currently for Liberty, but Tomi has doubts it will be accepted for Liberty
13:09:05 <r-mibu> #chair ildikov
13:09:05 <collabot> Current chairs: GeraldK ildikov r-mibu
13:09:10 <r-mibu> #chair tojuvone
13:09:10 <collabot> Current chairs: GeraldK ildikov r-mibu tojuvone
13:09:30 <GeraldK> #info there might be situations where bad decisions could be made and data could be deleted
13:09:58 <GeraldK> #info this BP is trying to fix this bug which is related to Doctor
13:10:50 <GeraldK> #info Tomi is currently working on documentation of mark-host
13:12:01 <GeraldK> #info plan is to make documentation available for Doctor and maybe also for OpenStack
13:12:22 <GeraldK> #action Tomi to create Jira ticket for this documentation work on the mark-host-down
13:12:42 <GeraldK> #action Tomi to create Jira ticket for "Make evacuate more robust" BP
13:14:16 <GeraldK> #undo
13:14:16 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2aa3510>
13:14:51 <r-mibu> #info the BP is related to Doctor some point, no action as doctor project so far
13:15:38 <GeraldK> #link https://review.openstack.org/#/c/192246/
13:16:28 <GeraldK> #action Tomi to create Jira ticket for "Get valid server state"
13:17:13 <GeraldK> #topic Pinpoint project
13:17:32 <GeraldK> #link https://wiki.opnfv.org/pinpoint/pinpoint_project_proposal
13:18:21 <GeraldK> #info Adi is presenting the proposal; seems there is overlap between Pinpoint and Doctor
13:19:51 <GeraldK> #info project is currently focusing on "NFV networking" and is related to RCA and fault localization
13:20:36 <GeraldK> #info goal is to find root cause for several problems being observed
13:21:32 <GeraldK> #info different APIs proposed: NB I/F to user/system; SB I/Fs to OAM tools, Fault information DB, System configuration DB, system model DB
13:23:13 <GeraldK> #info interfaces to Neutron, Nova, Ceilometer, Monasca, Cinder, ...
13:25:00 <GeraldK> #info proposal is to have Fault Correlator for NFVI collecting and correlating faults in virtual and physical infrastructure
13:25:30 <GeraldK> #info focus on offline network state analytics
13:28:27 <GeraldK> #info Ryota: in Doctor project there are 4 functional blocks: Ceilometer is used as Notifier
13:29:57 <GeraldK> #info Adi: Pinpoint has different focus than Doctor; e.g. find configuration mistake
13:33:07 <GeraldK> #info Gerald: RCA is important project, but concern is that new NB I/F is not aligned with ETSI NFV
13:33:57 <GeraldK> #info Tommy: what is the use case here? help the tenant/cloud to extract root cause from a huge number of logs; help IP manager
13:35:37 <GeraldK> #info Tommy: in the shown MANO architecture most of the arrows in the proposal go to the OSS side
13:37:37 <GeraldK> #info Ryota: for Doctor project we are providing NB I/F to user that cannot see the infrastructure, whereas in PinPoint the user can see the infrastructure, thus the NB I/F might be different. PinPoint may extend the Doctor inspector.
13:38:09 <GeraldK> #info we can work together on how to learn about events and send notifications about faults
13:41:25 <GeraldK> #info Bryan: what's relationship to Predictor? Adi: Prediction is another analyticts using similar input, but running different algorithms and producing differnet output (predict failures vs analyze existing failures)
13:42:02 <GeraldK> #info Bryan: there is commonality between the data sources used. which project would work on the data sources side?
13:44:25 <GeraldK> #info Bryan: what is common for Pinpoint, Doctor, Predictor is what data sources are being used.
13:44:54 <GeraldK> #info Bryan: we should not have OPNFV projects that are so close that people should join multiple projects on similar topic
13:46:45 <GeraldK> #info Gerald: isn't there big overlap in fault correlation in the above projects?
13:47:10 <GeraldK> #info Adi: different information type is needed to predict fault.
13:49:17 <GeraldK> #info Adi: regarding Pinpoint and Doctor there is similarity. Pinpoint is more offline analytics. proposal that fault correlation can be worked in Doctor. Fault correlation is not the main topic in both projects.
13:50:17 <GeraldK> #info Larry: in practise in a real system only few faults should occur
13:54:08 <GeraldK> #info Larry: analytics should be run by the entity detecting the fault, but some entity in a higher layer having a wider view and understanding of the system
13:54:16 <GeraldK> #undo
13:54:16 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2acc450>
13:54:22 <GeraldK> #info Larry: analytics should not be run by the entity detecting the fault, but some entity in a higher layer having a wider view and understanding of the system
13:55:24 <GeraldK> #info Al Morton: it would be good to differentiate transient and steady-state failures.
13:56:03 <GeraldK> #info Ryota: wants to see use case of Pinpoint to better understand motivation of the project and difference to Doctor
13:57:12 <GeraldK> #info Adi: plan is to start with use cases
14:03:33 <r-mibu> #info we'll continue discussion on the mailing list
14:03:38 <r-mibu> #endmeeting