#opnfv-doctor: Doctor

Meeting started by GeraldK at 13:02:21 UTC (full logs).

Meeting summary

    1. Carlos Goncalves (cgoncalves, 13:02:25)

  1. Roll Call (GeraldK, 13:02:29)
    1. Gerald Kunzmann (GeraldK, 13:02:37)
    2. Tomi Juvonen (tojuvone, 13:02:37)
    3. Uli Kleber (uli-k_, 13:02:38)
    4. agenda for today's meeting: https://etherpad.opnfv.org/p/doctor_meetings (cgoncalves, 13:03:52)
    5. Hackfest Quick Reports (GeraldK, 13:04:35)
    6. https://etherpad.opnfv.org/p/doctor_2016Q1_hackfest (GeraldK, 13:05:00)
    7. all intended Nova and Aodh BPs are already implemented in upstream (GeraldK, 13:06:36)
    8. potential new use case on "how to mark down ports". gap analysis needed. (GeraldK, 13:07:27)
    9. we need to start discussion on OPNFV Summit in one of the next calls (GeraldK, 13:08:43)
    10. Colorado planning (GeraldK, 13:09:27)
    11. add installers, test cases, SB API specs, and integration of Inspector modules (GeraldK, 13:11:09)
    12. cgonvalves, we had a good discussion with Vitrage team on how to integrate Inspector(s). user could choose which one to use. (GeraldK, 13:13:23)
    13. for maintenance, Tomi led discussion on "Maintenance". identified some gaps. (GeraldK, 13:14:43)
    14. https://wiki.opnfv.org/_media/opnfv_doctor_maintenance_api_20160313.pptx (cgoncalves, 13:14:47)
    15. it was discussed that this might not be the right approach to use the Inspector, but integrate the actions into Nova (GeraldK, 13:17:17)

  2. Maintenance changes to Nova (GeraldK, 13:19:34)
    1. Tomi has a new proposal for the maintenance in mind (GeraldK, 13:21:06)
    2. Tomi already had some chat with John Garbutt (Nova plt) and he is also very interested about the topic and looking to see spec and it would be natural continue for get-valid-server-state work. Also proposed I could discuss this with API team. (GeraldK, 13:21:52)
    3. Initial proposal would be to have start and end time visible. API to set that and visibility to VM owner also. Currently only disable/enable to stop schduling, but this would be for the real maintanance period. (GeraldK, 13:22:23)
    4. Any actions for VMs would be harder and out of scope. Also talked a bit about this with Sean Dague (core). Mostly opinion has been to have this external, but gaps surely needs to implement in Nova if use case needs it. Some discussion exists about auro recovery, but perhaps addressed later. (GeraldK, 13:22:32)
    5. Tomi: the proposal from the hackfest was more complex and complete; the new proposal is to have maintenance window visible; have an API to have start time and end time. (GeraldK, 13:24:27)
    6. cgoncalves: would this fully cover maintenance use case or would we need other mechanisms, e.g. migration actions? (GeraldK, 13:25:06)
    7. Tomi: anyway all maintenance actions are left out of scope (GeraldK, 13:25:23)
    8. ACTION: Tomi to share draft BP spec (GeraldK, 13:28:31)
    9. Tomi: user will be notified similar to "mark host down" use case (GeraldK, 13:30:56)
    10. cgoncalves: this is only a notification to VIM, but you would also need alarming to consumer to inform them about the planned maintenance window (GeraldK, 13:32:33)

  3. AOB (GeraldK, 13:34:11)
    1. OpenStack Summit in Austin: multiple Doctor members got presentations accepted (GeraldK, 13:34:38)
    2. OPNFV Summit: Reminder CFP deadline is March 31 (GeraldK, 13:36:31)
    3. pls note the meeting time adjusted to summer times (GeraldK, 13:40:33)
    4. proposal to have discussion on OPNFV Summit proposals / demo in next week's call (GeraldK, 13:45:17)
    5. if someone missed the Vitrage demo from last week contact Ohad, they volunteer to present it again (GeraldK, 13:46:20)
    6. happy Easter (GeraldK, 13:47:07)


Meeting ended at 13:47:10 UTC (full logs).

Action items

  1. Tomi to share draft BP spec


People present (lines said)

  1. GeraldK (35)
  2. collabot (5)
  3. cgoncalves (4)
  4. tojuvone (1)
  5. uli-k_ (1)


Generated by MeetBot 0.1.4.