13:00:28 <r-mibu> #startmeeting doctor
13:00:28 <collabot> Meeting started Tue Aug 16 13:00:28 2016 UTC.  The chair is r-mibu. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:28 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:00:28 <collabot> The meeting name has been set to 'doctor'
13:00:36 <r-mibu> #topic roll call
13:00:41 <r-mibu> #info Ryota Mibu
13:01:08 <yujunz> #info Yujun Zhang
13:01:18 <tojuvone> #info Tomi Juvonen
13:01:46 <tommyL> #info Tommy Lindgren
13:02:03 <tommyL> only on chat for a while
13:02:15 <r-mibu> np
13:03:23 <r-mibu> #link https://etherpad.opnfv.org/p/doctor_meetings
13:03:33 <bertys> #info Bertrand Souville
13:03:33 <ljlamers> #info Larry Lamers
13:05:38 <GeraldK> #info Gerald Kunzmann
13:06:11 <mtahhan> #info Maryam Tahhan
13:08:16 <r-mibu> #link https://wiki.opnfv.org/display/doctor/Colorado+Planning
13:08:28 <r-mibu> #topic Fix Doctor test in functest
13:08:37 <r-mibu> #link https://jira.opnfv.org/browse/DOCTOR-63
13:09:05 <mtahhan> #info current status of Doctor Test in CI pipeline - still no green light
13:09:27 <mtahhan> #info there still an issue in the deployment and more investigation is required
13:09:49 <mtahhan> #info Ryota has access to the relevant POD.
13:10:18 <mtahhan> #info Question: is it the same issue we are seeing in the Nokia Lab? that the consumer does not receive
13:10:59 <bertys> #info Response: yes
13:11:11 <mtahhan> #info debug logs can be see in the DOCTOR-63 issue
13:14:43 <r-mibu> #action ryota to comment in JIRA ticket how to debug
13:16:17 <r-mibu> #topic Congress integration
13:16:21 <yujunz> losing audio?
13:16:24 <r-mibu> #link https://jira.opnfv.org/browse/DOCTOR-56
13:17:06 <mtahhan> #info Carlos uploaded a new patch
13:17:23 <r-mibu> #link https://gerrit.opnfv.org/gerrit/#/c/18429/
13:17:40 <mtahhan> #info script was tested with devstack deployment
13:18:15 <mtahhan> #info Ryota suggests that this patch can be merged as soon as we get a green light in the OPNFV CI pipekine
13:18:25 <mtahhan> #info pipeline*
13:19:12 <mtahhan> #info Ryota Question: should this be merged right now, or what's the criteria to merge this patch?
13:19:35 <yujunz> Is it reviewed?
13:20:32 <mtahhan> #info no verify testing is attached with this patch, which might be a concern... but it can be merged
13:20:51 <r-mibu> yujunz: not yet
13:21:15 <yujunz> I think we should review before merging any patch.
13:21:22 <r-mibu> yujunz: i mean once we reviewed and got green light in base test case (apex)
13:21:42 <yujunz> That would be OK
13:23:15 <r-mibu> #topic Fuel support
13:23:28 <r-mibu> #link https://jira.opnfv.org/browse/DOCTOR-58
13:23:41 <r-mibu> #link http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2016-August/012054.html
13:24:31 <mtahhan> #info there is a misconfiguration of ceilometer in the Fuel plugin
13:24:37 <r-mibu> #link https://gerrit.opnfv.org/gerrit/#/c/18285/
13:26:45 <mtahhan> did anyone else lose audio?
13:26:56 <yujunz> No body hear me?
13:27:00 <r-mibu> yujunz: i cann't hear you
13:27:08 <GeraldK> same here
13:27:18 <yujunz> #info I think we should take the first step to verify the modification works for fuel
13:27:36 <yujunz> #info Then start to resolve the conflict with other scenario if there will be any
13:28:49 <yujunz> #info The current fix will verify the doctor scenario on fuel, and I think we should apply it first.
13:28:54 <yujunz> I can hear
13:29:11 <yujunz> #info whether it is a plugin or not is not so important
13:30:13 <r-mibu> yujunz: agree, so I +1ed to have script to touch ceilometer config
13:30:22 <yujunz> I can hear. So other people may use the audio as before.
13:31:33 <yujunz> Lost audio?
13:31:59 <dwj> Is there any difference about a script to touch ceilometer config or fuel plugin?
13:32:24 <yujunz> If we provide a plugin at the moment, some people may enable it by mistake
13:32:38 <yujunz> I think that's why modifying the script is less risky
13:33:16 <r-mibu> dwj, no - Carlos pointed that we run our test in different platform/OpenStack once we touched it
13:35:28 <dwj> The fuel plugin is hot pluggable,before we run the doctor test, we install the plugin to modify the configuration.After the test run finished, uninstall the plugin to restore the ceilometer configuration
13:36:38 <dwj> I think it's the same about adding a script to handle this.
13:37:38 <r-mibu> dwj, having test in different config of ceilometer means we need paltform/OpenStack different from default OPNFV platform
13:38:37 <yujunz> Yes, finally we shall arrive at one platform as Carlos pointed out " If we cannot even validate that OPNFV-enabled scenarios are functional and don't conflict among each other we are failing at ..."
13:39:03 <yujunz> The first step is to validate the scenario are functional.
13:39:12 <r-mibu> agree
13:40:10 <r-mibu> I can propose to close this ticket first
13:40:21 <r-mibu> and leave known issue in release note
13:40:47 <yujunz> Do you mean merge the patch then close?
13:41:15 <r-mibu> no
13:41:24 <r-mibu> just close tocket
13:41:31 <r-mibu> *ticket*
13:42:23 <r-mibu> verify the function could be another task
13:43:33 <yujunz> OK. So we shall go with the approach suggest in Email thread. Modify the script to validate it under fuel.
13:43:45 <r-mibu> right
13:43:55 <yujunz> I'm OK with that.
13:45:57 <r-mibu> moving on to next topic...
13:46:04 <r-mibu> #topic Docs!
13:48:07 <r-mibu> #action ryota to create JIRA task for Docs as a placeholder
13:48:18 <r-mibu> #topic Branch cut policy
13:51:31 <r-mibu> #info ryota suggest to have three steps: 1) get green light in base apex test, 2) merge new features and 3) get another green light after 2)
13:52:03 <yujunz> OK for me
13:52:21 <r-mibu> #info step 1) should be done by Aug 18 (Thu)
13:53:48 <r-mibu> yujunz: thanks
13:54:36 <r-mibu> #info how we made decision whether we should drop new features when we couldn't finish 1) or 2)
13:59:14 <r-mibu> #info we will skip meeting in next week, resume the meeting from Aug 30
13:59:18 <r-mibu> #endmeeting