13:02:58 <r-mibu> #startmeeting doctor
13:02:58 <collabot> Meeting started Tue Apr 18 13:02:58 2017 UTC.  The chair is r-mibu. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:58 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:02:58 <collabot> The meeting name has been set to 'doctor'
13:03:05 <r-mibu> #topic roll call
13:03:08 <tojuvone> #info Tomi Juvonen
13:03:10 <r-mibu> #info Ryota Mibu
13:03:11 <cgoncalves> #info Carlos Goncalves
13:03:23 <cgoncalves> yujunz: ping
13:03:26 <cgoncalves> bertys: ping
13:03:31 <yujunz> #info Yujun Zhang
13:04:49 <GeraldK> #info Gerald
13:05:13 <r-mibu> any topic for today's meeting?
13:07:50 <r-mibu> #topic E release planning
13:08:28 <r-mibu> #link https://etherpad.opnfv.org/p/doctor_e_release_items
13:09:55 <GeraldK> #link https://wiki.opnfv.org/display/doctor/Euphrates+Planning
13:09:57 <r-mibu> #action ryota to report completion of doctor E release planning to david (using summary template)
13:10:19 <r-mibu> #topic Report from meeting with HA
13:10:54 <r-mibu> #link https://lists.opnfv.org/pipermail/opnfv-tech-discuss/2017-April/015863.html
13:11:56 <GeraldK> #link http://docs.opnfv.org/en/stable-danube/submodules/availability/docs/development/overview/index.html
13:12:11 <r-mibu> #link http://artifacts.opnfv.org/availability/docs/development_overview/_images/OPNFV_HA_Guest_APIs-Overview_HLD-Guest_Heartbeat-FIGURE-1.png
13:12:24 <r-mibu> #link http://artifacts.opnfv.org/availability/docs/development_overview/_images/OPNFV_HA_Guest_APIs-Overview_HLD-Peer_Messaging-FIGURE-2.png
13:18:48 <GeraldK> #info two use cases from HA had been presented. the document will be revised based on the discussion.
13:19:37 <GeraldK> in the first use case (figure 1), Doctor work flow can be utilized. in the second use case the overlap is mainly on the notification
13:19:53 <r-mibu> #topic AoB
13:20:17 <GeraldK> #link https://review.openstack.org/424340 port-data-plane-status was accepted
13:20:45 <GeraldK> congrats cgoncalves
13:21:05 <r-mibu> #info we can test with those merged code, and can ask installers to backport this feature from pike to ocata
13:21:52 <GeraldK> #action cgoncalves will create a new Jira ticket for backporting of this feature
13:24:30 <cgoncalves> GeraldK: thanks
13:26:48 <r-mibu> #info status of collectd support in OPNFV installers; apex will support soon
13:27:45 <dwj> #link https://gerrit.opnfv.org/gerrit/#/c/33381/
13:27:58 <cgoncalves> #info Carlos assigned to DOCTOR-101. plan is to add collectd support introduced by the Barometer project
13:30:21 <yujunz> #info dwj suggests one verify job for python code unit testing and another for doctor function validation
13:30:34 <GeraldK> #link https://gerrit.opnfv.org/gerrit/#/c/33381/
13:30:38 <GeraldK> #undo
13:32:03 <yujunz> #info workaround for experimental job type "recheck-experimental"
13:32:44 <yujunz> Otherwise when "check-experimental" will remove verify +1 and does not give verify +1 even when it passes
13:34:34 <r-mibu> #info rewrite by python - add tox for test; Wenjuan reported 1) there is a patch set introducing tox, and 2) we can have new job to kick tox
13:34:51 <r-mibu> #action ryota to create new tox job for doctor
13:38:45 <yujunz> Could you type a summary? r-mibu
13:38:52 <r-mibu> ok
13:39:40 <r-mibu> #info Ryota proposed to have some guideline in order to avoid rewrite python code of new codes which will be developed in E release
13:40:43 <r-mibu> #info the guideline could be that the asignee/developer of new testing code inform the place in which he/she edit to wenjuan or team
13:41:26 <r-mibu> #info so that wenjuan/team can help he/she writing new code with python
13:42:21 <yujunz> Sound good
13:44:35 <GeraldK> +1
13:44:37 <cgoncalves> +1
13:44:40 <yujunz> +1
13:44:43 <tojuvone> +1
13:44:44 <dwj> +1
13:45:08 <r-mibu> #info doctor team agreed the guideline
13:46:26 <cgoncalves> r-mibu: https://wiki.opnfv.org/display/doctor/Euphrates+Planning
13:47:11 <GeraldK> r-mibu, check https://wiki.opnfv.org/display/SWREL/Release+Milestone+Description+for+Euphrates
13:47:30 <yujunz> bye
15:07:13 <r-mibu> #endmeeting