13:01:01 <xudan> #startmeeting dovetail weekly meeting
13:01:01 <collabot> Meeting started Wed Oct 30 13:01:01 2019 UTC.  The chair is xudan. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:01 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:01:01 <collabot> The meeting name has been set to 'dovetail_weekly_meeting'
13:01:36 <xudan> #topic roll call
13:01:40 <xudan> #info xudan
13:02:30 <lylavoie> #info lylavoie
13:03:28 <xudan> #topic discuss requirements of VNF 2019.04 release
13:04:30 <xudan> #info This is dovetail repo https://github.com/opnfv/dovetail
13:04:37 <lylavoie> What we need: a copy of the docs and a tagged Dovetail release for 2019.04, that was for the VNF program. That should have been released and then posted here: https://vnf-verified.lfnetworking.org/#/
13:05:39 <xudan> #info yes, I understand that. But there are still some problems.
13:06:12 <lylavoie> Yes, I was just trying to state the discussion, so others can get up to speed
13:06:51 <xudan> 1. We are lacking of all test cases specification docs.
13:07:03 <georgk> hi guys, sorry to interrupt. Are you doing this RRC only?
13:07:13 <georgk> or do I need to update my zoom link?
13:07:28 <lylavoie> email this morning said IRC only
13:07:39 <georgk> oh, thanks
13:08:13 <xudan> yes, I change Dovetail meeting to be IRC only
13:08:35 <xudan> it helps to got the minutes exactly.
13:08:42 <georgk> thanks, sorry for being very disconnected lately
13:09:08 <georgk> and sorry for interrupting... please continue
13:09:58 <xudan> All specification docs should be provided by VVP and VTP teams.
13:10:26 <lylavoie> Yes, they have them, but they are part of the ONAP documentation
13:10:42 <xudan> They used to give Dovetail the wiki links
13:10:50 <lylavoie> I don't think it is reasonable we expect them to copy them into the Dovetail documentation
13:10:59 <lylavoie> as that is just duplication
13:11:12 <xudan> We don't need to copy them into Dovetail
13:11:51 <xudan> We can give the links to ONAP documentation on both Dovetail docs and VNF home page.
13:12:15 <lylavoie> So, for 2019.04, the requirements were based on the Casablanca ONAP release, and we should be able to point to the documentation for that release
13:12:24 <xudan> I don't think it's a big problem as long as they have these docs.
13:12:43 <xudan> yes, exactly.
13:13:13 <xudan> Except those specification docs, do we also need other ones?
13:13:35 <lylavoie> Are you missing other requirements?
13:14:00 <xudan> such as release notes
13:14:30 <lylavoie> for the VVP and VNF-SDK parts, or other?  What would you like release notes for
13:14:49 <xudan> release note for 2019.04 release
13:15:25 <lylavoie> Ok, so I would call that release notes for Dovetail
13:15:42 <lylavoie> since for 2019.04, tests are run from the Dovetail container
13:17:25 <xudan> It should be the release note for OVP VNF 2019.04 release to give the details of that release, such as test case scope
13:17:28 <xudan> https://docs.opnfv.org/en/stable-fraser/submodules/dovetail/docs/release/release-notes/index.html
13:18:14 <xudan> you can refer to the NFVI release note. It has nothing to do with Dovetail. It's all about the test cases themselves,
13:19:55 <lylavoie> That document has more than just the test cases, it lists the Dovetail repo tag, etc
13:20:43 <xudan> That's can be taken as the test cases dependencies.
13:20:48 <lylavoie> but it is listed as part of the OPNFV Fraser documentation
13:21:31 <lylavoie> So, here is the larger question.  We have OVP releases, which are an LFN thing, they are not tied to OPNFV or ONAP releases, beyond pulling from those releases stable sets of the tooling
13:21:51 <xudan> Those are not the repo tag, those are the docker tags used to run the tests.
13:22:38 <lylavoie> so, how should we handle release of these documentation components, which would likely come after the the formal project's release
13:23:35 <xudan> yes, that's my next question.
13:24:01 <xudan> All the docs generated are relied on the OPNFV rtd(read the doc)
13:24:06 <lylavoie> For example, say you are going to, as part of the 2019.12 release, update to support testing based on the stable tooling released as part of the Hunter release
13:24:16 <lylavoie> how would you publish these "release notes"
13:25:10 <xudan> Then Dovetail should have a new branch stable/hunter
13:25:46 <xudan> Then all docs can be published automatically by OPNFV with the link
13:26:06 <xudan> for example https://docs.opnfv.org/en/stable-hunter/submodules/dovetail/docs/release/release-notes/index.html
13:26:12 <lylavoie> But that has already occurred, so has Dovetail not continued to develop or update, or move tooling forward
13:27:26 <xudan> All docs are required a stable branch.
13:27:58 <lylavoie> so, there doesn't appear to be one for hunter
13:28:05 <lylavoie> at lease not for Dovetail
13:28:24 <xudan> one what?
13:29:49 <lylavoie> The link you give, doesn't work, setting read the docs to hunter, there is not documentation for Dovetail
13:30:27 <lylavoie> So, I'm assuming that means Dovetail's last stable release was Fraser
13:30:41 <xudan> yes, that's an example. Dovetail doesn't have the branch stable/hunter
13:31:23 <xudan> yes, it's stable/fraser  which is NFVI 2018.09
13:31:58 <lylavoie> Correct, OVP is 2018.09, but is there a reason Dovetail hasn't continued to develop and have a stable version with each OPNFV release
13:32:06 <xudan> I mean if we have a stable/hunter branch, then we can have the hunter docs with that example link
13:33:14 <xudan> Dovetail doesn't release every OPNFV version. Until now, it only have 2 releases which are based on Danube and Fraser.
13:34:00 <xudan> Now it works on the hunter release, but still has some gaps.
13:34:47 <xudan> It's difficult and unnecessary to keep the same release speed with OPNFV release.
13:35:45 <lylavoie> Sure, but we need Dovetail to have a stable release, before we can even have a NFVI release
13:36:25 <lylavoie> so if projects like Dovetail, or VVP, or VNFSDK don't "keep" up with their projects, it's impossible to do the follow on step of having an OVP release
13:38:30 <xudan> yes
13:38:51 <lylavoie> So, this gives me some ideas of additional clarifications we need to add  (from the CVC prospective), to document expectations on projects feeding into OVP releases
13:39:16 <lylavoie> But, we do need to solve the problem, re-writing history aside, of the 2019.04 release
13:40:22 <lylavoie> Or, since we do not have any VNFs that have gone through that release, we "delete" it, and move forward with the 2019.12 (I'm assuming it will be 12) release, which is needed for ONAP
13:40:40 <lylavoie> it is fairly clear at this point that release can't include or support any updates to NFVI
13:40:50 <lylavoie> since there is no stable release of Dovetail tooling
13:41:13 <xudan> I prefer to delete 2019.04
13:41:39 <xudan> because I tried to run that tests, but it seems doesn't work.
13:42:10 <xudan> Because the docker tags VNFSDK and VVP provided are not fixed ones.
13:42:31 <lylavoie> let me guess, they pointed to "tip of master"
13:43:13 <xudan> VVP is master, and VNFSDK is an temporal veriosn
13:43:34 <xudan> I don't think they are maintaining them any more.
13:44:14 <xudan> So in fact, 2019.04 is unusable.
13:44:25 <lylavoie> So, for 2019.04 - There is not an easy way to fix this, we remove this from the VNF verified portal. First real VNF release will be the upcoming one.  It will not use Dovetail container to run the testing, but it will need the updates to the portal, based on the results json update, you agreed with the VVP teams (and VNFSDK has adopted)
13:46:42 <lylavoie> So, for VNF 2019.12, we need the Dovetail team to finalize updates to the portals, and get that pushed up.
13:47:11 <xudan> actually, I am not agree with VVP to run and generate the results by itself. But it said it can't be integrated with Dovetail. So I have no other good idea about that.
13:47:16 <lylavoie> I think that is your second meeting topics
13:48:21 <xudan> I can try my best to update the portal.
13:48:59 <lylavoie> Do we have Jira items for this?  Maybe we can track this as an epic, with story items for what needs to be completed
13:49:05 <xudan> But as you know, Dovetail and the portal are lacking of developers and I am really not a good portal developer.
13:49:44 <xudan> sure, I will create an JIRA epic and some tasks to track these.
13:50:13 <lylavoie> I understand, please tag me in that, and I will try to find you some resources.
13:50:21 <xudan> #action xudan will create an jira epic to track the portal updates for 2019.12 release.
13:50:50 <xudan> that is perfect
13:51:20 <lylavoie> Ok, for the last topic, i.e. next NFVI release
13:52:23 <lylavoie> Is Dovetail participating in the Iruya release
13:52:32 <lylavoie> Will you have a stable version?
13:53:57 <xudan> Dovetail always doesn't claim to  participate any  OPNFV release
13:54:17 <xudan> Because it can't keep the time schedule of any OPNFV release.
13:54:23 <lylavoie> So, how do you get a stable version out
13:55:50 <xudan> Dovetail uses other projects in OPNFV after they have a stable release. So Dovetail will at least release about 2 months behind the  OPNFV .
13:56:55 <xudan> It's ok. Dovetail can still has its stable version out, but it doesn't follow the OPNFV release plan (time schedule).
13:56:58 <lylavoie> Right, but in terms of process, you want to do release notes, which are part of the read the docs, which requires a stable branch, as part of a release, so we seem to have a paradox here in terms of how you actually have a Dovetail release that OVP could point to
13:57:58 <xudan> The docs can be updated all the time after the OPNFV release as well as the code.
13:58:52 <lylavoie> Ok, so what is Dovetail's current plan for its next release?
13:59:08 <xudan> All the existing NFVI docs are generated after the OPNFV official releases.
13:59:40 <xudan> if we want to have an NFVI release together with VNF this December, then we can have a release based on OPNFV hunter.
13:59:57 <xudan> That's what Dovetail is doing now.
14:00:55 <xudan> But I am afraid it doesn't have any new test scope. It may keep the scope the same as last release.
14:01:08 <lylavoie> Ok, so you will add that to the hunter documentation, we will refer to it was Dovetail - hunter, and it will be released on xyz?
14:01:45 <lylavoie> In terms of scope, I think that is ok, as long as it could validate OPNFV hunter (i.e. some thing installed from that version), that would be an improvement
14:03:14 <xudan> yes, and there are some new features added to Dovetail such as restful API
14:03:21 <lylavoie> Should we clean up this page: https://wiki.opnfv.org/display/dovetail/OVP+2019.05+%28Hunter%29+Release
14:04:01 <xudan> we can change it to be 2019.12
14:04:09 <xudan> still based on Hunter
14:04:36 <lylavoie> Right, but in terms of tracking progress and making sure we are on schedule, do you have Jira issues or similar to track that
14:05:18 <xudan> Not yet. But as we decide to release 2019.12, we need to have those jira tickets.
14:10:40 <lylavoie> Ok, I think that would be good
14:10:47 <xudan> #info so we get the conclusion:
14:10:47 <xudan> 1. remove 2019.04 release because it's unusable anymore
14:10:47 <xudan> 2. update docs and portal for VNF 2019.12 VNF release, and create JIRA tickets to track the progress
14:10:47 <xudan> 3. Release NFVI 2019.12 together with VNF, which is based on OPNFV Hunter and without any test scope extension.
14:11:27 <lylavoie> For #2, we will need the branch, so we can work on that documentation, etc.
14:11:54 <xudan> I plan to create a stable/hunter branch for both NFVI and the VNF
14:13:01 <xudan> even though it's a little weird for VNF to have the stabl/hunter branch
14:13:21 <xudan> But otherwise, it couldn't get the docs
14:13:32 <lylavoie> Well, the only part for VNF is where / how we push the documentation
14:13:46 <lylavoie> there isn't any "code" for VNF in a branch
14:15:36 <xudan> there are 2 kinds of VNF docs.
14:16:21 <xudan> One is from ONAP projects (VVP and VNFSDK), such as the specification docs.
14:16:59 <xudan> The other docs OVP requires, we can add them to Dovetail repo and release with OPNFV doc tool
14:17:04 <xudan> Is that make sense?
14:17:21 <lylavoie> Yeah, but we can point those, as they should released as part of the sable documentation for a specific release, i.e. the El Alto release, etc.
14:17:29 <lylavoie> yes
14:18:24 <xudan> yes, also adding the docs links within ONAP to Dovetail docs.
14:18:34 <lylavoie> What I'm most concerned about is, having a stable version of the documents, that represent the specific release, i.e. 2019.12, and are "stable", in pointing to specific containers, versions, tagged repos, etc.
14:20:02 <xudan> yes. it should be specific ones instead of latest/master ones
14:24:29 <xudan> if we have no other questions, I will end today's meeting.
14:25:02 <xudan> #endmeeting