#opnfv-functest: Functest weekly meeting July 12th

Meeting started by morgan_orange at 08:01:03 UTC (full logs).

Meeting summary

  1. call role (morgan_orange, 08:01:08)
    1. Morgan Richomme (morgan_orange, 08:01:54)
    2. ollivier (ollivier, 08:01:54)
    3. agenda: https://wiki.opnfv.org/display/functest/Functest+Meeting (morgan_orange, 08:02:42)
    4. SerenaFeng (SerenaFeng, 08:02:49)
    5. Jose Lausuch (jose_lausuch, 08:02:58)

  2. action point follow up (morgan_orange, 08:03:01)
    1. http://ircbot.wl.linuxfoundation.org/meetings/opnfv-testperf/2016/opnfv-testperf.2016-07-05-08.00.html (morgan_orange, 08:03:11)
    2. AP1 => request sent to helpdesk to get our gerrit robot on this chan, no feedback so far (morgan_orange, 08:03:36)
    3. but jenkins/flake8 now operationnal for Functest (morgan_orange, 08:03:55)
    4. AP2: document opnfv-functest documented from the functest main page, I should also still change it in the different documents (morgan_orange, 08:04:32)
    5. AP3: ollivier pythonization of ODL almost done (morgan_orange, 08:04:57)

  3. Colorado release Status (morgan_orange, 08:06:49)
    1. feedback provided to all the installers (except apex / mail ready but not sent yesterday) (morgan_orange, 08:07:20)
    2. https://wiki.opnfv.org/display/apex/Apex+Scenario+Status (morgan_orange, 08:07:56)
    3. apex scenario: issues with ODL, security_scan and DVR support (odl_l3 scenario) (morgan_orange, 08:08:28)
    4. fuel feedback most of the scenarios almost OK http://testresults.opnfv.org/reporting/functest/release/master/index-status-fuel.html (morgan_orange, 08:12:51)
    5. fuel last issues: bgpvpn (integration in progress) (morgan_orange, 08:13:26)
    6. http://testresults.opnfv.org/test/api/v1/results?case=tempest_smoke_serial&last=10&scenario=os-onos-sfc-ha (morgan_orange, 08:15:14)
    7. ACTION: morgan_orange asks Anthony if onos-sfc tests can be enable as there is one fuel scenario ready to support it (morgan_orange, 08:16:07)
    8. https://build.opnfv.org/ci/view/functest/job/functest-fuel-baremetal-daily-master/148/console (morgan_orange, 08:16:52)
    9. http://testresults.opnfv.org/test/api/v1/results?case=onos&last=10&scenario=os-onos-sfc-ha (morgan_orange, 08:18:27)
    10. feedback on compass, except ocl scenario (still under integration), other scenarios have issues with rally sanity - but last runs seems OK so wait and see .. (morgan_orange, 08:19:27)
    11. feedback on joid: Narinder indicated a DHCP issue under investigation that should be a root cause of several issues (morgan_orange, 08:20:34)
    12. Luke Hinds (lhinds, 08:20:50)
    13. ACTION: morgan_orange create wiki pages to reference installer related JIRA (morgan_orange, 08:22:13)
    14. ACTION: morgan cretae a jira assigned to SerenaFeng and details issues on rally_sanity result (morgan_orange, 08:26:56)

  4. security_scan (morgan_orange, 08:30:19)
    1. discussion planned during the TSC meeting today to validate the creation of a dedicated repo (morgan_orange, 08:30:37)
    2. http://testresults.opnfv.org/reporting/functest/release/master/index-tempest-apex.html (morgan_orange, 08:35:46)
    3. http://testresults.opnfv.org/reporting/ in addition of tempest vIMS and Status (morgan_orange, 08:36:35)
    4. security_scan now producing nice reports (morgan_orange, 08:40:54)
    5. still an issue with integration in CI pipeline when collecting the restuks (morgan_orange, 08:41:12)
    6. secruity_scan not used for scenario validation (must be generalized to all the installers first) (morgan_orange, 08:41:33)
    7. however as teh info are usefull => adopt tempest approach to collect success rate, errors and create a Security reporting (like Tempest of vIms) (morgan_orange, 08:42:03)
    8. minor priority / generalization to othe installers and fix in CI (morgan_orange, 08:42:29)

  5. AoB (morgan_orange, 08:42:39)
    1. SerenaFeng participating to OpenStack Summit China => could be interesting to discuss with Rally community as we are using rally for Tempest/Rally and could use it more for additional scenario (morgan_orange, 08:43:30)
    2. requests from feature project to be able to connect to the different SUT nodes (morgan_orange, 08:50:56)
    3. so far no standard way => namual processing different from one installer to another (morgan_orange, 08:51:12)
    4. discussions on an installer integrated approach versus a post-installation through test umbrella projects (morgan_orange, 08:51:34)
    5. could be a genesis topic (morgan_orange, 08:52:03)
    6. ACTION: morgan_orange jose_lausuch discuss this topic with testing community (morgan_orange, 08:52:05)
    7. summer organization: I will be on vacations on Wednesday until the 8th of August (morgan_orange, 08:52:50)
    8. Jose will take the lead until beginning of August (morgan_orange, 08:53:15)
    9. SerenaFeng will lead Functest on the first week of August (morgan_orange, 08:56:44)
    10. auto update of testapi using ansible-playbook impemented by SerenaFeng (morgan_orange, 08:57:48)
    11. ACTION: SerenaFeng update test api on testresults.opnfv.org with last version of datamodel (morgan_orange, 09:03:36)


Meeting ended at 09:05:48 UTC (full logs).

Action items

  1. morgan_orange asks Anthony if onos-sfc tests can be enable as there is one fuel scenario ready to support it
  2. morgan_orange create wiki pages to reference installer related JIRA
  3. morgan cretae a jira assigned to SerenaFeng and details issues on rally_sanity result
  4. morgan_orange jose_lausuch discuss this topic with testing community
  5. SerenaFeng update test api on testresults.opnfv.org with last version of datamodel


Action items, by person

  1. jose_lausuch
    1. morgan_orange jose_lausuch discuss this topic with testing community
  2. morgan_orange
    1. morgan_orange asks Anthony if onos-sfc tests can be enable as there is one fuel scenario ready to support it
    2. morgan_orange create wiki pages to reference installer related JIRA
    3. morgan_orange jose_lausuch discuss this topic with testing community
  3. SerenaFeng
    1. morgan cretae a jira assigned to SerenaFeng and details issues on rally_sanity result
    2. SerenaFeng update test api on testresults.opnfv.org with last version of datamodel


People present (lines said)

  1. morgan_orange (126)
  2. jose_lausuch (43)
  3. SerenaFeng (23)
  4. lhinds (12)
  5. ollivier (6)
  6. collabot (5)
  7. raghavendrachari (2)


Generated by MeetBot 0.1.4.