08:01:11 <jose_lausuch> #startmeeting Functest weekly meeting April 5th 2016
08:01:11 <collabot> Meeting started Tue Jul 19 08:01:11 2016 UTC. The chair is jose_lausuch. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:01:11 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:01:11 <collabot> The meeting name has been set to 'functest_weekly_meeting_april_5th_2016'
08:01:22 <jose_lausuch> #link https://wiki.opnfv.org/display/functest/Functest+Meeting
08:01:33 <jose_lausuch> #topic roll call
08:01:37 <lhinds> #info Luke Hinds
08:01:42 <raghavendrachari> #info raghavendrachari
08:01:46 <jose_lausuch> #info Jose Lausuch
08:02:09 <mbuil> #info Manuel Buil (sfc)
08:02:29 <jose_lausuch> May-meimei: are you there? we might need some info from you today :)
08:03:09 <May-meimei> hi, jose_lausuch
08:03:45 <jose_lausuch> hi
08:03:48 <jose_lausuch> good
08:03:59 <jose_lausuch> #chair May-meimei
08:03:59 <collabot> Current chairs: May-meimei jose_lausuch
08:04:28 <jose_lausuch> #info previous minutes: http://ircbot.wl.linuxfoundation.org/meetings/opnfv-functest/2016/opnfv-functest.2016-07-12-08.01.html
08:04:35 <jose_lausuch> #topic Action point follow-up (meeting on the 12th July)
08:04:52 <jose_lausuch> it's going to be quick today :)
08:05:10 <jose_lausuch> #info AP: morgan_orange asks Anthony if onos-sfc tests can be enable as there is one fuel scenario ready to support it
08:05:17 <jose_lausuch> #info the tests have been enabled, but the basic healtcheck is failing in that scenario (The instance opnfv-instance3 couldn't get an IP from the DHCP agent.)
08:05:21 <jose_lausuch> #link https://build.opnfv.org/ci/job/functest-fuel-baremetal-daily-master/201/console
08:05:53 <jose_lausuch> #info AP: morgan_orange create wiki pages to reference installer related JIRA
08:06:19 <jose_lausuch> #info I think he was refering to this: https://wiki.opnfv.org/display/apex/Apex+Scenario+Status but it is not done for other installers. To follow up with Morgan.
08:06:56 <jose_lausuch> #info AP: morgan cretae a jira assigned to SerenaFeng and details issues on rally_sanity result. DONE: https://jira.opnfv.org/browse/FUNCTEST-365
08:07:27 <jose_lausuch> #info AP: SerenaFeng update test api on testresults.opnfv.org with last version of datamodel
08:07:39 <jose_lausuch> Serena is not here today...
08:07:50 <jose_lausuch> #action jose_lausuch ask Serena about the status of this AP
08:08:30 <jose_lausuch> #info AP: morgan_orange jose_lausuch discuss this topic with testing community. Not done yet. Maybe we wait a bit and prepare a proposal. Let's postpone this after Summer vacation.
08:09:17 <jose_lausuch> any questions regarding APs ?
08:09:21 <jose_lausuch> many people on vacation...
08:09:40 <jose_lausuch> #topic Feature projects integration status
08:09:49 <jose_lausuch> I will start
08:10:11 <jose_lausuch> #info SDNVPN: the code is completed and running the scenario in CI successfully. Small issues to fix with regards to pushing the results to the DB. Example: https://build.opnfv.org/ci/job/functest-fuel-baremetal-daily-master/204/
08:10:24 <jose_lausuch> mbuil: do you wanna share the status of ODL-SFC ?
08:11:49 <mbuil> ODL-SFC is test case is finished but not automated. To do so, we need to make OVS 2.5.90 (Yi Yang patch) work with ODL and that is taking us more time than expected due to the inestability of the Boron branch for ODL
08:12:34 <jose_lausuch> ok, thanks
08:12:36 <jose_lausuch> I'll info that
08:12:43 <jose_lausuch> #info ODL-SFC is test case is finished but not automated. To do so, we need to make OVS 2.5.90 (Yi Yang patch) work with ODL and that is taking us more time than expected due to the inestability of the Boron branch for ODL
08:13:02 <mbuil> oh, yes, sorry!
08:13:14 <jose_lausuch> mbuil: any estimation about when that can be done?
08:14:19 <jose_lausuch> anyway, as soon as that is ready, we just need to enable the test case in Functest to run when the odl-sfc scenario is triggered. Not a big deal
08:15:08 <May-meimei> onos-sfc will run the same testcase?
08:15:35 <jose_lausuch> May-meimei: no, there is a dedicated test case for onos-sfc and another one for odl-sfc
08:15:58 <May-meimei> I see
08:16:06 <jose_lausuch> there is a scenario called os-onos-sfc-ha and another one called os-odl_l3-sfc-ha
08:16:09 <jose_lausuch> or l2, dont remember now
08:16:23 <mbuil> #info it should be ready around mid-august latest but I cannot gurantee
08:16:57 <jose_lausuch> ok, thanks mbuil
08:17:03 <jose_lausuch> regarding onos-sfc
08:17:06 <mbuil> you are welcome
08:18:14 <jose_lausuch> #info functest-compass is failing
08:18:21 <jose_lausuch> May-meimei: shall we have a look together ?
08:18:34 <jose_lausuch> HTTPServiceUnavailable: 503 Service Unavailable: The server is currently unavailable. Please try again at a later time. (HTTP 503)
08:18:39 <jose_lausuch> I see that type of errors
08:19:07 <May-meimei> which one? I will check it
08:19:31 <jose_lausuch> https://build.opnfv.org/ci/view/functest/job/functest-compass-baremetal-daily-master/120/
08:19:32 <jose_lausuch> for example
08:19:39 <jose_lausuch> May-meimei: https://build.opnfv.org/ci/view/functest/job/functest-compass-baremetal-daily-master/
08:19:44 <jose_lausuch> different errors
08:20:02 <jose_lausuch> but some of them its because of uploading the artifacts
08:20:25 <jose_lausuch> #action May-meimei jose_lausuch check the problem with the jumphost accessing the artifacts: AccessDeniedException: 401 Login Required
08:20:40 <jose_lausuch> this is the cause why we get so many "red balls" in jenkins
08:22:06 <May-meimei> I think we need a access right from aric
08:22:32 <jose_lausuch> yes
08:22:38 <jose_lausuch> I'll contact him later
08:22:40 <jose_lausuch> ok
08:22:41 <jose_lausuch> moving on
08:22:48 <jose_lausuch> lhinds: any status for sec scan?
08:23:15 <jose_lausuch> status or updates :)
08:23:19 <lhinds> I am still looking into that issue and trying out some tests, so that's WIP
08:23:30 <jose_lausuch> ok
08:23:36 <jose_lausuch> let's follow up next week
08:23:56 <lhinds> I have the new git repo and jira, but what I will do is work with you to change the exec_test.sh script, with lots of prep time.
08:24:10 <lhinds> mainly add a 'git clone' along with the others.
08:24:13 <jose_lausuch> lhinds: ok
08:24:20 <jose_lausuch> that's in the Dockerfile
08:24:27 <jose_lausuch> what do you need to clone?
08:24:38 <lhinds> Sorry, yes Dockerfile...
08:25:09 <lhinds> securityscan will have its own repo, so you will pull down the code like you do for the other test cases
08:25:30 <jose_lausuch> ok
08:25:39 <jose_lausuch> no problem about that
08:25:45 <lhinds> but we will get onto that after the holidays
08:25:51 <jose_lausuch> any ideas when the repo will be set up?
08:26:32 <lhinds> its already set up, so after the summer break we can work on adding the needed to the Dockerfile etc to point to the new repo
08:26:59 <lhinds> have a crossover point, we we make the change
08:27:00 <jose_lausuch> lhinds: ok, awesome
08:27:54 <lhinds> another contributor is looking at the debain (ubuntu) scans as well, that will be used for Fuel
08:28:05 <jose_lausuch> #link security scan already has its own repo https://gerrit.opnfv.org/gerrit/#/admin/projects/securityscanning. The code will be moved from Functest to there after the summer break
08:28:10 <lhinds> that's it!
08:28:18 <jose_lausuch> lhinds: ok, thanks for the update!
08:28:20 <lhinds> I will be away for two weeks as of next week
08:28:23 <May-meimei> jose_lausuch: sorry, about 503 error, it happened sometimes , shuaichen is checking this error
08:28:50 <jose_lausuch> #info there will be support for security scan on Debian(Ubuntu), that might be activated for Fuel installers
08:28:56 <jose_lausuch> May-meimei: ok
08:29:15 <jose_lausuch> good
08:29:24 <jose_lausuch> moving on, I'll info something about some feature projects
08:29:35 <jose_lausuch> #info COPPER: the tests are running on CI, but giving a failure of type "No such file or directory". https://build.opnfv.org/ci/view/functest/job/functest-apex-apex-daily-master-daily-master/85/console
08:29:55 <jose_lausuch> #action jose_lausuch contact Bryan (bryan_att) to report the failure.
08:30:06 <jose_lausuch> #info MOON: the scenario is not active in CI yet. No tests run.
08:30:42 <jose_lausuch> #action jose_lausuch contact moon project to see when the scenario can be active
08:31:04 <jose_lausuch> #info MULTISITE: the test is enabled for CI, but there hasn't been a multisite scenario run yet.
08:31:10 <jose_lausuch> May-meimei: any info on this?
08:31:41 <May-meimei> some issues of multisite testcase
08:31:54 <May-meimei> I will submit a patch today
08:32:30 <jose_lausuch> May-meimei: ok, but there will be a multisite scenario, right?
08:32:37 <jose_lausuch> os-onos-multisite?
08:32:40 <jose_lausuch> or how?
08:33:27 <May-meimei> no scenario, we just have a verify job of multisite
08:33:41 <jose_lausuch> ok
08:33:48 <May-meimei> we don't have a e2e ci pipeline of multisite
08:33:55 <jose_lausuch> aha
08:34:01 <May-meimei> verify job+functest
08:34:09 <jose_lausuch> the test cases is defined in testcases.yaml
08:34:16 <jose_lausuch> dependencies:
08:34:16 <jose_lausuch> installer: 'compass'
08:34:16 <jose_lausuch> scenario: 'multisite'
08:34:50 <May-meimei> I think we can trigger functest by setting multisite senario
08:35:04 <jose_lausuch> ok
08:35:10 <jose_lausuch> let's follow up next week to see the status
08:35:15 <May-meimei> :)
08:35:18 <jose_lausuch> thanks
08:35:44 <jose_lausuch> #info DOMINO: it is enabled for CI, but there hasn't been a successful run of functest-joid so far.
08:35:50 <jose_lausuch> #action jose_lausuch: try to find the reason why Functest-joid fails and contact joid folks for support.
08:37:17 <jose_lausuch> #info IPv6 project requested some help to include a basic tempets validation of keystone using ipv6. Work in progress with Bin and Pakrash
08:37:26 <jose_lausuch> any other feature I'm missing?
08:38:36 <jose_lausuch> ok
08:38:39 <jose_lausuch> #topic Colorado status
08:38:56 <jose_lausuch> This is our current track of issues
08:38:57 <jose_lausuch> #link https://jira.opnfv.org/issues/?jql=project%20%3D%20FUNCTEST%20AND%20status%20in%20(Open%2C%20%22In%20Progress%22%2C%20Reopened)
08:39:02 <jose_lausuch> by the way, SerenaFeng
08:39:08 <jose_lausuch> there was an action point for you
08:39:15 <jose_lausuch> AP: SerenaFeng update test api on testresults.opnfv.org with last version of datamodel
08:39:18 <jose_lausuch> any updates on this>?
08:39:29 <SerenaFeng> not yet
08:39:40 <jose_lausuch> ok
08:39:44 <jose_lausuch> you were in the summit :)
08:40:08 <SerenaFeng> I am wondering I will do it now, or wait until the adapation of functest_util is oK?
08:40:19 <jose_lausuch> adaptatoin of functest_util?
08:40:46 <SerenaFeng> yeah, after the update, trust_indicator will be different from previous one
08:40:54 <SerenaFeng> data model
08:41:17 <jose_lausuch> ahmm
08:41:28 <jose_lausuch> do you know what changes we need in functest_util?
08:41:35 <SerenaFeng> so there will be some date missing during that time
08:42:05 <SerenaFeng> implement the strategy of trust_indicator we disscussed before
08:42:20 <jose_lausuch> ok
08:42:33 <jose_lausuch> I don't think I'll have time for this before August :)
08:42:41 <SerenaFeng> for now, I think we can implement a simple version, just change the data model of trust_indicator
08:42:46 <jose_lausuch> ok
08:43:00 <jose_lausuch> go ahead if you have time to implement it
08:43:05 <SerenaFeng> ok
08:43:13 <SerenaFeng> I will try
08:43:18 <jose_lausuch> no worries
08:43:37 <jose_lausuch> I'll try to help if I have some time next week
08:43:45 <SerenaFeng> okey
08:44:27 <jose_lausuch> #info ODL refactor has been completed, but reporting to DB fails. https://jira.opnfv.org/browse/FUNCTEST-370
08:44:34 <jose_lausuch> SerenaFeng: I might need some help from you here :)
08:44:58 <SerenaFeng> okey
08:45:11 <jose_lausuch> thanks
08:46:19 <jose_lausuch> #info not so many improvements to do in Functest, just bug fixing some issues and supporting features to integrate test cases.
08:46:35 <jose_lausuch> #info feedback is provided from the Functest jenkins jobs towards installers
08:46:56 <jose_lausuch> #info we are on track, but there are still some JIRA tickets open that need to be closed soon
08:47:07 <jose_lausuch> I have noticed some bugs that we need to fix
08:47:17 <jose_lausuch> ok
08:47:19 <jose_lausuch> anyway
08:47:27 <jose_lausuch> any other comment to Colorado status?
08:48:22 <jose_lausuch> ok
08:48:25 <jose_lausuch> #topic AoB
08:48:36 <jose_lausuch> Q2 awards are open
08:50:06 <jose_lausuch> I will vote SerenaFeng for her contribution with the Test API
08:50:36 <jose_lausuch> well, not vote. It's nomination time now :)
08:51:05 <jose_lausuch> nominate lhinds as well for his efforts with the security testing work
08:52:53 <jose_lausuch> any other business ?
08:53:26 <SerenaFeng> I am working on integration of parser to functest
08:53:58 <jose_lausuch> ok
08:54:03 <jose_lausuch> what's the status?
08:54:11 <SerenaFeng> just beginning
08:54:19 <jose_lausuch> ok
08:54:41 <jose_lausuch> let us know if you need help
08:54:48 <SerenaFeng> okey, thanks
08:55:42 <jose_lausuch> ok, I think we can close the meting
08:55:44 <jose_lausuch> meeting
08:56:02 <jose_lausuch> #endmeeting