#opnfv-functest: Functest weekly meeting December 13th

Meeting started by morgan_orange at 08:01:35 UTC (full logs).

Meeting summary

  1. call role (morgan_orange, 08:01:42)
    1. Morgan Richomme (morgan_orange, 08:01:46)
    2. Helen Yao (HelenYao, 08:01:52)
    3. Juha Kosonen (juhak, 08:02:01)
    4. agenda https://wiki.opnfv.org/display/functest/Functest+Meeting (morgan_orange, 08:02:38)
    5. SerenaFeng (SerenaFeng, 08:03:23)

  2. action point follow_up (morgan_orange, 08:03:43)
    1. http://ircbot.wl.linuxfoundation.org/meetings/opnfv-functest/2016/opnfv-functest.2016-12-06-08.10.html (morgan_orange, 08:03:52)
    2. AP1 morgan_orange ask ray on the LF expected feedback for the internship (morgan_orange, 08:04:06)
    3. discussion with Jose who had a discussion with Ray: nothing formal expected (morgan_orange, 08:04:35)
    4. LF will not ask for a specific documentation (morgan_orange, 08:04:54)
    5. AP2 HelenYao prepare a topic on openstack_utils status for next weekly meeting (refactoring/SNAPS/..) (morgan_orange, 08:05:10)
    6. topic for today (morgan_orange, 08:05:22)
    7. http://docs.openstack.org/developer/keystoneauth/using-sessions.html (HelenYao, 08:05:47)
    8. HelenYao submited a new patch for Newton support (blocking for installers) https://gerrit.opnfv.org/gerrit/#/c/25725/ is merged (morgan_orange, 08:07:17)
    9. patch to be validated and merged (support also Mitaka) (morgan_orange, 08:07:32)
    10. patch is leveraging keystoneauth1.session for each client and it will take care of different version of openstack (morgan_orange, 08:07:47)
    11. easy to use it and it provides way to query endpoint and token info for different service client (morgan_orange, 08:07:55)
    12. http://docs.openstack.org/developer/keystoneauth/using-sessions.html (morgan_orange, 08:08:02)
    13. SNAPS good candidate after it finishes the support for Newton (currently same than Functets util function linked to client version) (morgan_orange, 08:08:32)
    14. ACTION: all review https://gerrit.opnfv.org/gerrit/#/c/25725/ asap to unblock newton integration (morgan_orange, 08:09:01)

  3. Feedback on the plugfest (morgan_orange, 08:09:23)
    1. interesting event , lots of demos/concrete meetings: dovetail, storPerf, and of course Functest by Jose (morgan_orange, 08:11:57)
    2. feedback from Jose: A lot of interest from Open-O community (Opera in OPNFV). They will be adding a Clearwater vIMS deployment using Open-O as a test case. They have also interest about using Functest in Open-O standalone, possibly doing some changes to make Functest VIM aware (needs further discussions) (morgan_orange, 08:12:22)
    3. The testing community gathered together to discuss topics like common documentation for the test cases. Common Dashboard (functest+yardstick), …   (morgan_orange, 08:12:35)
    4. Doctor team wants to run more than 1 test case. I suggested to follow the same approach as SFC, SDNVPN. Create a runner script in their repo and call it from Functest. This way, all the logic is kept in Doctor and Functest is a dummy that just runs it and expects a result to report to the DB.  Idea suggested for the Functest dashboard: show the overall result for Doctor and click on the icon for more information (e.g. pop-up wi (morgan_orange, 08:12:43)
    5. Functest ran on 3 different HW, with different installers and collected the results in the DB. Good results in general, but not extense test have been run, only smoke testing. Dovetail was also target of testing in some cases.   (morgan_orange, 08:13:06)
    6. ABOT proposal under consideration. (see next topic) (morgan_orange, 08:13:21)
    7. I talked a bit about the test promotion proposal from you. That it could work together with the CI evolution, but maybe we can’t make it for Danube, since the CI evolution that does promotions won’t apply until E-release. (morgan_orange, 08:13:32)
    8. Same issues as CI found in a WindRiver deployment with v3 endpoints. I managed to get the Functest apis working, but Rally failed. No time to provide a fix in the plugfest, but HelenYao is working on that. (see previous topic) (morgan_orange, 08:14:11)

  4. Status on openstack_utils (refacting/SNAPS/..) (morgan_orange, 08:15:04)
    1. done in action point follow up (morgan_orange, 08:15:10)

  5. Exit status code (TEST_EX_OK, TEST_OK,..) (morgan_orange, 08:15:54)
    1. ACTION: morgan_orange ask fdegir if any progress on the capability to jenkins to create a new status (blue/red + orange? balls) (morgan_orange, 08:21:10)
    2. ACTION: morgan_orange see with Cedric on the improvement of the testcaseBase class (morgan_orange, 08:21:23)

  6. Proposal for integration of ABOT (Automated Behaviour Oriented Testing) - Debayan Chaudhuri (morgan_orange, 08:22:46)
    1. ACTION: morgan_orange see with Jose to suggest a presentation of ABOty during weekly meeting (possible that they are US based..so 8 UTC is a bit hard) (morgan_orange, 08:25:39)

  7. Unified way to provide conf and env variables (morgan_orange, 08:27:08)
    1. SerenaFeng submitted to proposal patch to address the problem (morgan_orange, 08:27:27)
    2. https://gerrit.opnfv.org/gerrit/25709 (morgan_orange, 08:27:36)
    3. https://gerrit.opnfv.org/gerrit/25719 (morgan_orange, 08:27:44)
    4. ACTION: HelenYao morgan_orange juhak Cedric Jose Steve: review this patch => target choice before end of the week if possible (to avoid same issues than on previous attempt) (morgan_orange, 08:30:41)

  8. AoB (morgan_orange, 08:39:28)
    1. I merged the patch on the DB testcase collection model and started the update (morgan_orange, 08:39:47)
    2. http://testresults.opnfv.org/test/api/v1/projects/functest/cases (morgan_orange, 08:40:07)
    3. sceanrio collection + associated API to be planned (morgan_orange, 08:42:49)
    4. Jun Li (MatthewLi, 08:43:13)
    5. SerenaFeng suggest we could create script/docker-compose to offer a complete functest ecosystem including functest + test DB + testapi + reporting (morgan_orange, 08:47:51)
    6. AGREED: (morgan_orange, 08:48:20)
    7. zhihui (zhihui, 08:48:39)
    8. since dovetail will use some testcases from functest for compliance and certification (MatthewLi, 08:49:50)
    9. need the local logs of these testcases, then our crawer can catch that (MatthewLi, 08:50:40)
    10. ACTION: morgan_orange create a wiki page to indicate the story of the logs in functest (morgan_orange, 09:07:02)
    11. https://wiki.opnfv.org/display/dovetail/Dovetail+Test+Case+Requirements (MatthewLi, 09:08:38)
    12. internship allocation of VNF catalog epic to Kumar (morgan_orange, 09:10:02)
    13. VnfOnBoard abastract class to be submitted this week (not tested yet..) but the idea is to indicate to projects dealing with VNF to follow the template (as we have for feature) (morgan_orange, 09:10:42)
    14. Umbrella feature class merged, people with allocation of existing feature projects => use this class to simplify integration (morgan_orange, 09:11:08)


Meeting ended at 09:13:34 UTC (full logs).

Action items

  1. all review https://gerrit.opnfv.org/gerrit/#/c/25725/ asap to unblock newton integration
  2. morgan_orange ask fdegir if any progress on the capability to jenkins to create a new status (blue/red + orange? balls)
  3. morgan_orange see with Cedric on the improvement of the testcaseBase class
  4. morgan_orange see with Jose to suggest a presentation of ABOty during weekly meeting (possible that they are US based..so 8 UTC is a bit hard)
  5. HelenYao morgan_orange juhak Cedric Jose Steve: review this patch => target choice before end of the week if possible (to avoid same issues than on previous attempt)
  6. morgan_orange create a wiki page to indicate the story of the logs in functest


Action items, by person

  1. HelenYao
    1. HelenYao morgan_orange juhak Cedric Jose Steve: review this patch => target choice before end of the week if possible (to avoid same issues than on previous attempt)
  2. juhak
    1. HelenYao morgan_orange juhak Cedric Jose Steve: review this patch => target choice before end of the week if possible (to avoid same issues than on previous attempt)
  3. morgan_orange
    1. morgan_orange ask fdegir if any progress on the capability to jenkins to create a new status (blue/red + orange? balls)
    2. morgan_orange see with Cedric on the improvement of the testcaseBase class
    3. morgan_orange see with Jose to suggest a presentation of ABOty during weekly meeting (possible that they are US based..so 8 UTC is a bit hard)
    4. HelenYao morgan_orange juhak Cedric Jose Steve: review this patch => target choice before end of the week if possible (to avoid same issues than on previous attempt)
    5. morgan_orange create a wiki page to indicate the story of the logs in functest


People present (lines said)

  1. morgan_orange (149)
  2. SerenaFeng (59)
  3. HelenYao (47)
  4. MatthewLi (24)
  5. juhak (7)
  6. collabot (3)
  7. OPNFV-Gerrit-Bot (1)
  8. zhihui (1)


Generated by MeetBot 0.1.4.