#opnfv-functest: Functest weekly meeting January 10th 2017

Meeting started by jose_lausuch at 08:00:46 UTC (full logs).

Meeting summary

  1. role call (jose_lausuch, 08:01:03)
    1. Morgan Richomme (morgan_orange, 08:01:10)
    2. Juha Kosonen (juhak, 08:01:14)
    3. Helen Yao (HelenYao, 08:01:21)
    4. Ashish Kumar (ashishk, 08:01:25)
    5. Kumar Rishabh (KumarRishabh, 08:01:32)
    6. Juan Vidal (jvidal, 08:01:56)
    7. Linda Wang (mywulin1, 08:01:57)
    8. agenda https://wiki.opnfv.org/display/functest/Functest+Meeting (morgan_orange, 08:02:00)
    9. previous minutes:http://ircbot.wl.linuxfoundation.org/meetings/opnfv-functest/2017/opnfv-functest.2017-01-03-08.00.html (jose_lausuch, 08:02:57)
    10. juhak could you check Tempest issues (as you have a apex env..) (jose_lausuch, 08:03:06)
    11. six failed cases, all due to floating IP creation failure (juhak, 08:03:20)
    12. jira ticket created: https://jira.opnfv.org/browse/APEX-380 (juhak, 08:03:27)
    13. AP3: morgan_orange sync with joid to get the status => done all CI joid runs done on Intel (currently not available), work to setup an env in Huawei in progress (morgan_orange, 08:06:50)
    14. AP5: morgan_orange contact other test projects to get their feedback on unit test startegy => thread initiated, Mark (Storeperf took the point to sync topic for testing group) (morgan_orange, 08:07:01)
    15. AP7: morgan_orange sync on VNF catalog done meeting on Friday, (morgan_orange, 08:07:13)
    16. AP8: morgan_orange SerenaFeng precise testresults.opnfv/org versus atifacts for testapi doc => discussion in progress (morgan_orange, 08:07:19)
    17. AP10: morgan_orange ask for bitergia update to Ray => done action Ray in progress (morgan_orange, 08:07:29)
    18. https://docs.google.com/presentation/d/1vFVLP1SRPaKL3b90wTlc6NuE6zyf5Q4FhbxcN12W4IA/edit#slide=id.p (ashishk, 08:09:07)
    19. AP6 ashishk created a short slide for unit tests (morgan_orange, 08:10:32)
    20. https://docs.google.com/presentation/d/1vFVLP1SRPaKL3b90wTlc6NuE6zyf5Q4FhbxcN12W4IA/edit#slide=id.p (morgan_orange, 08:10:39)
    21. ACTION: HelenYao check compass issues (issue with keystone version during snapshot/clean phase) (jose_lausuch, 08:11:01)
    22. HelenYao working on keystone/ Rally issue (morgan_orange, 08:11:13)
    23. rally is having big refactor and there is no backward compability (HelenYao, 08:11:30)
    24. I talked to Rally team and they will release a new version once some patches are merged (HelenYao, 08:11:56)
    25. AP7: KumarRishabh already enjoyed the reading of some ETSI documentation (morgan_orange, 08:12:12)
    26. Status (Dev/JIRA/Jenkins) (jose_lausuch, 08:14:10)
    27. Jenkins: currently runs only on fuel and compass and no runs on apex/joid run (morgan_orange, 08:15:07)
    28. jenkins: compass healtcheck fails "ERROR: There are no external networks in the deployment." (morgan_orange, 08:15:49)
    29. jenkins: fuel run further, issues with SNAPS (external networks not found - detected in healthcheck) (morgan_orange, 08:16:25)
    30. issue to troubelshoot for steve (SNAPS) no access to fuel lab (morgan_orange, 08:16:39)
    31. https://build.opnfv.org/ci/view/functest/job/functest-fuel-baremetal-daily-master/lastFailedBuild/ (morgan_orange, 08:18:11)
    32. ACTION: morgan_orange initiate a mail with Functest contributor to indicate current status on community lab access (morgan_orange, 08:19:57)
    33. ACTION: steve ask for access to ad oc community labs (morgan_orange, 08:20:16)
    34. https://build.opnfv.org/ci/view/apex/job/apex-daily-master/ (HelenYao, 08:20:19)
    35. apex daily is back (jose_lausuch, 08:21:17)
    36. ACTION: jose_lausuch remove colorado view in jenkins functest page (jose_lausuch, 08:22:17)
    37. ACTION: jose_lausuch update JIRA sprint (morgan_orange, 08:22:58)
    38. sprint 4 started https://jira.opnfv.org/secure/RapidBoard.jspa?rapidView=59&projectKey=FUNCTEST (jose_lausuch, 08:23:11)

  2. Discussion on unit test strategy (jose_lausuch, 08:23:45)
    1. thanks to ashishk coverage is increasing... (morgan_orange, 08:24:15)
    2. https://build.opnfv.org/ci/view/functest/job/functest-verify-master/2878/cobertura/ (morgan_orange, 08:24:48)
    3. https://lists.opnfv.org/pipermail/test-wg/2017-January/000056.html (ashishk, 08:25:25)
    4. during sync we agreed on a target of min of 80% for the coverage in a first step (morgan_orange, 08:27:48)
    5. ACTION: ashishk sinc with Mark Beier (morgan_orange, 08:28:44)
    6. plan slot with GTM on the 26/1 for unit tests (morgan_orange, 08:29:04)
    7. ACTION: plan slot with GTM on the 26/1 for unit tests (jose_lausuch, 08:29:25)

  3. VNF on boarding for Danube (jose_lausuch, 08:29:44)
    1. VNF onboard patch submitted: https://gerrit.opnfv.org/gerrit/#/c/26769/ (morgan_orange, 08:30:00)
    2. mail thread initiated with orchestra, opera and OAI (morgan_orange, 08:30:17)
    3. feedback from orchestra and opera (morgan_orange, 08:30:24)
    4. no news from OAI - the person who initiated the description left OAI project (morgan_orange, 08:31:11)
    5. ACTION: plan slot with GTM on the 2/2 for unit tests (jose_lausuch, 08:32:06)
    6. based on giuseppe feedback, we shall distinguish 2 aspects (morgan_orange, 08:32:23)
    7. 1) VNF on boarding (show we cna deploy VNF with or without orchestrator i.e. like vIMS with cloudify showed in Brahmaputra) (morgan_orange, 08:32:34)
    8. 2) test MANO stack seen as a feature (morgan_orange, 08:32:47)
    9. the patch only addresses the first topic (morgan_orange, 08:33:04)
    10. ACTION: morgan_orange plan a meeting tomorrow 5PM CET to discuss VNF on boarding - send invitation and bridge details (morgan_orange, 08:41:32)

  4. test result API (status, update, automation) (jose_lausuch, 08:42:00)
    1. patch submitted for running unit tests in jenkins. (morgan_orange, 08:44:14)
    2. work in progress on running unit tests in jenkins. (morgan_orange, 08:44:28)
    3. in // Serena worked on an update of teh datamodel by introducing scenario collection (morgan_orange, 08:44:47)
    4. https://gerrit.opnfv.org/gerrit/#/c/26493/ (morgan_orange, 08:45:05)
    5. datamodel discussed in the wiki: https://wiki.opnfv.org/display/testing/Testing+group+Danube+priorities (morgan_orange, 08:45:50)
    6. in the future we should have: change in the API => creation of a new docker => replace docker on testresults.opnfv.org + doc pushed in the docker and in the artifact (morgan_orange, 08:46:32)
    7. once API finalized, we should add a call from jenkins to update the scenario status (morgan_orange, 08:46:52)
    8. this status will be consummed by the landing page to give a global status... (morgan_orange, 08:47:06)

  5. AoB (jose_lausuch, 08:47:56)
    1. ACTION: all feedback requested on https://gerrit.opnfv.org/gerrit/#/c/26695/ (morgan_orange, 08:49:58)
    2. Serena 1. propose a class in releng for constants The action was made during the weekly meeting held on Dec. 20th. 2016 http://ircbot.wl.linuxfoundation.org/meetings/opnfv-functest/2016/opnfv-functest.2016-12-20-08.04.log.html (morgan_orange, 08:50:57)
    3. Serena 2. patch https://gerrit.opnfv.org/gerrit/#/c/26681/    Now we are making OO as our main framework, I think functest_utils.py should be removed eventually, or at least appears in an OO mode, this patch is a proposal about what we should do with it: There are some methods referenced nowhere; some of them should be substituted with constants; and some only work for a special module, and ush_results_to_db() will be merged w (morgan_orange, 08:51:47)
    4. Helen submitted a patch about refactoring logging, team to provide your feedback: https://gerrit.opnfv.org/gerrit/#/c/26695/ (HelenYao, 08:52:53)
    5. https://git.opnfv.org/releng/tree/modules/opnfv/utils/OPNFVLogger.py (jose_lausuch, 08:54:01)
    6. we should use Releng commons as much as possible (morgan_orange, 08:59:34)


Meeting ended at 09:00:34 UTC (full logs).

Action items

  1. HelenYao check compass issues (issue with keystone version during snapshot/clean phase)
  2. morgan_orange initiate a mail with Functest contributor to indicate current status on community lab access
  3. steve ask for access to ad oc community labs
  4. jose_lausuch remove colorado view in jenkins functest page
  5. jose_lausuch update JIRA sprint
  6. ashishk sinc with Mark Beier
  7. plan slot with GTM on the 26/1 for unit tests
  8. plan slot with GTM on the 2/2 for unit tests
  9. morgan_orange plan a meeting tomorrow 5PM CET to discuss VNF on boarding - send invitation and bridge details
  10. all feedback requested on https://gerrit.opnfv.org/gerrit/#/c/26695/


Action items, by person

  1. ashishk
    1. ashishk sinc with Mark Beier
  2. HelenYao
    1. HelenYao check compass issues (issue with keystone version during snapshot/clean phase)
  3. jose_lausuch
    1. jose_lausuch remove colorado view in jenkins functest page
    2. jose_lausuch update JIRA sprint
  4. morgan_orange
    1. morgan_orange initiate a mail with Functest contributor to indicate current status on community lab access
    2. morgan_orange plan a meeting tomorrow 5PM CET to discuss VNF on boarding - send invitation and bridge details
  5. UNASSIGNED
    1. steve ask for access to ad oc community labs
    2. plan slot with GTM on the 26/1 for unit tests
    3. plan slot with GTM on the 2/2 for unit tests
    4. all feedback requested on https://gerrit.opnfv.org/gerrit/#/c/26695/


People present (lines said)

  1. morgan_orange (127)
  2. jose_lausuch (123)
  3. HelenYao (28)
  4. lorenzotomasini (10)
  5. ashishk (8)
  6. juhak (7)
  7. rohitsakala (5)
  8. collabot (5)
  9. mywulin1 (4)
  10. KumarRishabh (1)
  11. jvidal (1)


Generated by MeetBot 0.1.4.