#opnfv-functest: Functest weekly meeting January 31th 2017

Meeting started by jose_lausuch at 08:00:42 UTC (full logs).

Meeting summary

  1. role call (jose_lausuch, 08:00:56)
    1. Jose Lausuch (jose_lausuch, 08:00:56)
    2. morgan Richomme (morgan_orange, 08:01:13)
    3. Juha Kosonen (juhak, 08:01:18)
    4. rohitsakala (rohitsakala, 08:01:19)
    5. ashishk (ashishk, 08:01:26)
    6. hideyasu (hideyasu, 08:01:37)

  2. Action point follow-up (jose_lausuch, 08:02:29)
    1. AP: ashishk sinc with Mark Beier. Email sent, waiting for Mark's answers and start working together. (jose_lausuch, 08:02:39)
    2. AP: jose_lausuch talk to trozet about openstack version vs keystone version. Can we use v3 as all the others? --> Tim said that v3 is supported, but not by default. Tempest test cases with v3 pass but Apex depends on TripleO releases and they will move to v3 in the next release, so for Danube we will have still v2 and E-river v3 most probably. (jose_lausuch, 08:03:24)
    3. AP jose_lausuch. create more than 1 fuel deployment. Resources are ok (enough disk and ram). DONE (jose_lausuch, 08:04:07)
    4. Cristina Pauna (ENEA) (Cristina_, 08:04:52)
    5. ACTION: morgan_orange indicate keystone v3 status in documentation for Danube (morgan_orange, 08:05:43)
    6. AP jose_lausuch. create 3 scenarios in our server: nosdn, odl_l2, odl_l3 DONE (jose_lausuch, 08:06:02)
    7. http://developer.openstack.org/api-ref/identity/v2/ ... (bertys_, 08:06:17)
    8. AP jose_lausuch add topic on feature tests refactor. DONE (jose_lausuch, 08:08:09)
    9. AP LindaWang check path issue with copper on apex virtual pod (jose_lausuch, 08:08:16)
    10. ACTION: re-check: LindaWang check path issue with copper on apex virtual pod (jose_lausuch, 08:09:01)
    11. AP morgan_orange contact steve to discuss exit conditions in SNAPS. -> Jira created and contacted Steve (jose_lausuch, 08:11:42)
    12. https://jira.opnfv.org/browse/FUNCTEST-713 (morgan_orange, 08:11:47)
    13. https://jira.opnfv.org/browse/FUNCTEST-714 (morgan_orange, 08:12:53)
    14. JIRA created for reporting a failure to DB in SNAPs (jose_lausuch, 08:12:56)
    15. https://jira.opnfv.org/browse/FUNCTEST-714 (morgan_orange, 08:13:01)

  3. Troubleshooting status (short update) (jose_lausuch, 08:13:48)
    1. ACTION: morgan_orange move api_check/connection_check in healtcheck on Thursday + remove historical healtcheck (morgan_orange, 08:15:21)
    2. there is something useful in healtcheck which is checking if the VMs get an IP from the DHCP agent (jose_lausuch, 08:15:50)
    3. ACTION: check with Steven if that is implemented in SNAPS (jose_lausuch, 08:16:00)
    4. APEX (jose_lausuch, 08:17:50)
    5. Tests that are ok: Healthcheck, vping_ssh/userdata, rally, security_scan (jose_lausuch, 08:17:55)
    6. Test that fail in one or more scenarios: doctor, copper, tempest_smoke (by just 1 error), snaps_smoke (jose_lausuch, 08:18:01)
    7. Compass (jose_lausuch, 08:18:18)
    8. healthcheck fails on almost all the scenarios. It only works on odl_l2 (jose_lausuch, 08:18:26)
    9. rally fails and 5 tempest errors on odl_l3-nofeature (jose_lausuch, 08:18:37)
    10. Daisy (jose_lausuch, 08:18:45)
    11. not integrated with Functest yet (jose_lausuch, 08:18:50)
    12. Fuel (jose_lausuch, 08:19:23)
    13. healtcheck passes only in nosdn-ovs scenario, but not in the base nosdn-nofeature scenario (jose_lausuch, 08:19:31)
    14. already contacted with the Fuel team and are in the progress of troubleshooting this on the ericsson-pods (jose_lausuch, 08:19:55)
    15. Joid (jose_lausuch, 08:20:18)
    16. healtcheck fails (jose_lausuch, 08:20:22)
    17. some concerns from Functest team: (jose_lausuch, 08:20:41)
    18. very few installers have good results... (jose_lausuch, 08:20:46)
    19. https://gerrit.opnfv.org/gerrit/#/c/27595/ (morgan_orange, 08:22:44)
    20. ACTION: morgan_orange follow up on JOID progress (jose_lausuch, 08:23:21)
    21. ocl scenario run but no dedicated test suite (jose_lausuch, 08:23:25)
    22. ACTION: juhak investigate why tempest skips 40-50 tests (jose_lausuch, 08:24:36)
    23. no news from Daisy after MS5 => no Functest in Daisy for Danube? (jose_lausuch, 08:24:53)
    24. a lot of features/scenarios not run on jenkins yet (jose_lausuch, 08:25:58)
    25. ACTION: morgan_orange remove non HA to draw daily reporting (morgan_orange, 08:29:27)

  4. Danube documentation (jose_lausuch, 08:30:07)
    1. 2 patches from morgan to update the user and dev guide (jose_lausuch, 08:30:20)
    2. https://gerrit.opnfv.org/gerrit/#/c/27385/ (jose_lausuch, 08:30:26)
    3. https://gerrit.opnfv.org/gerrit/#/c/27665/ (jose_lausuch, 08:30:33)
    4. https://gerrit.opnfv.org/gerrit/#/c/27247/ (morgan_orange, 08:30:44)
    5. ACTION: morgan_orange suggest a cross project review of the documentation to the testing group (jose_lausuch, 08:34:07)

  5. Feature project integration status (jose_lausuch, 08:38:58)
    1. doctor run (apex) but FAIL (jose_lausuch, 08:39:14)
    2. copper run (apex) but FAIL (jose_lausuch, 08:39:19)
    3. promise run (fuel) but FAIL --> Morgan working on it with Promise guys (jose_lausuch, 08:39:23)
    4. parser run (fuel) but FAIL (jose_lausuch, 08:39:27)
    5. ovs run (fuel) but FAIL (jose_lausuch, 08:39:32)
    6. NOT run: moon, bgpvpn, odl-sfc, onos-sfc, ons, domino, kvm (jose_lausuch, 08:39:36)
    7. no recent news from: opera, orchestra, movie, models, ... (jose_lausuch, 08:39:42)
    8. NetReady PTL contacted me to start creating a test case. (jose_lausuch, 08:39:51)
    9. bgpvpn scenario activation is waiting for merge (jose_lausuch, 08:40:35)
    10. sfc scenario already discussed with fuel and apex to activate it in CI asap (jose_lausuch, 08:40:52)
    11. https://gerrit.opnfv.org/gerrit/#/c/27603/3 ? (jose_lausuch, 08:52:01)

  6. AoB (jose_lausuch, 08:52:13)
    1. we should only pass the testcasebase adaptation for those that are missing (morgan_orange, 08:54:39)
    2. but major refactorings should not happen now, as they can break CI (morgan_orange, 08:54:46)
    3. we should have an stable framework and start thinking about fixing bugs (morgan_orange, 08:54:59)
    4. no new feature in Functest framework for Danube (morgan_orange, 08:55:28)
    5. green light from LF to ask bitergia to manage Dashboard (consuming test API) (morgan_orange, 08:56:42)
    6. Plugfest officially announced - will be in paris from the 24 to 27 => good occation for European contributors => organize a meetup here for E? (morgan_orange, 08:57:21)


Meeting ended at 09:00:31 UTC (full logs).

Action items

  1. morgan_orange indicate keystone v3 status in documentation for Danube
  2. re-check: LindaWang check path issue with copper on apex virtual pod
  3. morgan_orange move api_check/connection_check in healtcheck on Thursday + remove historical healtcheck
  4. check with Steven if that is implemented in SNAPS
  5. morgan_orange follow up on JOID progress
  6. juhak investigate why tempest skips 40-50 tests
  7. morgan_orange remove non HA to draw daily reporting
  8. morgan_orange suggest a cross project review of the documentation to the testing group


Action items, by person

  1. juhak
    1. juhak investigate why tempest skips 40-50 tests
  2. morgan_orange
    1. morgan_orange indicate keystone v3 status in documentation for Danube
    2. morgan_orange move api_check/connection_check in healtcheck on Thursday + remove historical healtcheck
    3. morgan_orange follow up on JOID progress
    4. morgan_orange remove non HA to draw daily reporting
    5. morgan_orange suggest a cross project review of the documentation to the testing group
  3. UNASSIGNED
    1. re-check: LindaWang check path issue with copper on apex virtual pod
    2. check with Steven if that is implemented in SNAPS


People present (lines said)

  1. jose_lausuch (215)
  2. morgan_orange (107)
  3. juhak (4)
  4. collabot (4)
  5. hideyasu (4)
  6. bertys_ (3)
  7. ashishk (2)
  8. Cristina_ (1)
  9. rohitsakala (1)


Generated by MeetBot 0.1.4.