#opnfv-functest: Functest weekly meeting February 14th 2017

Meeting started by jose_lausuch at 08:00:10 UTC (full logs).

Meeting summary

  1. role call (jose_lausuch, 08:00:14)
    1. Jose Lausuch (jose_lausuch, 08:00:17)
    2. Morgan Richomme (morgan_orange, 08:00:23)
    3. Juha Kosonen (juhak, 08:00:37)
    4. Helen Yao (HelenYao, 08:00:58)
    5. Cristina Pauna (Enea) (CristinaPauna, 08:01:00)
    6. Linda Wang (LindaWang, 08:01:21)

  2. Action point follow-up (jose_lausuch, 08:03:19)
    1. AP1 morgan_orange: suggest a cross project review of the documentation to the testing group. DONE (jose_lausuch, 08:03:24)
    2. Cédric Ollivier (ollivier, 08:03:41)
    3. AP2 jose_lausuch check for security scan logs in apex (jose_lausuch, 08:03:43)
    4. Still too long and too much output. See this: https://build.opnfv.org/ci/view/functest/job/functest-apex-apex-daily-master-daily-master/398/consoleFull (jose_lausuch, 08:03:50)
    5. ACTION: jose_lausuch contact Luke to see if we can reduce output (jose_lausuch, 08:04:15)
    6. AP3 All: all (specially Luke ): review for sec scan logs https://gerrit.opnfv.org/gerrit/#/c/28019/ (jose_lausuch, 08:04:16)
    7. Merged (jose_lausuch, 08:04:23)
    8. AP jose_lausuch create a wikipage for logging best practicies for Functest. Not done. (jose_lausuch, 08:04:49)
    9. ACTION: jose_lausuch create a wikipage for logging best practicies for Functest (jose_lausuch, 08:04:58)
    10. morgan_orange moon refactoring (Jira + FeatureBase) (jose_lausuch, 08:05:07)
    11. Done (jose_lausuch, 08:05:52)
    12. done (morgan_orange, 08:05:56)
    13. https://gerrit.opnfv.org/gerrit/#/c/28219/2 (morgan_orange, 08:05:58)
    14. AP6 morgan_orange check moon status. Might need test refactor if it's in Danube. (jose_lausuch, 08:06:08)
    15. not refactored but excluded from Danube release (morgan_orange, 08:06:17)
    16. refactoring could be done later with the new version of moon (morgan_orange, 08:06:26)
    17. AP7 SerenaFeng remove multisite.py. DONE: https://gerrit.opnfv.org/gerrit/#/c/28353/ (jose_lausuch, 08:06:37)
    18. ACTION: ollivier add a wiki page about review best practices (jose_lausuch, 08:07:06)

  3. Troubleshooting status (short update) (jose_lausuch, 08:07:16)
    1. status apex http://testresults.opnfv.org/reporting/functest/release/master/index-status-apex.html (jose_lausuch, 08:07:30)
    2. Functest apex has been executed last days (last time 10 Feb) (jose_lausuch, 08:08:01)
    3. bgpvpn scenario integrated but not working yet (jose_lausuch, 08:08:17)
    4. work in progress (jose_lausuch, 08:08:21)
    5. since it is not executed, we don't have results in the dashboard (jose_lausuch, 08:08:46)
    6. ACTION: morgan_orange fix hyperlink to jenkins on the dashboard (jose_lausuch, 08:11:38)
    7. lot of scenarios executed in fuel (jose_lausuch, 08:12:08)
    8. https://gerrit.opnfv.org/gerrit/#/c/28163/ (ollivier, 08:15:25)
    9. status compass http://testresults.opnfv.org/reporting/functest/release/master/index-status-compass.html (jose_lausuch, 08:17:45)
    10. currently 2 scenarios in functest (jose_lausuch, 08:18:07)
    11. compass is trying to run on centos and the snaps related healthcheck failed (jose_lausuch, 08:19:41)
    12. compass team is still working on odl_I3 (jose_lausuch, 08:19:45)
    13. ACTION: work on tempest stopper https://jira.opnfv.org/browse/FUNCTEST-725 (jose_lausuch, 08:23:25)
    14. status fuel http://testresults.opnfv.org/reporting/functest/release/master/index-status-fuel.html (jose_lausuch, 08:24:34)
    15. ACTION: morgan_orange add api_check and conenction_check in reporting (morgan_orange, 08:27:24)
    16. SNAPS working on basic scenario in fuel (jose_lausuch, 08:28:01)
    17. status joid http://testresults.opnfv.org/reporting/functest/release/master/index-status-joid.html (jose_lausuch, 08:28:37)
    18. : last joid successful RUN yesterday (lxd-noha): https://build.opnfv.org/ci/view/functest/job/functest-joid-baremetal-daily-master (morgan_orange, 08:28:51)
    19. ACTION: morgan_orange see why huawei-pod12 is stil not seen as a CI POD  (morgan_orange, 08:28:57)
    20. 3 scenarios (jose_lausuch, 08:29:01)
    21. on this scenario only basic tests are OK (morgan_orange, 08:29:05)
    22. nosdn-nofeature-ha scenario FAIL during installation due to '' => should be fixed by your nightly patch (morgan_orange, 08:29:27)

  4. Refactoring status: ONOs/Moon (jose_lausuch, 08:29:55)
    1. https://build.opnfv.org/ci/view/functest/job/functest-joid-baremetal-daily-master/926/console (morgan_orange, 08:31:02)
    2. https://gerrit.opnfv.org/gerrit/#/q/project:functest+onos (jose_lausuch, 08:34:26)
    3. Moon excluded already from exec_tests and not in Danube (jose_lausuch, 08:36:41)
    4. only ONOS and ONOS-SFC to be refactored and be 100% using the new framework (jose_lausuch, 08:38:41)

  5. Plugfest/Hackfest planning (jose_lausuch, 08:38:55)
    1. Plugfest in France: http://events.linuxfoundation.org/events/opnfv-plugfest (jose_lausuch, 08:39:24)
    2. planning topic: Finalize landing page (jose_lausuch, 08:41:06)
    3. planning topic: present Kumar's work on VNF catalog (jose_lausuch, 08:41:22)
    4. planning topic: presentation about new Functest framework and how easy is to integrate test cases (jose_lausuch, 08:41:51)

  6. AoB (jose_lausuch, 08:46:08)
    1. http://pastebin.com/raw/zj8zJLJa (jose_lausuch, 08:46:50)
    2. http://pastebin.com/raw/s9e4WVcR (jose_lausuch, 08:48:08)
    3. http://pastebin.com/raw/s9e4WVcR (jose_lausuch, 08:50:39)


Meeting ended at 09:04:17 UTC (full logs).

Action items

  1. jose_lausuch contact Luke to see if we can reduce output
  2. jose_lausuch create a wikipage for logging best practicies for Functest
  3. ollivier add a wiki page about review best practices
  4. morgan_orange fix hyperlink to jenkins on the dashboard
  5. work on tempest stopper https://jira.opnfv.org/browse/FUNCTEST-725
  6. morgan_orange add api_check and conenction_check in reporting
  7. morgan_orange see why huawei-pod12 is stil not seen as a CI POD 


Action items, by person

  1. jose_lausuch
    1. jose_lausuch contact Luke to see if we can reduce output
    2. jose_lausuch create a wikipage for logging best practicies for Functest
  2. morgan_orange
    1. morgan_orange fix hyperlink to jenkins on the dashboard
    2. morgan_orange add api_check and conenction_check in reporting
    3. morgan_orange see why huawei-pod12 is stil not seen as a CI POD 
  3. ollivier
    1. ollivier add a wiki page about review best practices


People present (lines said)

  1. jose_lausuch (199)
  2. morgan_orange (63)
  3. ollivier (43)
  4. HelenYao_ (14)
  5. collabot` (5)
  6. OPNFV-Gerrit-Bot (4)
  7. juhak (3)
  8. LindaWang (2)
  9. HelenYao (1)
  10. CristinaPauna (1)


Generated by MeetBot 0.1.4.