08:00:15 <morgan_orange> #startmeeting Functest weekly meeting March 14th
08:00:15 <collabot`> Meeting started Tue Mar 14 08:00:15 2017 UTC.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:15 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:00:15 <collabot`> The meeting name has been set to 'functest_weekly_meeting_march_14th'
08:00:21 <morgan_orange> #topic call role
08:00:24 <morgan_orange> #info Morgan Richomme
08:00:34 <CristinaPauna> #info Cristina Pauna (ENEA)
08:00:39 <juhak> #info Juha Kosonen
08:00:42 <ollivier> #info Cédric
08:00:48 <leo_wang> #info leo wang
08:00:57 <MatthewLi> #info Jun Li
08:01:07 <HelenYao> #info Helen Yao
08:01:09 <morgan_orange> #info agendat for today => https://wiki.opnfv.org/display/functest/Functest+Meeting
08:01:18 <LindaWang> #info Linda Wang
08:01:23 <morgan_orange> #topic action point follow up
08:01:28 <ChrisPriceAB> #info Chris Price (irc only)
08:01:33 <morgan_orange> #info AP1, AP2, AP3, AP4 juhak give feedback on tempest_smoke & rallay_sanity error => see next topic
08:01:38 <morgan_orange> #info AP5 juhak troubleshooting multisite
08:01:44 <morgan_orange> #info AP6: ollivier add a wiki page about review best practices
08:02:00 <ollivier> AP6 still pending
08:02:00 <morgan_orange> #action ollivier add a wiki page about review best practices
08:02:08 <morgan_orange> #info note a page for Euphrates has been initiated
08:02:18 <morgan_orange> #link https://wiki.opnfv.org/display/functest/Functest+Euphrates+page
08:02:39 <morgan_orange> we will nto have time to discuss it this week , but we may plan a topic next time of after the release...
08:02:45 <morgan_orange> #info AP7: morgan_orange ollivier clarify python way for feature projects inhering feature based - see impact on sfc, sdnvpn
08:03:15 <morgan_orange> #info done (security_scan not ready for a cleaner integration => , patch merged)  (security scanning OK)
08:03:21 <morgan_orange> #info AP8: ollivier see what is wrong on odl_l3 scenario => see next topic
08:03:26 <morgan_orange> #info AP9: SerenaFeng check testapi fixed are included on testresults.opnfv.org, if not apply them and maybe enable automatic mechanism now..
08:03:32 <morgan_orange> #info done, testapi is now fully automated from releng to testresults.opnfv.org and artifacts => congratulation to Serena and Rohit
08:03:39 <morgan_orange> #info AP10: morgan_orange => share the mail with scenario owners (any alias?)
08:03:44 <morgan_orange> #info info shared during weekly meeting, I also reported that the wiki page referencing the scenario does not seem fully accurate anymore
08:03:50 <morgan_orange> #info AP11 steve and morgan_orange, see if SNAPS smoke is compatible with lxd (probably not...) if not exclude it
08:04:00 <morgan_orange> #info done, SNAPS smoke excluded for this scenario, JIRA created for adaptation in Euphrates
08:04:06 <morgan_orange> #info AP12 morgan_orange create Danube branch March 10th 2PM CET
08:04:11 <morgan_orange> #info branch created by aric on friday
08:04:20 <morgan_orange> #info jenkins board modified, but no danube CI run seen so far
08:04:26 <morgan_orange> #info only Danube runs come from Cisco labs (not connected to CI but pushing results in DB)
08:04:31 <morgan_orange> #info reporting page update
08:04:36 <morgan_orange> #link morgan_orange adapt reporting to include Danube version
08:04:41 <morgan_orange> #link http://testresults.opnfv.org/reporting/functest/release/danube/index-status-apex.html
08:04:46 <morgan_orange> #info AP13: all close the JIRA that are fixed to clarify
08:04:52 <morgan_orange> #info still pending...
08:04:57 <morgan_orange> #info AP14 morgan_orange clean JIRA for Danube
08:05:01 <morgan_orange> #info in progress
08:05:25 <morgan_orange> ChrisPriceAB: do not worry, it is always IRC only
08:05:34 <morgan_orange> any question on the action point from last week?
08:05:37 <ChrisPriceAB> :)
08:05:56 <morgan_orange> #topic Danube status
08:06:07 <morgan_orange> I ma preparing a mail on the topic,
08:06:22 <morgan_orange> no fuel or apex run sicne several days....
08:06:45 <morgan_orange> tim reported on issue on danube first try
08:06:54 <morgan_orange> we must regenerate a functest:stable docker
08:07:07 <morgan_orange> I modified the jenkins panel
08:07:35 <morgan_orange> HelenYao: do you know if I have only to initiate the docker-build-push-danube....
08:07:58 <morgan_orange> danube jobs are using functest:stable (that is currently still colorado based)
08:08:16 <HelenYao> I have to check the jjb first
08:08:29 <HelenYao> the stable is outdated
08:08:35 <morgan_orange> ok can I action you on that (production of a new stable
08:08:45 <HelenYao> sure
08:08:53 <morgan_orange> #action HelenYao generate new functest:stable based on danube
08:08:57 <morgan_orange> thanks
08:09:24 <morgan_orange> #info new danube jobs call functest:stable (outdated still based on colorado)
08:09:36 <morgan_orange> #info danube Cisco run (not connected to CI) still used latest
08:10:09 <morgan_orange> #info as a consequence on danube job we only see fdio scenario today
08:10:18 <morgan_orange> #info still needs to consider master results
08:10:36 <morgan_orange> juhak: regarding the different AP you have on the different scenarios/installer, do you have an update
08:11:14 <juhak> there are a lot of scenarios, still working of this
08:11:17 <morgan_orange> #info apex
08:11:18 <morgan_orange> #link http://testresults.opnfv.org/reporting/functest/release/master/index-status-apex.html
08:11:40 <juhak> apex, failures on os-odl_l3-nofeature-ha and os-odl-bgpvpn-ha. Error details missing, needs https://gerrit.opnfv.org/gerrit/#/c/30187/ (merged 10.3) to get further info
08:12:46 <morgan_orange> it seems that all the tempest_smoke_serial secnarios (whatever the installer) have issues with odl_l3 scenarios => maybe need to restrict the list of tests if they do not make sense (if that is true errors, we shall remain them of course)
08:13:23 <juhak> they may be related to tempest/paramiko bug: https://bugs.launchpad.net/tempest/+bug/1577632
08:13:48 <pma> https://gerrit.opnfv.org/gerrit/#/c/30341/
08:14:03 <morgan_orange> #action morgan_orange contact bgpvpn team for apex
08:14:20 <MatthewLi> morgan_orange: https://build.opnfv.org/ci/view/functest/job/functest-docker-build-push-danube/
08:14:42 <MatthewLi> need to trigger this to generate  STABLE
08:14:43 <juhak> pma: thanks
08:15:16 <morgan_orange> MatthewLi: yep I added this menu this morning, was just asking Helan to check if running the job is enough or if the job needs to be adapted
08:15:37 <morgan_orange> #info patch submitted for doctor but no apex run on master since more than 5 days....
08:15:38 <MatthewLi> morgan_orange: think only releng committer have priviledge
08:15:42 <morgan_orange> #info so not possible to test the patch
08:16:35 <morgan_orange> #info warning no run on Master during 5 days 10 days before the release....it is a bit hot..
08:17:06 <morgan_orange> #info apex scoring will probably decrease on master due ti lack of CI runs
08:17:09 <morgan_orange> #info compass
08:17:20 <morgan_orange> #info new openo scenario sucessfully itnegrated
08:17:36 <morgan_orange> #info issues with odl scenarios (odl_l2 and odl_l3)
08:18:06 <morgan_orange> #info issues also with ocl (but only installer with such sdn controler)
08:18:13 <morgan_orange> #info fuel
08:18:30 <morgan_orange> #info no run on master since 2 days
08:18:55 <morgan_orange> #still lots of scenario, relative good shape
08:19:14 <morgan_orange> #link http://testresults.opnfv.org/reporting/functest/release/master/index-status-fuel.html
08:20:22 <morgan_orange> also tempest_smoke _serial to be checked in several scenarios, juhak any update for fuel?
08:21:12 <juhak> there are different failure in several scenarios, working on this
08:21:21 <morgan_orange> ok thanks
08:21:25 <morgan_orange> #info joid
08:21:35 <morgan_orange> #link http://testresults.opnfv.org/reporting/functest/release/master/index-status-joid.html
08:22:03 <morgan_orange> #info lxd and nosdn scenario stable (only 1 error remaining on rally_sanity for lxd)
08:22:09 <juhak> rally/nova failed, but no data available
08:22:10 <morgan_orange> #info odl scenario also failing
08:22:20 <juhak> "Not possible to push results to artifact: some error happened when using gsutil"
08:22:26 <juhak> I'll follow this
08:22:29 <morgan_orange> there is a pending jira, resutls are not pushed to artifacts ion huawei-12
08:23:32 <morgan_orange> that is for the current status
08:23:58 <morgan_orange> for fuel barometer scenario, patched has been submitted yesterday, wait for CI run to check the effect
08:24:21 <morgan_orange> any update in Daisy?
08:25:01 <morgan_orange> #info no update on Daisy
08:25:11 <morgan_orange> #topic Danube Documentation
08:25:37 <morgan_orange> #info Functest documentation had been updated (first iteration) several weeks ago
08:25:54 <morgan_orange> #info as we are approaching we need to do the second iteration
08:26:10 <morgan_orange> #aciton morgan_orange review user/conf/dev guide and put contributors in review
08:26:34 <morgan_orange> #info there is still also possibility to including other test prohects and review also their documentation
08:27:04 <morgan_orange> #link https://wiki.opnfv.org/pages/viewpage.action?pageId=10289177
08:27:37 <morgan_orange> #info feel free to add your name to review the doc of another project (last time review were very valuable...)
08:28:00 <morgan_orange> #info release note to be initated
08:28:08 <morgan_orange> #action morgan_orange prepare release note
08:28:18 <morgan_orange> #info release note will be validated by José
08:28:18 <ollivier> morgan_orange: issues vping_ssh (Joid) as test cannot establish connection to IP '10.6.15.12'. Not related to functest test.
08:28:39 <morgan_orange> ollivier: ok
08:28:48 <morgan_orange> any question on the documentation?
08:29:10 <ollivier> morgan_orange: I'm facing a similar issue here. I am investigating
08:29:34 <morgan_orange> #topic RefStack
08:30:06 <morgan_orange> #link https://gerrit.opnfv.org/gerrit/#/c/30225/
08:30:40 <morgan_orange> #info patch ready to be merged, introducing refstack testing as a new test case (i.e. running Refstack suite launched from refstack client)
08:30:56 <morgan_orange> #info test case using testBase abstraction, so results pushed to the DB
08:31:32 <morgan_orange> #info mail this morning refstack could be fine to consume our testAPI but we need to put all the results in the detaisl section (not only the errors or skipped)
08:31:38 <MatthewLi> will amend 30225 soon
08:32:06 <morgan_orange> #info this test will replace defcore created by José but we can try some cycles with both and remove refcore once refstack is fine
08:32:46 <morgan_orange> MatthewLi: I jnow that dovetail roadmap is different from the release, the goal is to include this testcase in Danube, right?
08:32:59 <MatthewLi> morgan_orange: yep
08:33:15 <morgan_orange> in the same time need to https support, HelenYao provided a patch for that https://gerrit.opnfv.org/gerrit/#/c/30253/
08:34:19 <morgan_orange> MatthewLi: OK so we can target merge today => check results on Master => if OK cherry pick on Danube ...timing is short, but I do not know if the release manage can reasonaby consider the 22 as the target...
08:34:43 <MatthewLi> morgan_orange: looks fine
08:35:00 <morgan_orange> HelenYao: can you explain the patch for https support
08:35:01 <MatthewLi> we can achieve that before 22 :) I think
08:35:22 <HelenYao> There is a request in the tech group
08:35:40 <morgan_orange> MatthewLi: yes but in theory we should have 4 succesful consecutive runs .... it takes some time...
08:36:07 <HelenYao> only os_cacert is required to be added to support https. Also, the check_os is changed a bit to support both http and https
08:36:08 <MatthewLi> morgan_orange: yep, let's see how it works in CI
08:36:58 <morgan_orange> HelenYao: I was a bit surprised, we do not need to deal with ceritificates at this stage?
08:37:01 <HelenYao> after the patch is merged, functest is able to run openstack which has http or https enabled
08:37:04 <MatthewLi> morgan_orange: by the way, the unittest will only to add some basic, since there maybe some adaption after CI checks.....
08:37:22 <MatthewLi> then we can add more unittest...
08:37:27 <HelenYao> morgan_orange: in the mail, functest is asked to support https
08:37:37 <morgan_orange> ok
08:38:46 <morgan_orange> MatthewLi: sorry to bother you with unit tests but we all should now consider unit tests when adding code. Thanks to Ahsish we got now a good base, not sure but probably the most complete of OPNFV project. It ensures some stability...we should not rely on 1 person but be all concerned by that..that is why I asked you to add them..
08:38:55 <morgan_orange> at least cover the main stuff
08:39:10 <morgan_orange> for Euphrates - we may expect a 80% coverage before merge -
08:39:20 <MatthewLi> morgan_orange: will achieve this
08:39:22 <morgan_orange> ChrisPriceAB: MatthewLi LindaWang, anything else you want to add for refstack?
08:39:47 <morgan_orange> assuming that apex/fuel are not up, we may have to test it either on compass or joid
08:40:10 <morgan_orange> #topic weekly jobs
08:40:26 <morgan_orange> #info weekly job introduce on fuel nosdn-nofeature master
08:40:30 <ChrisPriceAB> Nothing to add other rthan we need to identify how we report from it.
08:40:50 <ChrisPriceAB> And store results (and details) consistently across projects.
08:41:14 <morgan_orange> #link https://build.opnfv.org/ci/job/fuel-os-nosdn-nofeature-ha-baremetal-weekly-master/
08:41:23 <morgan_orange> #info jobs can be triggered manually from jenkns
08:41:35 <morgan_orange> #info such jobs shall allow the testing of VNF on boarding features
08:41:46 <morgan_orange> #info cloudify_ims tested
08:42:05 <morgan_orange> #info patch merged to avoid exit on vnf tests to see results of orchestra and vrouter
08:42:19 <morgan_orange> #info as soon as fuel is back in town we could try to trigger the job to see that
08:43:06 <morgan_orange> hideyasu: in theory next time we run the job, we should be able to see the vrouter results...I was expecting that over last week end, but fuel installation is failing at the moment...
08:43:34 <morgan_orange> any comment...
08:43:36 <hideyasu> ok, thank you
08:43:50 <morgan_orange> #topic plugfest
08:44:10 <OPNFV-Gerrit-Bot> Michael Polenchuk proposed functest: [tempest/defcore] Configure volume device name  https://gerrit.opnfv.org/gerrit/30161
08:44:28 <morgan_orange> #link https://wiki.opnfv.org/display/EVNT/Plugfest+-+Danube+Release
08:44:42 <morgan_orange> juhak: I did not see any participants from Nokia yet, do you plan to join?
08:45:23 <morgan_orange> Several people from Functest will attend => as usual provides support on running the tests + plugfest test DB,...
08:45:24 <juhak> we are planning, but no official decision yet
08:45:56 <morgan_orange> I read yesterday the the number of seats was limitted to 100 and there were for the moment 49 people registered...
08:46:07 <morgan_orange> so if you plan to go, do not forget to register...
08:46:20 <juhak> yep, I know...
08:46:41 <morgan_orange> I asked during the last weekly meeting if it would have been possible to run bottlenecks+ yardstick stress test defined for Danube
08:47:08 <morgan_orange> I sw gabriel_yuyang connected, maybe he has an update on the participation of people from bottlenecks/yardstick to the event?
08:47:25 <morgan_orange> otherwise we will probably discuss the roadmap for Euphrates
08:47:38 <morgan_orange> #info several functesters will attend
08:47:56 <morgan_orange> #info usual job: explain and support functest towards the different SUT
08:48:06 <morgan_orange> #info probably discussion on Functest roadmap
08:48:29 <morgan_orange> HelenYao: will you be in Paris?
08:48:42 <HelenYao> morgan_orange: i am afraid not
08:49:03 <morgan_orange> ok
08:49:08 <gabriel_yuyang> morgan_orange: for plugfest, I may not be able to attend. I am looking for proxy now.
08:49:28 <morgan_orange> hongbo will be there but he will probably deal with dovetail
08:50:19 <morgan_orange> any other info/questions on the plugfest?
08:51:07 <morgan_orange> it could be also the right place for a new demo of the VNF catalogue
08:51:08 <gabriel_yuyang> morgan_orange: could we do demo remotely?
08:51:22 <morgan_orange> Kumar made a demo during the weekly test meeting, we could replay
08:51:29 <morgan_orange> gabriel_yuyang: sure it shall be possible
08:51:50 <morgan_orange> #action morgan_orange initiate a wiki page for Functest@plugfest - plan remote demo for stress tests
08:52:15 <morgan_orange> #info demo on the Open Source VNF catalogue could be proposed (interesing for the end user)
08:52:30 <morgan_orange> #link https://wiki.opnfv.org/display/DEV/VNF+Catalogue
08:52:37 <morgan_orange> #topic AoB
08:52:46 <morgan_orange> #info CFP Beijing Summit
08:53:13 <gabriel_yuyang> morgan_orange: I mean if I can not attend. I connect remotely and do the demo. Or play some video.
08:53:45 <morgan_orange> #info etherpad page initiated to reference possible topics for the testing community
08:53:47 <morgan_orange> #link https://etherpad.opnfv.org/p/TestCommunitySummit
08:54:04 <morgan_orange> #info page shared on the wg mailing list (no comments/remarks so far)
08:54:11 <morgan_orange> #info deadline 27th of March
08:54:24 <morgan_orange> do you see valuable topics for Functest
08:54:39 <morgan_orange> what would be interesting/useful to report to the community
08:54:48 <morgan_orange> it can be things that are fine, or not....
08:55:12 <morgan_orange> easy or challenging...
08:55:52 <morgan_orange> I think we will give an update on Functest (what is new, what has been changed, vision,...)
08:56:21 <morgan_orange> but we may imagine other topics: difficulty to troubleshoot, evolution to alpine, micro service approach to be consolidated,...
08:56:58 <morgan_orange> ok for Beijing
08:57:05 <morgan_orange> any other topic you want to raise for today?
08:57:36 <morgan_orange> i can see that during the meeting there were 2 attempts to produce the stable functest docker https://build.opnfv.org/ci/view/functest/job/functest-docker-build-push-danube/
08:57:41 <morgan_orange> without success.. :)
08:58:30 <morgan_orange> MatthewLi: HelenYao will have a look at the job...
08:58:51 <HelenYao> morgan_orange: I kicked off the build
08:59:10 <morgan_orange> ok thanks
08:59:41 <morgan_orange> no other point? I think it will be hard for the release date
09:00:17 <morgan_orange> we can see in the scenarios that we have compared to Colorado some new scenarios but some are no more available (no more onos scenarios with any installer)
09:01:09 <morgan_orange> that is probably life..but it could be seen as a form of unstability and/or difficulty to maintain scenarios in release in a sustainable way...
09:01:15 <morgan_orange> ok it is time
09:01:44 <morgan_orange> José will be back next week as a married man, full of energy...
09:02:15 <morgan_orange> thanks for joining, enjoy troubleshooting, docker production, and last danube patches
09:02:17 <morgan_orange> #endmeeting