#opnfv-functest: Functest weekly meeting April 4th

Meeting started by morgan_orange1 at 08:00:08 UTC (full logs).

Meeting summary

  1. call role (morgan_orange1, 08:00:13)
    1. Morgan Richomme (morgan_orange1, 08:00:19)
    2. Jose is at ONS (so hopefully sleeping now it is AM local time) (morgan_orange1, 08:01:13)
    3. https://pbs.twimg.com/media/C8gh7ecUAAAMV9T.jpg:large (morgan_orange1, 08:01:22)
    4. Valentin Boucher (boucherv, 08:02:35)

  2. action points follow-up (morgan_orange1, 08:03:43)
    1. AP1: everyone to agree on Cedric's proposal: https://wiki.opnfv.org/display/functest/Review+checkpoints (morgan_orange1, 08:03:51)
    2. done (at least me and Jose) (morgan_orange1, 08:04:08)
    3. Cédric (ollivier, 08:04:12)
    4. AP2: morgan_orange jose_lausuch prepare short summary "presentation on Functest (introduction/vision) + framework evolution and interface with third party to be initiated" and share with Functest contributors (morgan_orange1, 08:04:17)
    5. Shuya (Shuya, 08:04:26)
    6. work initiated by ollivier... :) a section had been added on teh abstraction class in the developer guide but a deeper discussion needed during the plugfest (morgan_orange1, 08:04:28)
    7. ACTION: jose_lausuch plan a slot for this topic during the Hackfest in Paris (morgan_orange1, 08:04:52)
    8. AP3: jose_lausuch update release note with referenced bug for vping (gluon, bgpvpn) (morgan_orange1, 08:05:04)
    9. done (morgan_orange1, 08:05:09)
    10. AP4: morgan_orange find compas/ocl scenario owner and asks for the status (morgan_orange1, 08:05:19)
    11. mail sent (Artur taylot for ocl/joid, chigang ocl/compass and Stuart Mackie for Juniper - note ovno project created a long time ago did even not branch this time causing CI errors...) wait for feedback. (morgan_orange1, 08:05:26)
    12. AP5: ALL: check JIRA issues and try to finish them or postpone them to Danube2.0 or Euphrates when makes sense (morgan_orange1, 08:05:36)
    13. done, Jose sent a mail to indicate that Functest was clean (morgan_orange1, 08:05:43)
    14. even if JIRAs are probably one of the worst indicator (code is more trustable), it is important to keep it clean ..... (morgan_orange1, 08:05:50)
    15. shall we create guideline for JIRA as we have for review? (morgan_orange1, 08:05:56)
    16. could make sense to try to be consistant, for the moment we have Jira for bug corrections, tasks, feature implementations, sometimes small, sometimes big, sometime several JIRAs for the same task. (morgan_orange1, 08:06:03)
    17. ACTION: morgan initiate page for Jira best practices in Functest (morgan_orange1, 08:07:37)
    18. AP6: morgan_orange propose https://jira.opnfv.org/browse/RELENG-185 to the APAC group test WG (morgan_orange1, 08:07:44)
    19. done (morgan_orange1, 08:07:56)
    20. ACTION: SerenaFeng plans a short slide deck for the meeting planned on the 12th (could be reused for the plugfest) (morgan_orange1, 08:08:01)
    21. AP7: jose_lausuch propose demo for the hackfest about the available tooling in releng (morgan_orange1, 08:08:07)
    22. due to Release/ONS I assume it is not done yet (morgan_orange1, 08:08:14)
    23. ACTION: jose_lausuch propose demo for the hackfest about the available tooling in releng (morgan_orange1, 08:08:20)
    24. AP8: propose a new talk about abstractions / best practices / common libraries / ... (morgan_orange1, 08:08:27)
    25. ??? (morgan_orange1, 08:08:31)
    26. AP9: SerenaFeng rename feature_base to feature (morgan_orange1, 08:10:20)
    27. done (morgan_orange1, 08:10:24)
    28. AP10: morgan_orange propose a vote for https://wiki.opnfv.org/display/functest/Review+checkpoints next week (morgan_orange1, 08:10:32)
    29. I think that due to ONS, the quorum is not reached (morgan_orange1, 08:10:43)

  3. Danube status (morgan_orange1, 08:13:39)
    1. release on the 31th of March (morgan_orange1, 08:13:54)
    2. functest release note updated, note that we validated less scenarios than in Colorado (morgan_orange1, 08:14:12)
    3. I initiated a postmortem as usual (morgan_orange1, 08:14:24)
    4. https://etherpad.opnfv.org/p/FunctestDanubePostMortem (morgan_orange1, 08:14:32)
    5. we will discuss it during the plugfest (morgan_orange1, 08:14:44)
    6. Jose sent a mail to thanks all the contributors, I associate myself to the the greetings (morgan_orange1, 08:15:03)
    7. ACTION: all complete Functest postmortem (what was ++, +, - or --) (morgan_orange1, 08:15:39)

  4. Feature project unit test / interface management (morgan_orange1, 08:15:59)
    1. ollivier started to review the way we are deailing with feature project and especially unit testing (uncovered in Danube) (morgan_orange1, 08:16:39)
    2. conencted to the topic on how we should manage feature project, what are our expectations in term of quality,... (morgan_orange1, 08:16:58)
    3. https://gerrit.opnfv.org/gerrit/#/q/status:open+project:functest+branch:master+topic:cover_features (morgan_orange1, 08:17:22)
    4. several unit tests skipped (though decorator) because of pending issues (JIRA indicated in the decorator) (morgan_orange1, 08:19:55)
    5. https://gerrit.opnfv.org/gerrit/#/c/32083/ (morgan_orange1, 08:20:42)
    6. ACTION: jose_lausuch review https://gerrit.opnfv.org/gerrit/#/c/32083/ and associate patches (32083 impacting all the feature projects..need to be merged to avoid too many rebasing) (morgan_orange1, 08:23:28)

  5. review Functest Euphrates page / discussion priorities (morgan_orange1, 08:25:14)
    1. connected with postmortem (morgan_orange1, 08:25:23)
    2. preparation for the plugfest (morgan_orange1, 08:25:33)
    3. https://wiki.opnfv.org/display/functest/Functest+Euphrates+page (morgan_orange1, 08:25:34)
    4. we should discuss the priorities and the tasks for next release (morgan_orange1, 08:25:49)
    5. ACTION: ALL review Functest Euphrates page (morgan_orange1, 08:26:06)
    6. boucherv suggest adding a topic on VNF in CI (only 1 weekly job on fuel /master created ) => either scenario promotion or more weekly jobs to be created if we want to give feedback to VNF providers (morgan_orange1, 08:27:30)

  6. reporting scenario status using the test API (morgan_orange1, 08:27:52)
    1. today we build reporting page by calling teh API. the scenario score is hosted in a txt file locally (morgan_orange1, 08:28:13)
    2. we made an evolution of teh test API and create a sceanrio object (morgan_orange1, 08:28:28)
    3. for scenario promotion we need to use them (morgan_orange1, 08:28:36)
    4. at the end of a CI loop we should use the APi to update the scenario scoring (morgan_orange1, 08:28:51)
    5. http://testresults.opnfv.org/test/api/v1/scenarios?name=os-fake-ha (morgan_orange1, 08:29:16)
    6. the scenario object will contains: scenario owner / score / custom test lists... (morgan_orange1, 08:29:45)
    7. to be discussed during the plugfest - Danube 2.0 is planned for May (morgan_orange1, 08:30:40)
    8. this mechanism could be put in place in // with existing one (transition during danube) (morgan_orange1, 08:30:58)
    9. using scenario backend will be also useful for the gloabl test landing page (morgan_orange1, 08:31:11)
    10. ACTION: morgan_orange1 organize a discussion during the plugfest (morgan_orange1, 08:31:23)

  7. AoB (morgan_orange1, 08:31:26)


Meeting ended at 08:36:22 UTC (full logs).

Action items

  1. jose_lausuch plan a slot for this topic during the Hackfest in Paris
  2. morgan initiate page for Jira best practices in Functest
  3. SerenaFeng plans a short slide deck for the meeting planned on the 12th (could be reused for the plugfest)
  4. jose_lausuch propose demo for the hackfest about the available tooling in releng
  5. all complete Functest postmortem (what was ++, +, - or --)
  6. jose_lausuch review https://gerrit.opnfv.org/gerrit/#/c/32083/ and associate patches (32083 impacting all the feature projects..need to be merged to avoid too many rebasing)
  7. ALL review Functest Euphrates page
  8. morgan_orange1 organize a discussion during the plugfest


Action items, by person

  1. morgan_orange1
    1. morgan_orange1 organize a discussion during the plugfest
  2. UNASSIGNED
    1. jose_lausuch plan a slot for this topic during the Hackfest in Paris
    2. morgan initiate page for Jira best practices in Functest
    3. SerenaFeng plans a short slide deck for the meeting planned on the 12th (could be reused for the plugfest)
    4. jose_lausuch propose demo for the hackfest about the available tooling in releng
    5. all complete Functest postmortem (what was ++, +, - or --)
    6. jose_lausuch review https://gerrit.opnfv.org/gerrit/#/c/32083/ and associate patches (32083 impacting all the feature projects..need to be merged to avoid too many rebasing)
    7. ALL review Functest Euphrates page


People present (lines said)

  1. morgan_orange1 (106)
  2. ollivier (14)
  3. Shuya (5)
  4. boucherv (4)
  5. collabot` (4)
  6. OPNFV-Gerrit-Bot (1)


Generated by MeetBot 0.1.4.