#opnfv-functest: Functest weekly meeting July 18th 2017

Meeting started by jose_lausuch at 08:00:36 UTC (full logs).

Meeting summary

  1. role call (jose_lausuch, 08:00:44)
    1. Jose Lausuch (jose_lausuch, 08:00:47)
    2. agenda for today: https://wiki.opnfv.org/display/functest/Functest+5.+Meeting#Functest5.Meeting-17/07(8UTC) (jose_lausuch, 08:00:50)
    3. Linda Wang (LindaWang, 08:01:17)
    4. Delia Popescu (ENEA) (depo, 08:01:43)
    5. SerenaFeng (serena-zte, 08:04:23)

  2. Action Point follow up (jose_lausuch, 08:04:55)
    1. AP: ollivier docker alpine image automatic build. DONE: https://gerrit.opnfv.org/gerrit/#/c/37215/ (jose_lausuch, 08:05:03)
    2. AP: jose_lausuch ask Steven to promote news snaps committer. DONE. Linda and Cedric can become committers in SNAPS after CI is properly setup for the project (a few weeks). (jose_lausuch, 08:05:09)
    3. AP: jose_lausuch sync with opnfv helpdesk for automatic builds from opnfv github mirror. (jose_lausuch, 08:05:16)
    4. We already have the docker repos created in Dockerhub, but still waiting for the automatic build from opnfv github. (jose_lausuch, 08:05:20)
    5. AP: jose_lausuch request a virtual deployment job for alpine testing (jose_lausuch, 08:05:46)
    6. I created a virtual server connected to Jenkins for our Alpine testing. https://build.opnfv.org/ci/computer/ericsson-virtual-pod1bl01/ (jose_lausuch, 08:05:50)
    7. ACTION: prepare jenkins job to run alpine containers on ericsson-virtual-pod1bl01 (jose_lausuch, 08:06:49)
    8. AP: jose_lausuch review all the enabled feature test if they perform any package installation (jose_lausuch, 08:07:13)
    9. Some fixes in Domino https://gerrit.opnfv.org/gerrit/#/c/37385/ (jose_lausuch, 08:07:16)
    10. Still doing some adaptations in Parser. https://gerrit.opnfv.org/gerrit/#/c/37625/ (jose_lausuch, 08:07:27)
    11. ONOS under investigation https://gerrit.opnfv.org/gerrit/#/c/37607/ (jose_lausuch, 08:07:48)
    12. AP: jose_lausuch propose a patch without add_images.sh (jose_lausuch, 08:07:57)
    13. DONE: https://gerrit.opnfv.org/gerrit/#/c/37373/ (jose_lausuch, 08:08:00)
    14. AP: LindaWang check with Compass team about opera_ims status due to ONAP changes (jose_lausuch, 08:08:04)
    15. currently, ONAP has no plan to be released in E release. (jose_lausuch, 08:08:42)
    16. but the scenario onap is ready, the testcase opera_ims needs to be updated (jose_lausuch, 08:08:51)
    17. AP: jose_lausuch propose a way to hack logging.ini in prepare_env according to env variable (jose_lausuch, 08:09:27)
    18. 2 proposals: 1) https://gerrit.opnfv.org/gerrit/#/c/37263/ 2) https://gerrit.opnfv.org/gerrit/#/c/37287/ (jose_lausuch, 08:09:35)
    19. Waiting for feedback. Valenting and Serena prefer option 2) (jose_lausuch, 08:09:38)
    20. AP: serena-zte morgan_orange jose_lausuch sync on test API issues (jose_lausuch, 08:10:01)
    21. serena-zte testing the stability and seems ok now with the update to 17.03.1-ce (jose_lausuch, 08:11:57)

  3. Alpine testing status (jose_lausuch, 08:13:04)
    1. Functest docker repositories created in Dockerhub: https://hub.docker.com/u/opnfv/dashboard/?page=2 (jose_lausuch, 08:13:29)
    2. functest-core functest-healthcheck functest-smoke functest-features functest-components functest-vnf (jose_lausuch, 08:13:34)
    3. https://hub.docker.com/u/opnfv/?page=2 (jose_lausuch, 08:14:51)
    4. https://hub.docker.com/u/opnfv/?page=2 (jose_lausuch, 08:14:55)
    5. I connected an Ericsson free server to jenkins with CentOS https://build.opnfv.org/ci/computer/ericsson-virtual-pod1bl01/ (jose_lausuch, 08:15:40)
    6. currently doing some tests with Fuel, but we can use any installer in principle (jose_lausuch, 08:15:53)
    7. https://build.opnfv.org/ci/job/fuel-deploy-virtual-daily-danube/1143/console (jose_lausuch, 08:15:58)
    8. the idea is to use this server for our Alpine testing (jose_lausuch, 08:16:19)
    9. ACTION: jose_lausuch create a jenkins job that triggers a deployment + testing on this server with Alpine containers. Healthcheck+smoke for the momment (jose_lausuch, 08:16:54)
    10. ACTION: Linda check for a free baremetal server to connect it to jenkins for Alpine testing in Compass (jose_lausuch, 08:22:49)
    11. ACTION: all review Functest API proposal https://gerrit.opnfv.org/gerrit/#/c/36703/ (jose_lausuch, 08:24:51)
    12. create swagger specification on top of this proposal (jose_lausuch, 08:29:43)
    13. https://github.com/openstack/nova/blob/master/nova/__init__.py (serena-zte, 08:33:53)
    14. https://github.com/openstack/nova/blob/master/nova/network/__init__.py (LindaWang, 08:35:05)
    15. https://stackoverflow.com/questions/448271/what-is-init-py-for (jose_lausuch, 08:38:25)
    16. https://github.com/openstack/neutron/blob/master/neutron/quota/__init__.py (LindaWang, 08:39:05)
    17. https://pythontips.com/2013/07/28/what-is-__init__-py/ (jose_lausuch, 08:41:29)
    18. ACTION: propose internship "Add Web portal to TestAPI" https://wiki.opnfv.org/display/functest/Internship+proposals (jose_lausuch, 08:46:51)
    19. https://wiki.opnfv.org/display/functest/Internship+proposals#Internshipproposals-Title:AddWebportaltoTestAPI (jose_lausuch, 08:47:17)
    20. https://gerrit.opnfv.org/gerrit/#/c/37053/ (serena-zte, 08:50:44)


Meeting ended at 08:56:02 UTC (full logs).

Action items

  1. prepare jenkins job to run alpine containers on ericsson-virtual-pod1bl01
  2. jose_lausuch create a jenkins job that triggers a deployment + testing on this server with Alpine containers. Healthcheck+smoke for the momment
  3. Linda check for a free baremetal server to connect it to jenkins for Alpine testing in Compass
  4. all review Functest API proposal https://gerrit.opnfv.org/gerrit/#/c/36703/
  5. propose internship "Add Web portal to TestAPI" https://wiki.opnfv.org/display/functest/Internship+proposals


Action items, by person

  1. jose_lausuch
    1. jose_lausuch create a jenkins job that triggers a deployment + testing on this server with Alpine containers. Healthcheck+smoke for the momment
  2. UNASSIGNED
    1. prepare jenkins job to run alpine containers on ericsson-virtual-pod1bl01
    2. Linda check for a free baremetal server to connect it to jenkins for Alpine testing in Compass
    3. all review Functest API proposal https://gerrit.opnfv.org/gerrit/#/c/36703/
    4. propose internship "Add Web portal to TestAPI" https://wiki.opnfv.org/display/functest/Internship+proposals


People present (lines said)

  1. jose_lausuch (177)
  2. serena-zte (54)
  3. LindaWang (40)
  4. collabot (4)
  5. depo (1)


Generated by MeetBot 0.1.4.