08:00:03 <jose_lausuch> #startmeeting Functest weekly meeting 12 Sep. 2017
08:00:03 <collabot> Meeting started Tue Sep 12 08:00:03 2017 UTC.  The chair is jose_lausuch. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:03 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:00:03 <collabot> The meeting name has been set to 'functest_weekly_meeting_12_sep__2017'
08:00:10 <jose_lausuch> #info Jose Lausuch
08:00:32 <boucherv> #info Valentin Boucher
08:00:42 <ollivier> #info Cédric
08:00:51 <LindaWang> #info Linda Wang
08:00:56 <serena-zte> #info SerenaFeng
08:01:03 <juhak> #info Juha Kosonen
08:01:11 <morgan_orange> #info Morgan Richomme
08:01:19 <jose_lausuch> #info Agenda https://wiki.opnfv.org/display/functest/Functest+5.+Meeting#Functest5.Meeting-12/09(8UTC)
08:01:24 <jose_lausuch> #chair morgan_orange
08:01:24 <collabot> Current chairs: jose_lausuch morgan_orange
08:01:37 <jose_lausuch> #topic action points follow up
08:01:45 <jose_lausuch> #info AP morgan_orange restrict orchestra test to apex (to avoid blocking compass gate)
08:01:49 <jose_lausuch> done?
08:02:11 <morgan_orange> #info done then reneable yesterday
08:02:26 <jose_lausuch> ok
08:02:29 <morgan_orange> #info orchestra made the fix to avoid redowloading their image + port 8080
08:02:46 <CristinaPauna> #info Cristina Pauna (Enea)
08:03:02 <jose_lausuch> #info AP iabashin give details on the sceanrio planned for calipso
08:03:29 <jose_lausuch> ?
08:04:03 <jose_lausuch> morgan_orange: do you know?
08:04:16 <morgan_orange> #info calipso out of Functest scope
08:04:31 <morgan_orange> #info they just perform a docker ps on addons installed aside of OpenStack
08:04:40 <morgan_orange> #info no need to use functest for such tests
08:04:41 <jose_lausuch> that seems not compatible with functest integration
08:04:43 <jose_lausuch> as we spoke
08:04:48 <morgan_orange> #info info sent to David Mc bride
08:05:14 <jose_lausuch> thanks
08:05:18 <jose_lausuch> #info AP juhak look at the cleaning issue on Tempest/Refstack issue
08:05:23 <juhak> #info fixed, patch https://gerrit.opnfv.org/gerrit/#/c/41265/ submitted by Linda
08:06:07 <jose_lausuch> ok,thanks
08:06:17 <jose_lausuch> #info AP jose_lausuch review the different internship requests / send mail to functest team / prepare answers to the students
08:06:38 <jose_lausuch> #info ongoing, there are a couple of students interested in the different topics, need to arrange interviews with them
08:06:47 <jose_lausuch> #info AP morgan_orange forward the different emails
08:06:51 <jose_lausuch> #info Done
08:06:52 <morgan_orange> #info done
08:06:57 <jose_lausuch> #undo
08:06:57 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x3563950>
08:07:14 <jose_lausuch> #topic Euphrates Status
08:07:26 <jose_lausuch> could you guys explain your current issues/blockers?
08:07:41 <LindaWang> which docker will be released?
08:07:51 <LindaWang> ubuntu or alpine based?
08:08:13 <LindaWang> I mean which functest image :)
08:08:15 <jose_lausuch> alpine is not supported by armnand so we still need to keep ubutnu https://gerrit.opnfv.org/gerrit/#/c/41663/
08:08:24 <jose_lausuch> but we could release alpine for the rest
08:08:51 <LindaWang> but now only alpine image is used in CI for 5 installers.
08:08:54 <morgan_orange> I am currently updating the doc accordingly
08:08:54 <ollivier> I do think it's a mistake. They should rely on the right image. Look at the tweak to bypass issues on libxml.
08:09:16 <jose_lausuch> #info Morgan updating the docs with Alpine information
08:09:20 <jose_lausuch> thanks moç
08:09:23 <jose_lausuch> thanks morgan_orange
08:09:28 <ollivier> morgan_orange: thanks.
08:10:07 <jose_lausuch> ollivier: is it cause by only some modules? or a bigger compatibility issue?
08:10:29 <jose_lausuch> if we could find the way to make it work on aarch64 easily...
08:10:31 <morgan_orange> I created a patch this morning to allow run on aarch64, CristinaPauna created a JIRA for future work in armband for alpine support. Meanwhile we still can use the monolithic ubuntu
08:10:53 <CristinaPauna> morgan_orange: Delia is working on it
08:11:03 <morgan_orange> LindaWang: it is even used by 6 installers if we consider osa ..
08:11:10 <CristinaPauna> she will submit a patch for the basic tests today
08:11:10 <LindaWang> rally_sanity failed to run in compass now, maybe I need Cedric's help.
08:11:22 <morgan_orange> CristinaPauna: ok so my patch will be maybe useless..
08:11:34 <jose_lausuch> CristinaPauna: do you know how much work could that bring?
08:11:43 <jose_lausuch> meaning.. how long could it take?
08:11:50 <LindaWang> is osa not compass master? morgan_orange
08:11:51 <ollivier> jose_lausuch: simply because the ubuntu is too old (e cannot rely on system librairies).  Technically speaking, we should have switched to Alpine for a while.
08:12:01 <jose_lausuch> LindaWang: OSA is also refered to XCI
08:12:29 <morgan_orange> LindaWang: OSA = OpenStack Ansible used by Compass and XCI
08:12:33 <ollivier> jose_lausuch: It's fine to keep the two images. But we should tag opnfv/functest as deprecated and the remove it in the next release dev cycle
08:12:37 <CristinaPauna> jose_lausuch: functest_core, and all docker files for the rest of the tests
08:13:13 <CristinaPauna> morgan_orange: can you sync with Delia to see what each of you did?
08:13:33 <jose_lausuch> so, the only dependency to keep Ubuntu image is arm right now?
08:13:59 <ollivier> I do think so.
08:14:03 <CristinaPauna> she is currnetly working on the vnf container, but will submit the patches without that
08:14:21 <morgan_orange> CristinaPauna: I did not work on alpine support for arm, just reenable the old way but OK I take the point and sync with Delia
08:14:21 <CristinaPauna> or maybe not even that
08:14:43 <CristinaPauna> morgan_orange: 10x
08:14:58 <LindaWang> ollivier: Could you create a full alpine image for functest restapi?
08:15:07 <morgan_orange> other concerns for Euphrates release: not lots of feedback from feature projects...
08:15:35 <jose_lausuch> I know from sfc they are working on making it work on XCI
08:15:49 <jose_lausuch> but you are right, not much feedback from all
08:16:25 <ollivier> LindaWang: Yes. I can. I will create a new dir full. The issue is simply to duplicate the work and it's against the slices. But it meets your target.
08:16:48 <LindaWang> ollivier: Thanks.
08:16:54 <jose_lausuch> ollivier: ok, can I action you?
08:17:19 <jose_lausuch> #action CristinaPauna give an update about supporting alpine on aarch64
08:17:19 <ollivier> LindaWang: Yes. Please give me details of rally_sanity after the meeting.
08:17:24 <LindaWang> another issue: functest daily job is often time out on huawei-virtual5, i am not sure if it also occurs on other pods.
08:17:26 <LindaWang> ollivier: ok
08:17:34 <jose_lausuch> #action ollivier LindaWang create alpine container for RestAPI
08:17:51 <LindaWang> ollivier: compass team would like to give you access to huawei-virtual5
08:17:53 <jose_lausuch> #info not much feedback provided from feature projects
08:18:17 <jose_lausuch> LindaWang: do you know the cause? I mean, is there a hanging test case?
08:18:31 <LindaWang> jose_lausuch: vnf tests take a long time
08:18:37 <LindaWang> jose_lausuch: https://build.opnfv.org/ci/view/functest/job/functest-alpine-compass-huawei-virtual5-daily-master/30/console
08:18:56 <jose_lausuch> 4 hours runtime...
08:18:58 <morgan_orange> LindaWang: on our POD a cloudify_ims is 15 minutes...
08:18:59 <ollivier> LindaWang: let me know if I should provide a shared key (ssh, gpg...)
08:19:10 <morgan_orange> I think such tests should be run only on baremetal
08:19:17 <jose_lausuch> +1
08:19:20 <LindaWang> morgan_orange: Lol, maybe you are right
08:19:28 <morgan_orange> but we can filter only on installer/sceanrio
08:19:29 <ollivier> some vnfs downloads external scripts (bug Valentin ;)
08:19:50 <morgan_orange> running a ha sceanrio in virtual..may lead to lots of performance issues precisely detected by such tests...
08:20:12 <boucherv> morgan_orange: +1
08:20:14 <ollivier> morgan_orange: +1
08:20:16 <jose_lausuch> agree
08:20:21 <ollivier> boucherv: +1
08:20:27 <serena-zte> +1
08:20:30 <jose_lausuch> how shall we fix that on virtual envs?
08:20:54 <morgan_orange> it looks like another constraint we did nto integrate so far...
08:20:58 <jose_lausuch> another filter by "virtual" vs "baremetal" seems overwhelming…
08:21:06 <serena-zte> by ha or noha
08:21:09 <jose_lausuch> just like ha/noha
08:21:16 <morgan_orange> if we could filter on pod name, we could filter on virtual/baremetal
08:21:21 <ollivier> normally kvm works well in guest if the module is well loaded.
08:21:28 <morgan_orange> some time ago HA = baremetal, NOHA = virtual
08:21:32 <morgan_orange> but it is not the case anymore...
08:21:33 <jose_lausuch> that has changed
08:21:34 <LindaWang> there is always ha for compass, no matter virtual or baremetal
08:21:35 <morgan_orange> we have HA on virtual
08:21:36 <serena-zte> parser used to run on virtual, but it requires lots of resources
08:21:43 <serena-zte> so we change to run on HA
08:22:13 <ollivier> serena-zte: I haven't received any feedback on parser container. Has it been tested?
08:22:38 <jose_lausuch> is it too late to implement that filter? or we leave it for next release
08:22:47 <serena-zte> I don't know either, I am out of office for a few days, I will sync with xiaodong tomorrow
08:23:31 <morgan_orange> a simple/ugly way would be in releng to exclude vnf tier from the list if virtual is in the POD name
08:24:09 <jose_lausuch> but we execute daily, right?
08:24:15 <morgan_orange> https://git.opnfv.org/releng/tree/jjb/functest/functest-alpine.sh#L74
08:24:24 <ollivier> I would propose to find the issues first. Then we will see if it's related to the second virtualization layer.
08:25:11 <morgan_orange> for me the issue is linked to the dimensioning of the virtual POD
08:25:22 <morgan_orange> not enough RAM/space/vCPU
08:25:31 <jose_lausuch> I'd say it's just a resources thing
08:25:34 <serena-zte> yes
08:25:36 <jose_lausuch> virtual is just slower
08:25:49 <morgan_orange> LindaWang: do you have the details for huwaei-virtual5?
08:25:55 <serena-zte> 8G/4G RAM usually
08:26:04 <LindaWang> no idea so far
08:26:15 <morgan_orange> boucherv: how many VMs in cloudify_ims?
08:26:20 <jose_lausuch> maybe we could put a note in the documentation
08:26:22 <morgan_orange> at least 10 ...
08:26:43 <jose_lausuch> #action get information from huawei-virtual5 (ram, cpu)
08:27:04 <LindaWang> ok
08:27:18 <jose_lausuch> #undo
08:27:18 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x357a7d0>
08:27:26 <jose_lausuch> irc://irc.freenode.net:6667/#action LindaWang get information from huawei-virtual5 (ram, cpu)
08:27:33 <boucherv> yes 8 (x2Gb RAM) and 1 (4 or 8 Gb ram)
08:27:38 <jose_lausuch> irc://irc.freenode.net:6667/#action LindaWang get information from huawei-virtual5 (ram, cpu)
08:27:44 <jose_lausuch> what's that?
08:27:57 <jose_lausuch> #action LindaWang get information from huawei-virtual5 (ram, cpu)
08:28:09 <LindaWang> https://hastebin.com/komarokuvi.rb
08:28:27 <jose_lausuch> also the ram that is assigned to the different virtual nodes
08:28:56 <ollivier> Can you please send the related testcase log files too? I think they were not published as artifacts.
08:29:29 <morgan_orange> ollivier: LF stack seems empty, LindaWangasked for gutils config for a while..but like our violation plugin..still not done... :)
08:29:40 <morgan_orange> humm not empty, full
08:29:58 <LindaWang> morgan_orange:  Done. log file can be pushed tp artifacts now
08:30:08 <morgan_orange> ah ok my bad..
08:30:21 <ollivier> and maybe violation plugin too?
08:30:43 <LindaWang> huawei-viatul5 cpu: 48  Intel(R) Xeon(R) CPU E5-2658A v3 @ 2.20GHz
08:31:08 <jose_lausuch> serena-zte: LindaWang: did you work before summer on a way to publish artifacts even though the job fails or timesout?
08:31:32 <LindaWang> jose_lausuch: no
08:31:45 <serena-zte> no
08:31:52 <jose_lausuch> #info huawei-virtual5: cpu: 48  Intel(R) Xeon(R) CPU E5-2658A v3 @ 2.20GHz
08:32:13 <jose_lausuch> ok, but I remember there was something from someone
08:32:19 <jose_lausuch> never mind
08:33:36 <LindaWang> I remember Helen worked on it
08:33:44 <jose_lausuch> ah it was Helen yes
08:33:47 <morgan_orange> LindaWang: and RAM..if it it 8 (assuming that we need at least 20) it may explain some issues...
08:33:52 <LindaWang> But i am not sure if it was finished
08:34:05 <serena-zte> free 1.3G
08:34:22 <serena-zte> according to LindaWang's hastbin infor
08:34:27 <LindaWang> Only 1.3G ram available
08:34:35 <serena-zte> I think it is the board's hw information
08:34:39 <serena-zte> not only for the pod
08:34:58 <ollivier> It begins swaping then perf' can decrease a little bit. But it may be a firewall issue too.
08:35:00 <jose_lausuch> you can do it by checking the individual vms
08:35:03 <jose_lausuch> with virsh or so
08:35:14 <serena-zte> a POD will not take so many RAM 180G consumed
08:35:28 <LindaWang> i will do that later, and maybe do some cleaning
08:35:42 <morgan_orange> yep do we have another virtual pod available somewhere? I rmemeber there were some alpine tests some time ago before the susification....
08:36:01 <morgan_orange> but the ericsson pod is no mre up&running I think
08:36:31 <serena-zte> LindaWang, can you confirm the resources assignment when deploy the pod? how many RAM/CPUs are assigned to the pod?
08:36:46 <LindaWang> https://build.opnfv.org/ci/view/functest/job/functest-compass-virtual-daily-master/  alpine based containers are running on these virtual pods now
08:37:06 <LindaWang> serena-zte: sure.
08:37:13 <ollivier> the virtual pod is very important in Alpine testing. Thank you.
08:38:20 <ollivier> CloudifyClientError: 502: 502:
08:38:35 <morgan_orange> LindaWang: ok you see on a virtual time is 20 minutes here
08:38:56 <morgan_orange> which is a little bit more than on baremetal but seems OK
08:38:58 <morgan_orange> not 4 hours
08:39:18 <LindaWang> maybe huawei-virtual5 has the worst performance.
08:39:52 <LindaWang> since alpine containers are running in CI,  we do not have to only rely on huawei-virtual5
08:40:19 <LindaWang> https://build.opnfv.org/ci/view/functest/job/functest-compass-baremetal-daily-master/1465/console
08:40:23 <morgan_orange> good question for you colleague managing the infra but there is probably somethign wrong (FW/Config/..) :)
08:40:38 <LindaWang> see cloudify_ims passed on huawei-pod1
08:41:00 <boucherv> good news !
08:41:03 <morgan_orange> we should also find a way to get tid off the ugly logs from urllib3...
08:41:05 <serena-zte> I think maybe 1.3G RAM is one of the problem, we can start with the RAM clean and try again
08:41:10 <jose_lausuch> boucherv: congrats :p
08:41:30 <jose_lausuch> yes, those logs shouldn't be there
08:41:39 <LindaWang> morgan_orange:  yes, agree, https://gerrit.opnfv.org/gerrit/#/c/40677/
08:41:46 <ollivier> LindaWang: maybe a network issue to raise CloudifyClientError: 502: 502:
08:41:47 <LindaWang> morgan_orange: this patch has not been dinished
08:42:22 <morgan_orange> #info logs to be cleaned
08:42:25 <morgan_orange> #info patch iunitiated
08:42:26 <LindaWang> ollivier: Which job do you refer?
08:42:29 <jose_lausuch> #link https://gerrit.opnfv.org/gerrit/#/c/40677/
08:42:36 <OPNFV-Gerrit-Bot> Jose Lausuch proposed functest: Disable urllib3 warnings  https://gerrit.opnfv.org/gerrit/40677
08:42:47 <morgan_orange> soumaya: do you have any update on the vEPC testcase?
08:42:57 <ollivier> I would have prefered disabling via logging.ini
08:42:59 <boucherv> ollivier: ssometimes this error appears when the pod is too slow ..
08:43:00 <soumaya> Hi Morgan . Yes
08:43:14 <soumaya> I am committing code today
08:43:36 <jose_lausuch> LindaWang: can you move that to logging.ini ?
08:43:42 <LindaWang> ollivier: Could you help with the patch "disable urllib3 warnings"?
08:43:49 <LindaWang> jose_lausuch: Aha
08:43:52 <LindaWang> jose_lausuch: I will try
08:44:11 <jose_lausuch> #action LindaWang and cedric, update logging.ini to disable urllib3 log output
08:44:12 <morgan_orange> thanks soumaya
08:44:18 <jose_lausuch> thanks
08:44:21 <morgan_orange> jose_lausuch: soumaya and debayan showed the traces on Orange Community POD3, sounds we will get a new VNF onboarded (vEPC)
08:44:24 <soumaya> welcome
08:44:42 <ollivier> LindaWang: yes
08:44:43 <jose_lausuch> #info soumaya ongoing work on vEPC  test case
08:44:52 <jose_lausuch> morgan_orange: ok, good !
08:45:24 <morgan_orange> #info vEPC successfully integrated on community PODs (traces PASS on Danube 3.0/Compass (Orange community POD 3)
08:45:44 <morgan_orange> #action soumaya push code to repo for final integration
08:46:00 <soumaya> Thanks
08:47:47 <jose_lausuch> what about the branching window?
08:48:37 <ollivier> Normally Functest should be branched at the end as it depends on lots of OPNFV projects.
08:48:49 <jose_lausuch> #info branching window closes on 15 Sep.
08:49:10 <jose_lausuch> they will start creating euphrates jobs next week
08:49:13 <morgan_orange> I think we can wait the end..we could imagine to have the authorization to do it after the 15th as we integrate other projects...
08:49:18 <jose_lausuch> everthing needs to have that branch
08:49:18 <ollivier> I will ask Aric to warm me when a project is branched
08:49:26 <jose_lausuch> but a lot of cherry pick is a pain
08:49:30 <jose_lausuch> ok
08:49:59 <morgan_orange> maybe you can ask for an exception to David and say that we need to have all the other projects to be branched before we can do it
08:50:02 <ollivier> Please let me configure the first operations when the new branch is created.
08:50:04 <jose_lausuch> #info need to ask if we can wait before branching, as functest depends on other opnfv projects
08:50:14 <jose_lausuch> yes
08:50:23 <ollivier> I'm not sure we should breate an exception as we are ready from a Functest POV
08:50:25 <jose_lausuch> #action bring the branching topic to release meeting
08:50:41 <ollivier> ..raise..
08:50:42 <jose_lausuch> at least we should wait until all the others are branched
08:50:47 <jose_lausuch> right?
08:50:54 <ollivier> at least we must be added in CC.
08:51:04 <morgan_orange> right, in theory the feature should have already branch but they wait the last minute
08:51:40 <morgan_orange> but ok not to raise an exception..we are ready from a project perspective
08:52:07 <jose_lausuch> thrre is a release meeting today, ollivier: do you want to join?
08:52:18 <ollivier> We could create the branch. I will operate the first steps. Then we need to update the branch when the project are ready.
08:52:29 <ollivier> I can't this morning sorry.
08:52:41 <jose_lausuch> it's in the afternoon
08:52:48 <jose_lausuch> but no problem, I will raise the topic
08:52:49 <jose_lausuch> but then
08:52:59 <jose_lausuch> do we just branch on the 15th?
08:53:11 <jose_lausuch> if so, no need to raise any exception or issue
08:53:12 <ollivier> Let's see if I finish first my hot topic for today.
08:53:35 <jose_lausuch> ok
08:53:41 <ollivier> (ODL related)
08:54:34 <jose_lausuch> I will skip the internship topic today and move it to next week
08:54:43 <jose_lausuch> I will probrably have talked to all the candidates
08:54:48 <jose_lausuch> #topic AoB
08:55:23 <jose_lausuch> does anyone wants to talk about some other topics?
08:55:25 <morgan_orange> LindaWang: juhak do we have still a need for a connectivity on the admin network - it is for the doc...
08:55:34 <pma> Is it known issue? https://build.opnfv.org/ci/view/fuel/job/functest-fuel-baremetal-daily-master/1845/console
08:55:58 <LindaWang> morgan_orange: No such need I think
08:56:11 <jose_lausuch> Connecting to marketplace.openbaton.org (marketplace.openbaton.org)|193.175.132.179|:8080... failed: Connection refused.
08:56:36 <pma> jose_lausuch> need just to wait?
08:56:40 <ollivier> It works here. (-N included)
08:56:49 <jose_lausuch> morgan_orange: that issue seems to be related to your patch with the openbaton image
08:57:14 <pma> Ok I'll re-run it later
08:57:31 <jose_lausuch> it is an internet connectivity issue?
08:57:34 <ollivier> jose_lausuch: the key point is solved (timestamps). Maybe we should simply open FW rules.
08:57:36 <jose_lausuch> if it works on other places…
08:57:40 <jose_lausuch> ok
08:58:00 <morgan_orange> I just tried right now from my laptop, it is answering..
08:58:15 <morgan_orange> so either a FW or a temporary connectivity issue
08:58:52 <jose_lausuch> pma:  can you try again?
08:58:56 <LindaWang> it works from my side.
08:59:01 <jose_lausuch> and check that there is no FW issue or anything?
08:59:11 <ollivier> Please simply telnet the tcp port.
08:59:24 <jose_lausuch> or netcat
08:59:33 <ollivier> telnet  193.175.132.179 8080. I bet on FW rules
09:00:36 <jose_lausuch> ok
09:00:39 <jose_lausuch> can we close the meeting?
09:00:41 <serena-zte> morgan_orange jose_lausuch Thuvaraka already finish his three commits, I think it is time for the interview, when do you think is the available time?
09:01:04 <jose_lausuch> serena-zte: let's schedule for this week, is it ok for you?
09:01:16 <serena-zte> Sure
09:01:32 <serena-zte> I will forward his resume to both of you
09:01:39 <jose_lausuch> serena-zte: please do so, thanks
09:01:44 <jose_lausuch> #endmeeting