08:04:06 <ollivier> #startmeeting Functest weekly meeting 16 Jan. 2018
08:04:06 <collabot> Meeting started Tue Jan 16 08:04:06 2018 UTC. The chair is ollivier. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:04:06 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:04:06 <collabot> The meeting name has been set to 'functest_weekly_meeting_16_jan__2018'
08:04:29 <ollivier> #info Cédric
08:04:39 <LindaWang> #info Linda Wang
08:04:57 <juhak> #info Juha Kosonen
08:05:28 <depo> #info Delia Popescu
08:05:32 <ollivier> Before starting, I sent you the email asked last week about the pending work integration XCI and Functest
08:06:44 <ollivier> #topic action point follow-up
08:06:57 <ollivier> #info opnfv/functest-kubernetes is now available (09/01 AP2)
08:07:22 <ollivier> #link https://build.opnfv.org/ci/view/functest/job/functest-kubernetes-docker-build-push-master/
08:07:32 <ollivier> #link https://hub.docker.com/r/opnfv/functest-kubernetes/tags/
08:07:45 <ollivier> #topic functest
08:07:55 <ollivier> #info the former stable tags were removed: https://gerrit.opnfv.org/gerrit/#/c/50469/
08:08:21 <ollivier> It avoids mixing euphrates and stable which was unmaintained. I removed the former tags by hand
08:08:45 <ollivier> #info all containers are now published for ARM
08:08:53 <ollivier> #link https://jira.opnfv.org/browse/FUNCTEST-899
08:10:01 <ollivier> Thank you all. That's a gerat news. Euphrates can be considered as finished now.
08:10:13 <LindaWang> ollivier: one quick question about manifest
08:10:20 <ollivier> LindaWang: sure
08:10:25 <LindaWang> ollivier: take this command for example:
08:10:25 <LindaWang> manifest-tool push from-args --platforms linux/amd64,linux/arm64 --template opnfv/functest-vnf:ARCH-latest --target opnfv/functest-vnf:latest
08:10:50 <LindaWang> does it need to pull opnfv/functest-vnf:ARCH-latest from dockeehub first?
08:11:37 <ollivier> In fact manifest tools pull the containers. It doesn't care about the containers possibly built locally
08:12:06 <ollivier> It breaks offline. That's why build.sh doesn't call manifest-tools
08:12:38 <ollivier> It's done by releng or travis-ci in post-processing
08:13:16 <ollivier> build.sh aims at building everything for a private repo.
08:13:16 <LindaWang> ok, thanks
08:13:51 <ollivier> offline is not right here. I should have said you don't require pulling the official opnfv images.
08:13:58 <ollivier> You could use ollivier or any repo.
08:14:45 <ollivier> #info the travis-ci jobs were updated to build functest-parser
08:15:00 <ollivier> #info ruby raises segfaults vs qemu-user-static then functest-vnf and functest-restapi are still disabled in the travis-ci jobs
08:15:22 <georgk> juhak: good morning
08:15:56 <juhak> georgk: hi
08:16:16 <georgk> juhak: I think I solved my problem. It was due to Rally telling the keystone client to ALWAYS use the public endpoint - which doesn´t work
08:16:16 <depo> :q
08:16:17 <ollivier> I will try to bypass that when I'm free. From the time being, it's useless as the native build works well.
08:16:35 <ollivier> Should I add a rally topic :) ?
08:16:35 <georgk> juhak: so, I think I am good for now. Thank you again for your support
08:17:33 <ollivier> #info Thank juhak for his rally support
08:17:39 <juhak> georgk: makes sense, good to hear its working now
08:17:43 <ollivier> #info 2 fixes were published for tempest
08:17:54 <ollivier> #link https://gerrit.opnfv.org/gerrit/#/c/50307/
08:18:00 <ollivier> #link https://gerrit.opnfv.org/gerrit/#/c/50389/
08:18:09 <georgk> oh, you are runnign your meeting - sorry for interrupting...
08:18:14 <ollivier> georgk: no pb
08:18:33 <LindaWang> It disables idnetity v2 when identity v3 is available
08:18:56 <ollivier> We have found a bug about one multiregion harcoding in tempest.
08:19:26 <ollivier> We could have considered testing double support but as v2 is hugely deprecated it's fine.
08:19:54 <ollivier> Thank you to keep testing v2 if v3 is unsupported
08:20:01 <ollivier> It may help
08:21:08 <LindaWang> For master, we run Functest on deployments where at least identity v3 shall be supported
08:21:22 <ollivier> One patch will be published this morning about tempest in multi-region contexts. I should have a look how it works vs Apex as it defines another region name too.
08:21:58 <ollivier> ok. I thought it only disables v2 when v3 is supported.
08:22:14 <LindaWang> multi-region? i have not found this bug.
08:22:37 <LindaWang> i will help test it on Compass when the patch is ready.
08:22:48 <ollivier> I think regionOne is harcoded. I haven't seen the patch yes. thank you
08:23:27 <ollivier> #topic functest-kubernetes
08:23:42 <ollivier> #info the first testcase has been proposed
08:23:48 <ollivier> #link https://gerrit.opnfv.org/gerrit/#/c/50591/
08:24:25 <ollivier> The topic is well started. That's great.
08:25:16 <ollivier> As it's a new work, I'm think about following the best rules. Pylint 10/10, full unit test coverage.
08:25:16 <LindaWang> could we add the unittest in the next patch?
08:25:25 <ollivier> yes. If it helps.
08:25:45 <ollivier> but I think it's easy here to fully cover the testcase
08:26:26 <ollivier> We can first initiate CI, python packages. But we should set that rules.
08:26:32 <LindaWang> yes
08:26:44 <LindaWang> but we only test it locally on compass
08:26:57 <ollivier> At least it will be great to take pylint report into account.
08:27:14 <LindaWang> yes, it makes sense
08:27:37 <ollivier> then we can write tox.ini and implement the verify job.
08:28:34 <ollivier> It's ok if we simply update k8stest.py. I will write tox.ini after that.
08:28:46 <LindaWang> thanks,
08:29:45 <ollivier> #action Linda,Konrad to update update k8stest.py (take current comments into account)
08:30:04 <ollivier> #action Cédric Write tox.ini and fix pylint errors
08:30:19 <ollivier> #action all implement verify job and testing job
08:30:54 <ollivier> I don't know if ARM will be supported. The question was asked already.
08:31:46 <ollivier> #topic functest-xtesting
08:32:00 <ollivier> #info push_results() and get_version() are being moved to TestCase
08:32:09 <ollivier> last actions are to update decorators and to fix unit tests
08:33:14 <ollivier> #topic releng
08:34:16 <ollivier> I am listing several releng actions
08:34:54 <ollivier> Delia already proposed her help on that. But be free to pick several actions.
08:35:02 <ollivier> #info to update the functest-* multijobs: the repo should be a variable, several variables may be cleant...
08:35:16 <ollivier> #info to be able to build automatically the official containers
08:35:25 <ollivier> #link https://gerrit.opnfv.org/gerrit/#/c/48049
08:35:56 <ollivier> (I published Euphrates.1 manifests by hand)
08:36:08 <ollivier> #info to create the new jobs for functest-requirements (when ready).
08:36:56 <LindaWang> what does it mean by saying building automatically the official containers?
08:36:56 <ollivier> Globally we should clean the dashboard. We should not consider templates for all installers. Only Fuel supports both architectures.
08:37:02 <LindaWang> Builds from Git Tag?
08:37:20 <LindaWang> what is the difference from the current way?
08:37:47 <ollivier> Yes. But in our case, it's useless to build all containers. We can simply push the manifests for last tested containers (see my review).
08:37:51 <LindaWang> I could clean the job dashboards in Jenkins
08:38:22 <ollivier> From the time being, we are building the containers when one patch is merged.
08:38:41 <ollivier> Nothing is done when creating a new tag.
08:39:29 <ollivier> Here our container is already ready for next steps (builds per tag or per gerrit patch sets). The issues are in releng.
08:40:51 <ollivier> But I think the update will build all containers. I would have selected to publish the manifests only (listing the last tested images).
08:42:01 <depo> about functest-* multijobs my question is similar, what should be fixed on the way it's done by functest-docker? or is it wrong?
08:43:13 <ollivier> In fact, the current releng is opnfv hardcoded. repo should be a variable and it will be great to reuse that for any purpose.
08:43:37 <ollivier> see travis-ci.
08:45:16 <ollivier> I think there are lots of useless variables in the job and only defining what we need will ease maintaining the job.
08:46:01 <ollivier> It will help reading the dashboard if we only list possible jobs and mask the childs (see docker multijobs).
08:46:41 <ollivier> We should also rewrite the daily job to run features in multijobs. Then we can send email to the right devs.
08:47:35 <LindaWang> This is a good idea.
08:47:38 <ollivier> And we do send an amail to David if Healthcheck fails.
08:47:46 <LindaWang> Especially for healthcheck, we could check if OPNFV installers reach milestones
08:49:25 <ollivier> Yes. I listed that points on my OPNFV report I sent last year. I would prefer to first publish xtesting but updating releng jobs will be an hot topic too.
08:49:56 <ollivier> depo: I will send the report to you and Cristina after the meeting.
08:50:08 <depo> thank you
08:50:19 <ollivier> #link https://build.opnfv.org/ci/view/functest/
08:50:26 <ollivier> Most of jobs are N/A.
08:50:51 <ollivier> Project Jobs - Branch: master should only list the parents.
08:51:23 <LindaWang> when could we publish xtesting? after moving push_results and get_version to TestCase is enough?
08:51:30 <ollivier> ~10 links should be enough here.
08:51:57 <LindaWang> what do the parents jobs mean here?
08:52:18 <ollivier> we will be close. As soon as the patch is merged. I will sync my local repo and I could check if it's ok.
08:52:19 <ollivier> functest-docker-master
08:52:46 <ollivier> functest-components-docker-build-amd64-master is run inside the multijob job.
08:53:28 <LindaWang> master will include baremetal and virtual deployments
08:53:28 <ollivier> I do discuss with Trevor about that because he proposed a change to list all of them (I did the opposite :))
08:54:16 <ollivier> Yes. But we shouldn't list ARM as an arch supported by Compass.
08:55:18 <ollivier> It's directly related to the releng job which relies on templates. Maybe it's not so trivial.
08:55:20 <LindaWang> As i know, Compass is working on ARM deployment nowdays.
08:56:09 <ollivier> But I'm fine to list arm if supported. From the time being only fuel is supporting ARM then N/A is useless on dashboard.
08:56:26 <ollivier> #topic AoB
08:56:58 <ollivier> Please keep on improving the code even if the testcase works :)
08:57:05 <ollivier> (by covering it, or by fixing pylint issues or by adding python3 support)
08:57:20 <LindaWang> sure
08:57:51 <LindaWang> i asked Valentin about cloudify_ims, it seems offline is impossible.
08:58:04 <ollivier> Again I'm giving a training course this week. I will read any email/review in the evening.
08:58:35 <LindaWang> got it.
08:58:35 <ollivier> Yes I was afraid of that. we could if we setup an apt repository in jumphost via a new container.
08:59:25 <LindaWang> each module has to install lots of packages.
08:59:49 <LindaWang> not only cloudify manager
08:59:58 <ollivier> Yes. If offline becomes mandatory for vnfs, we could consider that.
09:00:14 <ollivier> I think we should first fix all vnfs :)
09:00:43 <ollivier> We are time this week :)
09:01:22 <LindaWang> Good.
09:01:24 <ollivier> Thank you very much. Have a good week.
09:01:31 <ollivier> #endmeeting