07:59:33 <ollivier> #startmeeting Functest weekly meeting 27 Feb. 2018
07:59:33 <collabot`> Meeting started Tue Feb 27 07:59:33 2018 UTC.  The chair is ollivier. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:59:33 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:59:33 <collabot`> The meeting name has been set to 'functest_weekly_meeting_27_feb__2018'
07:59:42 <ollivier> #info Cédric Ollivier
08:00:29 <LindaWang> #info Linda Wang
08:00:36 <jose_lausuch> #info Jose Lausuch
08:02:35 <depo> #info Delia Popescu
08:02:45 <ollivier> Juha is on holidays. Serena may be on holidays as well.
08:02:56 <ollivier> I think we could start :)
08:03:42 <ollivier> #topic Action point follow-up
08:03:55 <ollivier> #info the full synchonization between functest and functest-xtesting has just been done
08:04:27 <ollivier> I am deleting all OpenStack related files in functest-xtesting
08:04:40 <ollivier> It works very well with samples
08:05:18 <ollivier> #info several bugs have been opened vs APEX
08:05:27 <ollivier> #link https://jira.opnfv.org/browse/APEX-564
08:05:36 <ollivier> #link https://jira.opnfv.org/browse/APEX-570
08:05:44 <ollivier> #link https://jira.opnfv.org/browse/APEX-571
08:06:24 <ollivier> They remain internet connectivity issues when testing cloudify based testcases (ims + vrouter).
08:07:15 <ollivier> I think a new Compass run is pending. Let's see the results. Others are not running or are not passing the first testcases.
08:07:26 <LindaWang> is it about installing packages on cloudify_manage?
08:08:00 <ollivier> Yes. We should check if 8.8.8.8 is badly set or simply if a firewall blocks internet traffic
08:08:07 <LindaWang> #link https://build.opnfv.org/ci/view/functest/job/functest-apex-baremetal-daily-master/810/console
08:08:16 <ollivier> (or simply related to a bug in APEX)
08:08:28 <LindaWang> what does it  mean "Cannot find a valid baseurl for repo: base/7/x86_64"
08:08:31 <ollivier> They work very well in Lannion
08:08:50 <ollivier> yum can't update its cache (network issue)
08:09:18 <LindaWang> oh.
08:09:26 <ollivier> juju_epc can't work as APEX doesn't set OS_REGION_NAME as expected
08:09:41 <ollivier> (discussed with Tim by irc)
08:10:23 <ollivier> Let's see if they work vs Compass https://build.opnfv.org/ci/view/functest/job/functest-compass-baremetal-daily-master/1807/console
08:10:49 <LindaWang> ok, i will help look at it
08:11:55 <ollivier> If keystone domains are default, all vnfs should work.
08:12:37 <ollivier> #info only refstack_defcore(under investigation) has to fixed in Orange POD
08:13:15 <ollivier> not sure, it's related to refstack because the same tests fail in tempest full.
08:13:39 <LindaWang> the network related tests?
08:14:04 <ollivier> I will give you the new list (4 tests failed)
08:14:59 <ollivier> I think one is about volume testing. The others are about network resource removals
08:16:20 <ollivier> #topic releng
08:16:37 <ollivier> #info the new proposal rewriting our Jenkins jobs has been merged then reverted
08:16:45 <ollivier> #link https://gerrit.opnfv.org/gerrit/#/c/51853/
08:16:49 <LindaWang> it seems i have missed something.
08:16:53 <LindaWang> it failed to work?
08:17:03 <ollivier> which?
08:17:16 <ollivier> we must ensure that everybody agrees with losing Jenkins jobs history
08:17:19 <LindaWang> the jenkins job refactor
08:17:42 <LindaWang> you mean it will remove all the jjb history?
08:18:20 <jose_lausuch> didn't the proposal work?
08:18:29 <ollivier> They were a merge conflict which has to be solved.
08:18:38 <ollivier> depo: be free to complete
08:18:47 <depo> you remove the jobs from Jenkins, so yes, the record of the jobs, but not the log fromn artifacts
08:19:02 <ollivier> yes
08:19:13 <depo> and yes, t=when you change the job as multijob, jenkins cannot convert it
08:19:25 <depo> the previous must be deleted
08:20:07 <ollivier> I fully agree to merge it. I will ask to David and Tim if they still agree (we already discussed in Portland).
08:20:57 <LindaWang> ok, i agree to it, too
08:21:00 <depo> then we have to coordinate and remove the jobs..I think is 79 jobs
08:21:10 <depo> then remerge the commit
08:21:13 <jose_lausuch> ok to me too
08:21:23 <ollivier> doctor has blocked gating and we should continue on that.
08:21:47 <ollivier> thank you all.
08:22:11 <ollivier> depo: yes the process seems good. Thank you
08:22:34 <depo> any time
08:22:37 <ollivier> #action Cédric ask to David and Tim if they agree with losing jenkins jobs history.
08:22:59 <ollivier> #topic code improvement
08:23:09 <ollivier> #info our code has been rated at 9.61/10 (be free to fix the remaining errors)
08:23:25 <ollivier> #info API has been cleant and now only core and utils modules could be reused by third-parties as they are
08:23:40 <ollivier> #info orchestra testcases now rely on SNAPS instead of OpenStack utils (even if they still don't work)
08:23:49 <ollivier> #info OpenStack utils have been removed from Functest (several methods have been copied to SDNVPN and SFC)
08:24:03 <ollivier> #ifno Functest utils were cleant (3 functions are kept unchanged)
08:24:11 <ollivier> #link https://gerrit.opnfv.org/gerrit/#/c/52685/
08:24:20 <ollivier> #link https://jira.opnfv.org/browse/FUNCTEST-938
08:24:31 <ollivier> All ci and utils modules should be more covered
08:24:47 <ollivier> I think the topic raised by Manuel is now closed
08:24:55 <jose_lausuch> very good work
08:25:00 <LindaWang> great
08:26:12 <ollivier> execute_command_raise(), execute_command() and get_parameter_from_yaml() seem very useful and we must cover/document them
08:27:13 <ollivier> such as core modules.
08:28:03 <ollivier> Now our code could be mainly improved in vnf (lots of duplicated code + pylint errors)
08:28:47 <ollivier> #topic functest
08:29:05 <ollivier> #info a new testcase integrating patrole should be published soon
08:29:27 <ollivier> I think I will propose a new container simply because it seems patrole is not mature enough for gating
08:30:00 <ollivier> It's well integrated as a new tempest plugin.
08:30:26 <ollivier> I think we could add tempest in Functest framework as vnf. We may refactor a little bit TempestCommon
08:31:04 <ollivier> It would be great to ease integrating any tempest pluging (neutron trunk, patrole) following the new tempest design
08:31:33 <ollivier> https://docs.openstack.org/tempest/latest/plugin-registry.html
08:32:35 <ollivier> I think it's more or less the case but we may document that.
08:32:55 <serena-zte> Great proposal, totally agree with it
08:34:10 <ollivier> yes. Let's go for that. 99% has already been done.
08:34:46 <ollivier> #info the new patchset on refstack has been published
08:35:36 <ollivier> LindaWang: sorry I could have waited you for the review but I failed regarding your holidays.
08:35:53 <LindaWang> i am fine with the patch.
08:35:58 <LindaWang> it is perfect
08:35:59 <ollivier> defcore.txt is simply downloaded instead of being hosted in tree.
08:36:14 <ollivier> great news
08:36:41 <LindaWang> but one issue i just remember
08:36:43 <ollivier> We could have considered reusing rally for running the selected patch. It would have been simpler.
08:37:00 <ollivier> ...  the selected tests ...
08:37:02 <LindaWang> we commented one sub test case in defcore.txt
08:37:36 <ollivier> yes I saw it but we could use the blacklist process in this case.
08:38:00 <LindaWang> it is about volume issue, i think it could be fixed.
08:38:13 <LindaWang> i will fix that
08:38:28 <ollivier> That's the best way.
08:38:41 <LindaWang> reusing rally to run defcore seems fine, but need to test it locally before publishing.
08:39:03 <ollivier> great. Now we are publishing the html report for any tempest run.
08:39:29 <ollivier> It would ease reading the refstack output as well.
08:39:37 <LindaWang> where could i see the report? have not noticed that yet.
08:40:14 <LindaWang> this one: http://artifacts.opnfv.org/logs/functest/lf-pod1/2018-02-27_04-53-42/tempest/tempest-report.html
08:40:41 <ollivier> It was done last week https://jira.opnfv.org/browse/FUNCTEST-934
08:41:10 <ollivier> https://gerrit.opnfv.org/gerrit/#/c/52311/
08:42:10 <LindaWang> it would be good if a report could be done for refstack, too
08:43:11 <ollivier> yes. Reusing rally will ease that and avoid an additional fork (running via refstack-client).
08:43:32 <ollivier> #info Dovetail still calls our functest binary
08:44:02 <ollivier> LindaWang: are you ok to update refstack?
08:44:35 <LindaWang> i will test it locally if it works, and let you know, ok?
08:44:44 <ollivier> We may be careful as Docker runs run_tests and dovetail still call functest pcmd
08:44:48 <ollivier> LindaWang: sure.
08:45:34 <ollivier> It may raise side effects and multiply issues. I think we should help Dovetail to update the entry points.
08:45:35 <LindaWang> i have told Dovetail team to use "run_tests" in next release
08:46:00 <ollivier> They are working on E for the next release?
08:46:25 <ollivier> or master? It's unclear
08:46:29 <LindaWang> Dovetail master is using our E now
08:46:32 <serena-zte> E
08:46:51 <ollivier> ok. Then we can modify cli modules without raising any issue in Dovetail
08:46:59 <serena-zte> Dovetail is always one release behind
08:49:00 <ollivier> Should we keep maintaining cli modules? It's redundant regarding ci modules (run_tests) and behaviors differ (eg ping)
08:49:57 <LindaWang> for the time being, api is still depending on them
08:50:26 <ollivier> true. As far as I remerber it's just about refactoring (inheritance)
08:50:44 <LindaWang> exactly
08:51:12 <ollivier> There is no rush about that but we shoud avoid duplicating tasks.
08:51:19 <serena-zte> After spliting the container, the current cli can not meet our need
08:52:14 <LindaWang> serena-zte:  why is that?
08:52:42 <serena-zte> one container one actually useful cli
08:53:25 <ollivier> it could be as generic as run_tests. Simply parser any yaml file to run the related testcases.
08:53:52 <serena-zte> it would be great if we can provide a kind cli to auto run a test, including pull image, healthcheck and run the test
08:54:08 <serena-zte> just my opinion
08:54:09 <ollivier> + download
08:54:19 <LindaWang> you mean other cli , like `functest openstack ...` could be deprecated?
08:54:46 <serena-zte> no they are still needed
08:54:58 <serena-zte> just the test running part is out-of-date
08:55:09 <ollivier> why not. But executing docker containers is very simple. It would be a kind of docker container catalog
08:55:52 <serena-zte> leveraging functest-core to control all the test running
08:56:41 <serena-zte> so the user only need to manual download and start functest-core(or other container), then use cli to run the test
08:58:26 <ollivier> cli would mainly replace https://wiki.opnfv.org/pages/viewpage.action?pageId=13211751
08:58:31 <serena-zte> I think this kind of cli is more useful than the current one
08:58:59 <serena-zte> ollivier, yes exactly
08:59:32 <serena-zte> so many manual work could be replaced by cli
08:59:53 <serena-zte> or, we can provide pip package, let the user install it and using it
09:00:13 <ollivier> yes. that's already on planning
09:00:33 <serena-zte> it won't be necessary to be put in functest-xx container
09:00:35 <ollivier> We should first release xtesting, then snaps :), then functest
09:00:46 <ollivier> agree
09:01:38 <serena-zte> I have already think about it for a long time, cli-driven-docker-testing
09:01:41 <ollivier> Or here we could create a complete new package to ease calling the docker containers.
09:02:17 <serena-zte> exactly, haha
09:02:20 <ollivier> I was think about publishing functest as it is on pup.
09:02:44 <ollivier> I was thinkingabout publishing functest asis on pip
09:03:10 <ollivier> we have to keep discussing on that. Just few words on kubernetes
09:03:33 <ollivier> #info functest-kubernetes
09:03:36 <ollivier> #undo
09:03:36 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1cfc950>
09:03:39 <ollivier> #topic functest-kubernetes
09:03:51 <ollivier> #info the second Kubernetes testcase is still under review
09:03:53 <serena-zte> okey, let's discuss it later
09:03:58 <ollivier> #link https://gerrit.opnfv.org/gerrit/51635
09:04:21 <ollivier> #info first unit tests are proposed as review
09:04:29 <ollivier> #link https://gerrit.opnfv.org/gerrit/#/c/52337/
09:04:45 <ollivier> We have to check if we could run them vs Joid, Compass or XCI
09:04:58 <ollivier> (Compass and XCI were not ready)
09:05:27 <LindaWang> i have triggered a new container built job now: https://build.opnfv.org/ci/job/functest-kubernetes-docker-build-push-master/
09:06:29 <LindaWang> the container was a bit old: https://build.opnfv.org/ci/view/functest/job/functest-compass-virtual-daily-master/3127/console
09:06:47 <ollivier> ok from a functest pov.
09:07:17 <ollivier> But is there an installer which is ready?
09:08:01 <LindaWang> have not checked that in Jenkins yet
09:08:32 <LindaWang> k8s tests have not run successfully on compass as far
09:08:55 <ollivier> ok
09:08:57 <ollivier> [functest-joid-baremetal-daily-master] $ /bin/bash /tmp/jenkins2015838366042836461.sh <13>Feb 25 15:47:34 fetch_k8_conf.info: Fetching admin.conf file... /tmp/jenkins2015838366042836461.sh: line 61: installer: unbound variable
09:09:24 <ollivier> #topic AoB
09:10:01 <ollivier> Additional topics ?
09:10:27 <serena-zte> who will go to ons?
09:10:51 <ollivier> I am preparing the last details. I think I will be in LA
09:12:09 <ollivier> we have to organize something there :)
09:12:28 <serena-zte> agree
09:12:40 <serena-zte> since OPNFV summit is cancelled
09:13:08 <ollivier> It replaced the former summits.
09:13:14 <ollivier> #endmeeting