#opnfv-functest: Functest weekly meeting 10 Apr. 2018

Meeting started by ollivier at 08:01:44 UTC (full logs).

Meeting summary

    1. Cédric Ollivier (ollivier, 08:01:52)
    2. SerenaFeng (serena-zte, 08:02:02)
    3. Juha Kosonen (juhak, 08:02:07)
    4. Viktor Tikkanen (viktor_t, 08:02:33)
    5. Linda Wang (LindaWang, 08:02:51)
    6. Delia Popescu (depo, 08:03:44)

  1. Action point follow-up (ollivier, 08:04:00)
    1. Functest Fraser containers are successfully built (jjobs are updated too) (ollivier, 08:04:22)
    2. https://build.opnfv.org/ci/view/functest/job/functest-daisy-baremetal-daily-fraser/1/console (ollivier, 08:04:38)
    3. opnfv/functest-kubernetes was split into 4 containers (core, healthcheck, smoke, features) (ollivier, 08:05:05)
    4. stor4vnf and clover are now hosted by opnfv/functest-kubernetes-features (ollivier, 08:05:17)
    5. https://jira.opnfv.org/browse/FUNCTEST-904 (ollivier, 08:06:25)
    6. https://jira.opnfv.org/browse/FUNCTEST-905 (ollivier, 08:06:32)
    7. https://jira.opnfv.org/browse/FUNCTEST-952 (ollivier, 08:06:39)
    8. https://jira.opnfv.org/browse/FUNCTEST-943 (ollivier, 08:06:46)

  2. functest (ollivier, 08:08:22)
    1. vnf testcases are now enabled in odl nofeature scenarios (ollivier, 08:08:32)
    2. https://build.opnfv.org/ci/view/functest/job/functest-daisy-baremetal-daily-fraser/1/console (ollivier, 08:08:42)
    3. https://gerrit.opnfv.org/gerrit/#/c/49071/ (ollivier, 08:10:51)
    4. Gnocchi metric service can be now verified by Rally (ollivier, 08:11:14)
    5. https://review.openstack.org/532551 (ollivier, 08:11:22)
    6. https://review.openstack.org/#/q/owner:juha.kosonen%2540nokia.com+status:merged (ollivier, 08:11:29)
    7. one snaps_smoke subtest seems buggy: (ollivier, 08:21:14)
    8. https://jira.opnfv.org/browse/SNAPS-298 (ollivier, 08:21:28)
    9. https://jira.opnfv.org/browse/SNAPS-299 (ollivier, 08:21:41)
    10. https://jira.opnfv.org/browse/SNAPS-299 (ollivier, 08:21:46)
    11. https://gerrit.opnfv.org/gerrit/#/c/53685/ (ollivier, 08:24:36)
    12. https://gerrit.opnfv.org/gerrit/#/c/53685/2/snaps/openstack/tests/create_router_tests.py (ollivier, 08:25:33)
    13. tempest 17.0.0 has a bug about volume client v2/v3, which also affects volume tests in patrole and refstack (ollivier, 08:26:47)
    14. https://jira.opnfv.org/browse/FUNCTEST-954 (ollivier, 08:27:07)
    15. ACTION: LindaWang to try to update tempest in OpenStack requirements (ollivier, 08:31:02)
    16. ACTION: ollivier to synchronize all OPNFV projects if updated (ollivier, 08:31:18)

  3. functest-kubernetes (ollivier, 08:40:04)
    1. Konrad is still converting his presentation to markdown (ollivier, 08:40:17)
    2. Kubernetes testcases have to be documentated (as part of classical Functest guides?) (ollivier, 08:40:33)
    3. https://jira.opnfv.org/browse/FUNCTEST-951 (ollivier, 08:40:51)
    4. several unit tests have been added to increase coverage (ollivier, 08:45:07)

  4. documentation (ollivier, 08:45:20)
    1. all rst files are now checked via doc8 (ollivier, 08:45:30)
    2. Release notes have been updated (results, links and refs must be modified to Fraser) (ollivier, 08:45:41)
    3. one patch updating User Guide is under review (ollivier, 08:46:04)
    4. https://gerrit.opnfv.org/gerrit/#/c/54367/ (ollivier, 08:46:16)
    5. All OpenStack testcases are passing on Orange ONAP Openlab (last night). (ollivier, 08:49:24)

  5. AoB (ollivier, 08:50:37)
    1. https://jira.opnfv.org/browse/SNAPS-295 (ollivier, 08:51:17)


Meeting ended at 08:57:10 UTC (full logs).

Action items

  1. LindaWang to try to update tempest in OpenStack requirements
  2. ollivier to synchronize all OPNFV projects if updated


Action items, by person

  1. LindaWang
    1. LindaWang to try to update tempest in OpenStack requirements
  2. ollivier
    1. ollivier to synchronize all OPNFV projects if updated


People present (lines said)

  1. ollivier (81)
  2. LindaWang (14)
  3. juhak (9)
  4. collabot` (3)
  5. serena-zte (1)
  6. viktor_t (1)
  7. depo (1)


Generated by MeetBot 0.1.4.