#opnfv-functest: Functest weekly meeting 4 Sept. 2018
Meeting started by ollivier at 08:00:43 UTC
(full logs).
Meeting summary
- 
  - Cédric Ollivier (ollivier,
    08:00:49)
 
  - Delia Popescu (delia_,
    08:00:59)
 
  - Juha Kosonen (juhak,
    08:01:05)
 
  - Viktor Tikkanen (viktor_t,
    08:01:11)
 
 
- Action point follow-up (ollivier, 08:02:08)
  - https://jira.opnfv.org/browse/FUNCTEST-1008
    (ollivier,
    08:02:21)
 
  - https://jira.opnfv.org/browse/FUNCTEST-1009
    (ollivier,
    08:02:29)
 
  - https://gerrit.opnfv.org/gerrit/61531
    (ollivier,
    08:05:22)
 
  - https://gerrit.opnfv.org/gerrit/61529
    (ollivier,
    08:05:32)
 
  - https://gerrit.opnfv.org/gerrit/61669
    (ollivier,
    08:05:47)
 
 
- Xtesting (ollivier, 08:07:51)
  - we should allow overriding the default runner
    (more or less linked to OpenStack) (ollivier,
    08:08:13)
 
  - all patches about new entry points (stevedore)
    has been pushed in OPNFV Feature trees. (ollivier,
    08:12:19)
 
 
- Functest-kubernetes (ollivier, 08:13:41)
  - updated to Alpine 3.8 and Kubernetes
    v1.11.2 (ollivier,
    08:13:53)
 
  - the docker image sizes have been hugely
    decreased (ollivier,
    08:14:01)
 
  - new jjbs have been proposed (ollivier,
    08:14:10)
 
 
- Functest (ollivier, 08:18:42)
  - our containers were updated to Alpine 3.8 (+few
    download optimizations) (ollivier,
    08:19:11)
 
  - barbican: few configs are missing compared to
    the current gates (it requires a dedicated Python class)
    (ollivier,
    08:20:18)
 
  - https://github.com/openstack/barbican-tempest-plugin/blob/master/tools/pre_test_hook.sh
    (ollivier,
    08:20:27)
 
  - tempest: all scenario configs are missing
    (img_dir, img_file and img_properties) (ollivier,
    08:25:38)
 
  - https://artifacts.opnfv.org/logs/functest/lf-pod2/2018-09-03_13-16-44/barbican/tempest.conf
    (ollivier,
    08:26:43)
 
  - rally raised conflicts once when creating
    mandatory roles (ResellerAdmin) (ollivier,
    08:28:15)
 
  - juju_epc currently raises conflicts when
    discovering cidr (if parallel testing only). (ollivier,
    08:32:31)
 
  - possible remaining resources (ollivier,
    08:33:15)
 
  - David agreed to create branches before the
    right milestones. SFC should apply the same rules. (ollivier,
    08:38:08)
 
  - tempest_full and tempest_scenario should still
    be enabled in daily gates (ollivier,
    08:43:29)
 
  - : we are asked to split download.sh (per arch
    and per tiers) (ollivier,
    08:43:58)
 
  - ACTION: all we do
    update docs and configs before releasing (ollivier,
    08:44:35)
 
  - https://git.opnfv.org/functest/tree/functest/opnfv_tests/openstack/shaker/shaker.py#n84
    (ollivier,
    08:50:47)
 
  - https://build.opnfv.org/ci/view/functest/job/functest-fuel-baremetal-daily-master/441/console
    (delia_,
    08:52:02)
 
 
- AoB (ollivier, 08:55:03)
 
Meeting ended at 08:59:16 UTC
(full logs).
Action items
  - all we do update docs and configs before releasing
 
People present (lines said)
  - ollivier (88)
 
  - delia_ (27)
 
  - juhak (4)
 
  - collabot (3)
 
  - viktor_t (2)
 
  - OPNFV-Gerrit-Bot (1)
 
Generated by MeetBot 0.1.4.