14:01:07 <dlenrow> #startmeeting OPNFV TSC
14:01:07 <collabot`> Meeting started Tue Oct 21 14:01:07 2014 UTC.  The chair is dlenrow. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:07 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:18 <dlenrow> #info Dave Lenrow
14:01:32 <ChrisPriceAB> #info Chris Price
14:02:29 <B_Smith_> #info Brian Smith
14:04:12 <Ashiq_docomo> #info Ashiq Khan
14:04:21 <Wenjing_> #info Wenjing Chu
14:04:26 <bin_> Bin Hu
14:04:32 <morgan_orange> hello
14:04:39 <arnaud_orange> morning
14:04:48 <bin_> #info Bin Hu
14:04:52 <ChrisPriceAB> HI Guys, and good morning/afternoon
14:05:04 <pals> Hello
14:05:08 <ChrisPriceAB> Please for TSC members use the # info tag to announce yourself
14:05:51 <dlenrow> #info reminder: all attendance (to establish quorum) and votes will be done on IRC. IRC use is mandatory to attend.
14:06:21 <pals> #info pals
14:07:02 <dlenrow> #info TSC members should show their presence by typing "#info member name" on IRC
14:07:39 <frankbrockners> #info Frank joined
14:07:59 <ulik> #info Uli joined
14:08:22 <ChrisPriceAB> #info Tom Nadeau via audio only
14:10:08 <frankbrockners> #info I'll need to leave by 8.30am PT; in case we run the full 2hrs, Palani will fill in for me
14:10:21 <dlenrow> #info Please note the antitrust and other warngings
14:10:25 <dlenrow> #link https://www.opnfv.org/about/bylaws-and-policies/antitrust-policy-compliance-checklist
14:10:51 <dlenrow> #info chris announces and begins recording of this meeting
14:11:04 <dlenrow> #topic approve last week's minutes
14:11:14 <dlenrow> #info approved by lack of dissent
14:11:25 <dlenrow> #topic project proposals
14:14:40 <dlenrow> #info first project proposal introduced by Uli
14:14:43 <ulik> #link https://wiki.opnfv.org/continuous_integration_ci
14:14:53 <dlenrow> thanks Uli
14:19:29 <dlenrow> #info Uli volunteers that this is very long and my be too much info for proposal, asks for feedback
14:20:05 <dlenrow> #info dlenrow suggests we try to keep project proposal to scope and generality and move deep design/description to project work product.
14:20:36 <dlenrow> #info CP points out that some of content describes things that will be provided by LF, and thus not part of CI project
14:23:43 <dlenrow> #info Policy for branching may want to be per-project. Is in-scope for TSC development steering, but out of scope for CI project
14:25:08 <bryan_att> #info Bryan Sullivan
14:26:20 <dlenrow> #action Begin work on a draft development process draft. Frank, Palani, CP
14:26:29 <TapioT> I would also help with the CI project. I cannot unmute myself
14:26:41 <TapioT> Sorry, development processs
14:27:01 * ChrisPriceAB Tapio I will unmute you centrally
14:27:09 <Thinh_> #info
14:27:22 <dlenrow> #action Schedule a call regarding development process  Palani
14:30:57 <dlenrow> #info Palani points out that  use-case subproject has identified some basic use cases and traffic patterns to test. Can provide basis for canonical/infra VNFs in OPNFV
14:32:14 <dlenrow> #info Uli describes possible need for developer smoke test that is less involved than larger system/release test coverage.
14:36:28 <dlenrow> #info dlenrow reminds that any gap between CI coverage and release coverage will lead to pain. Need to make as small as possible
14:38:40 <dlenrow> #info Discussion about where glue code should live before or instead of pushing to upstream projects.
14:40:44 <dlenrow> #info development process for OPNFV should include guidance for how we structure code that needs to build on upstream projects
14:43:13 <dlenrow> #info frank suggests subprojects within development process to address different (local integration, test, global integration) needs
14:44:30 <dlenrow> #info frank asks for follow up meeting this week on this topic
14:44:48 <dlenrow> #action Uli to schedule meeting to discuss dev process around upstream co-existence
14:45:19 <dlenrow> #info Send suggestions to email list to kick off upstream dev process discussion
14:46:40 <dlenrow> #info dlenrow we need to discuss assumption that we will continuously pull top of dev tree for upstreams
14:48:53 <dlenrow> #info palani suggests we need to plan our releases (stable, latest, etc.) within OPNFV
14:50:19 <dlenrow> #info agree to follow up in breakout meetings and close discussion of CI project in order to get time on other proposals
14:50:52 <dlenrow> #topic Testing Project Proposals
14:52:58 <dlenrow> #info there is a thursday AM meeting weekly to discuss test project.
14:53:04 <bryan_att> #info re the test meeting - send a calendar invite to the list - that ensures it gets on our calendars best
14:54:04 <dlenrow> #action Pranav Mehta to put test meeting info on Wiki
14:54:18 <dlenrow> #info agree to discuss test project after groups next weekly meeting
14:54:59 <dlenrow> #parviz suggests that we prioritize discussions of work items for weekly agenda.
14:57:14 <dlenrow> #info parviz suggests that we prioritize discussions of work items for weekly agenda.
15:00:03 <dlenrow> #topic packaging
15:00:19 <dlenrow> #info CP asks which automation tool (chef, puppet, etc)?
15:01:11 <dlenrow> #info Frank suggests this "continuous deployment" is possibly a standalone project scope
15:01:37 <dlenrow> #info CP points out tradeoffs between choosing a packaging tool versus allowing latitude for selection
15:03:00 <dlenrow> #info CP suggests we add packaging tooling to Uli's call this week
15:04:23 <Ashiq_docomo> https://wiki.opnfv.org/requirements_projects/resource_management
15:04:34 <dlenrow> #topic resource management project
15:04:47 <dlenrow> #link https://wiki.opnfv.org/requirements_projects/resource_management
15:06:10 <dlenrow> #info Ashiq leads discussion on proposal doc
15:07:58 <dlenrow> #info Ashiq points out that this functionality may not need to live permanently within OPNFV. Probably moves upstream.
15:10:13 <dlenrow> #info summary calendar scheduling for compute, storage, and network resources by exposing NBIs from OpenStack
15:14:45 <dlenrow> #info Project Proposal: List of contributors & Committers will remain open until the project approval vote by TSC.
15:16:58 <dlenrow> #info Clarification on founding committers. CP restates that these must be long-term, planning to be a significant participant.
15:17:34 <dlenrow> #info Parviz asks what is relationship/requirement to cite e.g. ETSI documents in projects/proposals
15:18:28 <dlenrow> #info Ashiq states that reference in proposal is for informational purposes and cites an existing NFV doc in support
15:19:16 <Ashiq_docomo> https://wiki.opnfv.org/requirements_projects/doctor_fault_mangement_and_maintenance
15:19:42 <dlenrow> #topic Doctor Project - fault management and maintenance
15:19:52 <dlenrow> #link https://wiki.opnfv.org/requirements_projects/doctor_fault_mangement_and_maintenance
15:20:38 <dlenrow> #info Ashiq notes that this describes functionality missing from OpenStack
15:21:58 <dlenrow> #info diagrams show block diagram of root cause analysis and mapping faults to affected users/VMs, etc.
15:22:48 <dlenrow> #info detect, inform affected user/tenant, instructions on if/how to recover VMs
15:25:42 <dlenrow> #info Palani asks when/where do we discuss details of individual faults and responses.
15:29:05 <bryan_att> #info Project proposal "Copper (Virtual Infrastructure Deployment Policies)" is at https://wiki.opnfv.org/requirements_projects/virtual_infrastructure_deployment_policies
15:29:12 <dlenrow> #action dlenrow to schedule call this week to discuss S/R  planning
15:29:39 <dlenrow> #topic virtual infra deployment project
15:29:49 <dlenrow> #link https://wiki.opnfv.org/requirements_projects/virtual_infrastructure_deployment_policies
15:31:32 <dlenrow> #info Bryan introduces policy as means to define/deploy VNFs
15:32:41 <dlenrow> #info propose that we start from use case requirements and propose policy means to achieve
15:33:48 <dlenrow> #info seeking contributors and committers
15:38:20 <dlenrow> #info Question: Is this just a requrements. Project?
15:38:41 <dlenrow> #info discussion about relationship between project proposals, requirements, implementation
15:39:05 <dlenrow> #info dlenrow points out that project scope should be much bigger than a single release. Release is a subset of scope in something larger.
15:39:29 <bryan_att> #info IPv6-enabled Vanilla OPNFV project proposal is at https://wiki.opnfv.org/ipv6-enabled_vanilla_opnfv
15:39:40 <dlenrow> #topic Recurring weekly calls on general technical content
15:40:32 <bryan_att> #info it would be great for us to coordinate project-specific calls on the wiki
15:40:34 <dlenrow> #link https://wiki.opnfv.org/ipv6-enabled_vanilla_opnfv
15:40:56 <Ashiq_docomo> #info may I suggest to upload requirement project proposals under the /requirement_projects
15:41:13 <dlenrow> #info CP asks for volunteer to insure that all recurring meetings are maintained on wiki
15:41:50 <dlenrow> #action bin to organize wiki meeting list
15:43:13 <dlenrow> #info posting project proposal to wiki and sending email announcing to TSC officially starts the two week public review period for a proposal
15:44:18 <dlenrow> #action CP to call meetign and propose project structure back to TSC
15:44:25 <dlenrow> #topi release naming convention
15:44:37 <dlenrow> #topic release naming convention
15:45:35 <dlenrow> #info palani say Ray has created poll to gather feedback for release naming themes.
15:46:10 <dlenrow> #action Ray will email list to announce URL and open the voting window. Plan to post tomorrow and leave open for a week.
15:49:18 <dlenrow> #vote  to start release name theme voting with the five candidates: cities, gemstones, rivers, nobel prize winners, mountains?
15:49:30 <TapioT> #vote +1
15:49:51 <dlenrow> #startvote  to start release name theme voting with the five candidates: cities, gemstones, rivers, nobel prize winners, mountains?
15:49:51 <frankbrockners> #vote +1
15:49:53 <Wenjing_> #vote +1
15:49:54 <bryan_att> #vote +1
15:49:54 <ulik> #vote +1
15:49:56 <pals> #vote +1
15:50:00 <MikeBugenhagen> #vote +1
15:50:04 <dlenrow> #vote +1
15:50:06 <Ashiq_docomo> #vote +1
15:50:07 <ChrisPriceAB> #vote +1
15:50:11 <morgan_orange> #vote+1
15:50:32 <dlenrow> #agreed to start release name theme voting with the five candidates: cities, gemstones, rivers, nobel prize winners, mountains?
15:51:39 <dlenrow> #info Vote is open to everyone. Not limited to TSC members or companies, etc.
15:51:49 <dlenrow> #topic Open Agenda
15:52:36 <dlenrow> #info Ray asks about need for GoToMeeting setup/accounts for other meetings and recurring calls. Currently cannot run simultaneous meetings due to license.
15:53:24 <Thinh_> #topic: liaison with ETSI NFV status?
15:53:44 <dlenrow> #info proposes getting more accounts and delegating admin controls to community.
15:53:59 <dlenrow> #info CP suggests in short term we avoid concurrent meetings.
15:55:15 <dlenrow> #info try not to use corporate conferencing resources, invitations, etc. to prevent apparent corporate bias
15:56:00 <dlenrow> #info Thinh_: Thanks for helping with minutes.
15:56:49 <dlenrow> #info Asks status of liaison. Points out we have opportunity to interact at NFV 8 and should plan for same
15:57:29 <dlenrow> #info CP states we don't have a SPOC for liaison yet.
15:57:55 <dlenrow> #info noted that board level liaising probably also going on. Need to sync
15:58:16 <dlenrow> #info asks what is our official dependency on ETSI NFV SIG? Need to clarify?
15:58:43 <dlenrow> #action CP to put liaison discussion on agenda for next week
15:59:43 <dlenrow> #info Daylight savings change in Europe coming up. Europe go one hour earlier on last Sunday October, one week before USA. Don't be fooled!
16:00:02 <dlenrow> #endmeeting