14:01:44 <ChrisPriceAB> #startmeeting OPNFV TSC Meeting
14:01:44 <collabot> Meeting started Tue Oct 28 14:01:44 2014 UTC.  The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:44 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:02:00 <ashiq_> #info Ashiq Khan
14:02:03 <ChrisPriceAB> #topic TSC members roll call
14:02:25 <ChrisPriceAB> #info Chris Price
14:02:26 <dneary> Should non-members pound in?
14:02:37 <ChrisPriceAB> no just TSC represenatives, :)
14:02:39 <dneary> ChrisPriceAB, My assumption is no, since we're expected to be quiet ;-)
14:02:47 * ChrisPriceAB you should stay that way!!!!
14:02:56 * ChrisPriceAB ;)
14:02:59 <dneary> On mute. Going dark.
14:03:26 <dneary> ChrisPriceAB, Taken in the spirit it was given Chris, no worries
14:04:51 <Pranav> #in
14:04:56 <ChrisPriceAB> TSC members please pound info in on IRC
14:04:59 <ulik> #in
14:05:01 <sgordon_> #info Steve Gordon (proxy for Chris Wright)
14:05:06 <Wenjing> #info Wenjing Chu
14:05:09 <Serge_> #info Serge Manning
14:05:11 <frankbrockners> #info Frank Brockners
14:05:12 <ulik> #info Uli Kleber
14:05:17 <Pranav> #info Pranav Mehta
14:05:21 <B_Smith> #info Brian Smith
14:05:33 <Palani> #info Palani
14:08:18 <dlenrow> startmeeting OPNFV TSC
14:08:28 <collabot> dlenrow: Error: Can't start another meeting, one is in progress.
14:08:36 <dlenrow> #info dlenrow
14:09:46 <dlenrow> #topic agenda bashing
14:10:23 <dlenrow> #info CP to add to agenda: discussion of releasing FOSS vs non-FOSS VNFs
14:10:58 <ChrisPriceAB> #topic OpenStack metup in Paris.
14:12:04 <cdub> yet another reminder...there is an NFV subteam meeting in Paris, please coordinate
14:12:16 * ChrisPriceAB thanks :)
14:12:54 <ChrisPriceAB> #info NFV sub-team activities are planned in the open stack conference.
14:13:25 <dlenrow> #info discussion of ways to sync OPNFV with OpenStack NFV discussions at Paris and beyond
14:13:45 <dlenrow> #info multiple folks point out existence of NFV tracks at Paris
14:13:51 <sgordon_> #link http://kilodesignsummit.sched.org/event/b3ccf1464e335b703fc126f068142792
14:14:00 <sgordon_> #link http://kilodesignsummit.sched.org/event/aa14a2bd2a4c1afa1aa24a60c3131fcc
14:14:05 <sgordon_> #link https://wiki.openstack.org/wiki/Teams/NFV
14:14:24 <dlenrow> #info links from sgordon to Paris sessions he's aware of  above
14:14:46 <cdub> nice, thanks sgordon_
14:15:28 <dlenrow> #info Wed eve and Thurs morning are times we should join OpenStack community sessions
14:15:54 <dlenrow> #info CP proposes OPNFV pre-meeting
14:16:37 <dlenrow> #info dlenrow try to get room and send invite to list for Tues or Wed AM premeeting
14:17:15 <dlenrow> #action dlenrow get room and send invite
14:17:55 <dlenrow> #info question about remote participation in premeeting
14:18:07 <bryan_att> #info and more importantly is the meeting open to remote non registered attendance?
14:18:25 <dlenrow> #info likely etherpad and IRC only at summit.
14:19:09 <dlenrow> bryan_att: good question, may need show badge to access physical room. I'll check
14:19:44 <bryan_att> But ok to attend virtually without pre-registering?
14:19:49 <sgordon_> for the meeting rooms i am pretty sure you will find you have guest passes dlenrow
14:20:05 <sgordon_> i believe they come with the meeting room slots so you can badge visitors in
14:20:23 <dlenrow> #info we can try to get GTM working too
14:21:44 <Pranav> #help
14:21:54 <rpaik> #info should be able to use the new GTM account that we just setup if needed
14:22:02 <dlenrow> #info asks is this instead of or in addition to TSC call next tuesday
14:24:02 <dlenrow> #info clarification We will have a TSC meeting at regular time and in addititon another meeting of folks that are attending F2F
14:24:32 <dlenrow> #info both meetings will try to have common room at summit and include remote folks with all available tools (IRC, etherpad, GTM)
14:24:48 <dlenrow> #topic CI Update from Uli
14:25:46 <dlenrow> #info Uli updates that we agreed to keep project proposal short and simple. Problem statement. Push lots of detail to project work items later.
14:26:15 <dlenrow> #info Offers to show new, concise project proposal draft
14:26:41 <dlenrow> CAn somebody #link the wiki doc he's sharing?
14:27:38 <rpaik> #link https://wiki.opnfv.org/wiki/call_to_continue_ci_project_proposal
14:29:05 <dlenrow> rpaik: Thx
14:32:23 <dlenrow> #action Uli to rearrange existing doc so we he can submit and start 2 week public review period. Thursday 10/30 deadline.
14:35:19 <dlenrow> #info dlenrow asks if this is time to discuss parallel progress on CI prototyping and experimentation
14:35:39 <dlenrow> #info CP suggests we discuss on mail lists to keep agenda moving
14:36:21 <dlenrow> #info Frank points out we can build a non-official sandbox where folks can do work without waiting on official OPNFV infrastructure
14:37:08 <dlenrow> #info CP asks rpaik about LF ability to create infrastructure sandbox to allow collaboration.
14:37:26 <dlenrow> #action rpaik to inquire about lead times in LF and report to lists
14:38:52 <dlenrow> #info CP suggests we continue on the lists.
14:39:04 <dlenrow> #topic testing discussion oupdate
14:39:41 <dlenrow> #info Trevor provides update on test subgroup
14:40:12 <dlenrow> #info first weekly call started last week. Thursday 7AM Pacific is recurring time. Notes on wiiki
14:40:20 <dlenrow> #info 4 streams of work
14:41:32 <dlenrow> #info test bed infras Orange/CableLabs are drafting proposal based on studying similar communities. First cut of doc late next week
14:42:45 <dlenrow> #info HW/SW definition of the reference platform: Using what's available today. Made proposal for hosted Infra. Working on proposal.
14:43:36 <dlenrow> #info System under test HW/SW proposal based on available parts.
14:44:23 <dlenrow> #info IT Testbed Tooling Dell has made a proposal addressing CI and test interface, also proposed toolset and getting community input
14:45:27 <dlenrow> #info Use Cases: Palani/Cisco leading macro/micro benchmarking and initial use cases identified.. Proposing 4 major use cases from ETSI
14:46:14 <dlenrow> #info working from ETSI cases: virtual provider edge, Virtual PCE, CDN, home gateway.  Also identified VNF candidates
14:47:01 <dlenrow> #info Palani adds he needs to resolve policy regarding VNF targets for testing (FOSS, non-FOSS)
14:49:03 <dlenrow> #info CP asks how we structure repo/infra for each of the use cases?
14:50:16 <dlenrow> #info Virtual PCE above should have been Virtual EPC (not to be confused with virtual CPE)
14:51:10 <dlenrow> #info discussion of structuring tests/use-cases.
14:52:12 <dlenrow> #info Trevor suggests that eventually we propose to TSC
14:53:12 <dlenrow> #info Pranav suggests that use-case repo could be different from other Test infra repo
14:54:19 <dlenrow> #info Pavani has done some work towards some of these use cases and can provide some suggestions.
14:54:55 <dlenrow> #info Pavani says he's headed towards split/distributed EPC because that's how most deployments will work
14:56:02 <dlenrow> #info Parviz asks when/if TSC will be asked to approve specifics
14:57:07 <dlenrow> #info Pranav points out this is just discussion. Proposal should include this when brought for approval
14:57:47 <dlenrow> #info dlenrow reminds that project proposal is mostly about scope. Solving the specific problems in scope becomes work product of project. Need to get proposals queued for approval
14:59:07 <dlenrow> #info Bin asks about US daylight savings change. Meeting is pinned to US Pacific TZ and will follow DST rules there.
15:01:35 <dlenrow> #info dlenrow asks if there is a schedule to post the test project proposal for review. CP says no deadline yet.
15:02:14 <dlenrow> #info Palani clarafies that Use cases and test infra need to be two different projects. CP assume we'll get more than one project from
15:02:46 <dlenrow> #info Parviz 1) Do we plan to have VNFs in release 1.0
15:03:08 <dlenrow> #info CP we won't release VNFS or Mano components
15:05:14 <ChrisPriceAB> #topic simultaneous release process
15:05:55 <ChrisPriceAB> #info dlenrow states the discussion on simultaneous release was agreed to focus on the release rpocess and delegate the perifferal problems to other projects and processes to solve.
15:06:23 <ChrisPriceAB> #info the simultaneous release process is planned to fulfill a 6 month release cadence
15:06:49 <ChrisPriceAB> #info the proposal is available on the WiKi indicating dates and process.
15:07:25 <dlenrow> #topic SR process
15:08:11 <dlenrow> #info dlenrow taking outcome of SR discussion meeting and and build draft.
15:08:19 <ChrisPriceAB> #action dlenrow to upload the process to the WiKi
15:08:27 <dlenrow> #action dlenrow to post draft SR document to wiki
15:08:56 <dlenrow> #action dlenrow to post draft SR document to wiki  Thursdayt 10/30
15:09:43 <dlenrow> #topic release schedule
15:10:24 <sgordon_> #info 2015.1 ("Kilo") release: Apr 23
15:10:31 <dlenrow> #info CP reminds current board commitment is V 1.0 release March 2015. Another date we've discussed is May 2015.
15:11:03 <dlenrow> #info End of may would be after OpenStack Kilo and ODL Lithium
15:11:40 <dlenrow> #info CP asks for discussion of goals for delivering V 1.0
15:12:29 <dlenrow> #info Pranav asks if we have created table based on upstream dates that show possible release windows.
15:12:46 <dlenrow> #info CP took action last week and this is in progress.
15:14:07 <dlenrow> #info frankbrockners reminds we agreed to walk before run approach. Asks can we all agree that we do little more than pull upstreams together and show packaging and infra
15:14:29 <dlenrow> #info points out above would be fairly independent of upstream schedules?
15:15:23 <dlenrow> #info still need to pick date for "walk". frankbrockners doesn't feel we have sufficient info to pick a hard date yet
15:15:59 <dlenrow> #info Pranav wants to talk about what it means to "walk"
15:16:26 <dlenrow> #info frankbrockners suggest first release point at stable upstreams
15:17:08 <dlenrow> #info CP points out that we will have to hold patches to even walk and thus non-trivial to "walk"
15:18:40 <bryan_att> party!
15:18:55 <dlenrow> #info kernelcdub notes that we can still deliver stuff outside of SRs
15:19:18 <dlenrow> #info CP notes that dlenrow SR proposal needs to address stable updates.
15:19:44 <dlenrow> #info kernelcdub adds that we can release pieces "piecemeal"
15:20:53 <dlenrow> #info Summary on dates:  CP we can't yet define a date. BOD date hasn't been confirmed or denied by TSC. Need more info/progress
15:21:51 <dlenrow> #topic upstream community/project engagement
15:24:34 <dlenrow> NEED SOMEONE TO TAKE OVER TYPING MINUTES (Need to drop off call)
15:24:46 <dlenrow> Can somebody take over?
15:25:03 <rpaik> I can take over
15:25:08 <sgordon_> #link https://lists.opnfv.org/mailman/private/opnfv-tech-discuss/2014-October/000128.html
15:25:22 <sgordon_> #info Tapio's on list response regarding critical functionality for NFV
15:25:43 <dlenrow> rpaik, sgordon: Thanks. bye
15:25:59 <Tapio_> https://wiki.openstack.org/wiki/Teams/NFV#Development_Efforts
15:26:07 <sgordon_> #link https://wiki.openstack.org/wiki/Teams/NFV#Development_Efforts
15:26:27 <Tapio_> http://nfv.russellbryant.net/
15:26:44 <sgordon_> #info Possible Kilo requirements?: CPU pinning, large pages support, enhanced NUMA awareness, VLAN trunking to VM
15:27:11 <sgordon_> #info How can OPNFV work with upstream communities on requirements and ultimately feature roadmaps
15:28:01 <rpaik> #info Ashiq suggests having formal liasion for upstream projects
15:29:59 <rpaik> cdub suggests bringing OPNFV developer resources along with requirements to upstream projects
15:30:22 <sgordon_> #info cdub suggests bringing OPNFV developer resources along with requirements to upstream projects
15:36:18 <rpaik> #topic FOSS vs. private VNF
15:37:43 <sgordon_> #info requirements for being included in the build/ci system?
15:43:32 <cdub> We should focus _our_ effort on open source and enable vendors to plug in
15:43:39 <rpaik> #info Can look at both FOSS & proprietary VNFs.  For proprietary VNFs, we need to consider issues around licensing, performanace data, etc.
15:44:49 <cdub> If performance testing requires special integration to use vrndor specifix APIs, vendor can do that work
15:47:25 <ChrisPriceAB> #topic release naming poll
15:47:44 <ChrisPriceAB> #info the poll has been open for a while, will close at the end of this week.
15:48:01 <ChrisPriceAB> #info the top two options are quite close on voting.
15:48:08 <rpaik> #action Test & Perf sub-team to make recommendations on VNFs
15:48:17 * ChrisPriceAB thanks ray
15:49:51 <cdub> Email with [ACTION REQUIRED] tag might help
15:50:17 <cdub> most communities assume people read vast majoriry of the email
15:51:20 <ChrisPriceAB> #info the use of an [ACTION REQUIRED] tag is proposed to be used when sending e-mail to the lists requiring action from list members
15:52:48 <ChrisPriceAB> #topic goto meeting account for tSC
15:53:10 <ChrisPriceAB> #info we have a new GoTo meeting account for use in technical and TSC discussions.
15:53:33 <ChrisPriceAB> #info Ray has the username and password that can be requested for meeting organisers when running GoTo meetings
15:53:48 <ChrisPriceAB> #info meetings cannot overlay due to restrictions on the account.
15:53:54 <ChrisPriceAB> #undo
15:53:54 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1495f10>
15:54:00 <ChrisPriceAB> #info meetings cannot overlap due to restrictions on the account.
15:54:19 <bryan_att> #info do we have a master meeting schedule on the wiki?
15:54:21 <ChrisPriceAB> #topic Any other business
15:54:40 <ChrisPriceAB> #info Ashiq raises the topic of reaching out to and working with upstream communities.
15:55:39 <sgordon_> #info OpenStack NFV subteam meeting tomorrow at 1600 UTC
15:55:46 <ChrisPriceAB> #info Guidelines should be described in the development process.  Palani has established a meeting call to begin to work on that between 07:00 - 08:00 PST tomorrow
15:56:01 <sgordon_> #link https://wiki.openstack.org/wiki/Teams/NFV#Agenda_for_next_meeting
15:56:51 <bryan_att> #info if we could get those leading project meetings to update it, I can create a calendar page on the wiki to capture meetings
15:57:00 <sgordon_> #info tomorrow's NFV subteam meeting largely focused on summit planning/finalization
15:58:33 <ChrisPriceAB> #endmeeting