15:08:11 <dlenrow> #startmeeting OPNFV TSC
15:08:11 <collabot> Meeting started Tue Nov  4 15:08:11 2014 UTC.  The chair is dlenrow. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:08:11 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:08:18 <pals> Ack sounds good
15:08:21 <dlenrow> #topic role call
15:08:26 <dlenrow> #info dlenrow
15:08:27 <ChrisPriceAB> #info Chris Price
15:08:37 <frankbrockners> #info Frank Brockners
15:09:26 <uli__> #info uli
15:10:06 <dlenrow> TSC Members please checkin by #info <name>
15:10:06 <TapioT> #join Tapio Tallgren (Nokia)
15:10:19 <TapioT> #info Tapio Tallgren (Nokia)
15:10:39 <frankbrockners> can we also get a quick update on the last board meeting?
15:11:22 <Thinh_> #info Thinh Nguyenphu (Nokia)
15:12:00 <dlenrow> #info Andrea
15:12:19 <Pranav> +info Pranav Mehta
15:12:27 <Pranav> #info Pranav Mehta
15:12:35 <bin_> #info Bin (AT&T)
15:13:01 <dlenrow> #info minutes from last meeting approved by lack of opposition
15:13:31 <aricg> can you guys hear me?
15:13:36 <uli__> no
15:13:40 <aricg> I think Im muted remotely
15:13:49 <dlenrow> #info board meeting summary added to today's agenda
15:14:22 <aricg> I think I got muted in the mass mute? Not sure how gotomeeting works
15:14:30 <uli__> We don't see your phone in the gotomeeting
15:16:17 <aricg> https://etherpad.opnfv.org/
15:16:17 <aricg> https://jenkins.opendaylight.org/controller/
15:16:17 <aricg> https://gerrit.opnfv.org/gerrit/#/
15:16:17 <aricg> https://jira.opnfv.org/secure/Dashboard.jspa
15:16:17 <aricg> https://lists.opnfv.org/
15:16:19 <aricg> https://ask.opnfv.org/questions/
15:17:07 <rpaik> sounds better
15:17:24 <dlenrow> #topic project status
15:17:26 <aricg> lapgroups opnfv-gerrit-managers opnfv-wiki-managers
15:19:26 <dlenrow> #info CP notes that in community discussion question was raised why we have a login/password.
15:19:52 <dlenrow> #info idea was to prevent spammers
15:20:11 <dlenrow> #info discussion of ways to make access easier
15:22:17 <dlenrow> #action aric to investigate removing password protection on OPNFV Etherpad
15:23:13 <rpaik> #info Hui
15:23:34 <aricg> Jenkins link above is wrong: https://build.opnfv.org/ci/
15:23:39 <dlenrow> #info Uli asks whether there is a way to discover Etherpads, answer no. You need to know of them ahead of time
15:25:05 <dlenrow> #info jenkins is setup, correct link to reach it is  https://build.opnfv.org/ci/
15:25:50 <dlenrow> #info gerrit is setup, link is https://gerrit.opnfv.org/gerrit/#/
15:26:14 <dlenrow> #info Etherpad is https://etherpad.opnfv.org/
15:26:54 <dlenrow> #info CP reminds that we need a getting started guide for devs in OPNFV that describes how to start using all these tools
15:27:28 <dlenrow> #info gerrit is where we do/manage code reviews
15:27:35 <rpaik> #link opnfv-helpdesk@rt.linuxfoundation.org  for opening tickets
15:27:49 <dlenrow> #info Jira is setup https://jira.opnfv.org/secure/Dashboard.jspa
15:30:22 <dlenrow> #info question from Pals about how/where we run tools that need specific OS e.g. Linux
15:31:06 <dlenrow> #info fbrockners points out that compute/memory requirements for OPNFV dev may not fit on laptops very well.
15:32:31 <dlenrow> #info discussion about getting pool of development systems with needed resources to support devs logging in remotely
15:32:48 <dlenrow> #info aric suggess we might be able to do on google compute
15:33:09 <dlenrow> #action palani and Aric to propose a solution
15:35:24 <dlenrow> aric: can you #info for links so they get in minutes?
15:35:54 <dlenrow> aric: I pasted the previous links into #info
15:35:57 <aricg> yes, once second.
15:36:44 <dlenrow> aric: just for future. I'll get the ones you already posted in the minutes
15:39:22 <dlenrow> #info discussion of which linux distro to include in our OPNFV OStack distro
15:40:29 <dlenrow> #info Tom N suggests OpenStack on Ubuntu is the only  combination that is easy to use and non-commercial
15:41:15 <dlenrow> #info clarify above non-commercial means free, main trunk
15:41:50 <aricg> #info devstack is an easy way to get started for developers (if they have 8g+ of RAM) it supports Ubuntu 14.04 (Trusty), Fedora 20 and CentOS/RHEL 6.5
15:42:15 <dlenrow> #info CP points out that long term we need to support many linux distros
15:42:47 <frankbrockners> devstack might be easy... but is could well be *too* easy - given that it does not represent typical deployments
15:42:54 <dlenrow> #info general agreement that if a commercial distro helped us get rel 1.0 out the door,
15:43:09 <frankbrockners> s/but is could/but it could/
15:43:50 <dlenrow> #info TN points out that we agreed that we won't release any commercial stuff among our artifacts
15:44:20 <dlenrow> #info Frank suggests we post to the list that we plan to use Ubuntu and see if community objects
15:44:52 <dlenrow> #action fbrockners email list regarding Ubuntu selection proposal
15:45:52 <TapioT> Did we agree to use packstack?
15:46:37 <dlenrow> #info Tapio asks did we agree to use packstack?
15:47:38 <dlenrow> #info fbrockners suggests that toolchain and linux distro are coupled and we  need to have more discussion about the choices
15:48:11 <dlenrow> #info We have prevously discussed making the packaging tool an upstream project that we pull in
15:48:52 <dlenrow> #info agreement that we need more discussion on packaging tool
15:50:06 <dlenrow> #info question re: what does ODL do. answer: Karafe which is java specific and won't solve our multi-language project requirements
15:51:29 <dlenrow> #info CP suggests we create a wiki page for a dev sandbox and make Palani project lead
15:51:31 <TapioT> I would like access to the sandbox
15:52:19 <dlenrow> #action palani to create wiki page for dev sandbox,, will be project lead, Contributors welcome, contact pals
15:52:40 <dlenrow> #action CP to start the wiki for dev sandbox.
15:53:38 <dlenrow> #info dlenrow found tool that converts doc/pdf to wiki language so we don't have to learn it
15:54:27 <dlenrow> #topic Ray's list of topics
15:55:07 <dlenrow> #info question re: open mail list archives to anyone, even if not subscribed to list?
15:55:44 <dlenrow> #info CP points out that if we send a link to somebody outside the community, they can't follow without subscribing.
15:56:29 <dlenrow> #info Agreed by lack of objection to open archives to anyone (not by official vote)
15:56:59 <dlenrow> #action CP to send email to list informing that we plan to open the archives to all.
15:57:21 <dlenrow> #info agreed not to decide now on opening archives, will wait for response to CP email from community
15:59:30 <dlenrow> #info Q: Do we want to have a meetup event at LF collaboration event Feb 18-20 in Sonoma. ?
16:00:05 <dlenrow> #info note: conflicts with Chinese Lunar New Year, this would be one of 4 per year.
16:01:01 <dlenrow> #info question is there a better time or venue for 1Q2014?
16:02:52 <dlenrow> #info M-P suggests we colocate with ETSI, in Prague, 2/24-27
16:04:04 <dlenrow> #action ray to compose email describing 1Q2015 hackfest options and get community input.
16:04:55 <dlenrow> #info CP points out that if we get free room/venue from LF in Sonoma, there's no reason not to have hackfest and folks in CA might as well have F2F
16:07:46 <rpaik> #info pramesh@linuxfoundation.org
16:08:34 <dlenrow> #info anyone planning to blog re: OStack summit? Anyone interested in doing so should contact pramesh@linuxfoundation.org
16:09:27 <dlenrow> #info marie-paul to check about Prague availability and contact vanessa Herick
16:10:55 <rpaik> #info Vanessa’s email @LF  vheric@linuxfoundation.org
16:10:59 <dlenrow> #info Time of OPNFV TSC call is not convenient for Asia. There have been some complaints. Proposing 6AM pacific on tuesdays.
16:13:13 <dlenrow> #action ray   to propose this new time to the TSC list and ask for feedback
16:13:45 <dlenrow> #topic CI project update
16:14:48 <dlenrow> #info Uli hasn't gotten much feedback. Needs more responses. before he can progress.
16:15:33 <dlenrow> #info Need to advertise the location of project proposals so that folks look.
16:16:12 <dlenrow> #info CP suggests a meeting (GTM) to discuss/review CI Proposal
16:17:09 <dlenrow> #info CP reminds process: put proposal on wiki, email to TSC list, two week public review,
16:17:37 <dlenrow> #info dlenrow asks does lack of CI Project approval keep us from progressing the CI work?
16:18:13 <dlenrow> #info CP no hard reason, but generally we need to start getting projects formalized ASAP
16:19:32 <dlenrow> #action Uli to setup meeting to review CI proposal.
16:20:18 <dlenrow> #info CP reminds we need to know who can commit developers to work on CI
16:21:21 <dlenrow> #info Uli states that he expects/hopes HP, ericsson, RH, provide resources
16:22:06 <dlenrow> #info CP encourages folks to research their resource commitment plans. We need contributors/committers
16:22:33 <dlenrow> #info marie-paul asks whether LF will provide the sandbox Infrastructure
16:23:46 <dlenrow> #topic other project status
16:24:47 <dlenrow> #info Uli reminds we have two projects that should begin 2 week review period
16:25:20 <dlenrow> #info parser project and IPV6 project are ready for this.
16:25:50 <dlenrow> #info policy project not ready quite, resource reservation project also not there yet
16:26:10 <dlenrow> #info call this week hope to get these two ready to start review
16:28:50 <TapioT> How do I log into Jenkins (https://build.opnfv.org/ci ) ?
16:29:09 <TapioT> LF username and password do not seem to work
16:29:20 <dlenrow> #action Uli to make sure emails get sent to start clock on the review period
16:29:50 <dlenrow> #info Bin's weekly thursday calls will continue to provide venue to review project proposals
16:32:08 <ChrisPriceAB> TapioT:  I think Aric mentioned Jenkins is not yet up and running.  You can log into Gerrit
16:32:47 <TapioT> Ok. Gerrit is working
16:34:34 <dlenrow> #info  pals asks should he create a project around benchmarking for well known use cases
16:37:06 <dlenrow> #info we agree to discuss on lists and at next TSC. Need a general approach to defining/mapping projects to work we do
16:39:05 <dlenrow> #info Need to resolve the questions about what we make a project ASAP
16:41:00 <dlenrow> #info clarify requirements for creating project.  1) email to TSC announcing project proposal and begin (minimum) two weeks public review 2) email to TSC asking to approve a project that has had at least two weeks public review
16:42:33 <dlenrow> #info reminder, if your project doesn't need LF infra setup (e.g. requirements project) work can begin without project approval
16:44:31 <dlenrow> #info Even for documentation projects we want git/gerrit/etc. so we plan to create a repo for all projects.
16:47:32 <dlenrow> #info no decision taken on moving project proposals from wiki to source conrol tools
16:47:53 <dlenrow> #action CP to share slides he presented to the BOD
16:48:09 <dlenrow> #topic OPNFV BOD summary
16:48:46 <dlenrow> #info CP presented three categories of projects, upstream, transient, OPNFV
16:49:13 <dlenrow> #info CP updated on some tool choices and project proposals
16:49:45 <dlenrow> #info CP informed BOD that we need more headcount assigned, more community engagement
16:50:29 <dlenrow> #info CP informed BOD that we need and are working on upstream project timing and implications for our relese
16:52:16 <dlenrow> #info Uli asks should we start to decide what use cases to try and support in first release.
16:52:39 <dlenrow> #info CP points out we need to get an SR process in place before we can decide this
16:55:19 <dlenrow> #topic OStack summit activity
16:55:22 <TapioT> I could work with Jonne Soininen to write up a proposal on how to use git, Jenkins and Gerrit to create project proposals.
16:56:17 <dlenrow> #info working on making sure we cover NFV OS sessions.
16:57:05 <dlenrow> #action Tapio to work with aric and Jonne Soininen to start wiki and writeup of developers beginner guide
16:57:44 <dlenrow> #endmeeting