15:01:08 <ChrisPriceAB> #startmeeting OPNFV TSC
15:01:08 <collabot> Meeting started Tue Nov 11 15:01:08 2014 UTC.  The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:08 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:01:20 <julienjut> #info Julien
15:01:28 <ChrisPriceAB> #info Chris Price
15:01:35 <ChrisPriceAB> #topic roll call
15:01:54 <ChrisPriceAB> #inf Chris Price
15:01:56 <uli_> #info Uli Kleber (Huawei)
15:02:05 <ChrisPriceAB> #info Chris Price
15:02:07 <julienjut> it's my first time to use irc, is there any voice?
15:02:13 <Ashiq> #info Ashiq Khan (DOCOMO)
15:02:13 * ChrisPriceAB third times the charm.
15:02:19 <ChrisPriceAB> not on IRC no.
15:02:20 <dneary> julienjut, There is
15:02:30 <TapioT> #info Tapio Tallgren
15:02:46 <ChrisPriceAB> TSC meeting information can be found at #link https://wiki.opnfv.org/wiki/tsc?&#tsc_meeting_november_11_2014
15:02:49 <dneary> julienjut, https://global.gotomeeting.com/join/798898261
15:03:04 <ChrisPriceAB> you can join the goto meeting from there, or follow the link Dave posted
15:03:43 <dlenrow> #info dlenrow
15:03:53 <bin_> #info Bin
15:04:05 <ChrisPriceAB> #chair dlenrow
15:04:05 <collabot> Current chairs: ChrisPriceAB dlenrow
15:04:12 <dlenrow> #topic roll call
15:04:14 <ChrisPriceAB> #chair rpaik
15:04:14 <collabot> Warning: Nick not in channel: rpaik
15:04:14 <collabot> Current chairs: ChrisPriceAB dlenrow rpaik
15:04:20 <frankbrockners> #info Frank Brockners
15:04:30 <Pranav> #info Pranav Mehta
15:04:31 <Wenjing> #info Wenjing Chu
15:05:11 <palani> #info palani
15:06:35 <ChrisPriceAB> #topic minute approval
15:06:54 <dlenrow> #topic approve previous minutes
15:07:25 <bryan_att> #info Bryan Sullivan
15:08:09 <dlenrow> #info Tapio asks for adjustment to minutes related to writeup of using CI tools
15:08:10 <ChrisPriceAB> #info Tapio proposed changes to the action on himself for the previous minutes
15:08:33 <dlenrow> #info postpone approval until we can correct
15:08:52 <TapioT> Comment on minutes: Tapio proposed to create a proposal to about how to use Git and Gerrit to review project proposals
15:09:04 <dlenrow> #info pranav reminds that we need to get convo on agenda about top level project selection
15:09:49 <dlenrow> #info wants TSC discussion about how we create top level project, subproject
15:10:23 <dlenrow> #info CP suggests we wait until we have more projects in motion and learn what issues are.
15:10:29 <dku> #info Dirk Kutscher
15:11:00 <dlenrow> #info fbrockners agrees this won't become issue until we have more mature projects
15:11:35 <dlenrow> #info occurs later in our lifecycle
15:12:15 <dlenrow> #info Uli points out we're building bottom up and may want to discuss some top-down soon
15:12:31 <dlenrow> #info general agreement to defer
15:12:37 <ChrisPriceAB> #topic agenda bashing
15:12:40 <dlenrow> #topic agenda bashing
15:14:04 <dlenrow> #info Chris reminds CI project is in public review and now is the time to contribute founding contributors/committers
15:16:09 <dlenrow> #info discussion of SR and of linux distro will be added to agenda
15:16:22 <dlenrow> #topic 2015 OPNFV event planning
15:17:11 <dlenrow> #info Brandon outlines event possibilities, hackfests, etc.,
15:17:30 <dlenrow> Did anybody get details of their biweekly call and could #info
15:17:37 <dlenrow> ??
15:17:42 <ray___> I can
15:17:50 <ray___> provide it
15:17:57 <dlenrow> #info ray___: Thx
15:18:20 <ChrisPriceAB> #info Brandon describes the plan to develop a presence for OPNFV at key events during 2015 including MWC and the OPNFV Summit
15:18:23 <dlenrow> #info Planning to improve tools to help remote folks participate
15:18:25 <ray___> #info OPNFV marketing committee calls bi-weekly on Wednesdays at 7:30am PT
15:18:55 <ray___> Next meeting is on Nov. 19th
15:19:01 <dlenrow> #info describes plans for expanding presence at events
15:19:12 <ChrisPriceAB> #info marketting events can include speakerships and panels at conferences and summits as well as OPNFV specific events
15:19:49 <dlenrow> #info Plan to discuss event candidates at next mktg call
15:20:32 <dlenrow> #info describes some collateral under development. Looking to have material to describe release.
15:20:54 <dlenrow> I can't type that fast, Would love to see this on a wiki
15:21:42 <dlenrow> #info Brandon has a sort of strawman roadmap he will show
15:22:14 <cdub> #info Chris Wright
15:23:59 <dlenrow> #info co-located events at OS Summit and SDN/NFV World congress next year
15:24:25 <dlenrow> #action ray will send to mailing list
15:25:41 <dneary> ray___, Is there generally a consultation around conference venues & dates with the OPNFV marketing committee, or does the Linux Foundation generally choose and just ask the board for approval?
15:26:10 <dlenrow> #info discussion of tradeoffs evaluated in choosing some dates and venues.
15:30:15 <dlenrow> #info lots of discussion about difficulty scheduling our summit in November-ish against existing cloud events
15:31:25 <dneary> dlenrow, ray___ answered me in PM to let me know that there had been consultation with the marketing committee before asking for board & TSC approval
15:32:48 <dlenrow> #info cwright asks "what are we trying to achieve at summit?"
15:33:49 <dlenrow> #info discussion of attract devs versus announce release details vs. plan next release
15:33:50 <margaret> By the end of next year we should have enough to talk about in one track. We may not have 2 tracks
15:35:12 <dlenrow> #info summit + hackfest targetting 3-4 days, expect TSC and devs to do presos, etc. Many on this call will find value in both summit and hackfest
15:35:45 <dlenrow> #info CP asks for folks to check calendars and find conflicts to help input into this difficult scheduling requirement
15:36:15 <dlenrow> #info CP Hackfest in May at OS Summit seems to make lots of sense due to tight coupling of projects/communities
15:38:20 <dlenrow> #info discussion of doodle poll or similar to zero in
15:39:49 <bryan_att> #info we need to give poll responders a way to say why they cannot support a proposed date, so that major conflicts with other meetings e.g. IETF are clearer
15:41:26 <dlenrow> #action Ray/Brandon to move this along offline so we can move on in agenda. To get poll out by end of week
15:41:40 <dlenrow> #info CP asks TSC to provide feedback on summit dates.
15:42:12 <dlenrow> #topic Project status
15:43:00 <dlenrow> #info trevor updates: testing plan to come back to TSC next week with more detailed updae
15:43:49 <dlenrow> #info lots of work items and volunteers to progress them across the four sub-areas identified within test
15:45:50 <dlenrow> #info will propose infrastructure, platform characterization sub-projects, asks if this direction makes sense to TSC.
15:46:36 <dlenrow> #info characterization 2 approaches, top-down VNF deployment test cases, or more traditional benchmarking approach. Both have owners working
15:46:43 <julienjut> what's the difference between hackfest and opnfv summit? it's my first time to hear about hackfest
15:47:30 <dlenrow> #info telco use cases and carrier grade performance testing are driving this
15:47:55 <dlenrow> #info 3 tracks top down, bottom up platform and then stability/reliability/perf testing
15:50:04 <dlenrow> #info asks for guidance now toward preso next week and project proposals
15:50:18 <cdub> Trevor_: have pointer to meetings, proposals, etc?
15:50:36 <dlenrow> #info dlenrow suggests we need some finer breakdown of OPNFV project than a single massive/monolithic test project
15:50:58 <dlenrow> #info CI update from ULI
15:51:26 <cdub> Trevor_: i have someone who'd like to participate in the platform performance effort
15:51:43 <dlenrow> #info CI still waiting for resource commitments on project proposal. Need to get moving.
15:51:50 <RK_> Who is the point of contact in the group to speak about the test effort here ?
15:52:19 <dlenrow> #info bin update on requirements and collaborative projects'
15:53:05 <dneary> RK_, Uli Kleber (uli_) from Huawei is leading the CI project
15:53:11 <dlenrow> #info several are announced and in public review window. Please read and familiarize yourself with these projects. Need feedback and contributors
15:53:26 <margaret> for performance testing use cases - palani is the contact
15:53:49 <RK_> thanks dneary !!
15:53:52 <cdub> Trevor_: have pointer to meetings, proposals, etc?
15:53:54 <cdub> Trevor_: i have someone who'd like to participate in the platform performance effort
15:54:13 <dlenrow> dneary, leading the project sounds a little formal, we haven't elected project leads
15:54:56 <dlenrow> #info CP points out that committer list is critical before approval meeting.
15:55:02 <dneary> dlenrow, My apologies, I clearly need to understand the process better. Would it be more accurate to say he is the project lead sponsor, or initiator?
15:55:40 <dlenrow> #info yes, I think those of us writing up stuff now as raporteurs/editors.
15:55:45 <dlenrow> undo
15:55:47 <dlenrow> #undo
15:55:47 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2bfe250>
15:55:56 <dlenrow> doh!
15:56:37 <dlenrow> #info discussion about getting reviews scheduled for projects coming out of public review stage.
15:56:56 <dlenrow> #action CP to add some creation reviews to agenda for next TSC
15:58:39 <dlenrow> #info Ashik asks for clarification of process. Process is sending email to TSC mail list starts two weeks, after two weeks founders can request by email to TSC a creation review
15:58:46 <margaret> palani is the facilitator of the performance test cases - we are creating use cases and traffic models.
15:58:51 <dlenrow> #topic
15:59:05 <ChrisPriceAB> #topic OpenStack summit update
15:59:12 <dlenrow> #topic OSTack Summit and design conference learnings
16:00:09 <dlenrow> #info dneary reports lots of NFV sessions, panels, well attended, some booked simultaneous made it hard to cover all.
16:00:22 <Thinh_> #info Thinh Nguyenphu
16:00:56 <dlenrow> #info dneary will post some links to some of the sessions he considered most interesting and relevant
16:01:51 <dlenrow> #info telco working group and NFV plans review both standing room only. dneary thinks dev community not fully sold on the  value to them of supporting NFV use cases
16:02:17 <dlenrow> #info congress session was helpful in terms of educating them about why they should care about NFV
16:03:02 <dlenrow> #info dneary reports that other communities encouraging OPNFV to make sure test coverage of contributions is strong and included with proposals/blueprints
16:03:06 <bryan_att> #info it would be great to get the materials from the congress/NFV session posted on the wiki or otherwise shared as this relates to the policy project we have proposed
16:04:27 <dlenrow> #info openstack kilo M1 and M2 are critical dates for work proposed to support NFV
16:04:43 <cdub> #link http://etherpad.openstack.org/kilo-nova-nfv NFV Nova blueprint review agenda and notes
16:06:10 <julienjut> #link https://wiki.openstack.org/wiki/Kilo_Release_Schedule for kilo_release_schedule
16:06:15 <dneary> #link https://etherpad.openstack.org/p/kilo-summit-ops-telco
16:06:21 <dlenrow> #info dneary notes there are several new Open "SDN" projects midonet, ONOS, Akanda vying for relationship with NFV/OPNFV
16:06:32 <dneary> (don't know if I have the permission to add links)
16:06:44 <dlenrow> #info margaret asks what commitments we made against Openstack milestones
16:06:47 <ChrisPriceAB> #chair dneary
16:06:47 <collabot> Current chairs: ChrisPriceAB dlenrow dneary rpaik
16:06:52 <dneary> #link https://etherpad.openstack.org/p/kilo-summit-ops-telco
16:07:07 <dlenrow> #info cdub points out that ian represented OPNFV and agreed we would respect their dates.
16:07:28 <Trevor_> #info Trevor
16:07:51 <dlenrow> #info cdub clarifies this is light-weight coupling with OStack, and shouldn't need a team
16:08:18 <dlenrow> #info margaret reminds pranav volunteered for this area
16:08:23 <dneary> #info "Developing OpenStack for NFV": https://www.youtube.com/watch?v=aQJ2du2UalA
16:08:40 <dlenrow> #info CP suggests we need ian on call to finish discussion about whether we need a project, etc.
16:09:05 <Trevor_> #info Test and Performance info on proposals and metings: https://wiki.opnfv.org/integration_testing_projects
16:09:06 <dneary> #info "Demonstrating NFV on OpenStack": https://www.youtube.com/watch?v=nqxKKJBCDjE
16:09:17 <dlenrow> #info cdub suggests we do real work upstream first because spinning up a project in OPNFV will have lead times
16:09:47 <dlenrow> #topic action item status
16:10:46 <dlenrow> #info fbrockners updates community began discussion last week about pro/con of various Linux distros for our CI/deployment work.
16:11:19 <dlenrow> #info mike young started table (not much feedback yet) comparing pluses and minuses
16:11:42 <ChrisPriceAB> #info and interesting link on the mailing list providing data on OpenStack and operating system:  http://superuser.openstack.org/articles/openstack-user-survey-insights-november-2014
16:13:28 <dlenrow> #info uli describes difficulty is the dependencies that come with various distros. packaging tools tie to distros, etc.
16:14:14 <dlenrow> #info uli reports CI can't move forward without a decision here.
16:17:34 <dlenrow> #info dlenrow reminds that picking a fork/distro is a short term hack we agreed to get version 1 out the door. Long term goal is to have tooling to make upstream consumable
16:17:53 <dneary> bryan_att, I don't believe we kept notes for the Congress session - it was rather ad hoc
16:18:03 <julienjut> is there any specified requirements for 3rd Party CI environment?
16:18:24 <dlenrow> #info general agreement that this is a V1 decision not a roadmap plan. fbrockner suggests we do offline discussion/analysis to enable a descions at next TSC
16:19:52 <dlenrow> #info CP aks who can take action to progress this
16:21:11 <dlenrow> #info pals feels it is close to his sandbox work as well. He hasn't had good support for canonical and leans toward RH
16:22:12 <dlenrow> #info aric suggest ODL has had good experience with vagrant images,may be targetted to avoid some of this sort of problem
16:23:41 <dlenrow> #info Uli asks for two proposals to "bake off" at next TSC. Get a RH sponsor and an Ubuntu sponsor to describe a full stack proposal including linux distero and deploy tools
16:25:03 <dlenrow> #info cdub points out there are entire companies devoted to this. Describes more of the complexity of the inter-dependencies in the "whole stack".
16:25:42 <dlenrow> #info RH ready to help but needs some scope restriction so it's not open ended. cdub points out we've discussed much of this on CI calls
16:27:01 <dlenrow> #info cdub talks about how RH has looked at lots of the stack inter-dependencies. Suggests we need more mix-and-match not two competing vertical stacks around linux distros
16:27:14 <dlenrow> #info suggests OPNFV may need to build some tooling to support this
16:27:45 <dlenrow> #info pals prefers centos/packstack based on his POC/proto work.
16:28:53 <dlenrow> #info begin diverging into a debate about favorite stack configurations
16:29:18 <aricg> If anyone is interested in joining a hangout tomorrow at 9am PST We are planning to discuss CI and Sandbox with lf's opendaylight admins, Just pm me. I have room for 6 more.
16:31:17 <dlenrow> aric: please #info that so non-attendees can get the word
16:31:33 <dneary> I think the starting point is what the requirements of the platform & deployment tools are for the CI project? Also, what will OPNFV ship as a download, if anything?
16:31:56 <dlenrow> #info CP encourages us to finish this discussion to the lists because we need to decide at next TSC to unblock work items
16:32:44 <dlenrow> #info Tapio suggests we work towards a wiki page with proposals to choose from on next call
16:33:42 <dlenrow> #info aric clarifies that call tomorrow is not specifically focused on distro choice
16:34:12 <dlenrow> #action palani will organize meeting and herd us towards a final discussion and decision on next call
16:34:43 <cdub> i can play palani's backup
16:34:51 <dlenrow> #action CP to add discuss/decide to agenda for next TSC
16:35:03 <dlenrow> #topic SR plan
16:35:58 <ChrisPriceAB> #info Dave identifies a matrix sent to the mail list as a point for discussion on the SR process
16:37:44 <cdub> dlenrow: typical engineer... ;)
16:38:01 <ChrisPriceAB> I have lost my laptop, while muted...
16:38:57 <ChrisPriceAB> Thanks Frank!
16:39:16 <dlenrow> #info CP has fallen and can't do audio. fbrockners steps in to Moderate
16:39:56 <ChrisPriceAB> #topic aob
16:40:24 <cdub> ray___: yes!  and for future...default open
16:40:41 <dlenrow> #info release name theme will be rivers as decided by poll last week
16:40:41 <ChrisPriceAB> #info mailing list archives to be open to the public
16:41:34 <dlenrow> #info revisit TSC call timing. Propose a rotating schedule to share the pain of off-hours attendance globally
16:42:28 <dlenrow> #action dlenrow to schedule meeting this week to discuss SR strawman schedule and SR process proposals
16:42:54 <dneary> Can I also suggest the radical approach of avoiding real-time meetings where possible?
16:43:07 <julienjut> this time is actually not reasonable for Aisa members
16:43:09 <dlenrow> #info frank suggest a poll is the route to driving a decision.
16:45:15 <dlenrow> #action ray to start a poll of community (not just TSC) on solution to call timing
16:46:03 <dku> I believe there is a value in having a fixed time to avoid confusion...
16:46:29 <dlenrow> #info dku points out that alternating can be confusing
16:47:05 <julienjut> Agree to have a vote and after that the schedule will be fixed
16:47:08 <dlenrow> #info update on planning next hackfest. Ray's view is venue is free and lots live close, there is no good reason not to take advantage
16:48:40 <dlenrow> #info ray reminds that prague opportunity exists, but may have lead time issues due to ETSI liaison process.
16:49:27 <dlenrow> #info M-P clarifies logistics and suggests formal colo could be approved at plenary next week if we move fast. She has drafted proposal/preso.
16:50:04 <dlenrow> #info M-P clairifies she has drafted liaison proposal and is on agenda at plenary.
16:51:00 * ChrisPriceAB has now lost audio... Will check the irc for conclusions in this topic.
16:51:49 * ChrisPriceAB thanks Frank for stepping in. Thanks all for good discussions, next week looks to be a productive meeting.
16:53:17 <dlenrow> #info problems with MP's voice line. Please summarize to IRC w/ #info...
16:55:19 <dlenrow> #info margaret aware of members ready to send devs who feel it's hard to engage. We need to support/encourage them
16:56:03 <dlenrow> #info fbrockner suggests we make a breakout room available at meetups to give devs a place to do implementation work in parallel with our work to bootstrap community
16:56:18 <palani> #info Chris Wright can you post your email address
16:56:34 <palani> #info mine is pals@cisco.com
16:56:39 <dlenrow> #info fbrockner asks if there are any prohibitive costs or should we just plan to proceed
16:56:43 <cdub> palani: yes, to where?
16:57:19 <palani> chris W:  in the chat or you can mail it to me.
16:57:29 <cdub> palani: chrisw@redhat.com
16:57:40 <cdub> it's also on the invite that we just got
16:57:56 <dlenrow> #info Ray reports we don't have a handle on potential cost. fbrockner suggests we continue this on the mail lists.
16:58:20 <dlenrow> #info fbrockner points out we're only hearing a few opinions and wants wider input from community
16:58:46 <dlenrow> #info cdub suggests we broadcast a call for input to community
16:59:51 <dlenrow> #action ray to take to list, present prospect events/venues ask for input
17:00:11 <dlenrow> #topic status of beginners guide
17:00:20 <julienjut> is Uli in charge of CI ?
17:00:45 <dlenrow> julienjut: nobody "in charge" as such, he's point of contact
17:00:58 <dlenrow> #endmeeting