14:59:12 <ChrisPriceAB> #startmeeting OPNFV TSC
14:59:12 <collabot> Meeting started Tue Nov 25 14:59:12 2014 UTC.  The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:12 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:59:30 <ChrisPriceAB> #chair rpaik
14:59:30 <collabot> Current chairs: ChrisPriceAB rpaik
14:59:44 <ChrisPriceAB> #topic roll call
14:59:55 <ChrisPriceAB> #info Chris Price
15:01:01 <trevor_intel> #info Trevor Cooper
15:01:15 <aricg> #info Aric Gardner
15:01:20 <bryan_att> #info Bryan Sullivan
15:02:05 <Wenjing> #info Wenjing Chu
15:02:29 <collabot> dlenrow: Error: Can't start another meeting, one is in progress.
15:02:36 <dlenrow> #info dlenrow
15:02:42 <frankbrockners> #info Frank Brockners
15:02:57 <Pranav> #info Pranav Mehta
15:03:01 <Ashiq> #info Ashiq
15:03:06 <ChrisPriceAB> #chair dlenrow
15:03:06 <collabot> Current chairs: ChrisPriceAB dlenrow rpaik
15:03:19 <uli___> #info Uli Kleber
15:03:43 <palani> #info palani
15:04:04 <julien_ZTE> #info Julien
15:04:49 <dlenrow> #topic approve minutes
15:05:30 <dlenrow> #info approved by lack of objection
15:05:44 <dlenrow> #topic agenda bashing
15:07:33 <dlenrow> #info events, board alternate, SR, are highlights
15:07:48 <dlenrow> #topic events
15:07:51 <bin_> #info Bin
15:08:05 <dlenrow> #info ray shares events table from wiki
15:08:14 <morgan_orange> #info Morgan
15:08:26 <margaret__> #info Margaret
15:08:30 <ChrisPriceAB> #topic proposed events for 2015
15:08:31 <dlenrow> #link https://wiki.opnfv.org/start
15:08:49 * ChrisPriceAB oops sorry dave
15:08:49 <dlenrow> #info table is on wiki main page linked above
15:08:54 <cdub> #info Chris Wright
15:10:57 <dlenrow> #info events co-located with 2 x OpenStack Summit, ODL summit SDN/OF world congress, LF, ETSI, events
15:11:14 <dlenrow> #info OPNFV Summit Q4, USA, TBD
15:11:49 <dlenrow> #info Chris asks whether budget includes outreach beyond 4 x hackfests?
15:12:53 <dlenrow> #info discuss marketing, facitlities, food, etc, room at venue? Ray says this is in TSC budget, but can get help elsewhere in LF.
15:13:18 <dlenrow> #info OS Paris we didn't have OPNFV room/venue, we go vendor room time donated
15:13:49 <dlenrow> #info CP wants meetups and such to be covered as well to build community
15:15:00 <dlenrow> #info Ray/CP discuss Prague logistics. Expect some overlap with ETSI NFV #9 that same week. two day overlap?
15:18:38 <TapioTallgren> #info Tapio Tallgren
15:19:12 <cdub> who's on first?
15:20:06 <dlenrow> #info debate about overlap logistics. bryan_att doesn't want overlap to make participants choos
15:20:49 <dlenrow> #info ETSI doesn't start until Tuesday. Margaret__ suggests we get lots of work done for OPNFV on Monday and then some overlap tuesday.
15:21:09 <dlenrow> #info CP summarizes Mon/Tues appears to be best target for OPNFV hackfest
15:23:13 <dlenrow> #info Ray will try to target Monday/Tuesday. Less technical overlap.
15:24:44 <dlenrow> #info More concern about Tuesday/Friday AM Plenary. Calling this a personal choice. Too many competing issues later in week.
15:24:58 <bryan_att> #info we need to ensure there is remote attendance possible at the TSC meeting - when can we get confirmation of that - e.g. Ray to take an action item for that
15:25:14 <dlenrow> #action ray to setup registration to understand who plans to come. Work w/ ETSI to coordinate
15:25:34 <dlenrow> #info further event discussion to the lists
15:25:41 <dlenrow> #topic board alternate
15:26:00 <dlenrow> #info CP as chair is TSC contact to the board, attend BOD meetings
15:26:03 <dlenrow> @
15:26:25 <bryan_att> #info the Board decided there were no alternates, I thought
15:26:29 <dlenrow> #info Board would like alternate for case where CP can't attend
15:27:38 <dlenrow> #info CP proposes fbrockners as board alternate. Asks what is process for selecting alternate
15:28:15 <dlenrow> #info Fbrockners reminds we discussed vice chair pre-creation and had no conclusion
15:28:47 <cdub> dlenrow: s/Fbrockners/Uli/ ^^^
15:29:03 <frankbrockners> thanks chris
15:29:17 <cdub> *nod* ;)
15:29:21 <dlenrow> cdub: Thx.
15:29:38 <cdub> you can #undo and then redo #info
15:29:48 <dlenrow> #undo
15:29:48 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2be9790>
15:30:05 <dlenrow> #info uli reminds we discussed vice chair pre-creation and had no conclusion
15:30:29 <dlenrow> #info two approaches: discretion of TSC Chair, or TSC elects this person
15:31:17 <dlenrow> #info proposal Chair appoints, TSC vote approves
15:32:39 <TapioT> +1
15:32:46 <ChrisPriceAB> #vote Frank Brockners to fill the role of TSC representative "alternate" on the OPNFV Board
15:32:54 <cdub> ChrisPriceAB: startvote
15:32:58 <TapioT> +1
15:32:59 <ChrisPriceAB> #startvote Frank Brockners to fill the role of TSC representative "alternate" on the OPNFV Board
15:33:00 <osanchez> +1
15:33:05 <frankbrockners> +1
15:33:05 <dlenrow> #info CP formally recommends Frank Brockners
15:33:13 <ChrisPriceAB> #vote +1
15:33:13 <Ashiq> +1
15:33:16 <dlenrow> #vote +1
15:33:18 <cdub> and you need the +1, -1, 0
15:33:18 <osanchez> #vote +4
15:33:21 <Wenjing> #vote +1
15:33:22 <frankbrockners> #vote +1
15:33:23 <uli___> #vote +1
15:33:24 <TapioT> #vote +1
15:33:25 <cdub> osanchez: heh
15:33:27 <Pranav> #vote +1
15:33:27 <Ashiq> #vote +1
15:33:27 <osanchez> #vote +1
15:33:31 <dlenrow> got a +4, nice!
15:33:41 <ChrisPriceAB> #endvote
15:33:51 <osanchez> Sorry - typo - should I just -4?
15:33:57 <dlenrow> #info frank approved unanimously
15:34:16 <dlenrow> osanchez: just having fun :)
15:34:26 <Hui> vote +1
15:34:36 <dlenrow> #info clarify alternate attends if/when TSC chair can't attend BOD meeting
15:34:47 <dlenrow> #topic SR
15:35:58 <dlenrow> #info Uli requests CP share TSC report to BOD prior to next BOD Meeting next MOnday
15:36:12 <dlenrow> #action CP to share his report to BOD later this week
15:37:17 <dlenrow> #info Uli reports on Liaison letter from M-P to ETSI. Margaret_ clarifies we're just seeking Colo and don't need liaison for ETSI #9
15:37:50 <dlenrow> #info question as to whether HP/Prodip offered space to host at ETSI
15:39:26 <dlenrow> #info Susana clarifies ETSI is not formally interacting with OPNFV at Prague. Margaret_ clarifies separate registration and attendance for colocated events
15:39:47 <dlenrow> #info Susana reminds there are IPR issues related to formal joint-meetings
15:40:32 <ChrisPriceAB> #topic Simultaneous release discussion
15:42:04 <ChrisPriceAB> #topic Project Approvals
15:43:18 <dlenrow> #action dlenrow to schedule a SR meeting ASAP this week. Will give brief update of SR status if time allows at end of this
15:44:12 <dlenrow> #info CP clarifies that creating project and having project join SR are not the same process
15:44:37 <ChrisPriceAB> #info review of IPv6 project
15:44:41 <ChrisPriceAB> #link https://wiki.opnfv.org/ipv6-enabled_vanilla_opnfv
15:45:42 <dlenrow> #info Bin presents the IPV6 project
15:46:33 <dlenrow> #info project is gap analysis against upstreams and support for same. Define auto and manual config processes
15:47:52 <dlenrow> #info deliverables are installable package, install scripts/tools, and process documentation for manual configs
15:49:01 <dlenrow> #info suggests that gap analysis could be a phase 2 or another project
15:49:28 <dlenrow> #info Uli asks will scripts be upstreamed or live in OPNFV repo long term?
15:50:22 <dlenrow> #info answer will depend on ability to get things accepted upstream. Will evolve over time. Goal is upstream.
15:51:50 <dlenrow> #info dlenrow suggests we might want general scope to work on IPV6, rather than fine segmentation of IPV6 project work
15:52:41 <dlenrow> #info pals asks relationship to overall platform installer for OPNFV. Don't want proliferation of fine-grain installers
15:54:00 <dlenrow> #info bin says happy to integrate into higher level tools. Details TBD as part of project work products.
15:54:38 <dlenrow> #info pals suggests that for gaps found, we design integration via language (e.g. puppet) to be part of overall installer
15:55:25 <dlenrow> #info bin agrees. Approach is to find where is best to insert V6 gap coverage
15:56:24 <dlenrow> #info CP summarizes intent is to build an OPNFV that does V6 properly. Wants proposal to emphasize dependency base platform
15:57:32 <dlenrow> #info CP asks if integration and test the correct category to put in? Is it more of an upstream ?
15:57:49 <dlenrow> #info cdub also questions which category this belongs in
15:58:50 <dlenrow> #info bin says analysis needed to know how and where work will occur. Happy to switch category if there is strong recommendation
16:00:22 <dlenrow> #info CP says it feels like a requirements project. fbrockners explains why it is hard to categorize. Asks what is outcome? doc & reqs? or lots of tests and validation
16:00:32 <dlenrow> #info bin says goal is both
16:02:28 <dlenrow> #info CP asks about duration/life-cycle. Is this 3 mo effort or a bigger bucket of work with 3 mo. first increment?
16:03:01 <dlenrow> #info bin suggests expand scope to IPV6 for OPNFV overall. Not micro-segmented within V6
16:06:44 <dlenrow> #info plan to have a conditional vote to approve
16:06:56 <dlenrow> #startvote
16:09:05 <dlenrow> #info Not clear we can state exactly what conditional changes we are voting against.
16:09:17 <dlenrow> #info question of how/whether to approve now.
16:09:39 <dlenrow> #info CP wants to see changes before approving.
16:10:04 <dlenrow> #info proposal is to have final approval achieved after changes are agreed on list. Voting would occur on list.
16:11:05 <frankbrockners> isn't it typically #startvote <your text here> <your options> with <your options> something like -1, 0, 1 or yes, maybe, no?
16:11:49 <ChrisPriceAB> #chair fbrockners
16:11:49 <collabot> Warning: Nick not in channel: fbrockners
16:11:49 <collabot> Current chairs: ChrisPriceAB dlenrow fbrockners rpaik
16:12:02 <ChrisPriceAB> #chair frankbrockners
16:12:02 <collabot> Current chairs: ChrisPriceAB dlenrow fbrockners frankbrockners rpaik
16:12:20 <cdub> btw iirc dlenrow already typed #startvote, may need to end it
16:12:33 <frankbrockners> #startvote Approve IPV6 project? -1, 0, +1
16:12:40 <dlenrow> #info  bin reports real-time changes to proposal on wiki. CP to start vote based on same.
16:12:46 <ChrisPriceAB> #vote +1
16:12:47 <cdub> #vote +1
16:12:50 <frankbrockners> #vote +1
16:12:53 <uli___> #vote +1
16:12:56 <TapioT> #vote +1
16:12:57 <Torsten__> #vote +1
16:12:57 <Ashiq> #vote +1
16:12:58 <dlenrow> #vote +1
16:13:03 <Hui> #startvote +1
16:13:03 <Wenjing> #vote +1
16:13:04 <Pranav> #vote +1
16:13:10 <Hui> #vote +1
16:13:11 <bryan_att> #vote +1
16:13:17 <frankbrockners> #endvote
16:13:20 <frankbrockners> #showvote
16:13:35 <cdub> didn't work, we are nested under dlenrow's #startvote
16:13:39 <dlenrow> #info Congratulations on being first approved project in OPNFV
16:13:52 <dlenrow> #info unanimous +1s from all who voted
16:14:35 <ChrisPriceAB> #action rpaik takes an action to ensure we are able to use voting on the meetbot moving forward
16:14:44 <dlenrow> #endvote
16:15:18 <dlenrow> #topic doctor project
16:18:13 <dlenrow> #info Ashik shares slide to describe project. Need to upload and #link.
16:18:42 <dlenrow> #action Ashiq to upload slides presented to TSC to OPNFV wiki
16:19:59 <Gerald> #link https://wiki.opnfv.org/requirements_projects/doctor_fault_mangement_and_maintenance
16:20:30 <dlenrow> This appears to be compute (not e.g. storage or network) doctor/fault-handling. Need to clarify in Project Proposal?
16:20:30 <Gerald> everything is described in the Wiki page.
16:21:07 <dlenrow> then why are we looking at slides. If they're presented to TSC they need to be available to full community non-realtime
16:24:32 <dlenrow> #info describes plan to drive upstream changes via blueprints, etc. Will meet SR train post first release
16:31:18 <dlenrow> #info question about how this relates to the high availability project? Is there overlapping scope?
16:32:16 <dlenrow> #info Ashiq clarifies that scope is all faults, not just compute domain. DRL ask for this to be stated CLEARLY in project proposal. It's in there, but you have to look for it currently
16:33:20 <dlenrow> project proposals can include links to documents with lots of specific detail about how you might implement the scope, but the proposal is really about the scope, not the proposed implementation
16:33:42 <dlenrow> lots of good work in these docs, just to much information for project proposal wiki document
16:34:00 <dlenrow> too much information
16:34:25 <dlenrow> #info discussion of how to make HA and doctor complementary, etc.
16:36:25 <dlenrow> #info  fbrockner suggests that we not try to restrict possible duplication this early in life-cycle
16:37:57 <dlenrow> #info qiao Fu wants to avoid overlap initially.
16:38:35 <dlenrow> #info uli suggests that project collaboration can clear up overlap issues
16:39:05 <dlenrow> #info Ashiq reminds we agreed to allow overlap in incubation projects at founding
16:39:30 <dlenrow> #info pals argues alignment and reuse.
16:42:24 <dlenrow> #info qiao Fu wants to avoid overlap initially.
16:44:16 <dlenrow> #info cdub has problems with 3-fold scope under single project. Expected some top-level, versus sub-project arrangement
16:46:07 <dlenrow> #info asks if we've departed from what some folks understood.
16:46:39 <dlenrow> #info suggestion is to do a requirements project around this and then derive implementation projects based on results
16:49:55 <dlenrow> #info CP suggests we try to approve a requirements project.
16:50:17 <dlenrow> #info dlenrow asks don't we need to see a draft of the modifications we are being asked to vote on?
16:51:18 <dlenrow> #info fbrockners suggests we get crisper on scope/motivation and try to avoid describing implementation to solve.
16:52:33 <dlenrow> #uli asks do all projects need  a requirements project first to justify them?
16:52:44 <dlenrow> #info uli asks do all projects need  a requirements project first to justify them?
16:53:09 <dlenrow> #info CP says not this is result of broad scope of doctor in current form.
16:53:28 <dlenrow> #info CP asks can we vote now or need to defer?
16:54:28 <dlenrow> #info Ashiq wants to know if he is prevented from making project with upstreams until project is approved
16:54:55 <dlenrow> #info cdub suggests that process should not be allowed to slow such work and upstream discussions.
16:56:17 <dlenrow> #info Ashiq offers to edit proposal to describe a requirements project for future approval. Can do project work in parallel
16:58:48 <dlenrow> #info cdub suggests subcommittee/interrum-forum to prepare a proposal to bring to next TSC for process for working through lifecycle in OPNFV
16:59:49 <dlenrow> #action cdub to mail list and invite folks to work on life-cycle proposal
17:01:51 <TapioT> Bye!
17:52:11 <rpaik> #endmeeting