16:05:15 <cdub> #startmeeting project proposal dicussion
16:05:15 <collabot> Meeting started Mon Dec  1 16:05:15 2014 UTC.  The chair is cdub. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:05:15 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:05:30 <Gerald> are we going to use WebEx? I did not receive any invitation
16:05:38 <cdub> #chair ChrisPriceAB
16:05:38 <collabot> Current chairs: ChrisPriceAB cdub
16:05:41 <cdub> Gerald: no
16:05:48 <frankbrockners> #info Frank Brockners
16:05:52 <cdub> Gerald: just voice bridge + this IRC
16:05:55 <cgoncalves> #info Carlos Goncalves
16:06:05 <ChrisPriceAB> #info Chris Price
16:06:07 <cdub> #info Chris Wright
16:06:17 <Gerald> #info: Gerald Kunzmann, Bertrand Souville (DOCOMO)
16:07:00 <r-mibu_> #info Ryota Mibu
16:07:53 <uli_> #info Uli Kleber
16:08:11 <Gerald> cdub: thanks for clarification
16:08:47 <ChrisPriceAB> #info cdub describes the intention of the meeting as a venue to discuss our project definition methodology now that we have begun to work as a community on creating projects
16:09:47 <ChrisPriceAB> #info cdub highlights an issue that there are not many projects defining the development components in upstream communities
16:10:37 <Wenjing> #info Wenjing Chu
16:10:50 <ChrisPriceAB> #info Pranav states agreement that we should invest some time to promote and create projects in this area
16:11:35 <ChrisPriceAB> #info frankbrockners states that this may be natural as we are early in the process of OPNFV formation.  Anticipates that once we are more mature the nature of the projects may also change.
16:11:41 <TapioT> #info Tapio Tallgren
16:11:50 <dlenrow> #info dlenrow
16:13:43 <aricg> info #aricg
16:14:21 <ChrisPriceAB> #info cdub asks if there are examples of potential improvements to project type definitions
16:14:58 <ChrisPriceAB> #info Gerald indicates that more clarity to the process will help the community understand how they should approach proposing projects.
16:15:09 * ChrisPriceAB I hope it was Gerald
16:15:37 <Gerald> yes
16:15:42 <cdub> ;)
16:16:01 <ChrisPriceAB> #info fbrockners indicates that a smaller scope to projects in the proposal phase will make it much easier to approve and create a clearer structure
16:17:04 <ChrisPriceAB> #info cdub agrees that concise scope is helpful in execution.  Asks if there are concrete examples of things we can do to the project proposal process.
16:17:44 <ChrisPriceAB> #info fbrockers states that having projects that fit only one category would help define what that project will set out to do.
16:18:40 <ChrisPriceAB> #info frankbrockners indicates that requesting a draft release plan as a component of the project review would help create clarity on the intention of the project
16:18:59 <ChrisPriceAB> #info Parvis asks how a project would fit into one of the catergories.
16:19:26 <ChrisPriceAB> #info franbrockners describes the project lifecycle document description of the project categories
16:20:34 <ChrisPriceAB> #frankbrockners describes that the projects proposed for review have been spread across multiple project types thus far
16:24:42 <cdub> #info some useful links
16:24:46 <ChrisPriceAB> #info a question was raised if we should allow multiple projects to be constructed under one project
16:25:07 <cdub> #link https://www.opnfv.org/developers/technical-project-governance/project-lifecycle project lifecycle
16:25:20 <ChrisPriceAB> #info according to our current project project lifecycle this is not how we expect execution to be done
16:26:53 <ChrisPriceAB> #info cdub describes an aversion to process
16:27:56 <ChrisPriceAB> #info cdub states our processes should provide value, some infrastructure to govern activity without undue process is required.
16:28:58 <ChrisPriceAB> #info frankbrockers states our process should help people engage, smaller projects with clear scope provide a greater chance of producing an outcome in a timely manner
16:30:08 <ChrisPriceAB> #info frankbronckers indicates out project structure is created to allow people with different skills to engage in the project in understood areas.
16:30:53 <ChrisPriceAB> #info all of these pieces could potentially be combined into one project that would coordinate and produce all these components.
16:32:15 <ChrisPriceAB> #info Parvis states we should make the project categories more concrete.  They should highlight areas that might combine sub-projects as potentially one project for approval.
16:33:53 <cdub> #info lenrow reminds us that we should review during the 2wk review period
16:34:43 <frankbrockners> frankbrockners seems to have many nicks :-)
16:37:00 <cdub> #info Parviz says the table template for a proposal is missing
16:37:07 <cdub> #link https://wiki.opnfv.org/oscar/project_proposal OCSCAR proposal
16:38:02 <cdub> #info Gerald suggests as follow-up to lenrow's reminder that during the 2wk period no comments == auto accept
16:39:44 <cdub> #info cdub agrees that 2wk review process isn't useful if we don't review, need to incentivize TSC members to do review
16:40:37 <cdub> #info ChrisPriceAB TSC members need to review, can bring this up in next TSC call
16:43:29 <cdub> #link https://wiki.opnfv.org/project_proposals/template proposal template
16:45:55 <cdub> #info lenrow, chrisprice, cdub, pranav and frankbrockers will make initial edits
16:46:07 <cdub> #info and propose those in upcoming TSC call
16:46:47 <cdub> #info cdub proposes make small edits to existing process (like adding "or" to the project type list in proposal template)
16:48:54 <frankbrockners> have a look at https://wiki.opnfv.org/project_proposals/template - just made some changes
16:52:19 <dlenrow> do we think our most basic projects (CI and test) would meet the "only one category" test?
16:52:27 <cdub> #info cdub need to capture either 4 different templates or details w/in a single template that make it clear which parts apply to which proposal type
16:53:29 <cdub> #info dlenrow do we think our most basic projects (CI and test) would meet the "only one category" test?
16:53:45 <cdub> #info cdub suggests that would be a collaborative development process, others agree
16:54:34 <cdub> #info ChrisPrice suggests that proposal should help identify project needs from infratstructure
16:56:39 <cdub> #info lack of clarity on what those needs might be beyond git/gerrit, but worth documenting
16:58:35 <cdub> #info Praviz asks where do we capture version numbers for sw components?
17:00:41 <cdub> #info agreed, we don't have mechanism for capturing this...tribal knowledge has suggested helium(odl) hydrogen(openstack)
17:02:16 <ChrisPriceAB> Thanks cdub!
17:02:46 <cdub> #action cdub to help small team make the simple edits to existing templates
17:03:12 <cdub> #action ChrisPrice to remind TSC members to review before TSC calls (during 2wk review)
17:03:42 <cdub> #action cdub will keep soliciting for input on how to make larger scoped changes to the process
17:03:49 <cdub> #endmeeting