15:02:43 <ChrisPriceAB> #startmeeting OPNFV TSC
15:02:43 <collabot> Meeting started Tue Dec  9 15:02:43 2014 UTC.  The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:43 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:02:48 <ChrisPriceAB> #topic roll call
15:02:56 <ChrisPriceAB> #info Chris Price
15:03:10 <ChrisPriceAB> #chair frankbrockners
15:03:10 <collabot> Current chairs: ChrisPriceAB frankbrockners
15:03:10 <uli_> #info Uli Kleber
15:03:11 <bryan_att> #info Bryan Sullivan
15:03:12 <Wenjing> #info Wenjing Chu
15:03:15 <ChrisPriceAB> #chair dlenrow
15:03:15 <collabot> Current chairs: ChrisPriceAB dlenrow frankbrockners
15:03:19 <frankbrockners> #info Frank Brockners
15:03:20 <ChrisPriceAB> #uli_
15:03:29 <ChrisPriceAB> #chair uli_
15:03:29 <collabot> Current chairs: ChrisPriceAB dlenrow frankbrockners uli_
15:03:31 <moizarif> #info Moiz Arif
15:03:33 <dlenrow> #info dlenrow
15:03:39 <ChrisPriceAB> #chair rpaik
15:03:39 <collabot> Current chairs: ChrisPriceAB dlenrow frankbrockners rpaik uli_
15:03:47 <Ashiq> #info Ashiq
15:04:18 <cgoncalves> uli_: https://wiki.debian.org/MeetBot
15:05:45 <TapioT> #info Tapio Tallgren
15:05:59 <rpaik> #info julien_ZTE
15:06:06 <aricg> meetbot commands: http://meetbot.debian.net/Manual.html
15:06:38 <dlenrow> #topic approve previous minutes
15:06:46 <Palani> #info Palani
15:06:50 <dlenrow> #info minutes approved by lack of dissent
15:06:58 <ChrisPriceAB> #topic Agenda Bashing
15:07:16 <rpaik> #info Hui
15:07:25 <dlenrow> #info look at holiday meeting schedule for end of year
15:07:57 <dlenrow> #info want to discuss how we map OPNFV projects to upstream relatives
15:09:26 <trevor_intel> #info Trevor Cooper (Intel)
15:10:06 <dlenrow> #topic holiday/end-of-year scheduling
15:10:45 <dlenrow> #info suggest Dec 16 as last TSC meeting prior to January.
15:11:28 <dlenrow> #info agree to meet 16th, CP propose we not meet on 23 due to peoples time-off
15:11:56 <dlenrow> #info CP suggest we be prepared for Dec 18 TSC call if needed for progress/approvals
15:12:13 <Andrea__> holiday in italy
15:12:20 <dlenrow> #info CP suggest next TSC meeting occur Jan 6. Holiday in Italy
15:12:20 <Andrea__> january 6th
15:12:34 <Andrea__> january 7 is ok
15:13:08 <rpaik> #info Andrea
15:13:12 <Hui> admire italy and germany
15:13:18 <dlenrow> #info Andrea__ can't attend Jan 6, but can get proxy. Germany also conflicts
15:13:18 * ChrisPriceAB yes!
15:13:35 <dlenrow> #info Frankbrockners suggests we switch to alternate date week of Jan 6.
15:13:49 <dku> #info Dirk Kutscher
15:14:00 <dlenrow> #info propose Thursday Jan 8 as first TSC call of new year.
15:14:42 <dlenrow> #info Considering taking testing meeting time slot at 7AM PT.
15:15:04 <dlenrow> #info agreed 7-9 PT Thursday Jan 8 is first TSC call of 2015
15:15:18 <dlenrow> #info agreed 7-9 AM  PT Thursday Jan 8 is first TSC call of 2015
15:15:30 <dlenrow> #agree  7-9 AM  PT Thursday Jan 8 is first TSC call of 2015
15:15:41 <ghall> #info agreed Greg Hall ( For Tom Nadeau )
15:15:54 <rpaik> #action Ray to update the wiki w.r.t. Jan. 8th TSC call
15:16:04 <dlenrow> #agree  7-9 AM  PT Thursday Dec 18 is last call of of 2014
15:16:09 <ChrisPriceAB> #topic collabortive developement projects
15:17:29 <dlenrow> #info two primary approaches considered. Project is a use case and engages as needed upstream. Or Project is an upstream proxy/liaison and map to upstream.
15:17:47 <bryan_att> #info are the collab development projects intended to be a SPOC for upstream contribution? Or will other projects be able to commit directly?
15:17:49 <dlenrow> #info need to decide as community how these "collaborative" projects will be structured
15:20:27 <dlenrow> #info CP says one issue to consider is duration of projects persistent or transient.
15:20:53 <dlenrow> #info Bryan_ATT asks about exclusivity of upstream mapped projects
15:21:03 <Andrea__> Current proposed Collaborative projects seem to be of the first kind , the use case
15:25:30 <Andrea__> May be we can arrange by use case aggregating those that work on the same components of the upstream projects
15:26:00 <Andrea__> As Open Stack is a very huge open source
15:26:14 <dlenrow> #info Andrea suggests May be we can arrange by use case aggregating those that work on the same components of the upstream projects
15:26:51 <dlenrow> #info Ashiq asks what is meant by use case? CP describes a feature spread across multiple upstreams
15:27:11 <bryan_att> #info by features makes more sense to me, e.g. policy and the facillities (event pub/sub) that enable it
15:27:49 <bryan_att> #info please use the term feature or function rather than use case...
15:27:58 <dlenrow> #info Mike Lynch has suggested that use case orientation might allow better architectural control. CP suggests that this could lead to fragmented architecture upstream, reliant on upstream decisions.
15:28:35 <dlenrow> #info Mike warns we want to become more than just a bunch of upstream artifacts. CP asks who are committers on those control points?
15:28:42 <bryan_att> #info can you define "control points"?
15:29:12 <dlenrow> #info Mike suggests we need a big picture architecture (owned by TSC) to inform the per-use-case approach
15:29:50 <dlenrow> #info basic issue is bottom-up vs top-town control/influence on the platform/system we build
15:30:07 <dlenrow> #info Mike advocating more TSC input into a system arch
15:31:12 <dlenrow> #info CP suggests we continue discussin on mail lists. Not converging on a solution here.
15:31:51 <dlenrow> #info CP reminds that when collaborative projects come up for creation review we need to have this figured out: How do we interact upstream?
15:32:47 <dlenrow> #info FrankBrockners suggests the first collab project headed for creation should be the pilot and use context to figure this out.
15:33:04 <ghall> is opnfv a platform for application development or an end user feature rich deliverable?  I think the former ... which means architecture is the real requirement.  So our "use cases" should really be for "generalized" features ... infrastructure.
15:34:51 <dlenrow> #info dlenrow asks what is first collab in queue. Can we get them to volunteer to propose a way to interact upstream.
15:35:22 <dlenrow> #info CP reminds that Telco KPI coming up for creation today and we can discuss more in that time slot
15:36:49 <dlenrow> #topic Julien_ZTE asks clarification about where code/committing will live.  CP clarifies mostly upstream.
15:37:01 <dlenrow> #undo
15:37:01 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x2c04710>
15:37:13 <dlenrow> #info Julien_ZTE asks clarification about where code/committing will live.  CP clarifies mostly upstream.
15:37:28 <dlenrow> #topic committer check for Octopus
15:37:38 <ChrisPriceAB> #link https://wiki.opnfv.org/octopus/project_proposal
15:37:55 <dlenrow> #info Final committer list for creation available
15:41:48 <julien_ZTE> #info Uli suggest approval projects should be listed in some wiki pages
15:43:45 <dlenrow> #info Octopus Committer list on wiki updated with 2x HP committers
15:44:16 <dlenrow> #action Uli to further organize projects so it is clear what is approved, pending, etc.
15:44:56 <dlenrow> #info CP reminds that projects don't go on main project page until approved. Keep proposed/unapproved off main project page
15:45:50 <dlenrow> #startvote approve CI project creation based on final changes to proposal on wiki which just occurred?
15:46:00 <bryan_att> #vote +1
15:46:02 <Hui> vote +1
15:46:02 <uli_> #vote +1
15:46:03 <ChrisPriceAB> #vote +1
15:46:03 <julien_ZTE> #vote +1
15:46:04 <Wenjing> #vote +1
15:46:05 <dku> #vote +1
15:46:06 <dlenrow> #vote +1
15:46:08 <Andrea__> #vote +1
15:46:14 <Ashiq> #vote +1
15:46:15 <frankbrockners> #vote +1
15:46:22 <TapioT> #vote +1
15:46:23 <dlenrow> #endvote
15:46:50 <dlenrow> #info I still don't know how to run the vote...
15:47:05 <dlenrow> #agreed Octopus project approved for creation
15:47:16 <dlenrow> congratulations Octopus
15:47:38 * ChrisPriceAB congratulations!
15:47:39 <Andrea__> Just to clarify the state of the approved projects in the lifecycle, now are they declared in incubation ?
15:47:45 * ChrisPriceAB yes.
15:47:56 <Andrea__> thanks
15:48:05 <Parviz> #info Parviz Yegani
15:48:24 <dlenrow> #topic approval and committer check for Infra policy project
15:49:06 <frankbrockners> Andrea: Incubation is the state post proposal: See https://www.opnfv.org/developers/technical-project-governance/project-lifecycle
15:50:38 <dlenrow> #info dlenrow  and Staffan Blau to be added as committer, NEC also one to add. We're editing wiki in realtime now
15:51:15 <julien_ZTE> #info ZTE is interested in copper, and I will check wheter we can put more resources in this project.
15:51:37 <dlenrow> #info final edits get us two more committers and another contributor during call.
15:51:37 <r-mibu_> dirk, thanks
15:52:09 <dlenrow> #startvote approve Copper project for creation based on final wiki edits just completed
15:52:22 <ChrisPriceAB> #vote +1
15:52:23 <Hui> #vote +1
15:52:27 <TapioT> #vote +1
15:52:28 <julien_ZTE> #vote +1
15:52:28 <frankbrockners> #vote +1
15:52:29 <Wenjing> #vote +1
15:52:29 <dku> #vote +1
15:52:29 <dlenrow> #vote +1
15:52:30 <bryan_att> #vote +1
15:52:30 <Andrea__> #vote +1
15:52:39 <Ashiq> vote +1
15:53:09 <dlenrow> #endvote
15:53:55 <dlenrow> #info previous vote cancelled. We needed to add one more committer
15:54:43 <dlenrow> #startvote approve Copper project for creation based on final wiki edits just completed including Huawei committer
15:54:46 <Hui> #vote +1
15:54:47 <uli_> #vote +1
15:54:48 <frankbrockners> #vote +1
15:54:51 <Parviz> #vote +1
15:54:55 <dku> #vote +1
15:54:55 <ChrisPriceAB> #vote +1
15:54:56 <dlenrow> #vote +1
15:54:57 <Wenjing> #vote 1
15:54:59 <Trevor_> #vote +1
15:55:01 <Ashiq> vote +1
15:55:06 <julien_ZTE> #vote +1
15:55:09 <bryan_att> #vote +1
15:55:09 <TapioT> #vote +1
15:55:09 <Ashiq> #vote +1
15:55:21 <dlenrow> This time for sure
15:55:27 <dlenrow> #endvote
15:55:46 <dlenrow> #agreed Copper approved for creation
15:55:51 * ChrisPriceAB congratulations
15:56:03 <dlenrow> #topic new project creation reviews
15:56:38 <ChrisPriceAB> #link https://wiki.opnfv.org/requirements_projects/high_availability_for_vnfs
15:57:06 <dlenrow> #topic HA project
15:57:30 <ChrisPriceAB> #link https://wiki.opnfv.org/requirements_projects/high_availability_for_vnfs
15:59:53 <dlenrow> ambiguous committer/contributor section will likely push final approval until next time?
16:00:15 <dlenrow> #info early deliverables are gap analysis and report/survey of use cases and HA approaches
16:01:18 <dlenrow> #info later work to define HA APIs derived from req.s. Also work on capabilities exchange APIs for diverse hardware/state
16:01:44 <dlenrow> #info analyze existing OpenStack HA work and consider extensions and enhancements.
16:09:29 <dlenrow> #info discussion of API requirements vs creating info models. CP proposes we change language to specify API requirements. Change made on proposal page.
16:10:45 <frankbrockners> just cleaned up the committers list
16:11:59 <frankbrockners> also cleaned up the Scope section to talk about "requirements for HA API"
16:12:05 <frankbrockners> see https://wiki.opnfv.org/requirements_projects/high_availability_for_opnfv?&#scope
16:17:05 <frankbrockners> dlenrow: just added ODL to https://wiki.opnfv.org/requirements_projects/high_availability_for_opnfv?&#dependencies
16:17:27 <dlenrow> frankbrockners: thx
16:20:26 <frankbrockners> updated https://wiki.opnfv.org/requirements_projects/high_availability_for_opnfv?&#scope to reflect the comment from Parvis to consider HA for the SDN controller
16:20:44 <dlenrow> #info Parviz concerned that ETSI spec referenced may be too broad of scope
16:22:43 <frankbrockners> #info Following the discussion, the proposal got updated to speak of "requirements for HA API" (not define HA API), removed the "maintainer" from list of contributors and committers, added "study HA for SDN controller" to the scope
16:25:34 <julien_ZTE> how about harden
16:26:39 <frankbrockners> https://wiki.opnfv.org/requirements_projects/high_availability_for_opnfv
16:27:32 <dlenrow> #startvote approve HA for VNFS for project creation? Vote +1, 0, or -1.
16:27:39 <Hui> #vote +1
16:27:41 <frankbrockners> #vote +1
16:27:41 <TapioT> #vote +1
16:27:42 <julien_ZTE> #vote +1
16:27:42 <ChrisPriceAB> #vote +1
16:27:42 <uli_> #vote +1
16:27:43 <Wenjing> #vote +1
16:27:45 <dlenrow> #vote +1
16:27:50 <dku> #vote +1
16:27:59 <Andrea__> #vote +1
16:28:01 <Trevor_> #vote +1
16:28:02 <Ashiq> #vote +1
16:28:05 <bryan_att> #info +1
16:28:14 <dlenrow> #endvote
16:28:32 <dlenrow> #agreed HA for OPNFV approved for creation
16:28:41 <fuqiao> thanking you very much
16:28:43 <dlenrow> Welcome HA project & team
16:28:54 <dlenrow> #topic project bootstrap/get-started
16:29:07 <ChrisPriceAB> #link https://wiki.opnfv.org/get_started/get_started_project_proposal
16:30:39 <dlenrow> #info Basic setup to deploy platform and run a couple of VNFs in a standard config as a starting point for dev/integration.
16:31:02 <dlenrow> #info We have access to systems and folks are starting to make things work.
16:31:45 <dlenrow> #info Need to approve and execute as this is the foundation to build all our deliverables. Big diverse group of contributors and committers.
16:32:01 <dlenrow> #info planning to have something working for Rel 1.0 in March 2015
16:36:06 <bryan_att> #info the point of the project is not about VNFs, but about the framework, so I don't understand why there is so much focus on VNFs in this discussion.
16:36:27 * ChrisPriceAB I think the point was to ensure cross pollination with the testing groups. :)
16:38:12 <dlenrow> #info usijng CentOS as Linux foundation for now...
16:38:37 <bryan_att> #info we can add Bin Hu as a contributor now or later
16:39:09 <dlenrow> #startvote approve Bootstrap/get-started  for project creation? Vote +1, 0, or -1.
16:39:14 <TapioT> #vote +1
16:39:17 <frankbrockners> #vote +1
16:39:18 <Hui> #vote +1
16:39:18 <Wenjing> #vote +1
16:39:19 <ChrisPriceAB> #vote +1
16:39:19 <julien_ZTE> #vote +1
16:39:21 <dlenrow> #vote +1
16:39:23 <uli_> #vote +1
16:39:24 <dku> #vote +1
16:39:25 <Andrea__> #vote +1
16:39:26 <bryan_att> #vote +1
16:39:30 <Susana_> +1
16:39:30 <Ashiq> #vote +1
16:39:31 <dlenrow> #endvote
16:39:51 <dlenrow> #agreed Bootstrap/get-started approved for creation
16:40:00 <dlenrow> Welcome bootstrap project
16:40:38 <dlenrow> #info FrankBrockners reminds that this is moving fast and communication occurs daily on IRC. Meeting info on Wiki. Webex as needed
16:41:30 <dlenrow> #topic project proposal Telco KPI
16:41:48 <dlenrow> #link https://wiki.opnfv.org/collaborative_development_projects/opnfv_telco_kpi_monitoring
16:47:51 <dlenrow> Do Telco KPIs not include any network infratructure? This appears to be vswitch or VM KPI monitoring, not as broad as Telco KPI based on description. Where is system view of traffic that includes pswitches, etc. ?
16:48:31 <frankbrockners> Folks, need to run - ChrisPrice will fill in for me for the vote
16:58:40 <julien_ZTE> #agree the name is easy to confused
17:01:56 <rpaik> #info project name & repository name repository suggested for the project
17:02:12 <dlenrow> #info plan to adjust repo name, project name, and then vote (without extensive discussion) next TSC call
17:02:24 <dlenrow> #endmeeting