14:57:55 <ChrisPriceAB> #startmeeting OPNFV TSC
14:57:55 <collabot`> Meeting started Tue Dec 16 14:57:55 2014 UTC.  The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:57:55 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:58:14 <ChrisPriceAB> #topic Roll Call , TSC members
14:58:17 <frankbrockners> #info Frank Brockners
14:58:20 <ChrisPriceAB> #info Chris Price
15:00:30 <Ashiq> #info Ashiq
15:00:38 <uli_> #info Uli
15:00:42 <bryan_att> #info Bryan Sullivan
15:01:53 <bryan_att> #info FYI Bin Hu will stand in for me as AT&T TSC member on any votes after I leave the call (flying)
15:02:08 <Palani> #info palani
15:03:30 <rpaik> #info Hui
15:03:32 <bin_> #info Bin Hu
15:03:37 <ChrisPriceAB> #chair frankbrockners
15:03:37 <collabot`> Current chairs: ChrisPriceAB frankbrockners
15:03:43 <ChrisPriceAB> #chair uli_
15:03:43 <collabot`> Current chairs: ChrisPriceAB frankbrockners uli_
15:03:44 <cdub> #info Chris Wright
15:03:57 <ChrisPriceAB> #chair rpaik
15:03:57 <collabot`> Current chairs: ChrisPriceAB frankbrockners rpaik uli_
15:04:01 <Parviz> #info Parviz Yegani
15:04:08 <ChrisPriceAB> #chair cdub
15:04:08 <collabot`> Current chairs: ChrisPriceAB cdub frankbrockners rpaik uli_
15:04:24 <ChrisPriceAB> #topic Approval of minutes
15:04:52 <ChrisPriceAB> #agree Minutes approved without comment
15:04:59 <ChrisPriceAB> #topic Agenda Bashing
15:05:28 <Wenjing> #info Wenjing Chu
15:07:10 <TapioT> #join Tapio Tallgren
15:08:31 <ChrisPriceAB> #action ChrisPriceAB establish a specific topic in the e-mails for requesting creation reviews.
15:10:55 <ChrisPriceAB> #info OSCAR project to be further discussed in the community prior to formal TSC review
15:11:10 <ChrisPriceAB> #topic Project Repo's
15:11:33 <uli_> #topic project repos
15:11:42 <ChrisPriceAB> #info Ray describes that there are now 7 repositories in place with committer e-mails being sent out.
15:12:14 <ChrisPriceAB> #info Gerrit and other tools on the OPNFV web site questions can be sent to the e-mail that is monitored:
15:12:14 <rpaik> #info opnfv-helpdesk@rt.linuxfoundation.org
15:12:52 <ChrisPriceAB> #info not all committers are established in the all the repo's due to missing linux foundation accounts
15:13:19 <ChrisPriceAB> #info corporate e-mail addresses should be used when creating the LinuxFoundation account to be used in OPNFV.
15:14:20 <TapioT> #help
15:14:30 <ChrisPriceAB> #info aricg: informs that there are no announcement e-mails for committers on projects.
15:15:17 <rpaik> #info https://gerrit.opnfv.org/gerrit/#/admin/projects/
15:16:01 <aricg> Send me a quick message if you need help changing the email address associated with with your lf-account.
15:16:27 <ChrisPriceAB> #link here is where I am trying to capture steps to getting started with accounts etc: #link https://wiki.opnfv.org/dev_step_by_step
15:18:13 <ChrisPriceAB> #topic Meet-up and HackFest committee's
15:19:09 <ChrisPriceAB> #info Ray sent a number of e-mails to the lists to rally help for setting agenda's, topics & goals for the meet-up's and hack-fests during 2015
15:19:21 <TapioT> I changed the email address, it was easy after all. Go to identity.linuxfoundation.org
15:20:08 <ChrisPriceAB> #info Registration links will be sent out soon for registering to the meet-up in santa rosa.
15:21:44 <ChrisPriceAB> #info frankbrockners mentions that on the main wiki page the events page can be updated with an etherpad to help organise and attend events.
15:22:13 <bryan_att> #info I will be in Santa Rosa and can help organize topics and hacking around Copper. As we kick off the project this will be one of the first discussion points.
15:22:24 <ChrisPriceAB> #info Prague hack-fest
15:23:08 <ChrisPriceAB> #info there are no venues within walking distance of the ETSI event.  The closest event venue is 15 minutes away by metro train at the Marriot.
15:23:31 <ChrisPriceAB> #info the LinuxFoundation has some awareness of the location and have a good impression of it.
15:23:47 <ChrisPriceAB> #info we will need to confirm the facility by the end of this week.
15:24:25 <ChrisPriceAB> #info The HackFest will be on the Monday and Tuesday of the week
15:24:28 <bryan_att> #info also AFAIK Dan Druta on my team (or maybe Margaret) will stand in for me at Prague and attend the hack fest IF it doesn't conflict with the ETSI meeting.
15:26:22 <B_Smith> The ETSO NFV NOC meets on Monday
15:28:24 <ChrisPriceAB> #info a discussion occurs on the location of the event being a subway ride away and if this may cause any issues.
15:30:31 <frankbrockners> #info main wiki page has been updated with links to etherpads which are to supply additional info on meetups/hackfests (for Feb19, Feb 23)
15:31:29 <bryan_att> #info I have to drop now, Bin will stand in for me now
15:32:35 <ChrisPriceAB> #agree The TSC has come to concensus that the locations proposed by the LinuxFoundation for the HackFest will be sufficient and that they should proceed to secure the venue.
15:33:21 <ChrisPriceAB> #topic Development process
15:37:30 <bryan_att> #info agree that's specifically the plan for copper... To create blueprints etc as output of the first release
15:37:51 <bryan_att> #info I can help do that
15:38:13 <bryan_att> #info ie facilitate the discussion
15:38:13 * ChrisPriceAB did you just volunteer?
15:39:21 <ChrisPriceAB> #action bryann_att to kick offf discussions around the design process for requirements rpojects
15:42:00 <ChrisPriceAB> #info ChrisPriceAB opens the floor to discussions around our collaborative development project structure
15:42:42 <ChrisPriceAB> #info cdub: comments that structuring our development projects around upstream communities provides a structure to engage with the communities.
15:43:13 <ChrisPriceAB> #info as yet we do not have mechanisms for working with upstream projects, not the deployment scripts for our CI.
15:45:08 <ChrisPriceAB> #info frankbrockners indicates using a "trial project" will provide guidance one our development process.  Proving the process by activity would seem to be the best way.
15:45:25 <bryan_att> #info I would start our assuming that projects with multiple up streams should directly commit to them, e.g. Copper will commit to ODL and OpenStack
15:45:59 <ChrisPriceAB> #info cdub indicates kicking off an OpenStack project would be a good starting point.  Feedback has been received that OPNFV could improve it's collaboration with OpenStack.
15:46:12 <cdub> #link https://etherpad.opnfv.org/p/DevProcess <-- strawman proposal
15:46:28 <ChrisPriceAB> #info frankbrockners agreed that kicking off a project on OpenStack would be a great way to start.
15:46:37 <bryan_att> #info having a SPOC as commit passthru will potentially create a bottleneck. Not that it might not optimize some projects, but for others may be a unnecessary overhead
15:49:32 <bryan_att> #info we need to keep subject areas contiguous and not arbitrarily split projects across multiple collab dev projects. IPv6 and Copper are good examples of how we need them to be mostly autonomous
15:49:53 <bryan_att> #info these projects will commit code in later phases
15:50:00 <frankbrockners> #info frankbrockners noted that a beachhead project should be concise in nature - i.e. no "general engagement with O/S" but focused on e.g. HA, or IPv6 etc.
15:53:32 <cdub> #info ChrisPriceAB notes config isn't trivial
15:55:41 <bryan_att> #info I think committing happens directly to the upstream but is done by the OPNFV projects. So I still am confused by the last discussion on that point. I think we need some more clarity on the list re how people expect the code to get to the upstream, and the role of discrete projects in pushing commits upstream.
15:56:49 <ChrisPriceAB> #action ChrisPriceAB and cdub to organise inviting members of the OpenStack TC to the OPNFv TSC call for a 30 minute bilateral discussion
15:57:10 <bryan_att> #info semantics
15:58:19 <bryan_att> #info in practical terms OPNFV members will be committing to the upstream on behalf of various projects, whether you view than as individuals or as a team in OPNFV
16:02:24 <bryan_att> #info gotta drop for real this time. I look forward to the discussion on how we interact with the upstream. I'm not a SME there and probably have some things to learn. I just suggest we team an OPNFV team/project approach to upstreaming.
16:02:33 * ChrisPriceAB thanks bryan
16:08:16 <ChrisPriceAB> #topic Project Approvals Name and committer check - opnfv_telco_kpi_monitoring
16:08:33 <ChrisPriceAB> #link https://wiki.opnfv.org/collaborative_development_projects/opnfv_telco_kpi_monitoring
16:08:57 <ChrisPriceAB> #info the project has been renamed to Software Fastpath Service Quality Metrics
16:10:35 <ChrisPriceAB> #info discussion around the project being requirements or development ensues
16:13:17 <ChrisPriceAB> #info frankbrockners asks if the project would act as a "beach-head" project for working through the development process in OPNFV.
16:13:58 <ChrisPriceAB> #info We would monitor and discuss the methodologies and challenges of this project as a method of iteratively improving and refining our processes.
16:15:23 <ChrisPriceAB> #info Ashiq agrees with Frank.  cdub agrees it is a good target project for evaluating our processes.
16:24:51 <ChrisPriceAB> #startvote Vote for creation of the Software Fastpath Service Quality Metrics - collaborative development project? (+1, 0, -1)
16:24:59 <ChrisPriceAB> #vote +1
16:24:59 <TapioT> #vote +1
16:25:03 <frankbrockners> #vote +1
16:25:05 <Ashiq> #vote +1
16:25:05 <Wenjing_Chu> #vote +1
16:25:07 <bin_> #vote +1
16:25:12 <cdub> #vote +1
16:25:46 <uli_> #vote +1
16:25:54 <ChrisPriceAB> #vote +1 (Mike Lynch)
16:26:34 <ChrisPriceAB> #vote +1 (Parviz)
16:26:48 <ChrisPriceAB> #endvote
16:27:22 <ChrisPriceAB> #agree fastpathmetrics project creation approved by the TSC
16:28:14 <ChrisPriceAB> #topic Review of the vSwitch Performance project
16:28:17 <ChrisPriceAB> #link https://wiki.opnfv.org/characterize_vswitch_performance_for_telco_nfv_use_cases
16:28:56 <ChrisPriceAB> #info Mark Gray presents the project proposal
16:34:50 <ChrisPriceAB> #info Parviz asks if there is a table or such for benchmarking today on jitter and delay
16:35:12 <ChrisPriceAB> #info Mark answers that the project intends to help create such a benchmark
16:36:14 <ChrisPriceAB> #info Parvis asks if the ETSI NFV documents have been referenced
16:36:37 <ChrisPriceAB> #info Mike responds that they have and are intending to remain aligned with those references
16:38:04 <morgan_orange> any // activity in ODL on generic testsuite definition for vswitch?
16:40:10 <ChrisPriceAB> #info frankbrockners asks if there is a vSwitch identified as a starting point.  The response is to start with OVS/DPDK however the project does not limit itself to that vSwitch
16:48:26 <Parviz> Chris I have to sign off but I vote yes for project "Characterize vSwitch Performance for Telco NFV Use Cases".
16:50:50 <ChrisPriceAB> #frankbrockners asks what requirements exist on the hardware for this project.
16:52:12 <ChrisPriceAB> #info Mark answers that some specific hardware will be required and that it will be described for the OPNFV infrastructure
16:52:33 <frankbrockners> #info frankbrockners asks what requirements exist on the hardware for this project.
16:53:50 <ChrisPriceAB> #info trevor_intel explains that there is a description of the required hardware on the test and infrastructure page.
16:54:08 * ChrisPriceAB :)
16:58:13 <ChrisPriceAB> #startvote Vote for creation of the vSwitch Performance - testing project? (+1, 0, -1)
16:58:17 <ChrisPriceAB> #vote +1
16:58:18 <TapioT> #vote +1
16:58:21 <Wenjing_Chu> #votee +1
16:58:26 <ChrisPriceAB> #vote +1 (Mike Lynch)
16:58:27 <cdub> #vote +1
16:58:27 <bin_> #vote +1
16:58:30 <Ashiq> vote +1
16:58:32 <frankbrockners> #vote +1
16:58:32 <uli_> #vote +1
16:58:38 <ChrisPriceAB> #vote +1 (Parviz)
16:58:39 <cdub> Wenjing_Chu: might try again...votee?
16:58:47 <Wenjing_Chu> #vote +1
16:58:57 <ChrisPriceAB> #endvote
16:59:37 <frankbrockners> happy holidays everyone!
17:00:02 <frankbrockners> #endmeeting