15:13:39 <ulik> #startmeeting Octopus
15:13:39 <collabot> Meeting started Mon Feb 16 15:13:39 2015 UTC. The chair is ulik. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:13:39 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:13:39 <collabot> The meeting name has been set to 'octopus'
15:14:25 <ulik> #info Fatih explains his work on the LF setup and walks us through the new infrastructure wiki page
15:15:01 <ulik> #link https://wiki.opnfv.org/octopus/infrastructure
15:15:26 <ulik> #info discussion on which plugins are needed
15:15:59 <ulik> #info Jerry (Zhaoxinyu) proposes to use zuul
15:17:25 <ulik> #info Carlos asks about forge.io
15:18:31 <frankbrockners> it is https://www.forj.io/
15:18:43 <frankbrockners> we had a presentation on forj in the past
15:18:58 <ulik> #chair frankbrockners
15:18:58 <collabot> Current chairs: frankbrockners ulik
15:21:00 <ulik> #info Uli asks how much we can re-use from ODL or OpenStack CI setup?
15:21:34 <ulik> #info Jerry mentions the problem of permissions for jenkins
15:21:55 <ulik> #info Jerry proposes to solve this using the jenkins job builder
15:25:07 <ulik> #info Jerry explains more about job builder.
15:27:00 <ulik> #info we need job creation permission to get the plugins installed and use job builder
15:27:46 <ulik> #info Jerry explains that this way we don't need to ask Aric for every plugin.
15:28:59 <ulik> #agreed to use job builder and ask Aric to install the cron job and necessary plugins for this
15:29:49 <ulik> #info Uli proposes to collect here the information which plugins Aric should install initially
15:30:25 <ulik> #chair fdegir
15:30:25 <collabot> Current chairs: fdegir frankbrockners ulik
15:30:53 <fdegir> #info Jenkins Job Builder plugin can help addressing the way to create/use/configure jobs
15:31:27 <ulik> #chair jerryz
15:31:27 <collabot> Current chairs: fdegir frankbrockners jerryz ulik
15:32:13 <fdegir> #info Correction: Jenkins Job Builder is not a plugin. It is just an application to install.
15:34:27 <ulik> #info Uli asks about what permissions are needed.
15:34:44 <ulik> #info Fatih says job creation permission should be enough.
15:36:37 <ulik> #info Uli proposes Fatih and Jerry be provided with job creation permission and may be few more contributors.
15:39:13 <ulik> #action ulik to ask Aric for 2 more people with job creation permission
15:40:00 <ulik> #info Fatih shows what he has proposed for release 1
15:41:11 <ulik> #link https://wiki.opnfv.org/octopus/flows
15:44:37 <ulik> #info the page talks about contributors/committers of other projects in that flow. The first commit should be getting BGS output to rerun BGS work automatically.
15:45:30 <ulik> #info Frank confirms that this is the goal.
15:46:36 <ulik> #info discussion on the runtime of such jenkins job
15:48:40 <ulik> #action to all to review this wiki page and further define these work flows.
15:49:20 <ulik> #info Uli asks about the test inputs
15:50:02 <ulik> #info tempest and robot will help organize the tests.
15:50:46 <ulik> #info Jerry proposes also to use rally
15:52:10 <ulik> #info Jerry explains that openstack uses these and deep down inside all use "tester" to run the tests.
15:54:50 <ulik> #info uli asks if these tools need installation. Answer: rally needs to be installed.
15:55:33 <ulik> #info We should wait for functest to decide whether they need that.
15:55:59 <frankbrockners> #info on tempest installation: http://fosshelp.blogspot.in/2014/02/how-to-manually-install-openstack.html
16:02:12 <ulik> #endmeeting