14:59:14 <ChrisPriceAB> #startmeeting TSC Meeting
14:59:14 <collabot> Meeting started Tue Feb 17 14:59:14 2015 UTC.  The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:14 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:59:14 <collabot> The meeting name has been set to 'tsc_meeting'
14:59:24 <ChrisPriceAB> #topic roll call
14:59:30 <ChrisPriceAB> #info Chris Price
14:59:54 <ChrisPriceAB> #char rpaik
14:59:57 <ulik> #info Uli Kleber
15:00:00 <ChrisPriceAB> #chair rpaik
15:00:00 <collabot> Current chairs: ChrisPriceAB rpaik
15:00:15 <ChrisPriceAB> #chair dlenrow
15:00:15 <collabot> Current chairs: ChrisPriceAB dlenrow rpaik
15:00:23 <ChrisPriceAB> #chair ulik
15:00:23 <collabot> Current chairs: ChrisPriceAB dlenrow rpaik ulik
15:00:30 <ChrisPriceAB> #chair frankbrockners
15:00:30 <collabot> Current chairs: ChrisPriceAB dlenrow frankbrockners rpaik ulik
15:00:56 <frankbrockners> #info Frank Brockners
15:00:59 <dku> #info Dirk Kutscher
15:01:03 <dlenrow> #info dlenrow
15:02:03 <Parviz> #info Parviz Yegani
15:02:12 <plynch> #info Pierre Lynch
15:02:21 <Thomas_> #info Thomas Nadeau
15:03:09 <Pranav> #info Pranav Mehta
15:03:43 <bryan_att> #info Bryan Sullivan
15:03:50 <Thinh_> #info Thinh Nguyenphu
15:03:54 <ChrisPriceAB> #topic Approval of previous minutes
15:03:56 <Ashiq> #info Ashiq Khan
15:04:18 <ChrisPriceAB> #agree TSC approves the precious minutes of the meeting
15:06:07 <ChrisPriceAB> #topic agenda bashing
15:06:42 <ChrisPriceAB> #info due to chinese new year the following project will not be able to be presented today: Resource Schdeuler - Resource Scheduler:
15:07:18 <julien_ZTE> #info Julien
15:07:26 <ChrisPriceAB> #Info adding a discussion on licencing of software in OPNFV
15:07:35 <ChrisPriceAB> #info adding a boar meeting review tot he agenda
15:08:07 <Guest52317> can whomever is typing please mute? sounds like machine guns on the phone.
15:08:09 <ChrisPriceAB> #undo
15:08:09 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1dfe650>
15:08:22 <ChrisPriceAB> #info adding a board meeting review to the agenda
15:09:29 <ChrisPriceAB> #topic Formation of an OPNFV Security Group
15:10:04 <ChrisPriceAB> #info luke has been leading community discussions around security for OPNFV
15:10:23 <ChrisPriceAB> #info the team have identified themselves as more of a working group than a project as such.
15:10:53 <ChrisPriceAB> #link https://wiki.opnfv.org/security
15:12:08 <ChrisPriceAB> #info luke has in addition sent an e-mial to the community outlining the intentions and actions to be addressed by the security group in OPNFV.
15:13:43 <ChrisPriceAB> #info there is a big interest in working with upstream security working groups
15:14:27 <ChrisPriceAB> #info Pranav asks what the deliverable would be for such a working group, he feels a requirements project might be a good way to capture anticipated needs on the platform.
15:15:08 <ChrisPriceAB> #info Luke refers to the e-mail identifying research areas and working closely with project to improve the security aspects of the platform
15:16:11 <ChrisPriceAB> #link http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2015-February/001120.html
15:16:27 <ChrisPriceAB> #info the above link refers to the mentioned e-mail
15:17:57 <ChrisPriceAB> #info Parviz asks what would be relevant to this group, if the ETSI NFV security group would have influence
15:18:41 <ChrisPriceAB> #info Luke answers that the ETSI NFV SG have already been invited to the discussion and there is an intention to feed-back to that and other upstream teams
15:19:32 <ChrisPriceAB> #info Pranav stresses the need to work toward actionable items for development that lead to security improvements in the platform
15:34:43 <ChrisPriceAB> #agree the TSC agrees to support the establishment of an OPNFV security group as outlined in the linked e-mail and WiKI pages.
15:36:17 <ChrisPriceAB> #topic Discussion on licencing of sourced software in OPNFV.
15:37:20 <ChrisPriceAB> #info Bryan refers to the use of software in OPNFV where we are using software with GPL licenses, where we have a goal of being an Apache licensed project.
15:41:29 <ChrisPriceAB> #action rpaik to request clarity on working with upstream GPL licenses in the OPNFV platform.
15:41:58 <Guest52317> a guiding checklist on the wiki for devs would be awesome too
15:44:04 <ChrisPriceAB> #action rpaik to add guidelines for contributions upstream under different licenses to https://wiki.opnfv.org/developer
15:45:18 <ChrisPriceAB> #action rpaik to identify how code scanning is being implemented in OPNFV and if it is automated
15:48:30 <ulik> #topic OPNFV Release 1 discussion
15:48:31 <ChrisPriceAB> #topic OPNFV Release 1 discussion
15:48:49 <frankbrockners> #link https://etherpad.opnfv.org/p/bgs
15:49:00 <frankbrockners> #link https://wiki.opnfv.org/get_started/get_started_release_plan
15:50:11 <rpaik> #info BGS milestones: End of Feb. base installer completed
15:51:11 <rpaik> mid-March: Install on OPNFV hardware & CI integration
15:51:32 <rpaik> #info mid-March: Install on OPNFV hardware & CI integration
15:52:12 <rpaik> #info end-of-March: Tempest / Robot scenario tests avail
15:53:52 <rpaik> #info. Recommend 2-4 additional weeks for Release 1
15:57:40 <rpaik> #info multiple installers is not a gating factor for timeline as work is being done in parallel
16:02:59 <rpaik> #info Frank notes that by end of Feb, HA limited to OpenStack
16:04:24 <rpaik> #info Uli provided CI update and noted that Jenkins is setup
16:05:27 <ulik> #link https://wiki.opnfv.org/octopus/infrastructure
16:05:41 <ulik> #link https://wiki.opnfv.org/octopus/flows
16:06:47 <ChrisPriceAB> #info Trevor outlines the function test requirements
16:06:50 <ChrisPriceAB> #link https://etherpad.opnfv.org/p/functiontestrelease1activities
16:08:12 <aricg> Example of jenkins master with views for each project https://jenkins.opendaylight.org/releng/
16:08:37 <aricg> Example of a repo with jjb definitions https://git.opendaylight.org/gerrit/releng/builder
16:09:34 <aricg> Example of merge jobs that bring the jjb code into production  https://jenkins.opendaylight.org/releng/view/builder/
16:11:36 <rpaik> #info Chirs notes the expectation is that the CI first deploys and tesing will be invoked from the staging server and Jenkins will determine success/failure
16:19:32 <fdegir> Added Jenkins Job Builder info and information provided by Aric to wiki: https://wiki.opnfv.org/octopus/infrastructure#jenkins_job_builder
16:22:36 <rpaik> #info Chris noted that BGS documentation is also needed
16:26:03 <Guest52317> im ok with the approach
16:26:36 <Guest52317> #info Thomas Nadeau
16:27:15 <ChrisPriceAB> #agree The TSC agrees to target the release for April, during the next week further work will continue to define the exact target date in April.  To be agreed in the next TSC meeting.
16:28:22 <ChrisPriceAB> #topic TSC update to the board
16:48:07 <ChrisPriceAB> #info the TSC update to the board was shared, there were questions around other topics on the board calls.
16:48:47 <ChrisPriceAB> #info the general agenda was discussed and it was proposed that other groups cross report to the TSC on related topics as well as to the board.
16:51:41 <ChrisPriceAB> #topic creation review of the openstack based vnf forwarding graph project.
16:51:45 <julien_ZTE> #info next week will be Chinese New Year. Shall we cancel next week TSC meeting?
16:51:55 <ChrisPriceAB> #link https://wiki.opnfv.org/requirements_projects/openstack_based_vnf_forwarding_graph
16:53:03 <ChrisPriceAB> #info Cathy updated the diagram as and text in the document.
17:05:54 <rpaik> #info discussion on how the project proposal fits within the scope of OPNFV
17:07:05 <ChrisPriceAB> #vote TSC vote to create the openstack based VNF forwarding graph project? (+1, 0, -1)
17:07:07 <ulik> #vote +1
17:07:10 <rprakash__> #vote +1
17:07:14 <ChrisPriceAB> #startvote TSC vote to create the openstack based VNF forwarding graph project? (+1, 0, -1)
17:07:14 <collabot> Begin voting on: TSC vote to create the openstack based VNF forwarding graph project? Valid vote options are , +1, 0, -1, .
17:07:14 <collabot> Vote using '#vote OPTION'. Only your last vote counts.
17:07:19 <dlenrow> #vote +1
17:07:19 <dku> #vote +1
17:07:20 <ulik> #vote +1
17:07:23 <bryan_att> #vote +1
17:07:31 <Pranav> #vote +1
17:07:32 <ChrisPriceAB> #vote +1
17:07:33 <AndreaP> #vote +1
17:07:38 <rprakash__> #vote +1
17:07:44 <Ashiq> #vote +1
17:08:16 <ChrisPriceAB> #endvote
17:08:16 <collabot> Voted on "TSC vote to create the openstack based VNF forwarding graph project?" Results are
17:08:16 <collabot> +1 (9): Pranav, AndreaP, dku, dlenrow, rprakash__, bryan_att, ChrisPriceAB, Ashiq, ulik
17:08:25 <ChrisPriceAB> #endmeeting