#opnfv-meeting: Octomus weekly meeting

Meeting started by dneary at 15:04:12 UTC (full logs).

Meeting summary

    1. Agenda bashing: Account of hackfest from Prague (dneary, 15:04:57)

  1. Jenkins set-up (dneary, 15:06:08)
    1. fdegir describes the current status of the CI project. (ChrisPriceAB, 15:08:12)
    2. CI scripts in place awaiting BGS and functest to provide build/deploy/commit scripts to be invoked. (ChrisPriceAB, 15:09:01)
    3. uli asks about maintenance of the scripts and coordination with other projects (ChrisPriceAB, 15:09:42)
    4. fdegir describes the current setup in releng and how these scripts will be evolved and invoke octopus scripts maintained by the community. (ChrisPriceAB, 15:11:18)
    5. Discussion about Jenkins jobs to be added initially, jobs to deploy projects, and various jobs which will be used for all projects (eg. verification job) (dneary, 15:18:30)
    6. Chris Price asking whether jobs should be in octopus repo instead of releng (ulik, 15:23:42)
    7. Aric suggest to move to octopus repo at the same time when we have the hardware (ulik, 15:27:27)

  2. Jira backlog (ChrisPriceAB, 15:28:38)
    1. fdegir talks about using Jira for backlog management and outlining inter project dependencies to be visible between projects. (ChrisPriceAB, 15:29:09)
    2. rather than using WiKi or etherpad moving to Jira makes things more visible (ChrisPriceAB, 15:29:35)
    3. aricg states we can submit bugs against octopus for the releng already now (ChrisPriceAB, 15:30:28)
    4. ChrisPriceAB states it is very good for CI as you can add actions to other projects backlog (ChrisPriceAB, 15:31:04)
    5. uli asks if this is only for inter-project issues or for use internally (ChrisPriceAB, 15:31:42)
    6. it is clarified that it should be for all agile backlog int the project and externally. (ChrisPriceAB, 15:31:59)
    7. iben asks if Jira items can be created by anyone? (ChrisPriceAB, 15:32:22)
    8. aricg indicates it is open to all, dneary agrees that it should be open for all to raise items and browse (chrispriceab agrees) (ChrisPriceAB, 15:32:54)
    9. aricg will look into it offline to test. fdegir indicates he cannot modify (ChrisPriceAB, 15:33:24)
    10. temporary home of released artifacts. https://build.opnfv.org/releases/ (aricg, 15:47:47)
    11. radez confirms there's no real directory structure in Genedis right now, that fdegir's proposal of a convention for directory structure would be a good initiative (dneary, 15:47:48)
    12. ACTION: - aricg to provide list of etherpads (iben_, 15:50:33)
    13. ACTION: - etherpads with technical debt and “todo” lists should make issues in JIRA for these. The etherpad should be updated with a link to JIRA and message about this recommendation (iben_, 15:51:37)
    14. It’s recommended to ensure the project leads are aware of new JIRA issues (iben_, 15:52:35)
    15. ACTION: aricg will add a build and verify job for each project to releng (that does nothing at first) (aricg, 15:54:28)
    16. iben_ offered to help set up multi-site Jenkins by connecting multiple instances in different labs (dneary, 15:56:05)


Meeting ended at 15:59:43 UTC (full logs).

Action items

  1. - aricg to provide list of etherpads
  2. - etherpads with technical debt and “todo” lists should make issues in JIRA for these. The etherpad should be updated with a link to JIRA and message about this recommendation
  3. aricg will add a build and verify job for each project to releng (that does nothing at first)


Action items, by person

  1. aricg
    1. - aricg to provide list of etherpads
    2. aricg will add a build and verify job for each project to releng (that does nothing at first)


People present (lines said)

  1. dneary (16)
  2. ChrisPriceAB (16)
  3. collabot (7)
  4. aricg (4)
  5. iben_ (4)
  6. ulik (2)
  7. rprakash (0)


Generated by MeetBot 0.1.4.